
  






<!DOCTYPE html>
        <html lang="en">
        <head>
<base href="https://www.suncoastnews.com/content/tncms/live/" />
<meta name="tncms-access-version" content="" />
<meta name="keywords" content="epiphany, tarpon springs, greece, greek orthodox church, 2022, open to public, cross dive, spring bayou" />
<meta name="news_keywords" content="epiphany, tarpon springs, greece, greek orthodox church, 2022, open to public, cross dive, spring bayou" />
<meta name="description" content="This year, organizers of the 116th edition of Epiphany promise the event will return to its full-scale glory." />
<meta name="author" content="Jeff Rosenfield, Tampa Bay Newspapers" />
<meta name="viewport" content="width=device-width, initial-scale=1.0" />
<meta name="apple-mobile-web-app-capable" content="yes" />
<meta name="apple-mobile-web-app-status-bar-style" content="black-translucent" />
<meta property="og:type" content="article" />
<meta property="og:url" content="https://www.suncoastnews.com/news/tarpon-springs-gears-up-to-celebrate-epiphany/article_02168946-6da3-11ec-96eb-b399dee05af8.html" />
<meta property="og:image" content="https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/5/be/5be84fb8-6da3-11ec-b84a-47a13e9128b4/61d4b8cd11bbd.image.jpg?crop=1609%2C845%2C0%2C221&amp;resize=1200%2C630&amp;order=crop%2Cresize" />
<meta property="og:image:width" content="1200" />
<meta property="og:image:height" content="630" />
<meta property="og:title" content="Tarpon Springs gears up to celebrate Epiphany" />
<meta property="og:description" content="This year, organizers of the 116th edition of Epiphany promise the event will return to its full-scale glory." />
<meta property="og:site_name" content="Suncoast News" />
<meta property="og:section" content="News" />
<meta property="article:publisher" content="http://www.facebook.com/SuncoastNews" />
<meta name="twitter:image" content="https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/5/be/5be84fb8-6da3-11ec-b84a-47a13e9128b4/61d4b8cd11bbd.image.jpg?crop=1609%2C845%2C0%2C221&amp;resize=438%2C230&amp;order=crop%2Cresize" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:site" content="@SuncoastNews" />
<meta name="twitter:image:alt" content="PI-EpiphanyAdv1-010521.jpg" />
<link rel="stylesheet preload" as="style" href="https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/shared-content/art/tncms/templates/libraries/flex/components/bootstrap/resources/styles/bootstrap.min.44f4ed00052aeaf66307fd409db0d101.css"/>
<link rel="stylesheet preload" as="style" href="https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/styles/layout.f8a85c0a4a6a87bd9b487bd6762cadcd.css"/>
<link rel="stylesheet preload" as="style" href="https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/shared-content/art/tncms/templates/libraries/flex/components/themes/resources/styles/theme-basic.61027f06cd4658b4c10ada7b6f93cdd2.css"/>
<link rel="stylesheet" href="https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/live/global/resources/styles/site.css?_dc=1472828967"/>
<link rel="stylesheet" href="https://fonts.googleapis.com/css?family=Oswald|PT+Serif:400,600,700"/>
<link rel="stylesheet" href="https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/styles/owl.carousel.d631cca58a0d014854c4a6c1815f1da3.css"/>
<link rel="stylesheet preload" as="style" href="https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/shared-content/art/tncms/templates/libraries/flex/components/block/resources/styles/flex-classifieds-bulletins.a78f8be1f6e0dabcb5acb9a8939501f8.css"/>
<style>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</style>
<script type="text/javascript">(function(){var tnsrc=window.location.hash.match(/[&#]tncms-source=([^&]+)/);var dl = window.dataLayer = window.dataLayer || [];dl.push({"townnews":{"product":{"software":"BLOX","version":"1.60.4"}},"tncms":{"template":{"version":"3.155.0"},"page":{"grid":"simple","style":"default","path":"\/news","syndicated":"false","reaction":"false","app":"editorial","theme":"flex","skin":"flex-editorial","http_status":200},"subscription":{"required":"false"},"asset":{"author":"Jeff Rosenfield, Tampa Bay Newspapers","presentation":null,"start_hour":"16","id":"02168946-6da3-11ec-96eb-b399dee05af8","app":"editorial","ga_page":"\/news\/article_02168946-6da3-11ec-96eb-b399dee05af8.html"},"vendor":{"outbrain":"Headlines and photo grid","taboola":""},"ad":{"vendor":"blox"},"system":{"render_time":491},"client":{"is_bot":"no","is_gdpr":"no"}}});if (tnsrc && tnsrc[1]) {dl.push({'tncms.campaign.internal_source': tnsrc[1]});}window.addEventListener("DOMContentLoaded", function(oEvent) {var oTest = document.createElement('div');oTest.innerHTML = '&nbsp;';oTest.className = 'adsbox';document.body.appendChild(oTest);var nTimeoutID = window.setTimeout(function() {if (oTest.offsetHeight === 0) {dl.push({'event': 'tncms.ad.blocked'});}document.body.removeChild(oTest);window.clearTimeout(nTimeoutID);}, 100);});var nWidth=Math.max(document.documentElement.clientWidth, window.innerWidth || 0),aBPs=[[300,"Extra small: Most smartphones."],[768,"Small: Tablet devices."],[992,"Medium: Laptops & landscape tablets."],[1200,"Large: Desktop computers."]],i,c,aThisBP,aBP;for(i=0,c=aBPs.length;i<c;i++){aThisBP=aBPs[i];if(aBP===undefined||aThisBP[0]<=nWidth){aBP=aThisBP;}}if(aBP!==undefined){dl.push({'tncms.client.breakpoint':aBP[1]});}(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'tncms.start':new Date().getTime(),event:'tncms.start'});var f=d.getElementsByTagName(s)[0],j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src='https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);})(window,document,'script','dataLayer','GTM-PDQV3N');})();</script>
<script type="module" async="async" src="/shared-content/art/tncms/api/access.js"></script>
<script src="/shared-content/art/tncms/api/access-legacy.js" defer="defer" nomodule="nomodule"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/shared-content/art/tncms/templates/libraries/flex/components/jquery/resources/scripts/jquery.min.d6d18fcf88750a16d256e72626e676a6.js"></script>
<script src="/shared-content/art/tncms/user/user.js"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/shared-content/art/tncms/templates/libraries/flex/components/bootstrap/resources/scripts/bootstrap.min.d457560d3dfbf1d56a225eb99d7b0702.js"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/common.08a61544f369cc43bf02e71b2d10d49f.js"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/tnt.f7f607461e880929e17a0ecdc234e5df.js"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/application.cb897187c4718280fd69d2e6d6c3909d.js"></script>
<script src="https://polyfill.io/v3/polyfill.min.js?features=default,fetch,IntersectionObserver,NodeList.prototype.@@iterator,Element.prototype.classList|gated" nomodule="nomodule"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/shared-content/art/tncms/templates/libraries/flex/components/ads_blox/resources/scripts/tnt.ads.init.c2b9574823d0d16ffc6f20eef83f4232.js"></script>
<script async="async" src="https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/shared-content/art/tncms/templates/libraries/flex/components/ads_blox/resources/scripts/tnt.ads.load.6a3c47703ee96f20ef132e36033ca1bc.js"></script>
<script src="/shared-content/art/tncms/tracking.js"></script>
<script src="/shared-content/art/tncms-ad-manager/admanager.js"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/ads/impressions.js?_dc=1641368118.temp"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/ads/traffic.js?_dc=1641360919"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/ads/settings.js?_dc=1626882303"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/ads/fixed-impact-top/1.js?_dc=1638908134"></script>
<script async="async" src="https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/shared-content/art/tncms/templates/libraries/flex/components/block/resources/scripts/user-controls.578df3df79d812af55ab13bae47f9857.js"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/tnt.navigation.accessibility.7a9170240d21440159b9bd59db72933b.js"></script>
<script async="async" src="https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/sms-link.8eefede3265fd6c6de07bc0cb5f3f779.js"></script>
<script async="async" src="https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/shared-content/art/tncms/templates/libraries/flex/components/asset/resources/scripts/tnt.nextPrev.283bfb49ef55c073fceda15ffbf58de8.js"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/ads/fixed-big-ad-middle-asset/1.js?_dc=1638540610"></script>
<script>/*<![CDATA[*/ var ZERG = ZERG || {};
                    ZERG.domain = "suncoastnews.com";
                    ZERG.user = 57683; /*]]>*/</script>
<script async="async" src="https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/shared-content/art/tncms/templates/libraries/flex/components/ads/resources/scripts/vendor.taboola.0f7d1c50406b868f466f9143671a50f4.js"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/ads/fixed-big-ad-top/1.js?_dc=1641311007"></script>
<script async="async" src="https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/ie.grid.placement.8d31e32afeebe4520bfab9638ef91435.js"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/shared-content/art/tncms/templates/libraries/flex/components/ads/resources/scripts/tnt.ads.adverts.66a3812a7b5c12fde8cd998fd691ad7d.js"></script>
<script>/*<![CDATA[*/ __tnt.recentFive = {
    /*
     * Gets the data stored in 'tnt:recent:five'
     * Returns Array
     */
        get:function(){
            if(window.localStorage && localStorage.getItem('tnt:recent:five')!=null){
                try{ return JSON.parse(localStorage.getItem('tnt:recent:five')); } catch {}
            }

            return [];
        },

    /*
     * Sets the 'tnt:recent:five' localStorage item
     * Returns boolean
     */
        set:function(data){
            if(window.localStorage){
                try{ 
                    localStorage.setItem('tnt:recent:five', JSON.stringify(data));
                    return true;
                } catch {}
            }

            return false;
        },

    /*
     * Adds the most recent item, prunes any duplicates, and trims the array down to 5 items
     * Returns Array on success, false on fail 
     */
        add:function(asset){
            var assets = __tnt.recentFive.get();
            assets.unshift(asset);

            if(assets.length > 1){
                assets = assets.filter(function(item, index, a){ return a.indexOf(item) == index });

                while(assets.length>5){
                    assets.pop();
                }
            }

            if(__tnt.recentFive.set(assets)){ return assets; }
            return false;
        }
    }; /*]]>*/</script>

            
            <title>Tarpon Springs gears up to celebrate Epiphany | News | suncoastnews.com</title>
            
    <style>body { background-color: #d5d4d0; color: #333333; }a, a:hover, .pagination>li>a, .pagination>li>a:hover, .btn-link, .dropdown-menu>li>a, blockquote, blockquote p, .asset .asset-body blockquote p { color: #4175aa; } #main-body-container .container, #main-body-container .container_fluid, .well-main { background-color: #ffffff; } .tnt-content-width-container > * { max-width: 1140px; margin-left: auto; margin-right: auto; } #site-navbar-container, #main-navigation { background-color: #f4f4f2; } .fixed-nav #main-navigation { background-color: #f4f4f2 !important; } #site-top-nav-container, #site-top-nav { background-color: #ffffff; } #site-footer { background-color: #ffffff; color: #333333; } .navbar-default .navbar-nav>li>a, .navbar-default .navbar-nav>li>a:hover, .navbar-default .navbar-nav>li>a:focus, .navbar-default .navbar-nav>.open>a, .navbar-default .navbar-nav>.open>a:hover, .navbar-default .navbar-nav>.open>a:focus { color: #666; } .navbar-toggle .icon-bar { background-color: #666 !important; } .navbar-toggle .sr-only-show { color: #666 !important; } #site-top-nav .list-inline>li>a { color: #4175aa; } .asset .asset-body p, .asset #asset-content p { color: #444; } #site-header { background-color: #ffffff; }/* remove full span bgs */ #site-navbar-container, #site-header-container, #site-top-nav-container { background-color: transparent !important; background-image: none !important; }/* remove full span bgs */ #site-footer-container { background-color: transparent !important; background-image: none !important; }@media (max-width: 991px){ .navbar-default .navbar-nav .open .dropdown-menu>li>a, .navbar-default .navbar-nav .open .dropdown-menu>li>a:hover, .navbar-default .navbar-nav .open .dropdown-menu>li>a:focus { color: #666; } }#site-copyright a, #site-footer a { color: #4175aa; }.search-redesign .top-breakout > .row { max-width: 1200px; }.nav-tabs>li.active>a, .nav-tabs>li.active>a:hover, .nav-tabs>li.active>a:focus { border-top-color: #005296; }#site-header{ border-bottom: 3px solid #005296; }#site-footer{ border-top: 3px solid #005296; } .tnt-bg-accent { background-color: #005296; } a .tnt-caret-down { color: #005296; } .block-title .block-title-inner { border-color: #005296; } a.thumbnail:hover, a.thumbnail:focus, a.thumbnail.active { border-color: #005296; } .form-control:focus { border-bottom-color: #005296; } /* Place site-wide CSS here */ /* Primary color: #1033e3Secondary color: #d6bd1a*/ a { color:#005296;} a:hover { color:#111111;} #weather-501439 .weather-expanded small { opacity: 0.8; color: #f4f4f2; } #site-header { border-bottom: 2px solid #cacaca;} .navbar-nav>li { border-left: 1px solid #e6e6e6; border-right: solid 1px #cacaca; } @media (min-width: 992px){ .sn-logo-block .img-responsive { max-width: 540px!important;} .nav>li>a { padding: 10px 20px;} } #main-navigation #navbar-collapse { box-shadow: 0px 10px 6px -6px rgba(0, 0, 0, 0.25); } .navbar { min-height: 40px;} .navbar-default .navbar-nav>.open>a, .navbar-default .navbar-nav>.open>a:hover { background-color: #111111!important; color: #ffffff!important; text-shadow: 1px 1px 1px #000000; } .site-search-form.input-group.pull-right.input-group-lg { box-shadow: 0px 10px 6px -6px rgba(0, 0, 0, 0.25); } #site-search-399654 .input-group-btn:last-child>.btn, .input-group-btn:last-child>.btn-group { color: #f5f0f0!important; background: #1f1a1c!important; } .navbar-default .navbar-nav>li>a:hover { background-color:#111111;color:#ffffff!important; text-shadow: 1px 1px 1px #000000;} .dropdown-menu { background-color:#111111;color:#f4f4f2!important;} .dropdown-menu>li>a { color:#f4f4f2!important;} .dropdown-menu>li>a:hover { background:#f7f7f7;color:#197DC0!important;} .btn-primary { color: #fff; background-color: #115588; border-color: #357ebd; } .btn-success { color: #564949; background-color: #b6eb07; border-color: #4cae4c; } .card figure .image .asset-icon { position: absolute; bottom: 0; left: 0; padding: 4px; color: #a4c8eb; } .block-title h1, .block-title h2, .block-title h3, .block-title h4, .block-title h5, .block-title h6 { /* font-family: 'Bevan', cursive; */ font-family: 'Oswald', sans-serif; margin: 0px; } .card-headline { font-family: 'PT Serif', serif!important; font-weight: bold; } .asset .asset-header h1 { font-family: 'PT Serif', serif;} .asset .asset-body p {color: #888887;} #site-footer { margin-bottom: 0px;} #site-copyright { color:#ffffff;background: #004d98;} #site-copyright a {color:#ffffff;} .dropdown-header { color: #8bbcea!important;} .datepicker.dropdown-menu th { color: #000000!important;} </style>
    
        <link rel="shortcut icon" type="image/x-icon" href="https://www.suncoastnews.com/content/tncms/site/icon.ico" />
    
        <link rel="preconnect" href="//cdn.taboola.com">
    
        <link rel="preconnect" href="//www.googletagmanager.com">
    
        <link rel="preconnect" href="//www.google-analytics.com">
    <link rel="alternate" type="application/rss+xml" title="Tarpon Springs gears up to celebrate Epiphany | News | suncoastnews.com" href="http://www.suncoastnews.com/search/?f=rss&amp;t=article&amp;c=news&amp;l=50&amp;s=start_time&amp;sd=desc" />
    <link rel="canonical" href="https://www.suncoastnews.com/news/tarpon-springs-gears-up-to-celebrate-epiphany/article_02168946-6da3-11ec-96eb-b399dee05af8.html" />
            <script defer src="https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/fontawesome.3aa64d478db9cdd63e9d4b159e0c9334.js"></script>
            
        </head>
        <body class="fixed-scroll-nav app-editorial grid-simple blox-asset uuid-02168946-6da3-11ec-96eb-b399dee05af8  section-news type-article infinity-disabled" data-path="/news">
	<script type='text/javascript' src='/shared-content/art/stats/common/tracker.js'></script>
	<script type='text/javascript'>
	<!--
	if (typeof(TNStats_Tracker) !== 'undefined' && typeof(TNTracker) === 'undefined') { TNTracker = new TNStats_Tracker('www.suncoastnews.com'); TNTracker.trackPageView(); }
	// -->
	</script>
	<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-PDQV3N&amp;townnews.product.software=BLOX&amp;townnews.product.version=1.60.4&amp;tncms.template.version=3.155.0&amp;tncms.page.grid=simple&amp;tncms.page.style=default&amp;tncms.page.path=%2Fnews&amp;tncms.page.syndicated=false&amp;tncms.page.reaction=false&amp;tncms.page.app=editorial&amp;tncms.page.theme=flex&amp;tncms.page.skin=flex-editorial&amp;tncms.page.http_status=200&amp;tncms.subscription.required=false&amp;tncms.asset.author=Jeff+Rosenfield%2C+Tampa+Bay+Newspapers&amp;tncms.asset.start_hour=16&amp;tncms.asset.id=02168946-6da3-11ec-96eb-b399dee05af8&amp;tncms.asset.app=editorial&amp;tncms.asset.ga_page=%2Fnews%2Farticle_02168946-6da3-11ec-96eb-b399dee05af8.html&amp;tncms.vendor.outbrain=Headlines+and+photo+grid&amp;tncms.vendor.taboola=&amp;tncms.ad.vendor=blox&amp;tncms.system.render_time=491&amp;tncms.client.is_bot=no&amp;tncms.client.is_gdpr=no&amp;tncms.client.noscript=yes" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
        
        <script type="text/javascript">
TNCMS.AdManager.init
({
  domain: "www.suncoastnews.com",
  secureDomain: "suncoastnews.com",
  virtualregion: {
            popup: __tnt.ads.popup
        },
  callback: {
            expandable: __tnt.ads.expandable,
            html: __tnt.ads.html,
            image: __tnt.ads.image,
            pagecurl: __tnt.ads.curl,
            text: __tnt.ads.text,
            video: __tnt.ads.video
        }
});
</script>

        <div data-tnt-ads-tmp='{"vendor":"blox","type":"region","region":"page-curl","id":"page-curl","pos":"page-curl, atf","fold":"above","size":"[[75,75]]","height":"75","width":"75","not_mobile":true,"refresh":false}' style="display:none;"></div>
        <!-- Google Tag Manager -->
        <script>
            var dataLayer = window.dataLayer || [];
            dataLayer.push(
                {'user_id': __tnt.user.screenName},
                {'user_state': __tnt.user.loggedIn ? 'logged in' : 'anonymous'},
                {'utm_label': __tnt.urlHash('utm_label')}
            );
        </script>
        <noscript><iframe src="//www.googletagmanager.com/ns.html?id=" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
        <script>
            (function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
            new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
            j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
            '//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
            })(window,document,'script','dataLayer','');
        </script>
        <script>
            $(function(){
                var bloxServiceIDs = [];
                var bloxUserServiceIds = [];
                var dataLayer = window.dataLayer || [];

                

                if (__tnt.user.services){
                    var bloxUserServiceIDs = __tnt.user.services.replace('%2C',',').split(',');
                }

                // GTM tncms.subscription.paid_access_service_ids
                if(bloxServiceIDs){
                    dataLayer.push({'tncms':{'subscription':{'access_service_ids':bloxServiceIDs.toString()}}});
                }

                // GTM tncms.subscrption.user_service_ids
                if(bloxUserServiceIDs){
                    dataLayer.push({'tncms':{'subscription':{'user_service_ids':bloxUserServiceIDs.toString()}}});
                }
            });
        </script>
        
        <div data-tnt-ads-tmp='{"vendor":"blox","type":"region","region":"fixed-impact-top","id":"fixed-impact-top","pos":"fixed-impact-top, atf","fold":"above","include_domain":null,"size":"[2,1]","height":"1","width":"2","js":{"video":"https:\/\/bloximages.newyork1.vip.townnews.com\/suncoastnews.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"index_slug":null,"url":"\/news","refresh":false}' style="display:none;"></div><div id="tncms-region-ads-fixed-impact-top" class="tncms-region-ads">

<div id="blox-ad-position-fixed-impact-top1">
<script type="text/javascript">TNCMS.AdManager.render({region: 'fixed-impact-top', slot: 1, fold: "above"});</script>

</div>
</div>

        <div id="blox-ad-position-_popup1" data-tnt-ads='{"vendor":"blox","type":"position","region":"_popup","id":"_popup","slot":1,"pos":"_popup, atf","size":"[[900,900]]","height":"900","width":"900","display":"popup","refresh":false}' class="blox-ad tnt-ads-container ">
        
        </div>
        <div id="site-container"><div id="asset-admin-bar" class="asset-edit-bar hidden-print">
                <div class="asset-edit-icon"><i class="fas tnt-lock-open tnt-fw"></i></div>
                <div class="asset-edit-message">You have permission to edit this article.</div>
                <div class="asset-edit-btns">
                    <a class="btn btn-primary btn-sm" target="_blank" rel="noopener" href="https://www.suncoastnews.com/tncms/admin/editorial-asset/?edit=02168946-6da3-11ec-96eb-b399dee05af8"><i class="fas tnt-pencil-alt tnt-fw"></i> Edit</a>
                    <button class="asset-edit-close btn btn-link btn-sm"><i class="fas tnt-times"></i><span class="sr-only">Close</span></button>
                </div>
            </div>
        
    
        
        
           <aside class="hidden-print offcanvas-drawer offcanvas-drawer-right visible-sm visible-xs" aria-label="Right Main Menu" aria-expanded="false" tabindex="-1">
                <div id="tncms-region-mobile-nav-top-right-region" class="tncms-region "><div id="tncms-block-501437" class="tncms-block hidden-md hidden-lg"><div id="user-controls-501437" class="user-controls show-onload clearfix default"><div class="not-logged-in">
        <ul class="list-inline"><li><a href="https://www.suncoastnews.com/users/signup/?referer_url=https%3A%2F%2Fwww.suncoastnews.com%2Fnews%2Ftarpon-springs-gears-up-to-celebrate-epiphany%2Farticle_02168946-6da3-11ec-96eb-b399dee05af8.html" class="btn btn-link btn-sm user-control-link" rel="nofollow">Sign Up</a></li><li>
                    <a href="https://www.suncoastnews.com/users/login/?referer_url=https%3A%2F%2Fwww.suncoastnews.com%2Fnews%2Ftarpon-springs-gears-up-to-celebrate-epiphany%2Farticle_02168946-6da3-11ec-96eb-b399dee05af8.html" class="btn btn-primary btn-sm login-btn user-control-link" rel="nofollow">
                        Log In
                    </a></li>
        </ul>
    </div>

    <div class="logged-in">
        
        
            <div class="hide show-offcanvas">
                <ul class="list-inline">
                    <li><a href="https://www.suncoastnews.com/users/admin/" class="btn btn-primary btn-sm login-btn user-control-link">Dashboard</a></li>
                    <li> <a class="btn btn-link btn-sm user-control-link" onclick="document.getElementById('user-logout-form-501437').submit(); return false;" rel="nofollow"> Logout</a></li>
                </ul>
            </div>
        
        <ul class="hide-offcanvas list-inline">
            <li class="dropdown pull-right">
                
                <div class="dropdown-toggle btn btn-link btn-sm user-dropdown" data-toggle="dropdown" data-hover="dropdown" data-hover-delay="250"><div class="tn-user-avatar pull-left"><!-- user avatar --></div><span class="tn-user-screenname pull-left"></span><b class="caret user-control-link"></b>
                </div>
                <ul class="dropdown-menu dropdown-menu-right" role="menu">
                    <li role="presentation" class="dropdown-header">My Account</li>
                    <li role="menuitem"><a href="https://www.suncoastnews.com/users/admin/" rel="nofollow"><i class="fas tnt-tachometer-alt tnt-fw"></i> Dashboard</a></li>
                    <li role="menuitem"><a class="tn-user-profile-url" href="" data-app="https://www.suncoastnews.com/users/"><i class="fas tnt-user tnt-fw"></i> Profile</a></li>
                    <li role="menuitem"><a href="https://www.suncoastnews.com/users/admin/list/" rel="nofollow"><i class="fas tnt-bookmark tnt-fw"></i> Saved items</a></li>
                    <li role="separator" class="divider"></li>
                    <li role="menuitem"><a class="logout-btn" onclick="document.getElementById('user-logout-form-501437').submit(); return false;" rel="nofollow"><i class="fas tnt-power-off tnt-fw"></i> Logout</a></li>
                </ul>
            </li>
        </ul>
    </div>
</div>

<form method="post" action="https://www.suncoastnews.com/users/logout/" id="user-logout-form-501437"><input type="hidden" name="referer_url" value="https://www.suncoastnews.com/news/tarpon-springs-gears-up-to-celebrate-epiphany/article_02168946-6da3-11ec-96eb-b399dee05af8.html"><input type="submit" name="logout" value="Logout" class="hide">
</form></div></div>
                <div id="tncms-region-nav-mobile-nav-right" class="tncms-region-nav"><div id="mobile-nav-right_menu" class="panel-group nav navbar-nav" role="tablist" aria-hidden="true"><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" href="/news/pasco/"  class="nav-link tnt-section-pasco">Pasco</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" href="/news/pinellas/"  class="nav-link tnt-section-pinellas">Pinellas</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" href="/news/hernando/"  class="nav-link tnt-section-hernando">Hernando</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" href="/sports/"  class="nav-link tnt-section-sports">Sports</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" href="/business/"  class="nav-link tnt-section-business">Business</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" href="/classifieds/"  class="nav-link tnt-section-classifieds">Classifieds</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-right_menu-child-7" data-target="#mobile-nav-right_menu-child-7">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a tabindex="-1" aria-hidden="true" href="/local-events/"  class="nav-link tnt-section-local-events">Local Events</a>
                        </div>
                    </div><ul id="mobile-nav-right_menu-child-7" class="collapse nav navbar-nav"><li>
                                    <a tabindex="-1" aria-hidden="true" href="https://new.evvnt.com/?with_navbar&amp;force_snap_sell&amp;partner=SUNCOASTNEWS&amp;publisher_url:suncoastnews.com#/quick"  target="_blank" rel="noopener" class="nav-link tnt-section-promote-your-event">Promote Your Event</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" href="/multimedia/"  class="nav-link tnt-section-multimedia">Multimedia</a>
                        </div>
                    </div></div></div></div>
                
                <div id="tncms-region-mobile-nav-bottom-right-region" class="tncms-region "><div id="tncms-block-501422" class="tncms-block hidden-md hidden-lg"><section id="block-501422" class="block emphasis-h3   " >
    <div class="clearfix"></div>
    <div id="search-form-501422" class="search-form-container card clearfix text-center hidden-print ">
    <form id="site-search-501422" aria-labelledby="site-search-button-501422" action="/search/" method="GET" >
    <input type="hidden" name="l" value="25">
    
        
        <input type="hidden" name="sort" value="relevance">
    
    
    
    
    <input type="hidden" name="f" value="html">
    
        
        <input type="hidden" name="t" value="article,video,youtube,collection">
    
    <input type="hidden" name="app" value="editorial">
    <input type="hidden" name="nsa" value="eedition">
    <div class="site-search-form input-group default normal form-control">
        <input id="site-search-501422-term" name="q" title="Site Search" type="text" placeholder="Search..." class="form-control" autocomplete="off">
        <input type="submit" class="hide" value="Search">
        <span class="input-group-btn">
            <button id="site-search-501422-btn" class="btn btn-link" aria-label="Submit Site Search" type="submit">
                
            </button>
        </span>
    </div>
    <div class="clearfix"></div>
</form>
        
        
        <div class="clearfix"></div>
    </div>
    </section> 

<script>
    $('#site-search-501422-btn').on(__tnt.client.clickEvent, function(){
        $('#site-search-501422').submit();
        return false;
    });

    $('#site-search-501422').on('submit', function(){
        // Filter query
        var sQueryFiltered = $("#site-search-501422 input[name=q]").val().replace(/\?/g, '');
    $("#site-search-501422 input[name=q]").val( sQueryFiltered );

        if( $('#site-search-501422-term').val() ){
            return true;
        }else{
            return false;
        }
    });</script>
</div></div>
            </aside>
        

        <div class="offcanvas-inner">
            <div class="offcanvas-close-btn hidden-md hidden-lg"></div>
    
    
    
    
    <div id="tncms-region-global-skyline" class="tncms-region "></div>
    

    
        <div id="site-top-nav-container" class="hidden-sm hidden-xs hidden-print">
            <header id="site-top-nav" class="container">
                <div class="row">
                    <div id="topbar-col-one" class="col-md-6 col-sm-6"><div id="tncms-region-topbar-col-one" class="tncms-region "></div><div id="tncms-region-nav-topbar-col-one-nav" class="tncms-region-nav"><ul id="topbar-col-one-nav_menu" class="list-inline nav-list" ><li>
                <a class="nav-link   tnt-section-about-us"  href="/site/about.html"  tabindex="0">
                    <span class="nav-label">About Us</span>
                </a></li><li>
                <a class="nav-link   tnt-section-contact-us"  href="/site/contact.html"  tabindex="0">
                    <span class="nav-label">Contact Us</span>
                </a></li><li>
                <a class="nav-link   tnt-section-advertising-information"  href="/advertise/"  tabindex="0">
                    <span class="nav-label">Advertising Information</span>
                </a></li><li>
                <a class="nav-link   tnt-section-subscribe"  href="/site/forms/subscription_services/"  tabindex="0">
                    <span class="nav-label">Subscribe</span>
                </a></li></ul></div></div>
    <div id="topbar-col-two" class="col-md-6 col-sm-6"><div id="tncms-region-topbar-col-two" class="tncms-region "><div id="tncms-block-501436" class="tncms-block"><div id="user-controls-501436" class="user-controls show-onload clearfix pull-right"><div class="not-logged-in">
        <ul class="list-inline"><li><a href="https://www.suncoastnews.com/users/signup/?referer_url=https%3A%2F%2Fwww.suncoastnews.com%2Fnews%2Ftarpon-springs-gears-up-to-celebrate-epiphany%2Farticle_02168946-6da3-11ec-96eb-b399dee05af8.html" class="btn btn-link btn-sm user-control-link" rel="nofollow">Sign Up</a></li><li>
                    <a href="https://www.suncoastnews.com/users/login/?referer_url=https%3A%2F%2Fwww.suncoastnews.com%2Fnews%2Ftarpon-springs-gears-up-to-celebrate-epiphany%2Farticle_02168946-6da3-11ec-96eb-b399dee05af8.html" class="btn btn-primary btn-sm login-btn user-control-link" rel="nofollow">
                        Log In
                    </a></li>
        </ul>
    </div>

    <div class="logged-in">
        
        
            <div class="hide show-offcanvas">
                <ul class="list-inline">
                    <li><a href="https://www.suncoastnews.com/users/admin/" class="btn btn-primary btn-sm login-btn user-control-link">Dashboard</a></li>
                    <li> <a class="btn btn-link btn-sm user-control-link" onclick="document.getElementById('user-logout-form-501436').submit(); return false;" rel="nofollow"> Logout</a></li>
                </ul>
            </div>
        
        <ul class="hide-offcanvas list-inline">
            <li class="dropdown pull-right">
                
                <div class="dropdown-toggle btn btn-link btn-sm user-dropdown" data-toggle="dropdown" data-hover="dropdown" data-hover-delay="250"><div class="tn-user-avatar pull-left"><!-- user avatar --></div><span class="tn-user-screenname pull-left"></span><b class="caret user-control-link"></b>
                </div>
                <ul class="dropdown-menu dropdown-menu-right" role="menu">
                    <li role="presentation" class="dropdown-header">My Account</li>
                    <li role="menuitem"><a href="https://www.suncoastnews.com/users/admin/" rel="nofollow"><i class="fas tnt-tachometer-alt tnt-fw"></i> Dashboard</a></li>
                    <li role="menuitem"><a class="tn-user-profile-url" href="" data-app="https://www.suncoastnews.com/users/"><i class="fas tnt-user tnt-fw"></i> Profile</a></li>
                    <li role="menuitem"><a href="https://www.suncoastnews.com/users/admin/list/" rel="nofollow"><i class="fas tnt-bookmark tnt-fw"></i> Saved items</a></li>
                    <li role="separator" class="divider"></li>
                    <li role="menuitem"><a class="logout-btn" onclick="document.getElementById('user-logout-form-501436').submit(); return false;" rel="nofollow"><i class="fas tnt-power-off tnt-fw"></i> Logout</a></li>
                </ul>
            </li>
        </ul>
    </div>
</div>

<form method="post" action="https://www.suncoastnews.com/users/logout/" id="user-logout-form-501436"><input type="hidden" name="referer_url" value="https://www.suncoastnews.com/news/tarpon-springs-gears-up-to-celebrate-epiphany/article_02168946-6da3-11ec-96eb-b399dee05af8.html"><input type="submit" name="logout" value="Logout" class="hide">
</form></div><div id="tncms-block-501423" class="tncms-block"><div class="follow-links-501423 pull-right">
    
    <section id="block-501423" class="block emphasis-h3   " ><ul class="list-inline">
        
            <li>
                <a href="http://facebook.com/SuncoastNews/" title="Facebook" target="_blank" rel="noopener" class="btn btn-xs btn-link fb" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-facebook-f"></i>
                    <span class="sr-only">Facebook</span>
                </a>
            </li>
        
        
            <li>
                <a href="http://twitter.com/SuncoastNews/" title="Twitter" target="_blank" rel="noopener" class="btn btn-xs btn-link tw" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-twitter"></i>
                    <span class="sr-only">Twitter</span>
                </a>
            </li>
        
        
        
            <li>
                <a href="http://www.youtube.com/user/SCNPasco" title="Youtube" target="_blank" rel="noopener" class="btn btn-xs btn-link yt" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-youtube"></i>
                    <span class="sr-only">YouTube</span>
                </a>
            </li>
        
        
        
        
        
        
        
        
        
        
        
        
        
        
    </ul>
    </section>
</div>
<script type="application/ld+json">
{ "@context" : "https://schema.org",
  "@type" : "Organization",
  "url" : "http://www.suncoastnews.com",
  "sameAs" : ["http://facebook.com/SuncoastNews/","http://twitter.com/SuncoastNews/","http://www.youtube.com/user/SCNPasco"]
}
</script>
<div class="clearfix"></div></div></div></div>
                </div>
            </header>
        </div>
    

    
        <div id="site-header-container" class="hidden-sm hidden-xs hidden-print">
            <header id="site-header" class="container" role="banner">
                
                <div class="row">
                    <div id="masthead-full-top" class="col-lg-12"><div id="tncms-region-masthead-full-top" class="tncms-region "></div></div>
                </div>
                <div class="row">
                    
                    <div id="masthead-col-one" class="col-md-4 col-sm-4"><div id="tncms-region-masthead-col-one" class="tncms-region "><div id="tncms-block-501413" class="tncms-block sn-logo-block"><section id="block-501413" class="block emphasis-h3   " ><div class="block"><a href="/" rel="nofollow" >
            <img 
                
                src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg==" 
                data-srcset="https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/custom/image/8f3f1b20-711f-11e6-9722-db0c86971413.jpg?resize=150%2C26 150w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/custom/image/8f3f1b20-711f-11e6-9722-db0c86971413.jpg?resize=200%2C34 200w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/custom/image/8f3f1b20-711f-11e6-9722-db0c86971413.jpg?resize=225%2C38 225w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/custom/image/8f3f1b20-711f-11e6-9722-db0c86971413.jpg?resize=300%2C51 300w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/custom/image/8f3f1b20-711f-11e6-9722-db0c86971413.jpg?resize=400%2C68 400w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/custom/image/8f3f1b20-711f-11e6-9722-db0c86971413.jpg?resize=540%2C92 540w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/custom/image/8f3f1b20-711f-11e6-9722-db0c86971413.jpg?resize=640%2C109 640w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/custom/image/8f3f1b20-711f-11e6-9722-db0c86971413.jpg 750w" 
                data-sizes="auto" 
                class=" img-responsive lazyload tnt-prop-img"
                width="750"
                height="128"
                alt=""></a></div></section></div></div></div>
    <div id="masthead-col-two" class="col-md-4 col-sm-4"><div id="tncms-region-masthead-col-two" class="tncms-region "><div id="tncms-block-501439" class="tncms-block"><div id="weather-501439" class="weather-current size-medium pull-right">
    <ul class="list-unstyled">
        <li class="current-conditions dropdown">
            <a href="/weather/?weather_zip=34668" class="dropdown-toggle" data-toggle="dropdown" data-hover="dropdown" data-hover-delay="250">
                <span class="icon pull-left">
                    
                    <span class="fas tnt-wi-night-cloudy"></span>
                </span>
                <span class="pull-left temp-desc medium">
                    <span class="temp">59&deg;</span>
                    
                        <span class="cond">Cloudy <i class="fas tnt-caret-down"></i></span>
                    
                </span>
                <span class="clearfix"></span>
            </a>
            
                <ul class="dropdown-menu" role="menu">
                    <li role="presentation">
                        <div class="weather-expanded">
                            <form action="/weather/" class="zip-update-form form-inline" method="get">
                                <input type="text" class="zip-update form-control" name="weather_zip" title="Weather ZIP Code" value="34668"> <input class="btn btn-primary" type="submit" value="GO">
                            </form>

                            <a id="weather_zip_toggle_501439" class="pull-right zip-update-link" aria-label="weather_zip_toggle"><span class="fas tnt-cog"></span></a><h4 class="city-title"><i class="fas tnt-map-marker-alt"></i>
                                
                                    Port Richey, FL
                                
                                 <small>(34668)</small>
                            </h4>
                            <h5>Today</h5>
                            <p>Partly cloudy. High 71F. Winds NW at 5 to 10 mph..</p>
                            <h5>Tonight</h5>
                            <p>A few clouds from time to time. Low 51F. Winds light and variable.</p>
                            <p class="text-center"><small><i class="fas tnt-info-circle"></i> Updated: January 5, 2022 @ 2:30 am</small></p>
                        </div>
                    </li>
                    <li role="separator" class="divider"></li>
                    <li role="menuitem" class="forecast-link text-center"><a href="/weather/?weather_zip=34668"><i class="fas tnt-caret-right"></i> Full Forecast</a></li>
                </ul>
            
        </li>
    </ul>
</div>

    <div class="clearfix"></div>
</div><div id="tncms-block-598965" class="tncms-block visible-lg visible-md hidden-sm hidden xs">
        <div id="blox-ad-position-micro-bar1" data-tnt-ads='{"vendor":"blox","type":"position","display":"default","region":"micro-bar","slot":"1","fold":"above","width":"88","js":{"video":"https:\/\/bloximages.newyork1.vip.townnews.com\/suncoastnews.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":"","refresh":false}' class="blox-ad tnt-ads-container ">
        
        </div></div></div></div>
    <div id="masthead-col-three" class="col-md-4 col-sm-4"><div id="tncms-region-masthead-col-three" class="tncms-region "><div id="tncms-block-501420" class="tncms-block"><section id="block-501420" class="block emphasis-h3   " >
    <div class="clearfix"></div>
    <div id="search-form-501420" class="search-form-container card clearfix text-center hidden-print well">
    <form id="site-search-501420" aria-labelledby="site-search-button-501420" action="/search/" method="GET" >
    <input type="hidden" name="l" value="25">
    
        
        <input type="hidden" name="sort" value="relevance">
    
    
    
    
    <input type="hidden" name="f" value="html">
    
        
        <input type="hidden" name="t" value="article,video,youtube,collection">
    
    <input type="hidden" name="app" value="editorial">
    <input type="hidden" name="nsa" value="eedition">
    <div class="site-search-form input-group pull-right input-group-lg ">
        <input id="site-search-501420-term" name="q" title="Site Search" type="text" placeholder="Search..." class="form-control" autocomplete="off">
        <input type="submit" class="hide" value="Search">
        <span class="input-group-btn">
            <button id="site-search-501420-btn" class="btn btn-primary" aria-label="Submit Site Search" type="submit">
                
	                <span class="hidden-xl hidden-lg hidden-md fas tnt-search"></span>
	                <span id="site-search-button-501420" class="hidden-xs hidden-sm">Search</span>
                
            </button>
        </span>
    </div>
    <div class="clearfix"></div>
</form>
        
        
        <div class="clearfix"></div>
    </div>
    </section> 

<script>
    $('#site-search-501420-btn').on(__tnt.client.clickEvent, function(){
        $('#site-search-501420').submit();
        return false;
    });

    $('#site-search-501420').on('submit', function(){
        // Filter query
        var sQueryFiltered = $("#site-search-501420 input[name=q]").val().replace(/\?/g, '');
    $("#site-search-501420 input[name=q]").val( sQueryFiltered );

        if( $('#site-search-501420-term').val() ){
            return true;
        }else{
            return false;
        }
    });</script>
</div></div></div>
                </div>
                <div class="row">
                    <div id="masthead-full-bottom" class="col-lg-12"><div id="tncms-region-masthead-full-bottom" class="tncms-region "></div></div>
                </div>
                
            </header>
        </div>
    

    
    
        <div id="site-navbar-container" class="hidden-print affix-top">
            
            <nav id="main-navigation" class="navbar yamm navbar-default container navbar-static">
                
                
                <div class="navbar-header">
                    
                    
                    
                        <button  type="button" class="visible-sm visible-xs navbar-toggle pull-right" data-toggle="offcanvas" data-target="right" aria-label="Right Main Menu" aria-expanded="false" >
                            <span class="sr-only">Toggle navigation</span>
                            <span class="icon-bar"></span>
                            <span class="icon-bar"></span>
                            <span class="icon-bar"></span>
                        </button>

                    

                    
                        <div class="navbar-brand hidden-md hidden-lg pos_right">
                            
                                <div id="tncms-region-main-nav-brand" class="tncms-region "><div id="tncms-block-501414" class="tncms-block"><section id="block-501414" class="block emphasis-h3   " ><div class="block"><a href="/" rel="nofollow" >
            <img 
                
                src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg==" 
                data-srcset="https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/custom/image/5f885670-7120-11e6-9fb9-e751a398bc1e.jpg?resize=150%2C64 150w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/custom/image/5f885670-7120-11e6-9fb9-e751a398bc1e.jpg?resize=200%2C86 200w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/custom/image/5f885670-7120-11e6-9fb9-e751a398bc1e.jpg?resize=225%2C96 225w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/custom/image/5f885670-7120-11e6-9fb9-e751a398bc1e.jpg?resize=300%2C128 300w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/custom/image/5f885670-7120-11e6-9fb9-e751a398bc1e.jpg?resize=400%2C171 400w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/custom/image/5f885670-7120-11e6-9fb9-e751a398bc1e.jpg?resize=540%2C231 540w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/custom/image/5f885670-7120-11e6-9fb9-e751a398bc1e.jpg?resize=640%2C274 640w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/custom/image/5f885670-7120-11e6-9fb9-e751a398bc1e.jpg 750w" 
                data-sizes="auto" 
                class=" img-responsive lazyload tnt-prop-img"
                width="750"
                height="321"
                alt=""></a></div></section></div></div>
                            
                        </div>
                    

                    
                </div>

                
                    <div id="navbar-collapse" class="navbar-collapse collapse">
                        
                            <div class="pull-right">
                                <div id="tncms-region-main-nav-right-region" class="tncms-region "></div>
                                
                            </div>
                        
                        <div class="navbar-left">
                            <div id="tncms-region-nav-main-nav" class="tncms-region-nav"><ul id="main-nav_menu" class="nav navbar-nav" role="navigation" aria-label="Main"><li>
                <a class="nav-link   tnt-section-pasco"  href="/news/pasco/"  tabindex="0">
                    <span class="nav-label">Pasco</span>
                </a></li><li>
                <a class="nav-link   tnt-section-pinellas"  href="/news/pinellas/"  tabindex="0">
                    <span class="nav-label">Pinellas</span>
                </a></li><li>
                <a class="nav-link   tnt-section-hernando"  href="/news/hernando/"  tabindex="0">
                    <span class="nav-label">Hernando</span>
                </a></li><li>
                <a class="nav-link   tnt-section-sports"  href="/sports/"  tabindex="0">
                    <span class="nav-label">Sports</span>
                </a></li><li>
                <a class="nav-link   tnt-section-business"  href="/business/"  tabindex="0">
                    <span class="nav-label">Business</span>
                </a></li><li>
                <a class="nav-link   tnt-section-classifieds"  href="/classifieds/"  tabindex="0">
                    <span class="nav-label">Classifieds</span>
                </a></li><li class="dropdown" aria-expanded="false">
                <a class="nav-link  dropdown-toggle  tnt-section-local-events"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/local-events/"  tabindex="0">
                    <span class="nav-label">Local Events</span>
                </a><ul id="main-nav_menu-child-7" class="dropdown-menu" ><li>
                <a class="nav-link   tnt-section-promote-your-event"  href="https://new.evvnt.com/?with_navbar&amp;force_snap_sell&amp;partner=SUNCOASTNEWS&amp;publisher_url:suncoastnews.com#/quick"  target="_blank" rel="noopener" tabindex="0">
                    <span class="nav-label">Promote Your Event</span>
                </a></li></ul></li><li>
                <a class="nav-link   tnt-section-multimedia"  href="/multimedia/"  tabindex="0">
                    <span class="nav-label">Multimedia</span>
                </a></li></ul></div>
                        </div>
                    </div>
                

                
            </nav>
            
            
        </div>
        
            
        
    
    
    <div id="main-body-container">
    <section id="main-top-container" class="container-fullscreen-region container-fluid">
        
        <div class="fullscreen-region"><div id="tncms-region-global-container-top-fullscreen" class="tncms-region "></div></div>
    </section>
    <section id="main-page-container" class="container">
        <div class="row">
                <div id="asset-container-top" class="col-md-12"><div id="tncms-region-asset_container_top" class="tncms-region hidden-print"></div></div>
            
            <div class="col-md-12"><div id="tncms-region-global-container-top" class="tncms-region "><div id="tncms-block-501337" class="tncms-block hidden-xs">
        <div id="blox-ad-position-block-leaderboard-top1" data-tnt-ads='{"vendor":"blox","type":"position","display":"default","region":"block-leaderboard-top","slot":"1","fold":"above","width":"728","js":{"video":"https:\/\/bloximages.newyork1.vip.townnews.com\/suncoastnews.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":"","refresh":false}' class="blox-ad tnt-ads-container ">
        
        </div></div></div></div>
        </div><div class="modal fullscreen" id="photo-carousel-02168946-6da3-11ec-96eb-b399dee05af8" tabindex="-1" role="dialog" aria-labelledby="photo-carousel-02168946-6da3-11ec-96eb-b399dee05af8" aria-hidden="true">
        <div class="modal-dialog modal-lg">
            <div class="modal-content">
                <div class="modal-body">
                    <button type="button" class="close" data-dismiss="modal">
                        <span aria-hidden="true" class="control-left fas tnt-times-circle"></span>
                        <span class="sr-only">Close</span>
                    </button>
                    
    <div id="carousel-02168946-6da3-11ec-96eb-b399dee05af8-photo-modal" class="card photo-carousel    subscriber-hide letterbox-style-default">
            
            <div class="photo-carousel-control-container">
                    <span class="photo-count">
                        <span class="current-count">1</span> of 2
                    </span>
                    <a class="photo-carousel-control left noselect hidden-print"><span class="control-left fas tnt-chevron-left"></span></a>
                    <a class="photo-carousel-control right noselect hidden-print"><span class="control-left fas tnt-chevron-right"></span></a>
            </div>
            
            <div id="gallery-items-02168946-6da3-11ec-96eb-b399dee05af8-photo-modal" class="carousel-inner"><div  class="item photo-5be84fb8-6da3-11ec-b84a-47a13e9128b4">
                            <div class="item-container">
                                <div data-track-object='{"title":"Tarpon Springs gears up to celebrate Epiphany","url":"/news/tarpon-springs-gears-up-to-celebrate-epiphany/article_02168946-6da3-11ec-96eb-b399dee05af8.html","uuid":"02168946-6da3-11ec-96eb-b399dee05af8","app":"editorial","metric":""}'  data-count="1"  class="photo-container layout-horizontal"><div class="loading-slide text-center"><i class="fas tnt-spinner tnt-spin"></i></div>
                                        
                                        
                                        
                                        
        
                <img
                    src="https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/5/be/5be84fb8-6da3-11ec-b84a-47a13e9128b4/61d4b8cd11bbd.image.jpg?resize=1200%2C960"
                    
                    alt="PI-EpiphanyAdv1-010521.jpg"
                    class="img-responsive owl-first-image owl-lazy default"
                    width="1609"
                    height="1287"
                    data-src="https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/5/be/5be84fb8-6da3-11ec-b84a-47a13e9128b4/61d4b8cd11bbd.image.jpg?resize=1200%2C960" />
                                        
                                        
                                </div>
        <div class="caption-container">
                <span class="pull-right photo-carousel-caption-toggle" data-toggle="collapse" data-instance="#carousel-02168946-6da3-11ec-96eb-b399dee05af8-photo-modal" data-target=".caption-inner-02168946-6da3-11ec-96eb-b399dee05af8-photo-modal">
                    <i class="fas tnt-minus-circle"></i>
                </span>
            <div class="caption-inner-02168946-6da3-11ec-96eb-b399dee05af8-photo-modal collapse in"><div class="caption-text"><p>The Epiphany statue stands tall outside St. Nicholas Greek Orthodox Cathedral.</p></div><div class="card-meta">
                        <ul class="list-inline">
                                    
                                    
                                        <li class="credit"><span  class="tnt-byline">JEFF ROSENFIELD</span></li>
                                    
                                
                            
                        </ul>
                    </div>
                    <div class="photo-share">
                        <ul class="social-share-links hidden-print list-inline icon"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.suncoastnews.com%2Fpi-epiphanyadv1-010521-jpg%2Fimage_5be84fb8-6da3-11ec-b84a-47a13e9128b4.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/pi-epiphanyadv1-010521-jpg/image_5be84fb8-6da3-11ec-b84a-47a13e9128b4.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"5be84fb8-6da3-11ec-b84a-47a13e9128b4"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=PI-EpiphanyAdv1-010521.jpg&via=SuncoastNews&url=https%3A%2F%2Fwww.suncoastnews.com%2Fpi-epiphanyadv1-010521-jpg%2Fimage_5be84fb8-6da3-11ec-b84a-47a13e9128b4.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/pi-epiphanyadv1-010521-jpg/image_5be84fb8-6da3-11ec-b84a-47a13e9128b4.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"5be84fb8-6da3-11ec-b84a-47a13e9128b4"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=https://www.suncoastnews.com/pi-epiphanyadv1-010521-jpg/image_5be84fb8-6da3-11ec-b84a-47a13e9128b4.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/pi-epiphanyadv1-010521-jpg/image_5be84fb8-6da3-11ec-b84a-47a13e9128b4.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"5be84fb8-6da3-11ec-b84a-47a13e9128b4"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-whatsapp tnt-stack-1x"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.suncoastnews.com/tncms/asset/editorial/5be84fb8-6da3-11ec-b84a-47a13e9128b4" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-image","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"5be84fb8-6da3-11ec-b84a-47a13e9128b4"}'  rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5Bsuncoastnews.com%5D%20PI-EpiphanyAdv1-010521.jpg&body=https%3A%2F%2Fwww.suncoastnews.com%2Fpi-epiphanyadv1-010521-jpg%2Fimage_5be84fb8-6da3-11ec-b84a-47a13e9128b4.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-image","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"5be84fb8-6da3-11ec-b84a-47a13e9128b4"}'  rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li><li class="social-share-link pr">
                <a href="javascript:window.print()" class="pr" title="Print" data-track='{"network":"Print","socialAction":"print","url":"/pi-epiphanyadv1-010521-jpg/image_5be84fb8-6da3-11ec-b84a-47a13e9128b4.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"5be84fb8-6da3-11ec-b84a-47a13e9128b4"}'  rel="nofollow">
                    <span class="tnt-stack" >
                        
                        <i class="fas tnt-print tnt-stack-1x"></i>
                    </span>
                    <span class="sr-only">Print</span>
                </a>
            </li><li class="social-share-link sv">
        <a class="save-list-5be84fb8-6da3-11ec-b84a-47a13e9128b4-btn save-asset " title="Save to list" href="#"  role="button" rel="nofollow" data-asset-uuid="5be84fb8-6da3-11ec-b84a-47a13e9128b4" >
            
                <span class="tnt-stack">
                    
                    <i class="asset-save-icon far tnt-bookmark tnt-stack-1x "></i>
                </span>
            
            
                <span class="sr-only">Save</span>
            
        </a>
        </li>
        
    </ul><form method="post" data-uuid="5be84fb8-6da3-11ec-b84a-47a13e9128b4" class="save-list-5be84fb8-6da3-11ec-b84a-47a13e9128b4-form save-asset-to-list" action="/users/admin/list/">
        <input type="hidden" name="action" value="addasset" />
        <input type="hidden" name="format" value="json" />
        <input type="hidden" name="listasset" value="5be84fb8-6da3-11ec-b84a-47a13e9128b4" />
        <input type="hidden" name="listapp" value="editorial" />
        <input type="hidden" name="autocreate" value="true" />
        <input type="hidden" name="listname" value="images" />
        <input class="hide" type="submit" name="submit" value="Save" />
    </form>

                    </div>
            </div>
        </div>
    <div class="clearfix"></div>
                            </div>
                        </div><div  class="item photo-5c9d4b52-6da3-11ec-93c9-f3576d920589">
                            <div class="item-container">
                                <div data-track-object='{"title":"Tarpon Springs gears up to celebrate Epiphany","url":"/news/tarpon-springs-gears-up-to-celebrate-epiphany/article_02168946-6da3-11ec-96eb-b399dee05af8.html","uuid":"02168946-6da3-11ec-96eb-b399dee05af8","app":"editorial","metric":""}'  data-count="2"  class="photo-container layout-horizontal"><div class="loading-slide text-center"><i class="fas tnt-spinner tnt-spin"></i></div>
                                        
                                        
                                        
                                        
        
                <img
                    src="https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/5/c9/5c9d4b52-6da3-11ec-93c9-f3576d920589/61d4b8ce3f0d3.image.jpg?resize=1200%2C968"
                    
                    alt="PI-EpiphanyAdv2-010521.jpg"
                    class="img-responsive owl-first-image owl-lazy default"
                    width="1602"
                    height="1292"
                    data-src="https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/5/c9/5c9d4b52-6da3-11ec-93c9-f3576d920589/61d4b8ce3f0d3.image.jpg?resize=1200%2C968" />
                                        
                                        
                                </div>
        <div class="caption-container">
                <span class="pull-right photo-carousel-caption-toggle" data-toggle="collapse" data-instance="#carousel-02168946-6da3-11ec-96eb-b399dee05af8-photo-modal" data-target=".caption-inner-02168946-6da3-11ec-96eb-b399dee05af8-photo-modal">
                    <i class="fas tnt-minus-circle"></i>
                </span>
            <div class="caption-inner-02168946-6da3-11ec-96eb-b399dee05af8-photo-modal collapse in"><div class="caption-text"><p>The Epiphany divers head for the splash the cross made as it hit the water of Spring Bayou.</p><p></p></div><div class="card-meta">
                        <ul class="list-inline">
                                    
                                    
                                        <li class="credit"><span  class="tnt-byline">File photos by JEFF ROSENFIELD</span></li>
                                    
                                
                            
                        </ul>
                    </div>
                    <div class="photo-share">
                        <ul class="social-share-links hidden-print list-inline icon"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.suncoastnews.com%2Fpi-epiphanyadv2-010521-jpg%2Fimage_5c9d4b52-6da3-11ec-93c9-f3576d920589.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/pi-epiphanyadv2-010521-jpg/image_5c9d4b52-6da3-11ec-93c9-f3576d920589.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"5c9d4b52-6da3-11ec-93c9-f3576d920589"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=PI-EpiphanyAdv2-010521.jpg&via=SuncoastNews&url=https%3A%2F%2Fwww.suncoastnews.com%2Fpi-epiphanyadv2-010521-jpg%2Fimage_5c9d4b52-6da3-11ec-93c9-f3576d920589.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/pi-epiphanyadv2-010521-jpg/image_5c9d4b52-6da3-11ec-93c9-f3576d920589.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"5c9d4b52-6da3-11ec-93c9-f3576d920589"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=https://www.suncoastnews.com/pi-epiphanyadv2-010521-jpg/image_5c9d4b52-6da3-11ec-93c9-f3576d920589.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/pi-epiphanyadv2-010521-jpg/image_5c9d4b52-6da3-11ec-93c9-f3576d920589.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"5c9d4b52-6da3-11ec-93c9-f3576d920589"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-whatsapp tnt-stack-1x"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.suncoastnews.com/tncms/asset/editorial/5c9d4b52-6da3-11ec-93c9-f3576d920589" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-image","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"5c9d4b52-6da3-11ec-93c9-f3576d920589"}'  rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5Bsuncoastnews.com%5D%20PI-EpiphanyAdv2-010521.jpg&body=https%3A%2F%2Fwww.suncoastnews.com%2Fpi-epiphanyadv2-010521-jpg%2Fimage_5c9d4b52-6da3-11ec-93c9-f3576d920589.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-image","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"5c9d4b52-6da3-11ec-93c9-f3576d920589"}'  rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li><li class="social-share-link pr">
                <a href="javascript:window.print()" class="pr" title="Print" data-track='{"network":"Print","socialAction":"print","url":"/pi-epiphanyadv2-010521-jpg/image_5c9d4b52-6da3-11ec-93c9-f3576d920589.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"5c9d4b52-6da3-11ec-93c9-f3576d920589"}'  rel="nofollow">
                    <span class="tnt-stack" >
                        
                        <i class="fas tnt-print tnt-stack-1x"></i>
                    </span>
                    <span class="sr-only">Print</span>
                </a>
            </li><li class="social-share-link sv">
        <a class="save-list-5c9d4b52-6da3-11ec-93c9-f3576d920589-btn save-asset " title="Save to list" href="#"  role="button" rel="nofollow" data-asset-uuid="5c9d4b52-6da3-11ec-93c9-f3576d920589" >
            
                <span class="tnt-stack">
                    
                    <i class="asset-save-icon far tnt-bookmark tnt-stack-1x "></i>
                </span>
            
            
                <span class="sr-only">Save</span>
            
        </a>
        </li>
        
    </ul><form method="post" data-uuid="5c9d4b52-6da3-11ec-93c9-f3576d920589" class="save-list-5c9d4b52-6da3-11ec-93c9-f3576d920589-form save-asset-to-list" action="/users/admin/list/">
        <input type="hidden" name="action" value="addasset" />
        <input type="hidden" name="format" value="json" />
        <input type="hidden" name="listasset" value="5c9d4b52-6da3-11ec-93c9-f3576d920589" />
        <input type="hidden" name="listapp" value="editorial" />
        <input type="hidden" name="autocreate" value="true" />
        <input type="hidden" name="listname" value="images" />
        <input class="hide" type="submit" name="submit" value="Save" />
    </form>

                    </div>
            </div>
        </div>
    <div class="clearfix"></div>
                            </div>
                        </div>
            </div>
        </div>
                    <div class="clearfix"></div>
                </div>
            </div>
        </div>
    </div><article itemscope itemtype="https://schema.org/Article" id="asset-02168946-6da3-11ec-96eb-b399dee05af8" class="asset article-default"  data-url="https://www.suncoastnews.com/news/tarpon-springs-gears-up-to-celebrate-epiphany/article_02168946-6da3-11ec-96eb-b399dee05af8.html">
    <span itemscope itemtype="http://schema.org/SpeakableSpecification">
        <meta itemprop="cssSelector" content=".asset-header .headline" />
        <meta itemprop="cssSelector" content=".asset-content p:first-of-type" />
    </span>
    <meta itemprop="description" content="<p>This year, organizers of the 116th edition of Epiphany promise the event will return to its full-scale glory.</p>"/><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
        <div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
            <meta itemprop="url" content="https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/5/be/5be84fb8-6da3-11ec-b84a-47a13e9128b4/61d4b8cd11bbd.image.jpg?crop=1609%2C845%2C0%2C221&resize=1200%2C630&order=crop%2Cresize">
            <meta itemprop="width" content="1200">
            <meta itemprop="height" content="630">
        </div>
        <meta itemprop="name" content="suncoastnews.com">
    </div>
    <link itemprop="mainEntityOfPage" href="https://www.suncoastnews.com/news/tarpon-springs-gears-up-to-celebrate-epiphany/article_02168946-6da3-11ec-96eb-b399dee05af8.html" />
    <style>
                .asset-paging .direction {
                    color: #005296;
                }
            </style><div class="asset-paging-container hidden-print" data-settings='{"assetType":"article","hasPageBreak":false,"isObit":false,"nextUrl":"https:\/\/www.suncoastnews.com\/tncms\/search\/mlt\/?origin=02168946-6da3-11ec-96eb-b399dee05af8&app=editorial&preview=1&type=article%2Ccollection%2Cvideo%2Cyoutube","uuid":"02168946-6da3-11ec-96eb-b399dee05af8","isFluid":false,"isAdminVenue":false}'>
            <div id="asset-paging-02168946-6da3-11ec-96eb-b399dee05af8" class="asset-paging">
                <div id="paging-prev-02168946-6da3-11ec-96eb-b399dee05af8" class="paging-link prev offset"></div>
                <div id="paging-next-02168946-6da3-11ec-96eb-b399dee05af8" class="paging-link next offset"></div>
                <div class="clearfix"></div>
            </div>
        </div>
        <template id="asset-paging-template">
            <a class="animate arrow text-center">
                <span class=""></span>
                <span class="animate direction hidden-sm hidden-xs text-primary"></span>
            </a>
            <div class="animate item">
                <div class="dismiss" onclick="document.body.classList.add('trigger-disabled'); document.body.classList.remove('trigger-next'); return false;">
                    <span class="tnt-stack" aria-hidden="true">
                        <i class="fas tnt-circle tnt-inverse tnt-stack-1x"></i>
                        <i class="fas tnt-times-circle tnt-stack-1x"></i>
                    </span>
                </div>
                <div class="inner">
                    <a class="overlay">
                        <span class="sr-only"></span>
                    </a>
                    <div class="head text-uppercase">
                        <small></small>
                    </div>
                    <div class="media">
                        <div class="media-body">
                            <h6 class="media-heading"></h6>
                            <p class="hidden-xs"></p>
                        </div>
                    </div>
                    <div class="clearfix"></div>
                </div>
            </div>
        </template><div class="asset-masthead ">
        <header class="asset-header">
    <div class="tow-wrapper has-flags">
        
            <div class="asset-label-flags has-work">
                <span class="tnt-flag label label-flag label-flag-default label-flag-featured">featured</span> 
            </div>
        
        
    </div>
    <h1 itemprop="headline" class="headline">
        <span>
            
            Tarpon Springs gears up to celebrate Epiphany
        </span>
    </h1>
    <h2 itemprop="alternativeHeadline" class="subhead">
            <span>116th annual Epiphany celebration will feature a series of events, highlighted by the cross dive in Spring Bayou on Thursday, Jan. 6.</span>
        </h2><div class="meta">
        <span>
            <ul class="list-inline">
        <li><span itemprop="author" class="tnt-byline">By Jeff Rosenfield, Tampa Bay Newspapers</span></li>
        
        
            <li class="visible-print">
        <time datetime="2022-01-04T16:12:00-05:00" class="tnt-date asset-date text-muted">
            Jan 4, 2022
        </time></li>
            <li class="hidden-print"><time datetime="2022-01-04T16:12:00-05:00" class="tnt-date asset-date text-muted">Jan 4, 2022</time>
        <span class="text-muted tnt-update-recent">Updated </span>
        <time datetime="2022-01-04T16:26:05-05:00" class="tnt-date tnt-update-recent asset-date text-muted">10 hrs ago</time>
    </li>
        
        
            <li class="hidden-print"></li>
        
        
    </ul>
        </span>
    </div>
    <meta itemprop="dateCreated" content="2022-01-04T16:12:00-05:00">
    <meta itemprop="datePublished" content="2022-01-04T16:12:00-05:00">
    <meta itemprop="dateModified" content="2022-01-04T11:26:05-05:00">
</header>
        
        
            <div class="share-container headline-right pull-right hidden-xs" data-subscription-required-remove><ul class="social-share-links hidden-print list-unstyled stacked icon"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.suncoastnews.com%2Fnews%2Ftarpon-springs-gears-up-to-celebrate-epiphany%2Farticle_02168946-6da3-11ec-96eb-b399dee05af8.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/news/tarpon-springs-gears-up-to-celebrate-epiphany/article_02168946-6da3-11ec-96eb-b399dee05af8.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"02168946-6da3-11ec-96eb-b399dee05af8"}' >
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="Share">
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=Tarpon%20Springs%20gears%20up%20to%20celebrate%20Epiphany&via=SuncoastNews&url=https%3A%2F%2Fwww.suncoastnews.com%2Fnews%2Ftarpon-springs-gears-up-to-celebrate-epiphany%2Farticle_02168946-6da3-11ec-96eb-b399dee05af8.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/news/tarpon-springs-gears-up-to-celebrate-epiphany/article_02168946-6da3-11ec-96eb-b399dee05af8.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"02168946-6da3-11ec-96eb-b399dee05af8"}' >
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="Tweet">
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=https://www.suncoastnews.com/news/tarpon-springs-gears-up-to-celebrate-epiphany/article_02168946-6da3-11ec-96eb-b399dee05af8.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/news/tarpon-springs-gears-up-to-celebrate-epiphany/article_02168946-6da3-11ec-96eb-b399dee05af8.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"02168946-6da3-11ec-96eb-b399dee05af8"}' >
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="WhatsApp">
                    
                    <i class="fab tnt-whatsapp tnt-stack-1x"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.suncoastnews.com/tncms/asset/editorial/02168946-6da3-11ec-96eb-b399dee05af8" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"02168946-6da3-11ec-96eb-b399dee05af8"}'  rel="nofollow">
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="SMS">
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5Bsuncoastnews.com%5D%20Tarpon%20Springs%20gears%20up%20to%20celebrate%20Epiphany&body=https%3A%2F%2Fwww.suncoastnews.com%2Fnews%2Ftarpon-springs-gears-up-to-celebrate-epiphany%2Farticle_02168946-6da3-11ec-96eb-b399dee05af8.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"02168946-6da3-11ec-96eb-b399dee05af8"}'  rel="nofollow">
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="Email">
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li></ul></div>
        
    </div>

    

    <div class="row">
        <div class="main-content col-lg-8 col-md-7 has-sidebar"><div class="main-content-wrap">
            <div id="tncms-region-article_top" class="tncms-region hidden-print"></div>
            
            <div id="asset-photo-carousel">
    <div id="carousel-02168946-6da3-11ec-96eb-b399dee05af8" class="card photo-carousel    subscriber-hide letterbox-style-default">
            
            <div class="photo-carousel-control-container">
                    <span class="photo-count">
                        <span class="current-count">1</span> of 2
                    </span>
                    <a class="photo-carousel-control left noselect hidden-print"><span class="control-left fas tnt-chevron-left"></span></a>
                    <a class="photo-carousel-control right noselect hidden-print"><span class="control-left fas tnt-chevron-right"></span></a>
            </div>
            
            <div id="gallery-items-02168946-6da3-11ec-96eb-b399dee05af8" class="carousel-inner"><div  class="item photo-5be84fb8-6da3-11ec-b84a-47a13e9128b4">
                            <div class="item-container">
                                <div data-track-object='{"title":"Tarpon Springs gears up to celebrate Epiphany","url":"/news/tarpon-springs-gears-up-to-celebrate-epiphany/article_02168946-6da3-11ec-96eb-b399dee05af8.html","uuid":"02168946-6da3-11ec-96eb-b399dee05af8","app":"editorial","metric":""}'  data-count="1"  class="photo-container layout-horizontal"><div class="loading-slide text-center"><i class="fas tnt-spinner tnt-spin"></i></div>
                                        
                                        
                                            <a href="#1" data-photo-target=".photo-5be84fb8-6da3-11ec-b84a-47a13e9128b4" data-instance="#gallery-items-02168946-6da3-11ec-96eb-b399dee05af8-photo-modal" data-target="#photo-carousel-02168946-6da3-11ec-96eb-b399dee05af8" class="hover-expand">
                                                <span class="expand">
                                                    <span class="fas tnt-expand"></span>
                                                </span>
                                        
                                        
                                        
        <div itemprop="image" itemscope itemtype="https://schema.org/ImageObject">
            <meta itemprop="width" content="1609">
            <meta itemprop="height" content="1287">
            <meta itemprop="contentUrl" content="https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/5/be/5be84fb8-6da3-11ec-b84a-47a13e9128b4/61d4b8cd11bbd.image.jpg?resize=1200%2C960">
            <meta itemprop="url" content="https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/5/be/5be84fb8-6da3-11ec-b84a-47a13e9128b4/61d4b8cd11bbd.image.jpg?resize=1200%2C960">
        
                <img
                    src="https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/5/be/5be84fb8-6da3-11ec-b84a-47a13e9128b4/61d4b8cd11bbd.image.jpg?resize=1200%2C960"
                    
                    alt="PI-EpiphanyAdv1-010521.jpg"
                    class="img-responsive owl-first-image owl-lazy default"
                    width="1609"
                    height="1287"
                    data-src="https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/5/be/5be84fb8-6da3-11ec-b84a-47a13e9128b4/61d4b8cd11bbd.image.jpg?resize=1200%2C960" />
            </div>
                                        
                                        </a><div class="clearfix"></div>
                                </div>
        <div class="caption-container">
            <div class="caption-inner-02168946-6da3-11ec-96eb-b399dee05af8 collapse in"><div class="caption-text"><p>The Epiphany statue stands tall outside St. Nicholas Greek Orthodox Cathedral.</p></div><div class="card-meta">
                        <ul class="list-inline">
                                    
                                    
                                        <li class="credit"><span  class="tnt-byline">JEFF ROSENFIELD</span></li>
                                    
                                
                            
                        </ul>
                    </div>
            </div>
        </div>
    <div class="clearfix"></div>
                            </div>
                        </div><div  class="item photo-5c9d4b52-6da3-11ec-93c9-f3576d920589">
                            <div class="item-container">
                                <div data-track-object='{"title":"Tarpon Springs gears up to celebrate Epiphany","url":"/news/tarpon-springs-gears-up-to-celebrate-epiphany/article_02168946-6da3-11ec-96eb-b399dee05af8.html","uuid":"02168946-6da3-11ec-96eb-b399dee05af8","app":"editorial","metric":""}'  data-count="2"  class="photo-container layout-horizontal"><div class="loading-slide text-center"><i class="fas tnt-spinner tnt-spin"></i></div>
                                        
                                        
                                            <a href="#2" data-photo-target=".photo-5c9d4b52-6da3-11ec-93c9-f3576d920589" data-instance="#gallery-items-02168946-6da3-11ec-96eb-b399dee05af8-photo-modal" data-target="#photo-carousel-02168946-6da3-11ec-96eb-b399dee05af8" class="hover-expand">
                                                <span class="expand">
                                                    <span class="fas tnt-expand"></span>
                                                </span>
                                        
                                        
                                        
        <div itemprop="image" itemscope itemtype="https://schema.org/ImageObject">
            <meta itemprop="width" content="1602">
            <meta itemprop="height" content="1292">
            <meta itemprop="contentUrl" content="https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/5/c9/5c9d4b52-6da3-11ec-93c9-f3576d920589/61d4b8ce3f0d3.image.jpg?resize=1200%2C968">
            <meta itemprop="url" content="https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/5/c9/5c9d4b52-6da3-11ec-93c9-f3576d920589/61d4b8ce3f0d3.image.jpg?resize=1200%2C968">
        
                <img
                    src="https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/5/c9/5c9d4b52-6da3-11ec-93c9-f3576d920589/61d4b8ce3f0d3.image.jpg?resize=1200%2C968"
                    
                    alt="PI-EpiphanyAdv2-010521.jpg"
                    class="img-responsive owl-first-image owl-lazy default"
                    width="1602"
                    height="1292"
                    data-src="https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/5/c9/5c9d4b52-6da3-11ec-93c9-f3576d920589/61d4b8ce3f0d3.image.jpg?resize=1200%2C968" />
            </div>
                                        
                                        </a><div class="clearfix"></div>
                                </div>
        <div class="caption-container">
            <div class="caption-inner-02168946-6da3-11ec-96eb-b399dee05af8 collapse in"><div class="caption-text"><p>The Epiphany divers head for the splash the cross made as it hit the water of Spring Bayou.</p><p></p></div><div class="card-meta">
                        <ul class="list-inline">
                                    
                                    
                                        <li class="credit"><span  class="tnt-byline">File photos by JEFF ROSENFIELD</span></li>
                                    
                                
                            
                        </ul>
                    </div>
            </div>
        </div>
    <div class="clearfix"></div>
                            </div>
                        </div>
            </div>
        </div></div>

            

            

            <div id="tncms-region-article_top_content" class="tncms-region hidden-print"></div>

            <div id="asset-content" data-asset-uuid="02168946-6da3-11ec-96eb-b399dee05af8">
                

                <div class="row">
                    <div class="col-lg-12 col-md-12 col-sm-12" data-subscription-required-class="col-xs-12">
                        
                        <div class="asset-body" data-subscription-required-class="asset-body">
                            
                                <div class="share-container content-above" data-subscription-required-remove><ul class="social-share-links hidden-print list-inline icon"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.suncoastnews.com%2Fnews%2Ftarpon-springs-gears-up-to-celebrate-epiphany%2Farticle_02168946-6da3-11ec-96eb-b399dee05af8.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/news/tarpon-springs-gears-up-to-celebrate-epiphany/article_02168946-6da3-11ec-96eb-b399dee05af8.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"02168946-6da3-11ec-96eb-b399dee05af8"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=Tarpon%20Springs%20gears%20up%20to%20celebrate%20Epiphany&via=SuncoastNews&url=https%3A%2F%2Fwww.suncoastnews.com%2Fnews%2Ftarpon-springs-gears-up-to-celebrate-epiphany%2Farticle_02168946-6da3-11ec-96eb-b399dee05af8.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/news/tarpon-springs-gears-up-to-celebrate-epiphany/article_02168946-6da3-11ec-96eb-b399dee05af8.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"02168946-6da3-11ec-96eb-b399dee05af8"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=https://www.suncoastnews.com/news/tarpon-springs-gears-up-to-celebrate-epiphany/article_02168946-6da3-11ec-96eb-b399dee05af8.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/news/tarpon-springs-gears-up-to-celebrate-epiphany/article_02168946-6da3-11ec-96eb-b399dee05af8.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"02168946-6da3-11ec-96eb-b399dee05af8"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-whatsapp tnt-stack-1x"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.suncoastnews.com/tncms/asset/editorial/02168946-6da3-11ec-96eb-b399dee05af8" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"02168946-6da3-11ec-96eb-b399dee05af8"}'  rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5Bsuncoastnews.com%5D%20Tarpon%20Springs%20gears%20up%20to%20celebrate%20Epiphany&body=https%3A%2F%2Fwww.suncoastnews.com%2Fnews%2Ftarpon-springs-gears-up-to-celebrate-epiphany%2Farticle_02168946-6da3-11ec-96eb-b399dee05af8.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"02168946-6da3-11ec-96eb-b399dee05af8"}'  rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li><li class="social-share-link pr">
                <a href="javascript:window.print()" class="pr" title="Print" data-track='{"network":"Print","socialAction":"print","url":"/news/tarpon-springs-gears-up-to-celebrate-epiphany/article_02168946-6da3-11ec-96eb-b399dee05af8.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"02168946-6da3-11ec-96eb-b399dee05af8"}'  rel="nofollow">
                    <span class="tnt-stack" >
                        
                        <i class="fas tnt-print tnt-stack-1x"></i>
                    </span>
                    <span class="sr-only">Print</span>
                </a>
            </li><li class="social-share-link sv">
        <a class="save-list-02168946-6da3-11ec-96eb-b399dee05af8-btn save-asset " title="Save to list" href="#"  role="button" rel="nofollow" data-asset-uuid="02168946-6da3-11ec-96eb-b399dee05af8" >
            
                <span class="tnt-stack">
                    
                    <i class="asset-save-icon far tnt-bookmark tnt-stack-1x "></i>
                </span>
            
            
                <span class="sr-only">Save</span>
            
        </a>
        </li>
        
    </ul><form method="post" data-uuid="02168946-6da3-11ec-96eb-b399dee05af8" class="save-list-02168946-6da3-11ec-96eb-b399dee05af8-form save-asset-to-list" action="/users/admin/list/">
        <input type="hidden" name="action" value="addasset" />
        <input type="hidden" name="format" value="json" />
        <input type="hidden" name="listasset" value="02168946-6da3-11ec-96eb-b399dee05af8" />
        <input type="hidden" name="listapp" value="editorial" />
        <input type="hidden" name="autocreate" value="true" />
        <input type="hidden" name="listname" value="articles" />
        <input class="hide" type="submit" name="submit" value="Save" />
    </form>
</div>
                            

                            <div id="tncms-region-article_body_top" class="tncms-region hidden-print"></div>

                            <div  itemprop="articleBody" class="asset-content  subscriber-premium">
                                <meta itemprop="isAccessibleForFree" content="true"/>
                                
                                
                                <p>TARPON SPRINGS — Two years ago, Tarpon Springs hosted the biggest Epiphany celebration in the city’s history. The prime minister of Greece and dignitaries from the Greek Orthodox Church, plus local and national politicians and thousands of residents and visitors, descended on the downtown district on Jan. 6, 2020, for the community’s annual celebration of Jesus’ baptism in the River Jordan.</p><p>That would be one of the last events Tarpon, or any other community, would hold for the next year-plus, as the coronavirus pandemic began ravaging the country, putting a halt to public gatherings and leaving the future of many such large-scale events in doubt.</p><p>During the leadup to the 2021 Epiphany, rumors of the possible cancellation led to charged atmosphere in town; ultimately, the event went off without a hitch, with 16-year-old Colten Sakadales capturing the cross one year after his older brother, Hunter, emerged from the Spring Bayou waters with it in his hand.</p>
        <div data-tnt-ads-tmp='{"vendor":"blox","type":"region","region":"fixed-big-ad-top-asset","id":"fixed-big-ad-top-asset","pos":"fixed-big-ad-top-asset, atf","fold":"above","include_domain":null,"size":"[300,250]","height":"250","width":"300","mobile":false,"js":{"video":"https:\/\/bloximages.newyork1.vip.townnews.com\/suncoastnews.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":null,"index_slug":null,"url":"\/news","refresh":false}' style="display:none;"></div><div id="tncms-region-article_instory_top" class="tncms-region hidden-print"></div><p>This year, organizers of the 116th edition of Epiphany promise the event will return to its full-scale glory, with the morning liturgy at St. Nicholas Greek Orthodox Cathedral on Thursday, Jan. 6, back to full capacity and no attendance restrictions at the bayou for the cross dive, although for the second straight year the Glendi, or feast, held at Craig Park following the dive was canceled, mainly due to a lack of volunteers, according to reports.</p><p>But with additional events, including an inaugural Epiphany Lecture on Friday, Jan. 7, and the return of the Epiphany Ball on Saturday, Jan. 8, plus several Sister City ceremonies, added to the schedule, this year’s Epiphany promises to be an extended, communitywide celebration, according to Tarpon Springs Mayor Chris Alahouzos.</p><p>“I’m very excited and looking forward to having an Epiphany celebration for all of Tarpon Springs,” Alahouzos said by phone a week before the event, noting that prior to the lecture on Friday, he will be presenting a delegation from Chania, one of Tarpon’s sister cities in Greece, with a key to the city at 5 p.m. in the City Hall auditorium. “The events we have scheduled for this week show this is not just a religious holiday but a holiday for the whole city.”</p>
        <div data-tnt-ads-tmp='{"vendor":"blox","type":"region","region":"fixed-big-ad-middle-asset","id":"fixed-big-ad-middle-asset","pos":"fixed-big-ad-middle-asset, stf","fold":"span","include_domain":null,"size":"[300,250]","height":"250","width":"300","mobile":false,"js":{"video":"https:\/\/bloximages.newyork1.vip.townnews.com\/suncoastnews.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":null,"index_slug":null,"url":"\/news","refresh":false}' style="display:none;"></div><div id="tncms-region-ads-fixed-big-ad-middle-asset" class="tncms-region-ads">

<div id="blox-ad-position-fixed-big-ad-middle-asset1">
<script type="text/javascript">TNCMS.AdManager.render({region: 'fixed-big-ad-middle-asset', slot: 1, fold: "span"});</script>

</div>
</div>
<div id="tncms-region-article_instory_middle" class="tncms-region hidden-print"></div><p>Indeed, Tarpon’s Epiphany celebration, widely considered to be the largest such gathering outside of Greece, annually draws thousands of spectators from around the country and the world.</p><p>And while COVID-19 is still an active part of everyday life globally, traveling to Florida remains a popular activity and this year the event is expected to bring many visitors to town, according to Tarpon Springs Chamber of Commerce President and CEO Jean Hungiville.</p><p>“I’ve visited a lot of our local business downtown and on the Sponge Docks over the weekend and everybody is very excited about the Epiphany celebration this year,” Hungiville said by text Monday, Jan. 2. “They are expecting lots of celebrants to out shopping and enjoying our little Greek city!”</p><p>Mayor Alahouzos agreed.</p><p>“We’re going back to the normal, regular celebration we usually have, and people are excited. They’re really looking forward to it,” he said, adding, “we’re going back to the way the Greeks used to do it and celebrating for a whole week! So, by the time it’s over I’ll probably gain 10 pounds!”</p>
        <div data-tnt-ads-tmp='{"vendor":"blox","type":"region","region":"fixed-big-ad-bottom-asset","id":"fixed-big-ad-bottom-asset","pos":"fixed-big-ad-bottom-asset, btf","fold":"below","include_domain":null,"size":"[300,250]","height":"250","width":"300","mobile":false,"js":{"video":"https:\/\/bloximages.newyork1.vip.townnews.com\/suncoastnews.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":null,"index_slug":null,"url":"\/news","refresh":false}' style="display:none;"></div><div id="tncms-region-article_instory_bottom" class="tncms-region hidden-print"></div>
                                <div id="tncms-region-article_bottom_content" class="tncms-region hidden-print"></div>
                                
                            </div>

                            

                            
    


                            
                                <div class="share-container content-below" data-subscription-required-remove><ul class="social-share-links hidden-print list-inline icon"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.suncoastnews.com%2Fnews%2Ftarpon-springs-gears-up-to-celebrate-epiphany%2Farticle_02168946-6da3-11ec-96eb-b399dee05af8.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/news/tarpon-springs-gears-up-to-celebrate-epiphany/article_02168946-6da3-11ec-96eb-b399dee05af8.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"02168946-6da3-11ec-96eb-b399dee05af8"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=Tarpon%20Springs%20gears%20up%20to%20celebrate%20Epiphany&via=SuncoastNews&url=https%3A%2F%2Fwww.suncoastnews.com%2Fnews%2Ftarpon-springs-gears-up-to-celebrate-epiphany%2Farticle_02168946-6da3-11ec-96eb-b399dee05af8.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/news/tarpon-springs-gears-up-to-celebrate-epiphany/article_02168946-6da3-11ec-96eb-b399dee05af8.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"02168946-6da3-11ec-96eb-b399dee05af8"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=https://www.suncoastnews.com/news/tarpon-springs-gears-up-to-celebrate-epiphany/article_02168946-6da3-11ec-96eb-b399dee05af8.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/news/tarpon-springs-gears-up-to-celebrate-epiphany/article_02168946-6da3-11ec-96eb-b399dee05af8.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"02168946-6da3-11ec-96eb-b399dee05af8"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-whatsapp tnt-stack-1x"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.suncoastnews.com/tncms/asset/editorial/02168946-6da3-11ec-96eb-b399dee05af8" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"02168946-6da3-11ec-96eb-b399dee05af8"}'  rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5Bsuncoastnews.com%5D%20Tarpon%20Springs%20gears%20up%20to%20celebrate%20Epiphany&body=https%3A%2F%2Fwww.suncoastnews.com%2Fnews%2Ftarpon-springs-gears-up-to-celebrate-epiphany%2Farticle_02168946-6da3-11ec-96eb-b399dee05af8.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"02168946-6da3-11ec-96eb-b399dee05af8"}'  rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li><li class="social-share-link pr">
                <a href="javascript:window.print()" class="pr" title="Print" data-track='{"network":"Print","socialAction":"print","url":"/news/tarpon-springs-gears-up-to-celebrate-epiphany/article_02168946-6da3-11ec-96eb-b399dee05af8.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"02168946-6da3-11ec-96eb-b399dee05af8"}'  rel="nofollow">
                    <span class="tnt-stack" >
                        
                        <i class="fas tnt-print tnt-stack-1x"></i>
                    </span>
                    <span class="sr-only">Print</span>
                </a>
            </li><li class="social-share-link sv">
        <a class="save-list-02168946-6da3-11ec-96eb-b399dee05af8-btn save-asset " title="Save to list" href="#"  role="button" rel="nofollow" data-asset-uuid="02168946-6da3-11ec-96eb-b399dee05af8" >
            
                <span class="tnt-stack">
                    
                    <i class="asset-save-icon far tnt-bookmark tnt-stack-1x "></i>
                </span>
            
            
                <span class="sr-only">Save</span>
            
        </a>
        </li>
        
    </ul><form method="post" data-uuid="02168946-6da3-11ec-96eb-b399dee05af8" class="save-list-02168946-6da3-11ec-96eb-b399dee05af8-form save-asset-to-list" action="/users/admin/list/">
        <input type="hidden" name="action" value="addasset" />
        <input type="hidden" name="format" value="json" />
        <input type="hidden" name="listasset" value="02168946-6da3-11ec-96eb-b399dee05af8" />
        <input type="hidden" name="listapp" value="editorial" />
        <input type="hidden" name="autocreate" value="true" />
        <input type="hidden" name="listname" value="articles" />
        <input class="hide" type="submit" name="submit" value="Save" />
    </form>
</div>
                            
                        </div>
                        
                    </div></div><!-- /asset-content -->

                <div id="asset-below">
                    

                    

                    

                    

                    

                    
                        <div class="asset-tags hidden-print">
                            <h4>Tags</h4>
                            <ul class="list-inline"><li>
                <a href="/search/?k=%22epiphany%22#tncms-source=keyword" class="tag-epiphany label label-default" >Epiphany</a>
            </li> <li>
                <a href="/search/?k=%22tarpon%20springs%22#tncms-source=keyword" class="tag-tarpon-springs label label-default" >Tarpon Springs</a>
            </li> <li>
                <a href="/search/?k=%22greece%22#tncms-source=keyword" class="tag-greece label label-default" >Greece</a>
            </li> <li>
                <a href="/search/?k=%22greek%20orthodox%20church%22#tncms-source=keyword" class="tag-greek-orthodox-church label label-default" >Greek Orthodox Church</a>
            </li> <li>
                <a href="/search/?k=%222022%22#tncms-source=keyword" class="tag-2022 label label-default" >2022</a>
            </li> <li>
                <a href="/search/?k=%22open%20to%20public%22#tncms-source=keyword" class="tag-open-to-public label label-default" >Open To Public</a>
            </li> <li>
                <a href="/search/?k=%22cross%20dive%22#tncms-source=keyword" class="tag-cross-dive label label-default" >Cross Dive</a>
            </li> <li>
                <a href="/search/?k=%22spring%20bayou%22#tncms-source=keyword" class="tag-spring-bayou label label-default" >Spring Bayou</a>
            </li> </ul>
                        </div>
                    

                    

                    

                    

                    

                    <div id="tncms-region-article_bottom" class="tncms-region hidden-print"><div id="tncms-block-1044046" class="tncms-block"><div class="zergnet-widget" id="zergnet-widget-loader"></div></div></div><div id="taboola-video-outstream"></div><div id="taboola-below-article-thumbnails" class="asset-recommend taboola hidden-print" data-page="article" data-mode="thumbnails-a" data-container="taboola-below-article-thumbnails" data-placement="Below Article Thumbnails"></div><div id="taboola-below-article-text-links" class="asset-recommend taboola hidden-print" data-page="article" data-mode="hybrid-text-links-a" data-container="taboola-below-article-text-links" data-placement="Below Article Text Links"></div>

                    <div class="asset-comments hidden-print"></div>
                    
                    <div id="tncms-region-article_container_bottom" class="tncms-region hidden-print"></div></div>
            </div>

            

            </div>
        </div><div class="main-sidebar col-lg-4 col-md-5 hidden-print">
                <div class="main-sidebar-wrap">
                    <div id="tncms-region-article_side_top" class="tncms-region hidden-print"></div>
        <div data-tnt-ads-tmp='{"vendor":"blox","type":"region","region":"fixed-big-ad-top","id":"fixed-big-ad-top","pos":"fixed-big-ad-top, atf","fold":"above","include_domain":null,"size":"[[300,250], [300,600]]","height":"250","width":"300","not_mobile":false,"js":{"video":"https:\/\/bloximages.newyork1.vip.townnews.com\/suncoastnews.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":null,"index_slug":null,"url":"\/news","refresh":false}' style="display:none;"></div><div id="tncms-region-ads-fixed-big-ad-top" class="tncms-region-ads">

<div id="blox-ad-position-fixed-big-ad-top1">
<script type="text/javascript">TNCMS.AdManager.render({region: 'fixed-big-ad-top', slot: 1, fold: "above"});</script>

</div>
</div>
<div id="tncms-region-asset_side_top" class="tncms-region hidden-print"></div><div id="tncms-region-global-side-primary" class="tncms-region "><div id="tncms-block-1050832" class="tncms-block">
        <div id="blox-ad-position-block-top-300x1001" data-tnt-ads='{"vendor":"blox","type":"position","display":"default","region":"block-top-300x100","slot":"1","fold":"","width":"","js":{"video":"https:\/\/bloximages.newyork1.vip.townnews.com\/suncoastnews.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":"","refresh":false}' class="blox-ad tnt-ads-container ">
        
        </div></div><div id="tncms-block-896902" class="tncms-block"><section id="block-896902" class="block emphasis-h3   " ><div class="clearfix">
    
    <div class="block-title title-896902 ">
        <div class="block-title-inner">
            <h3>
                
                Weekly COVID-19 update
                
            </h3>
        </div>
    </div></div><div class=" ">
        
            
            <article id="card-showcase-28bc5dd6-5bc0-11ec-8e26-fb0eb7d88d74" class="clearfix card showcase position-0 odd  tnt-section-news">
            <div class="card-container"><div class="card-image ">
                <div class="media-preview-28bc5dd6-5bc0-11ec-8e26-fb0eb7d88d74 media-preview article-asset " data-aspect="16:9"><figure class="photo layout-horizontal letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/news/florida-doh-reports-increase-in-covid-19-cases-deaths/article_28bc5dd6-5bc0-11ec-8e26-fb0eb7d88d74.html" class="tnt-asset-link" >                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAABAAAAAJCAQAAACRI2S5AAAAEklEQVR42mM8U8+AFzCOKgADAHdUC60wg0dkAAAAAElFTkSuQmCC"
                            alt="Florida DOH reports increase in COVID-19 cases, deaths"
                            class="img-responsive lazyload full default"
                            width="1662"
                            height="935"
                            data-sizes="auto"
                            data-srcset="https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/4/47/44741d28-75d7-11ea-aecc-4b2353234c75/5e877db263642.image.png?crop=1662%2C935%2C0%2C97&resize=150%2C84&order=crop%2Cresize 150w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/4/47/44741d28-75d7-11ea-aecc-4b2353234c75/5e877db263642.image.png?crop=1662%2C935%2C0%2C97&resize=200%2C113&order=crop%2Cresize 200w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/4/47/44741d28-75d7-11ea-aecc-4b2353234c75/5e877db263642.image.png?crop=1662%2C935%2C0%2C97&resize=225%2C127&order=crop%2Cresize 225w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/4/47/44741d28-75d7-11ea-aecc-4b2353234c75/5e877db263642.image.png?crop=1662%2C935%2C0%2C97&resize=300%2C169&order=crop%2Cresize 300w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/4/47/44741d28-75d7-11ea-aecc-4b2353234c75/5e877db263642.image.png?crop=1662%2C935%2C0%2C97&resize=400%2C225&order=crop%2Cresize 400w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/4/47/44741d28-75d7-11ea-aecc-4b2353234c75/5e877db263642.image.png?crop=1662%2C935%2C0%2C97&resize=540%2C304&order=crop%2Cresize 540w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/4/47/44741d28-75d7-11ea-aecc-4b2353234c75/5e877db263642.image.png?crop=1662%2C935%2C0%2C97&resize=640%2C360&order=crop%2Cresize 640w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/4/47/44741d28-75d7-11ea-aecc-4b2353234c75/5e877db263642.image.png?crop=1662%2C935%2C0%2C97&resize=750%2C422&order=crop%2Cresize 750w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/4/47/44741d28-75d7-11ea-aecc-4b2353234c75/5e877db263642.image.png?crop=1662%2C935%2C0%2C97&resize=990%2C557&order=crop%2Cresize 990w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/4/47/44741d28-75d7-11ea-aecc-4b2353234c75/5e877db263642.image.png?crop=1662%2C935%2C0%2C97&resize=1035%2C582&order=crop%2Cresize 1035w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/4/47/44741d28-75d7-11ea-aecc-4b2353234c75/5e877db263642.image.png?crop=1662%2C935%2C0%2C97&resize=1200%2C675&order=crop%2Cresize 1200w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/4/47/44741d28-75d7-11ea-aecc-4b2353234c75/5e877db263642.image.png?crop=1662%2C935%2C0%2C97&resize=1333%2C750&order=crop%2Cresize 1333w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/4/47/44741d28-75d7-11ea-aecc-4b2353234c75/5e877db263642.image.png?crop=1662%2C935%2C0%2C97&resize=1476%2C830&order=crop%2Cresize 1476w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/4/47/44741d28-75d7-11ea-aecc-4b2353234c75/5e877db263642.image.png?crop=1662%2C935%2C0%2C97&resize=1662%2C935&order=crop%2Cresize 2008w" />
                </a>
                
            </div>
            
        </figure></div>
            </div><div class="card-body">
        <div class="card-headline"><h3 class="tnt-headline ">
        
             <a href="/news/florida-doh-reports-increase-in-covid-19-cases-deaths/article_28bc5dd6-5bc0-11ec-8e26-fb0eb7d88d74.html" class="tnt-asset-link">
        

        
            Florida DOH reports increase in COVID-19 cases, deaths</a></h3></div>
    <div class="card-meta">
            <ul class="list-inline"><li class="card-date">
        <time datetime="2021-12-12T21:55:00-05:00" class="tnt-date asset-date text-muted">Dec 12, 2021</time></li></ul>
        </div>
                        <div class="card-social pull-right">
                            <ul class="social-share-links hidden-print list-inline icon"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.suncoastnews.com%2Fnews%2Fflorida-doh-reports-increase-in-covid-19-cases-deaths%2Farticle_28bc5dd6-5bc0-11ec-8e26-fb0eb7d88d74.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/news/florida-doh-reports-increase-in-covid-19-cases-deaths/article_28bc5dd6-5bc0-11ec-8e26-fb0eb7d88d74.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"28bc5dd6-5bc0-11ec-8e26-fb0eb7d88d74"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=Florida%20DOH%20reports%20increase%20in%20COVID-19%20cases%2C%20deaths&via=SuncoastNews&url=https%3A%2F%2Fwww.suncoastnews.com%2Fnews%2Fflorida-doh-reports-increase-in-covid-19-cases-deaths%2Farticle_28bc5dd6-5bc0-11ec-8e26-fb0eb7d88d74.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/news/florida-doh-reports-increase-in-covid-19-cases-deaths/article_28bc5dd6-5bc0-11ec-8e26-fb0eb7d88d74.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"28bc5dd6-5bc0-11ec-8e26-fb0eb7d88d74"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=https://www.suncoastnews.com/news/florida-doh-reports-increase-in-covid-19-cases-deaths/article_28bc5dd6-5bc0-11ec-8e26-fb0eb7d88d74.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/news/florida-doh-reports-increase-in-covid-19-cases-deaths/article_28bc5dd6-5bc0-11ec-8e26-fb0eb7d88d74.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"28bc5dd6-5bc0-11ec-8e26-fb0eb7d88d74"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-whatsapp tnt-stack-1x"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.suncoastnews.com/tncms/asset/editorial/28bc5dd6-5bc0-11ec-8e26-fb0eb7d88d74" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"28bc5dd6-5bc0-11ec-8e26-fb0eb7d88d74"}'  rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5Bsuncoastnews.com%5D%20Florida%20DOH%20reports%20increase%20in%20COVID-19%20cases%2C%20deaths&body=https%3A%2F%2Fwww.suncoastnews.com%2Fnews%2Fflorida-doh-reports-increase-in-covid-19-cases-deaths%2Farticle_28bc5dd6-5bc0-11ec-8e26-fb0eb7d88d74.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"28bc5dd6-5bc0-11ec-8e26-fb0eb7d88d74"}'  rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li></ul>
                        </div>
                    
                    
                        <div class="card-lead">
                            <p>Florida Department of Health reported another uptick in COVID-19 cases in the weekly report released Dec. 10. New cases for the week of Dec. 3-9 totaled 13,530 (about 1,933 a day) compared to 10,892 (about 1,556 a day) for Nov. 26-Dec. 2. </p>
                        </div>
                    </div>
            </div>
            <div class="clearfix"></div>
        </article>
            
        
    </div></section></div><div id="tncms-block-501366" class="tncms-block visible-lg visible-md"><section id="block-501366" class="block emphasis-h4 dark  " ><div class="clearfix">
    
    <div class="block-title title-501366 ">
        <div class="block-title-inner">
            <h4>
                
                Latest News
                
            </h4>
        </div>
    </div></div>
    <div class=" card-bg-color"><div class="card-panel panel">
            <div class="panel-body"><ul class="card headline-list bullet-square border border-dashed"><li class="">
            <span class="tnt-headline ">
        
             <a href="/news/tarpon-springs-gears-up-to-celebrate-epiphany/article_02168946-6da3-11ec-96eb-b399dee05af8.html" class="tnt-asset-link">
        

        
            Tarpon Springs gears up to celebrate Epiphany</a></span>
        </li><li class="">
            <span class="tnt-headline ">
        
             <a href="/news/trinity-centenarian-wishes-for-a-birthday-call-from-buccaneers-quarterback-tom-brady/article_273a0cae-6db0-11ec-881a-f7dd5ede494b.html" class="tnt-asset-link">
        

        
            Trinity centenarian wishes for a birthday call from Buccaneers quarterback Tom Brady</a></span>
        </li><li class="">
            <span class="tnt-headline ">
        
             <a href="/sports/the-nature-coast-fishing-report-inshore-fishing-yielding-good-results/article_d7adcd7e-6d9b-11ec-8d9b-2b2c9d0f4d39.html" class="tnt-asset-link">
        

        
            The Nature Coast Fishing Report: Inshore fishing yielding good results</a></span>
        </li><li class="">
            <span class="tnt-headline ">
        
             <a href="/news/school-resource-deputies-participate-in-autism-awareness-training/article_7a7952fa-6d86-11ec-bae4-5b0af32cc34a.html" class="tnt-asset-link">
        

        
            School resource deputies participate in autism awareness training</a></span>
        </li><li class="">
            <span class="tnt-headline ">
        
             <a href="/news/chinsegut-events-give-environmental-start-to-the-new-year/article_1e2f16b8-6d74-11ec-9f57-bf79b9bcb7de.html" class="tnt-asset-link">
        

        
            Chinsegut events give environmental start to the new year</a></span>
        </li><li class="">
            <span class="tnt-headline ">
        
             <a href="/news/oak-hill-hospital-to-hold-six-blood-drives-in-2022/article_aebda38a-6d73-11ec-8b2c-932be1d5a1ef.html" class="tnt-asset-link">
        

        
            Oak Hill Hospital to hold six blood drives in 2022</a></span>
        </li><li class="">
            <span class="tnt-headline ">
        
             <a href="/news/hudson-beach-boat-ramp-closing-for-jan-6/article_6b2264da-6d69-11ec-bbb1-2b6dc56dcd27.html" class="tnt-asset-link">
        

        
            Hudson Beach Boat Ramp closing for Jan. 6</a></span>
        </li><li class="">
            <span class="tnt-headline ">
        
             <a href="/crime_crashes_fires/hcso-units-teamed-up-over-holiday-weekend/article_c59e5a56-6d5d-11ec-a0d1-0fdb840426db.html" class="tnt-asset-link">
        

        
            HCSO units teamed up over holiday weekend</a></span>
        </li><li class="">
            <span class="tnt-headline ">
        
             <a href="/news/odessa-teens-fundraiser-honors-girl-who-lost-battle-with-cancer/article_dcdb10ba-6d76-11ec-adac-13121453241d.html" class="tnt-asset-link">
        

        
            Odessa teen's fundraiser honors girl who lost battle with cancer</a></span>
        </li><li class="">
            <span class="tnt-headline ">
        
             <a href="/crime_crashes_fires/navy-sailor-charged-with-lewd-and-lascivious-battery/article_e0c0743a-6ce6-11ec-a6e7-874037c95568.html" class="tnt-asset-link">
        

        
            Navy sailor charged with lewd and lascivious battery</a></span>
        </li></ul></div>
        </div></div></section></div><div id="tncms-block-644299" class="tncms-block">
        <div id="blox-ad-position-block-right-rail1" data-tnt-ads='{"vendor":"blox","type":"position","display":"default","region":"block-right-rail","slot":"1","fold":"","width":"","js":{"video":"https:\/\/bloximages.newyork1.vip.townnews.com\/suncoastnews.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":"","refresh":false}' class="blox-ad tnt-ads-container ">
        
        </div></div><div id="tncms-block-501416" class="tncms-block"><section id="block-501416" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-501416 ">
        <div class="block-title-inner">
            <h4>
                
                Most Popular
                
            </h4>
        </div>
    </div></div><div class="most-popular">
    <ul class="nav nav-tabs nav-tabs-popular">
        
            <li class="active">
                <a href="#articles-501416" data-toggle="tab"><i class="far tnt-file-alt" title="Articles"></i><span class="tab-text"> Articles</span></a>
            </li>
        
        
            <li >
                <a href="#images-501416" data-toggle="tab"><i class="far tnt-image" title="images"></i><span class="tab-text"> Images</span></a>
            </li>
        
        
            <li >
                <a href="#videos-501416" data-toggle="tab"><i class="fas tnt-play-circle" title="Videos"></i><span class="tab-text"> Videos</span></a>
            </li>
        
        
        
        
            <li >
                <a href="#commented-501416" data-toggle="tab"><i class="far tnt-comments" title="Commented"></i><span class="tab-text"> Commented</span></a>
            </li>
        
    </ul>
    <div class="tab-content">
        
            <div id="articles-501416" class="tab-pane tab-pane-articles fade in active">
                <h4 class="tab-content-heading">Articles</h4><ul class="tab-content-list bullet-disc "><li><a href="/crime_crashes_fires/backyard-fire-causes-total-loss-of-home/article_4f783556-6978-11ec-860a-abbb90bfe6be.html">Backyard fire causes total loss of home</a></li><li><a href="/crime_crashes_fires/wanted-felony-subject-arrested-at-brooksville-bus-stop/article_f4034c5e-6cdf-11ec-9e37-d36410fd41b2.html">Wanted felony subject arrested at Brooksville bus stop</a></li><li><a href="/crime_crashes_fires/hernando-sheriff-says-four-dead-from-possible-holiday-overdoses/article_c6312f5e-67de-11ec-ad91-0fbb4a70beb9.html">Hernando sheriff says four dead from possible holiday overdoses</a></li><li><a href="/crime_crashes_fires/man-arrested-in-joint-investigation-with-u-s-postal-service/article_ba1414c6-6ce2-11ec-8e69-37819f0904f5.html">Man arrested in joint investigation with U.S. Postal Service</a></li><li><a href="/news/stalled-pasco-road-projects-getting-back-on-track/article_278d7570-6850-11ec-84df-bb151bfa3e62.html">Stalled Pasco road projects getting back on track</a></li><li><a href="/crime_crashes_fires/hcso-units-teamed-up-over-holiday-weekend/article_c59e5a56-6d5d-11ec-a0d1-0fdb840426db.html">HCSO units teamed up over holiday weekend</a></li><li><a href="/crime_crashes_fires/garbage-truck-triggers-fatal-multi-vehicle-accident/article_e54fcf86-67f6-11ec-b76e-63d3994896a7.html">Garbage truck triggers fatal multi-vehicle accident</a></li><li><a href="/news/off-duty-deputy-saves-choking-woman-at-restaurant/article_80eb02f4-698b-11ec-bfac-a704af8fa59c.html">Off-duty deputy saves choking woman at restaurant</a></li><li><a href="/news/ring-supports-aging-seniors-with-donation-to-pasco-and-pinellas-nonprofit/article_c3574550-62c2-11ec-8bd0-c3bc43767399.html">Ring supports aging seniors with donation to Pasco and Pinellas nonprofit</a></li><li><a href="/crime_crashes_fires/sheriff-says-county-saw-increase-in-accidental-overdoses-in-2021/article_f4a16d48-6c9a-11ec-9ec4-1beaabab316b.html">Sheriff says county saw increase in accidental overdoses in 2021</a></li></ul></div>
        
        
            <div id="images-501416" class="tab-pane tab-pane-images fade in ">
                <h4 class="tab-content-heading">Images</h4><ul class="tab-content-list">
                            <li><figure class="photo layout-square letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/man-arrested-in-joint-investigation-with-u-s-postal-service/image_04b6bab0-6ce3-11ec-a431-774bbd2e3e71.html" class="tnt-asset-link" >                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="Man arrested in joint investigation with U.S. Postal Service"
                            class="img-responsive lazyload full default"
                            width="335"
                            height="335"
                            data-sizes="auto"
                            data-srcset="https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/0/4b/04b6bab0-6ce3-11ec-a431-774bbd2e3e71/61d3761b64457.image.jpg?crop=335%2C335%2C0%2C60&resize=150%2C150&order=crop%2Cresize 150w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/0/4b/04b6bab0-6ce3-11ec-a431-774bbd2e3e71/61d3761b64457.image.jpg?crop=335%2C335%2C0%2C60&resize=200%2C200&order=crop%2Cresize 200w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/0/4b/04b6bab0-6ce3-11ec-a431-774bbd2e3e71/61d3761b64457.image.jpg?crop=335%2C335%2C0%2C60&resize=225%2C225&order=crop%2Cresize 225w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/0/4b/04b6bab0-6ce3-11ec-a431-774bbd2e3e71/61d3761b64457.image.jpg?crop=335%2C335%2C0%2C60&resize=300%2C300&order=crop%2Cresize 300w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/0/4b/04b6bab0-6ce3-11ec-a431-774bbd2e3e71/61d3761b64457.image.jpg?crop=335%2C335%2C0%2C60&resize=335%2C335&order=crop%2Cresize 400w" />
                </a>
                
            </div>
            
        </figure></li>
                        
                            <li><figure class="photo layout-square letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/wanted-felony-subject-arrested-at-brooksville-bus-stop/image_25779e0c-6ce0-11ec-b31f-133e8536fbea.html" class="tnt-asset-link" >                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="Wanted felony subject arrested at Brooksville bus stop"
                            class="img-responsive lazyload full default"
                            width="300"
                            height="300"
                            data-sizes="auto"
                            data-srcset="https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/2/57/25779e0c-6ce0-11ec-b31f-133e8536fbea/61d371807640b.image.jpg?crop=300%2C300%2C0%2C42&resize=150%2C150&order=crop%2Cresize 150w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/2/57/25779e0c-6ce0-11ec-b31f-133e8536fbea/61d371807640b.image.jpg?crop=300%2C300%2C0%2C42&resize=200%2C200&order=crop%2Cresize 200w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/2/57/25779e0c-6ce0-11ec-b31f-133e8536fbea/61d371807640b.image.jpg?crop=300%2C300%2C0%2C42&resize=225%2C225&order=crop%2Cresize 225w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/2/57/25779e0c-6ce0-11ec-b31f-133e8536fbea/61d371807640b.image.jpg?crop=300%2C300%2C0%2C42&resize=300%2C300&order=crop%2Cresize 300w" />
                </a>
                
            </div>
            
        </figure></li>
                        
                            <li><figure class="photo layout-square letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/deputies-see-arrest-wanted-person-while-on-patrol/image_a31f0886-5f61-11ec-8fd5-2f1d4c030e3f.html" class="tnt-asset-link" >                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="Deputies see, arrest wanted person while on patrol"
                            class="img-responsive lazyload full default"
                            width="384"
                            height="384"
                            data-sizes="auto"
                            data-srcset="https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/a/31/a31f0886-5f61-11ec-8fd5-2f1d4c030e3f/61bccdd72c010.image.jpg?crop=384%2C384%2C0%2C47&resize=150%2C150&order=crop%2Cresize 150w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/a/31/a31f0886-5f61-11ec-8fd5-2f1d4c030e3f/61bccdd72c010.image.jpg?crop=384%2C384%2C0%2C47&resize=200%2C200&order=crop%2Cresize 200w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/a/31/a31f0886-5f61-11ec-8fd5-2f1d4c030e3f/61bccdd72c010.image.jpg?crop=384%2C384%2C0%2C47&resize=225%2C225&order=crop%2Cresize 225w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/a/31/a31f0886-5f61-11ec-8fd5-2f1d4c030e3f/61bccdd72c010.image.jpg?crop=384%2C384%2C0%2C47&resize=300%2C300&order=crop%2Cresize 300w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/a/31/a31f0886-5f61-11ec-8fd5-2f1d4c030e3f/61bccdd72c010.image.jpg?crop=384%2C384%2C0%2C47&resize=384%2C384&order=crop%2Cresize 400w" />
                </a>
                
            </div>
            
        </figure></li>
                        
                            <li><figure class="photo layout-square letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/bishop-mclaughlin-tabs-bob-dare-as-next-head-football-coach/image_b2e0c1ca-5f56-11ec-b745-83a3f45363f6.html" class="tnt-asset-link" >                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="Bishop McLaughlin tabs Bob Dare as next head football coach"
                            class="img-responsive lazyload full default"
                            width="483"
                            height="483"
                            data-sizes="auto"
                            data-srcset="https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/b/2e/b2e0c1ca-5f56-11ec-b745-83a3f45363f6/61bcbb4f86a72.image.jpg?crop=483%2C483%2C131%2C0&resize=150%2C150&order=crop%2Cresize 150w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/b/2e/b2e0c1ca-5f56-11ec-b745-83a3f45363f6/61bcbb4f86a72.image.jpg?crop=483%2C483%2C131%2C0&resize=200%2C200&order=crop%2Cresize 200w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/b/2e/b2e0c1ca-5f56-11ec-b745-83a3f45363f6/61bcbb4f86a72.image.jpg?crop=483%2C483%2C131%2C0&resize=225%2C225&order=crop%2Cresize 225w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/b/2e/b2e0c1ca-5f56-11ec-b745-83a3f45363f6/61bcbb4f86a72.image.jpg?crop=483%2C483%2C131%2C0&resize=300%2C300&order=crop%2Cresize 300w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/b/2e/b2e0c1ca-5f56-11ec-b745-83a3f45363f6/61bcbb4f86a72.image.jpg?crop=483%2C483%2C131%2C0&resize=400%2C400&order=crop%2Cresize 400w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/b/2e/b2e0c1ca-5f56-11ec-b745-83a3f45363f6/61bcbb4f86a72.image.jpg?crop=483%2C483%2C131%2C0&resize=483%2C483&order=crop%2Cresize 540w" />
                </a>
                
            </div>
            
        </figure></li>
                        
                            <li><figure class="photo layout-square letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/live-oak-to-offer-two-special-acting-classes/image_28bfda4e-6c99-11ec-aa21-2fcdb7e82dcc.html" class="tnt-asset-link" >                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="Live Oak to offer two special acting classes"
                            class="img-responsive lazyload full default"
                            width="1205"
                            height="1205"
                            data-sizes="auto"
                            data-srcset="https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/2/8b/28bfda4e-6c99-11ec-aa21-2fcdb7e82dcc/61d2fa311b371.image.jpg?crop=1205%2C1205%2C0%2C257&resize=150%2C150&order=crop%2Cresize 150w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/2/8b/28bfda4e-6c99-11ec-aa21-2fcdb7e82dcc/61d2fa311b371.image.jpg?crop=1205%2C1205%2C0%2C257&resize=200%2C200&order=crop%2Cresize 200w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/2/8b/28bfda4e-6c99-11ec-aa21-2fcdb7e82dcc/61d2fa311b371.image.jpg?crop=1205%2C1205%2C0%2C257&resize=225%2C225&order=crop%2Cresize 225w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/2/8b/28bfda4e-6c99-11ec-aa21-2fcdb7e82dcc/61d2fa311b371.image.jpg?crop=1205%2C1205%2C0%2C257&resize=300%2C300&order=crop%2Cresize 300w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/2/8b/28bfda4e-6c99-11ec-aa21-2fcdb7e82dcc/61d2fa311b371.image.jpg?crop=1205%2C1205%2C0%2C257&resize=400%2C400&order=crop%2Cresize 400w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/2/8b/28bfda4e-6c99-11ec-aa21-2fcdb7e82dcc/61d2fa311b371.image.jpg?crop=1205%2C1205%2C0%2C257&resize=540%2C540&order=crop%2Cresize 540w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/2/8b/28bfda4e-6c99-11ec-aa21-2fcdb7e82dcc/61d2fa311b371.image.jpg?crop=1205%2C1205%2C0%2C257&resize=640%2C640&order=crop%2Cresize 640w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/2/8b/28bfda4e-6c99-11ec-aa21-2fcdb7e82dcc/61d2fa311b371.image.jpg?crop=1205%2C1205%2C0%2C257&resize=750%2C750&order=crop%2Cresize 750w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/2/8b/28bfda4e-6c99-11ec-aa21-2fcdb7e82dcc/61d2fa311b371.image.jpg?crop=1205%2C1205%2C0%2C257&resize=990%2C990&order=crop%2Cresize 990w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/2/8b/28bfda4e-6c99-11ec-aa21-2fcdb7e82dcc/61d2fa311b371.image.jpg?crop=1205%2C1205%2C0%2C257&resize=1035%2C1035&order=crop%2Cresize 1035w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/2/8b/28bfda4e-6c99-11ec-aa21-2fcdb7e82dcc/61d2fa311b371.image.jpg?crop=1205%2C1205%2C0%2C257&resize=1200%2C1200&order=crop%2Cresize 1200w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/2/8b/28bfda4e-6c99-11ec-aa21-2fcdb7e82dcc/61d2fa311b371.image.jpg?crop=1205%2C1205%2C0%2C257&resize=1205%2C1205&order=crop%2Cresize 1333w" />
                </a>
                
            </div>
            
        </figure></li>
                        
                            <li><figure class="photo layout-square letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/sheriff-s-office-executes-two-search-warrants-in-brooksville/image_2b280eb4-6401-11ec-bae2-8bf127ee8340.html" class="tnt-asset-link" >                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="Sheriff’s Office executes two search warrants in Brooksville"
                            class="img-responsive lazyload full default"
                            width="265"
                            height="265"
                            data-sizes="auto"
                            data-srcset="https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/2/b2/2b280eb4-6401-11ec-bae2-8bf127ee8340/61c48f3853f00.image.jpg?crop=265%2C265%2C0%2C107&resize=150%2C150&order=crop%2Cresize 150w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/2/b2/2b280eb4-6401-11ec-bae2-8bf127ee8340/61c48f3853f00.image.jpg?crop=265%2C265%2C0%2C107&resize=200%2C200&order=crop%2Cresize 200w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/2/b2/2b280eb4-6401-11ec-bae2-8bf127ee8340/61c48f3853f00.image.jpg?crop=265%2C265%2C0%2C107&resize=225%2C225&order=crop%2Cresize 225w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/2/b2/2b280eb4-6401-11ec-bae2-8bf127ee8340/61c48f3853f00.image.jpg?crop=265%2C265%2C0%2C107&resize=265%2C265&order=crop%2Cresize 300w" />
                </a>
                
            </div>
            
        </figure></li>
                        
                            <li><figure class="photo layout-square letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/backyard-fire-causes-total-loss-of-home/image_aa7b740e-6978-11ec-a91b-2f143f58b7bc.html" class="tnt-asset-link" >                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="Backyard fire causes total loss of home"
                            class="img-responsive lazyload full default"
                            width="960"
                            height="960"
                            data-sizes="auto"
                            data-srcset="https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/a/a7/aa7b740e-6978-11ec-a91b-2f143f58b7bc/61cdbb5e7a4ec.image.jpg?crop=960%2C960%2C0%2C160&resize=150%2C150&order=crop%2Cresize 150w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/a/a7/aa7b740e-6978-11ec-a91b-2f143f58b7bc/61cdbb5e7a4ec.image.jpg?crop=960%2C960%2C0%2C160&resize=200%2C200&order=crop%2Cresize 200w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/a/a7/aa7b740e-6978-11ec-a91b-2f143f58b7bc/61cdbb5e7a4ec.image.jpg?crop=960%2C960%2C0%2C160&resize=225%2C225&order=crop%2Cresize 225w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/a/a7/aa7b740e-6978-11ec-a91b-2f143f58b7bc/61cdbb5e7a4ec.image.jpg?crop=960%2C960%2C0%2C160&resize=300%2C300&order=crop%2Cresize 300w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/a/a7/aa7b740e-6978-11ec-a91b-2f143f58b7bc/61cdbb5e7a4ec.image.jpg?crop=960%2C960%2C0%2C160&resize=400%2C400&order=crop%2Cresize 400w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/a/a7/aa7b740e-6978-11ec-a91b-2f143f58b7bc/61cdbb5e7a4ec.image.jpg?crop=960%2C960%2C0%2C160&resize=540%2C540&order=crop%2Cresize 540w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/a/a7/aa7b740e-6978-11ec-a91b-2f143f58b7bc/61cdbb5e7a4ec.image.jpg?crop=960%2C960%2C0%2C160&resize=640%2C640&order=crop%2Cresize 640w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/a/a7/aa7b740e-6978-11ec-a91b-2f143f58b7bc/61cdbb5e7a4ec.image.jpg?crop=960%2C960%2C0%2C160&resize=750%2C750&order=crop%2Cresize 750w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/a/a7/aa7b740e-6978-11ec-a91b-2f143f58b7bc/61cdbb5e7a4ec.image.jpg?crop=960%2C960%2C0%2C160&resize=960%2C960&order=crop%2Cresize 990w" />
                </a>
                
            </div>
            
        </figure></li>
                        
                            <li><figure class="photo layout-square letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/hernando-sheriff-says-four-dead-from-possible-holiday-overdoses/image_058aa0c2-67df-11ec-9fa4-2fffca84cebb.html" class="tnt-asset-link" >                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="Hernando sheriff says four dead from possible holiday overdoses"
                            class="img-responsive lazyload full default"
                            width="1428"
                            height="1428"
                            data-sizes="auto"
                            data-srcset="https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/0/58/058aa0c2-67df-11ec-9fa4-2fffca84cebb/61cb0c1891d59.image.jpg?crop=1428%2C1428%2C11%2C0&resize=150%2C150&order=crop%2Cresize 150w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/0/58/058aa0c2-67df-11ec-9fa4-2fffca84cebb/61cb0c1891d59.image.jpg?crop=1428%2C1428%2C11%2C0&resize=200%2C200&order=crop%2Cresize 200w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/0/58/058aa0c2-67df-11ec-9fa4-2fffca84cebb/61cb0c1891d59.image.jpg?crop=1428%2C1428%2C11%2C0&resize=225%2C225&order=crop%2Cresize 225w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/0/58/058aa0c2-67df-11ec-9fa4-2fffca84cebb/61cb0c1891d59.image.jpg?crop=1428%2C1428%2C11%2C0&resize=300%2C300&order=crop%2Cresize 300w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/0/58/058aa0c2-67df-11ec-9fa4-2fffca84cebb/61cb0c1891d59.image.jpg?crop=1428%2C1428%2C11%2C0&resize=400%2C400&order=crop%2Cresize 400w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/0/58/058aa0c2-67df-11ec-9fa4-2fffca84cebb/61cb0c1891d59.image.jpg?crop=1428%2C1428%2C11%2C0&resize=540%2C540&order=crop%2Cresize 540w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/0/58/058aa0c2-67df-11ec-9fa4-2fffca84cebb/61cb0c1891d59.image.jpg?crop=1428%2C1428%2C11%2C0&resize=640%2C640&order=crop%2Cresize 640w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/0/58/058aa0c2-67df-11ec-9fa4-2fffca84cebb/61cb0c1891d59.image.jpg?crop=1428%2C1428%2C11%2C0&resize=750%2C750&order=crop%2Cresize 750w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/0/58/058aa0c2-67df-11ec-9fa4-2fffca84cebb/61cb0c1891d59.image.jpg?crop=1428%2C1428%2C11%2C0&resize=990%2C990&order=crop%2Cresize 990w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/0/58/058aa0c2-67df-11ec-9fa4-2fffca84cebb/61cb0c1891d59.image.jpg?crop=1428%2C1428%2C11%2C0&resize=1035%2C1035&order=crop%2Cresize 1035w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/0/58/058aa0c2-67df-11ec-9fa4-2fffca84cebb/61cb0c1891d59.image.jpg?crop=1428%2C1428%2C11%2C0&resize=1200%2C1200&order=crop%2Cresize 1200w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/0/58/058aa0c2-67df-11ec-9fa4-2fffca84cebb/61cb0c1891d59.image.jpg?crop=1428%2C1428%2C11%2C0&resize=1333%2C1333&order=crop%2Cresize 1333w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/0/58/058aa0c2-67df-11ec-9fa4-2fffca84cebb/61cb0c1891d59.image.jpg?crop=1428%2C1428%2C11%2C0&resize=1428%2C1428&order=crop%2Cresize 1476w" />
                </a>
                
            </div>
            
        </figure></li>
                        
                            <li><figure class="photo layout-square letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/brooksville-man-charged-with-numerous-sex-crimes/image_75426f04-5933-11ec-8a21-1fb01b909ee7.html" class="tnt-asset-link" >                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="Brooksville man charged with numerous sex crimes"
                            class="img-responsive lazyload full default"
                            width="549"
                            height="549"
                            data-sizes="auto"
                            data-srcset="https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/7/54/75426f04-5933-11ec-8a21-1fb01b909ee7/61b26f543e605.image.jpg?crop=549%2C549%2C0%2C87&resize=150%2C150&order=crop%2Cresize 150w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/7/54/75426f04-5933-11ec-8a21-1fb01b909ee7/61b26f543e605.image.jpg?crop=549%2C549%2C0%2C87&resize=200%2C200&order=crop%2Cresize 200w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/7/54/75426f04-5933-11ec-8a21-1fb01b909ee7/61b26f543e605.image.jpg?crop=549%2C549%2C0%2C87&resize=225%2C225&order=crop%2Cresize 225w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/7/54/75426f04-5933-11ec-8a21-1fb01b909ee7/61b26f543e605.image.jpg?crop=549%2C549%2C0%2C87&resize=300%2C300&order=crop%2Cresize 300w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/7/54/75426f04-5933-11ec-8a21-1fb01b909ee7/61b26f543e605.image.jpg?crop=549%2C549%2C0%2C87&resize=400%2C400&order=crop%2Cresize 400w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/7/54/75426f04-5933-11ec-8a21-1fb01b909ee7/61b26f543e605.image.jpg?crop=549%2C549%2C0%2C87&resize=540%2C540&order=crop%2Cresize 540w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/7/54/75426f04-5933-11ec-8a21-1fb01b909ee7/61b26f543e605.image.jpg?crop=549%2C549%2C0%2C87&resize=549%2C549&order=crop%2Cresize 640w" />
                </a>
                
            </div>
            
        </figure></li>
                        
                            <li><figure class="photo layout-square letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/navy-sailor-charged-with-lewd-and-lascivious-battery/image_106c2bca-6ce7-11ec-b541-47c48ffef9ec.html" class="tnt-asset-link" >                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="Navy sailor charged with lewd and lascivious battery"
                            class="img-responsive lazyload full default"
                            width="384"
                            height="384"
                            data-sizes="auto"
                            data-srcset="https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/1/06/106c2bca-6ce7-11ec-b541-47c48ffef9ec/61d37d130a91f.image.jpg?crop=384%2C384%2C0%2C47&resize=150%2C150&order=crop%2Cresize 150w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/1/06/106c2bca-6ce7-11ec-b541-47c48ffef9ec/61d37d130a91f.image.jpg?crop=384%2C384%2C0%2C47&resize=200%2C200&order=crop%2Cresize 200w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/1/06/106c2bca-6ce7-11ec-b541-47c48ffef9ec/61d37d130a91f.image.jpg?crop=384%2C384%2C0%2C47&resize=225%2C225&order=crop%2Cresize 225w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/1/06/106c2bca-6ce7-11ec-b541-47c48ffef9ec/61d37d130a91f.image.jpg?crop=384%2C384%2C0%2C47&resize=300%2C300&order=crop%2Cresize 300w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/1/06/106c2bca-6ce7-11ec-b541-47c48ffef9ec/61d37d130a91f.image.jpg?crop=384%2C384%2C0%2C47&resize=384%2C384&order=crop%2Cresize 400w" />
                </a>
                
            </div>
            
        </figure></li>
                        </ul></div>
        
        <div id="videos-501416" class="tab-pane tab-pane-videos fade in ">
                <h4 class="tab-content-heading">Videos</h4><p class="no-results text-muted">Sorry, there are no recent results for popular videos.</p></div>
        
        
        
        
            <div id="commented-501416" class="tab-pane tab-pane-commented fade in ">
                <h4 class="tab-content-heading">Commented</h4><p class="no-results text-muted">Sorry, there are no recent results for popular commented articles.</p></div>
        
    </div>
</div></section></div><div id="tncms-block-501393" class="tncms-block"></div><div id="tncms-block-501355" class="tncms-block"></div><div id="tncms-block-975241" class="tncms-block"><section id="block-975241" class="block emphasis-h3   " ><div id="evvnt-calendar-975241"></div>
<script defer src="//production-evvnt-plugin-herokuapp-com.global.ssl.fastly.net/evvnt_discovery_plugin_s.js" onload="evvntDiscoveryInit_975241();"></script></section></div><div id="tncms-block-644301" class="tncms-block">
        <div id="blox-ad-position-block-right-rail2" data-tnt-ads='{"vendor":"blox","type":"position","display":"default","region":"block-right-rail","slot":"2","fold":"","width":"","js":{"video":"https:\/\/bloximages.newyork1.vip.townnews.com\/suncoastnews.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":"","refresh":false}' class="blox-ad tnt-ads-container ">
        
        </div></div><div id="tncms-block-633912" class="tncms-block"></div></div>
        <div data-tnt-ads-tmp='{"vendor":"blox","type":"region","region":"fixed-big-ad-middle","id":"fixed-big-ad-middle","pos":"fixed-big-ad-middle, stf","fold":"span","include_domain":null,"size":"[[300,250], [300,600]]","height":"250","width":"300","not_mobile":false,"js":{"video":"https:\/\/bloximages.newyork1.vip.townnews.com\/suncoastnews.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":null,"index_slug":null,"url":"\/news","refresh":false}' style="display:none;"></div><div id="tncms-region-asset_side_middle" class="tncms-region hidden-print"></div><div id="tncms-region-article_side_middle" class="tncms-region hidden-print"></div><div id="tncms-region-global-side-secondary" class="tncms-region hidden-print"><div id="tncms-block-501387" class="tncms-block"></div></div>
        <div data-tnt-ads-tmp='{"vendor":"blox","type":"region","region":"fixed-big-ad-bottom","id":"fixed-big-ad-bottom","pos":"fixed-big-ad-bottom, btf","fold":"below","include_domain":null,"size":"[[300,250], [300,600]]","height":"250","width":"300","not_mobile":false,"js":{"video":"https:\/\/bloximages.newyork1.vip.townnews.com\/suncoastnews.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":null,"index_slug":null,"url":"\/news","refresh":false}' style="display:none;"></div><div id="tncms-region-asset_side_bottom" class="tncms-region hidden-print"></div><div id="tncms-region-global-side-tertiary" class="tncms-region "><div id="tncms-block-1075888" class="tncms-block">
        <div id="blox-ad-position-fixed-big-ad-middle21" data-tnt-ads='{"vendor":"blox","type":"position","display":"default","region":"fixed-big-ad-middle2","slot":"1","fold":"","width":"","js":{"video":"https:\/\/bloximages.newyork1.vip.townnews.com\/suncoastnews.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":"","refresh":false}' class="blox-ad tnt-ads-container ">
        
        </div></div></div><div id="tncms-region-article_side_bottom" class="tncms-region hidden-print"></div><div id="insticator-container" style="position:relative;margin-left:auto;margin-right:auto;width:300px;margin-bottom:40px;">
                    <div id="div-insticator-ad-1" style="height: 280px; margin-bottom: 20px;"></div>
                    <div id="insticator-embed"></div>
                    <div id="div-insticator-ad-2"></div>
                </div>
                <div id="sticky-right-rail-spacer">
                    <div id="sticky-right-rail"><div id="tncms-region-global-side-sticky" class="tncms-region hidden-print"></div><div id="tncms-region-asset_side_sticky" class="tncms-region hidden-print"></div></div>
                </div>
                </div>
            </div></div>
</article>
<div class="row">
            <div class="col-md-12"><div id="tncms-region-global-container-bottom" class="tncms-region "><div id="tncms-block-501339" class="tncms-block hidden-xs">
        <div id="blox-ad-position-block-leaderboard-bottom1" data-tnt-ads='{"vendor":"blox","type":"position","display":"default","region":"block-leaderboard-bottom","slot":"1","fold":"below","width":"728","js":{"video":"https:\/\/bloximages.newyork1.vip.townnews.com\/suncoastnews.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":"","refresh":false}' class="blox-ad tnt-ads-container ">
        
        </div></div><div id="tncms-block-501340" class="tncms-block visible-xs">
        <div id="blox-ad-position-block-leaderboard-bottom-mobile1" data-tnt-ads='{"vendor":"blox","type":"position","display":"default","region":"block-leaderboard-bottom-mobile","slot":"1","fold":"below","width":"320","js":{"video":"https:\/\/bloximages.newyork1.vip.townnews.com\/suncoastnews.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":"","refresh":false}' class="blox-ad tnt-ads-container ">
        
        </div></div><div id="tncms-block-585128" class="tncms-block visible-xs">
        <div id="blox-ad-position-block-leaderboard-bottom-mobile2" data-tnt-ads='{"vendor":"blox","type":"position","display":"default","region":"block-leaderboard-bottom-mobile","slot":"2","fold":"below","width":"320","js":{"video":"https:\/\/bloximages.newyork1.vip.townnews.com\/suncoastnews.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":"","refresh":false}' class="blox-ad tnt-ads-container ">
        
        </div></div></div></div>
        </div></section>
    <section id="main-bottom-container" class="container-fullscreen-region container-fluid">
        <div class="fullscreen-region"><div id="tncms-region-global-container-bottom-fullscreen" class="tncms-region "></div></div>
    </section><!-- / main-body-container -->
    </div>
    <div id="site-footer-container" class="hidden-print">
         
            <div class="container">
                <div id="asset-container-bottom" class="col-md-12">
                    <div id="tncms-region-asset_container_bottom" class="tncms-region hidden-print"></div> 
                </div>
            </div>
        

        
            <footer id="site-footer" class="container well-main">
                
                <div id="tncms-region-footer-top-col-full" class="tncms-region "></div>
                <div class="row">
                    <div id="footer-col-one" class="col-md-4 col-sm-4"><div id="tncms-region-footer-col-one" class="tncms-region "><div id="tncms-block-501401" class="tncms-block"><section id="block-501401" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-501401 ">
        <div class="block-title-inner">
            <h4>
                
                Sections
                
            </h4>
        </div>
    </div></div></section></div></div><div id="tncms-region-nav-footer-col-one-nav" class="tncms-region-nav"><ul id="footer-col-one-nav_menu" class="bullet-nav nav-list" ><li>
                <a class="nav-link  nav-home  tnt-section-home"  href="/"  tabindex="0">
                    <span class="nav-icon fas tnt-home tnt-fw"></span> <span class="nav-label">Home</span>
                </a></li><li>
                <a class="nav-link   tnt-section-news"  href="/news/"  tabindex="0">
                    <span class="nav-label">News</span>
                </a></li><li>
                <a class="nav-link   tnt-section-sports"  href="/sports/"  tabindex="0">
                    <span class="nav-label">Sports</span>
                </a></li><li>
                <a class="nav-link   tnt-section-business"  href="/business/"  tabindex="0">
                    <span class="nav-label">Business</span>
                </a></li><li>
                <a class="nav-link   tnt-section-obituaries"  href="/obituaries/"  tabindex="0">
                    <span class="nav-label">Obituaries</span>
                </a></li><li>
                <a class="nav-link   tnt-section-local-events"  href="/local-events/"  tabindex="0">
                    <span class="nav-label">Local Events</span>
                </a></li><li>
                <a class="nav-link   tnt-section-multimedia"  href="/multimedia/"  tabindex="0">
                    <span class="nav-label">Multimedia</span>
                </a></li></ul></div></div>
    <div id="footer-col-two" class="col-md-4 col-sm-4"><div id="tncms-region-footer-col-two" class="tncms-region "><div id="tncms-block-501402" class="tncms-block"><section id="block-501402" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-501402 ">
        <div class="block-title-inner">
            <h4>
                
                Services
                
            </h4>
        </div>
    </div></div></section></div></div><div id="tncms-region-nav-footer-col-two-nav" class="tncms-region-nav"><ul id="footer-col-two-nav_menu" class="bullet-nav nav-list" ><li>
                <a class="nav-link   tnt-section-subscription-services"  href="/site/forms/subscription_services/"  tabindex="0">
                    <span class="nav-label">Subscription Services</span>
                </a></li><li>
                <a class="nav-link   tnt-section-submission-forms"  href="/site/forms/"  tabindex="0">
                    <span class="nav-label">Submission Forms</span>
                </a></li><li>
                <a class="nav-link   tnt-section-classifieds"  href="/classifieds/"  tabindex="0">
                    <span class="nav-label">Classifieds</span>
                </a></li><li>
                <a class="nav-link   tnt-section-place-an-ad"  href="http://www.suncoastnews.com/site/contact.html"  target="_blank" rel="noopener" tabindex="0">
                    <span class="nav-label">Place an Ad</span>
                </a></li><li>
                <a class="nav-link   tnt-section-promote-your-event"  href="https://new.evvnt.com/?with_navbar&amp;force_snap_sell&amp;partner=SUNCOASTNEWS&amp;publisher_url:suncoastnews.com#/quick"  target="_blank" rel="noopener" tabindex="0">
                    <span class="nav-label">Promote Your Event</span>
                </a></li><li>
                <a class="nav-link   tnt-section-search"  href="/search/"  tabindex="0">
                    <span class="nav-label">Search</span>
                </a></li><li>
                <a class="nav-link   tnt-section-weather"  href="/weather/"  tabindex="0">
                    <span class="nav-label">Weather</span>
                </a></li><li>
                <a class="nav-link   tnt-section-legal-notices"  href="https://www.suncoastnews.com/classifieds/legal_notices/?l=25"  target="_blank" rel="noopener" tabindex="0">
                    <span class="nav-label">Legal Notices</span>
                </a></li></ul></div></div>
    <div id="footer-col-three" class="col-md-4 col-sm-4"><div id="tncms-region-footer-col-three" class="tncms-region "><div id="tncms-block-501415" class="tncms-block padding-bottom"><section id="block-501415" class="block emphasis-h3   " ><div class="block"><a href="/" rel="nofollow" >
            <img 
                
                src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg==" 
                data-srcset="https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/custom/image/17727cd0-7120-11e6-8a40-33d15f4612ac.jpg?resize=150%2C64 150w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/custom/image/17727cd0-7120-11e6-8a40-33d15f4612ac.jpg?resize=200%2C86 200w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/custom/image/17727cd0-7120-11e6-8a40-33d15f4612ac.jpg?resize=225%2C96 225w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/custom/image/17727cd0-7120-11e6-8a40-33d15f4612ac.jpg?resize=300%2C128 300w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/custom/image/17727cd0-7120-11e6-8a40-33d15f4612ac.jpg?resize=400%2C171 400w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/custom/image/17727cd0-7120-11e6-8a40-33d15f4612ac.jpg?resize=540%2C231 540w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/custom/image/17727cd0-7120-11e6-8a40-33d15f4612ac.jpg?resize=640%2C274 640w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/custom/image/17727cd0-7120-11e6-8a40-33d15f4612ac.jpg 750w" 
                data-sizes="auto" 
                class=" img-responsive lazyload tnt-prop-img"
                width="750"
                height="321"
                alt=""></a></div></section></div><div id="tncms-block-501407" class="tncms-block"><section id="block-501407" class="block emphasis-h4   " ><address>
    <strong>www.SuncoastNews.com</strong><br>
    11321 U.S. Hwy 19 North<br>
    Port Richey, FL. 34668
    <br>
    
        <strong>Phone:</strong> 727-815-1023<br>
        <strong>Email:</strong> <a href="mailto:dpleus@SuncoastNews.com">dpleus@SuncoastNews.com</a><br>
    
</address></section></div><div id="tncms-block-501424" class="tncms-block padding-bottom"><div class="follow-links-501424 default">
    
    <section id="block-501424" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-501424 ">
        <div class="block-title-inner">
            <h4>
                
                Follow Us
                
            </h4>
        </div>
    </div></div><ul class="list-inline">
        
            <li>
                <a href="http://facebook.com/SuncoastNews/" title="Facebook" target="_blank" rel="noopener" class="btn btn-md btn-link fb" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-facebook-f"></i>
                    <span class="sr-only">Facebook</span>
                </a>
            </li>
        
        
            <li>
                <a href="http://twitter.com/SuncoastNews/" title="Twitter" target="_blank" rel="noopener" class="btn btn-md btn-link tw" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-twitter"></i>
                    <span class="sr-only">Twitter</span>
                </a>
            </li>
        
        
        
            <li>
                <a href="http://www.youtube.com/user/SCNPasco" title="Youtube" target="_blank" rel="noopener" class="btn btn-md btn-link yt" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-youtube"></i>
                    <span class="sr-only">YouTube</span>
                </a>
            </li>
        
        
        
        
        
        
        
        
        
        
        
        
        
        
    </ul>
    </section>
</div>
<script type="application/ld+json">
{ "@context" : "https://schema.org",
  "@type" : "Organization",
  "url" : "http://www.suncoastnews.com",
  "sameAs" : ["http://facebook.com/SuncoastNews/","http://twitter.com/SuncoastNews/","http://www.youtube.com/user/SCNPasco"]
}
</script>
<div class="clearfix"></div></div></div></div>
                </div>
                <div id="tncms-region-footer-bottom-col-full" class="tncms-region "></div>
                
            </footer>
        

        <div id="site-copyright-container" class="container">
            <div id="tncms-region-footer-copyright" class="tncms-region "><div id="tncms-block-501408" class="tncms-block"><div id="site-copyright" class="row">
    <section id="block-501408"><div class="col-md-7"><small>&copy; Copyright 2022 <a href="/">suncoastnews.com</a>, 9911 Seminole Blvd. Seminole, FL</small><small>&nbsp;| <a href="/site/terms.html">Terms of Use</a></small><small>&nbsp;| <a href="/site/privacy.html">Privacy Policy</a></small></div>
        <div class="col-md-5"><small>Powered by <a href="https://bloxcms.com" title="BLOX Content Management System" target="_blank" rel="noopener">BLOX Content Management System</a> from <a href="https://townnews.com/" title="TownNews.com BLOX Newspaper Content Management" target="_blank" rel="noopener">TownNews.com</a>.</small></div>
    </section>
</div></div></div>
        </div>
    </div>
    
    
        </div><!-- / offcanvas close  -->
    

    
    
    <!-- / site-container close -->
    </div>
    
    
        <div data-tnt-ads-tmp='{"vendor":"blox","type":"region","region":"fixed-impact-bottom","id":"fixed-impact-bottom","pos":"fixed-impact-bottom, btf","fold":"below","include_domain":null,"size":"[1,1]","height":"1","width":"1","js":{"video":"https:\/\/bloximages.newyork1.vip.townnews.com\/suncoastnews.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"index_slug":null,"url":"\/news","refresh":false}' style="display:none;"></div>
    <script>
        window.__tnt = window.__tnt || {};
        __tnt.compatibility = __tnt.compatibility || {};

        __tnt.compatibility.status = '';
        __tnt.compatibility.check = function() {
            if (typeof __tnt.advertisements == 'undefined') {
                __tnt.compatibility.status = 'FAIL: object 0 undefined';
                return false;
            }
            return true;
        };
        __tnt.compatibility.notification = function() {
            if (!document.getElementById('notification-area')) {
                    var el = document.createElement('div');
                    el.id = 'notification-area';
                    document.querySelector('#asset-content .asset-body').appendChild(el);
                }
                __tnt.template(
                    document.getElementById('template-blox-message-incompatible'),
                    document.getElementById('notification-area'),
                    true,
                    [],
                    function(el) {
                        setTimeout(function() {
                            var message = document.getElementById('blox-message-incompatible');
                            var authStatusCls = (__tnt.user.authToken) ? 'logged-in' : 'not-logged-in';
                                Array.from(message.getElementsByClassName(authStatusCls)).forEach(function(el) {
                                    el.style.display = 'block';
                                });
                            
                            if (__tnt.user.services) {
                                message.parentNode.removeChild(message);
                            } else {
                                message.style.display = 'block';
                                }
                        }, 100);
                    }
                );
            };
        (function() {
            function compatibilityCheck() {
                if (!__tnt.compatibility.check()) {
                    __tnt.trackEvent({
                        'category':'subscription',
                        'action':'adblock',
                        'label':'adblock detected',
                        'value':'1'
                    });
                    __tnt.compatibility.notification();
                }
            }

            if (document.readyState != 'loading') {
                compatibilityCheck();
            } else {
                document.addEventListener('DOMContentLoaded', compatibilityCheck);
            }
        })();
    </script>
    <template id="template-blox-message-incompatible">
            </template>
    
    
    <script>
        jQuery(function() {
            if(typeof TNCMS.Tracking != 'undefined'){
                jQuery(TNCMS.Tracking.trackDeclarativeEvents);
            }dataLayer.push({'tncms.client.recent_five':__tnt.recentFive.add("02168946-6da3-11ec-96eb-b399dee05af8")});});
    </script>

    <script>
        __tnt.trackEvent = function(obj) {
            if (typeof obj === 'object') {
                    if (obj.category && obj.action) {
                        __tnt.googleEvent(obj);
                    } else if (obj.network && obj.socialAction) {
                        __tnt.googleSocial(obj);
                    } else if (obj.url) {
                        __tnt.googlePageView(obj);
                    }
                    if (typeof TNCMS.Tracking != 'undefined' && obj.metric) {
                        TNCMS.Tracking.addEvent({
                            app: obj.app,
                            metric: obj.metric,
                            id: obj.uuid
                        });
                    }
            }
        };

        if (__tnt.trackEventLater.length > 0) {
            __tnt.trackEventLater.forEach(function(obj) {
                __tnt.trackEvent(obj);
            });
        }

        Array.from(document.querySelectorAll('body [data-track]')).forEach(function(el) {
            el.addEventListener(__tnt.client.clickEvent, function() {
                __tnt.trackEvent(JSON.parse(el.dataset.track));
            });
        });
        Array.from(document.querySelectorAll('body [data-tncms-track-event]')).forEach(function(el) {
            el.addEventListener(__tnt.client.clickEvent, function() {
                __tnt.trackEvent(JSON.parse(el.dataset.tncmsTrackEvent));
            });
        });
        
        Array.from(document.querySelectorAll('body [data-tncms-track-dmp]')).forEach(function(el) {
            el.addEventListener(__tnt.client.clickEvent, function() {
                var dmpData = el.dataset.tncmsTrackDmp;
                
            });
        });
    
    </script>
    
    
<script>/*<![CDATA[*/ dataLayer.push({
            'tncms.asset.sections': ["news", "news/pinellas"],
            'tncms.asset.flags': ["featured"],
            'tncms.asset.keywords': ["epiphany", "tarpon springs", "greece", "greek orthodox church", "2022", "open to public", "cross dive", "spring bayou"]
        }); /*]]>*/</script>
<script>/*<![CDATA[*/ 
                __tnt.googleEvent = function(obj) {
                    dataLayer.push({
                        'event': 'tncms.event.trigger',
                             'tncms.event.trigger.category': obj.category,
                             'tncms.event.trigger.action': obj.action,
                             'tncms.event.trigger.label': obj.label, 
                             'tncms.event.trigger.value': obj.value
                    });
                }
                /* Virtual page view */
                __tnt.googlePageView = function(obj) {
                    var sURL = obj.url.replace(/^.*\/\/[^\/]+/, '');
                    dataLayer.push({
                        'event': 'tncms.event.virtual_pageview',
                            'tncms.event.virtual_pageview.url': sURL,
                            'tncms.event.virtual_pageview.title': obj.title
                    });
                }
                /* Social event */
                __tnt.googleSocial = function(obj) {
                    dataLayer.push({
                        'event': 'tncms.event.social',
                            'tncms.event.social.network': obj.network,
                            'tncms.event.social.action': obj.socialAction,
                            'tncms.event.social.target': obj.url
                    });
                } /*]]>*/</script>
<script src="https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/asset-edit.60e8e67e04be1194326dcfbe7f00b8c3.js"></script>
<script>/*<![CDATA[*/ jQuery(document).ready(function($){
                                    $('#weather_zip_toggle_501439').click(function(e){
                                        $('#weather-501439 .zip-update-form').toggle('fast');
                                        return false; 
                                    });
                                }); /*]]>*/</script>
<script>/*<![CDATA[*/ 
                        !function(t,i,n){var e,a,s,o,c,d={init:function(){a=i.getElementById("site-navbar-container"),n.client.platform.ios?a.classList.add("affix-sticky"):(e=i.getElementById("main-body-container"),s=a.offsetHeight||a.clientHeight,o=!1,c=0,t.addEventListener("scroll",d.navPosition,!1),t.addEventListener("mousewheel",d.navPosition,!1))},navPosition:function(){o||(o=!0,setTimeout(function(){var n=a.getBoundingClientRect(),d=t.pageYOffset||i.documentElement.scrollTop,f=n.top+d;d>=f&&d>c?a.classList.contains("affix")||(c=f,a.classList.add("affix"),a.classList.remove("affix-top"),e.style.marginTop=s+"px"):a.classList.contains("affix-top")||(a.classList.remove("affix"),a.classList.add("affix-top"),e.style.marginTop="0px"),o=!1},25))}};"loading"==i.readyState?i.addEventListener("DOMContentLoaded",d.init,!1):d.init()}(window,document,__tnt);
                    document.addEventListener('DOMContentLoaded', function() {
                        var isIOS = /iPad|iPhone|iPod/.test(navigator.userAgent) && !window.MSStream;
                        if (isIOS) {
                            Array.from(document.querySelectorAll('[data-toggle="offcanvas"]')).forEach(function(drawer) {
                                drawer.addEventListener("mouseover", function(e) {
                                    var drawerCls = drawer.dataset.target === 'left' ? 'active-left' : 'active-right';
                                    document.documentElement.classList.add('drawer-open', drawerCls);
                                })
                            })
                        }
                    }); /*]]>*/</script>
<script src="https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/owl.carousel.66c591eb93f177b0f59892f361c3b1b4.js"></script>
<script>/*<![CDATA[*/ 
                jQuery(document).ready(function($) {
            
                var gallery_ad_02168946_6da3_11ec_96eb_b399dee05af8_photo_modal = false;
                var gallery_changed_02168946_6da3_11ec_96eb_b399dee05af8_photo_modal = false;
                var sUrl =  window.location.href,
                        sUuid = sUrl.split("_").pop(),
                        sId = sUuid.substring(0, sUuid.indexOf('.')),
                        aInlineImages = document.querySelectorAll('.inline-image .image, .inline-image .expand');
                     for (i = 0; i < aInlineImages.length; ++i) {
                        var oImage = aInlineImages[i],
                            sInstance = oImage.getAttribute('data-instance'),
                            sTarget = oImage.getAttribute('data-target');
                        if (!oImage.classList.contains("tnt-asset-presentation-infographic")) {
                            if (sInstance != null && sTarget != null){
                                if (!sInstance.includes(sId)){
                                    oImage.setAttribute('data-instance', '#gallery-items-' + sId + '-photo-modal');
                                }
                                if (!sTarget.includes(sId)){
                                    oImage.setAttribute('data-target', '#photo-carousel-' + sId);
                                }
                            }
                        }
                     }
                $('#gallery-items-02168946-6da3-11ec-96eb-b399dee05af8-photo-modal').owlCarousel({
                    items: 1,
                    autoHeight: true,
                    lazyLoad: true,
                    loop: false,
                    navRewind: true,
                    responsiveRefreshRate: 500,
                    
                    
                    dots : false,
                    
                    onTranslated:function(){
                        
                        
                        
                            __tnt.trackEvent($('#gallery-items-02168946-6da3-11ec-96eb-b399dee05af8-photo-modal .photo-container').eq(this._current).data('track-object'));
                        

                        
                        

                        

                    }
                });
                
                var owl = $('#gallery-items-02168946-6da3-11ec-96eb-b399dee05af8-photo-modal');
                owl.on('changed.owl.carousel', function(event) {if( !$('#gallery-items-02168946-6da3-11ec-96eb-b399dee05af8-photo-modal .photo-container').eq(event.item.index).hasClass('engagement-stage') ){
                        setTimeout(function(){
                            $("#gallery-items-02168946-6da3-11ec-96eb-b399dee05af8-photo-modal .owl-stage-outer").height( $('#carousel-02168946-6da3-11ec-96eb-b399dee05af8-photo-modal .owl-item.active').height() );
                        }, 300);
                    }
                 
                 
                        

                        
                            var currItem = $('#gallery-items-02168946-6da3-11ec-96eb-b399dee05af8-photo-modal .photo-container').eq(event.item.index).data('count');
                            if(currItem){
                                $('#carousel-02168946-6da3-11ec-96eb-b399dee05af8-photo-modal .current-count').html(currItem);
                            }
                            $('.modal.in, #carousel-02168946-6da3-11ec-96eb-b399dee05af8-photo-modal .item').removeClass('hover');
                        
                        
                });
                
                var photo_carousel_02168946_6da3_11ec_96eb_b399dee05af8_photo_modal = $('#gallery-items-02168946-6da3-11ec-96eb-b399dee05af8-photo-modal').data('owlCarousel');
                $('#carousel-02168946-6da3-11ec-96eb-b399dee05af8-photo-modal .photo-carousel-control.left').on(__tnt.client.clickEvent, function(e){
                    photo_carousel_02168946_6da3_11ec_96eb_b399dee05af8_photo_modal.prev();
                });
                $('#carousel-02168946-6da3-11ec-96eb-b399dee05af8-photo-modal .photo-carousel-control.right').on(__tnt.client.clickEvent, function(e){
                    photo_carousel_02168946_6da3_11ec_96eb_b399dee05af8_photo_modal.next();
                });
            }); /*]]>*/</script>
<script>/*<![CDATA[*/ 
                // open photo modal
                jQuery(document).ready(function($){
                    $('[data-photo-target]').on('click', function(e){
                        e.preventDefault();
                        var item_target = $(this).data('target');
                        // get item index
                        var item_index = $(item_target +' '+$(this).data('photo-target')).parent().index();
                        // get current instance of carousel
                        var carousel_instance = $(this).data('instance');
                        var carousel_instance_data = $(carousel_instance).data('owlCarousel');
                        // fix non explict widths at viewports less than 900.
                        if(carousel_instance_data.width() < 320 & carousel_instance_data.viewport() < 900){
                            carousel_instance_data.onThrottledResize();
                        }
                        // load item from index
                        carousel_instance_data.to(item_index, 100, true);
                        // open modal
                        $(item_target).modal({'show':true});
                        __tnt.trackEvent({'category':'tnt-lightbox','action':'carousel-open', 'label':'article', 'value':'1'});
                        return false;
                    });
                    $('.photo-carousel-caption-toggle').on(__tnt.client.clickEvent, function(e){
                        var item_instance = $(this).data('instance');
                        $(item_instance +' .photo-carousel-caption-toggle').find('[data-fa-i2svg]').attr('data-icon', $(item_instance +' .photo-carousel-caption-toggle').find('[data-fa-i2svg]').attr('data-icon') == 'minus-circle' ? 'plus-circle' : 'minus-circle');
                    });
                }); /*]]>*/</script>
<script>/*<![CDATA[*/ 
                jQuery(document).ready(function($) {
            
                var gallery_ad_02168946_6da3_11ec_96eb_b399dee05af8 = false;
                var gallery_changed_02168946_6da3_11ec_96eb_b399dee05af8 = false;
                var sUrl =  window.location.href,
                        sUuid = sUrl.split("_").pop(),
                        sId = sUuid.substring(0, sUuid.indexOf('.')),
                        aInlineImages = document.querySelectorAll('.inline-image .image, .inline-image .expand');
                     for (i = 0; i < aInlineImages.length; ++i) {
                        var oImage = aInlineImages[i],
                            sInstance = oImage.getAttribute('data-instance'),
                            sTarget = oImage.getAttribute('data-target');
                        if (!oImage.classList.contains("tnt-asset-presentation-infographic")) {
                            if (sInstance != null && sTarget != null){
                                if (!sInstance.includes(sId)){
                                    oImage.setAttribute('data-instance', '#gallery-items-' + sId + '-photo-modal');
                                }
                                if (!sTarget.includes(sId)){
                                    oImage.setAttribute('data-target', '#photo-carousel-' + sId);
                                }
                            }
                        }
                     }
                $('#gallery-items-02168946-6da3-11ec-96eb-b399dee05af8').owlCarousel({
                    items: 1,
                    autoHeight: true,
                    lazyLoad: true,
                    loop: false,
                    navRewind: true,
                    responsiveRefreshRate: 500,
                    
                    
                    dots : false,
                    
                    onTranslated:function(){
                        
                        
                        
                            __tnt.trackEvent($('#gallery-items-02168946-6da3-11ec-96eb-b399dee05af8 .photo-container').eq(this._current).data('track-object'));
                        

                        
                        

                        

                    }
                });
                
                var owl = $('#gallery-items-02168946-6da3-11ec-96eb-b399dee05af8');
                owl.on('changed.owl.carousel', function(event) {if( !$('#gallery-items-02168946-6da3-11ec-96eb-b399dee05af8 .photo-container').eq(event.item.index).hasClass('engagement-stage') ){
                        setTimeout(function(){
                            $("#gallery-items-02168946-6da3-11ec-96eb-b399dee05af8 .owl-stage-outer").height( $('#carousel-02168946-6da3-11ec-96eb-b399dee05af8 .owl-item.active').height() );
                        }, 300);
                    }
                 
                 
                        try {
            
            var bOnlyDFP = false;
            if( typeof gptAdSlots != 'undefined' ){
                        googletag.cmd.push(function(){
                            googletag.pubads().clear();
                            googletag.pubads().refresh();
                        });}
                if( !bOnlyDFP && typeof TNCMS.AdManager != 'undefined' ){
                        TNCMS.AdManager.refresh({region: ''});}
            } catch(e) {
            __tnt.log(e);
        }

                        
                            var currItem = $('#gallery-items-02168946-6da3-11ec-96eb-b399dee05af8 .photo-container').eq(event.item.index).data('count');
                            if(currItem){
                                $('#carousel-02168946-6da3-11ec-96eb-b399dee05af8 .current-count').html(currItem);
                            }
                            $('.modal.in, #carousel-02168946-6da3-11ec-96eb-b399dee05af8 .item').removeClass('hover');
                        
                        
                });
                
                var photo_carousel_02168946_6da3_11ec_96eb_b399dee05af8 = $('#gallery-items-02168946-6da3-11ec-96eb-b399dee05af8').data('owlCarousel');
                $('#carousel-02168946-6da3-11ec-96eb-b399dee05af8 .photo-carousel-control.left').on(__tnt.client.clickEvent, function(e){
                    photo_carousel_02168946_6da3_11ec_96eb_b399dee05af8.prev();
                });
                $('#carousel-02168946-6da3-11ec-96eb-b399dee05af8 .photo-carousel-control.right').on(__tnt.client.clickEvent, function(e){
                    photo_carousel_02168946_6da3_11ec_96eb_b399dee05af8.next();
                });
            }); /*]]>*/</script>
<script>/*<![CDATA[*/ (function(){ var fallback = 72508; let zergnet = document.createElement("SCRIPT"); zergnet.type = 'text/javascript'; zergnet.async = true; zergnet.src = "https://www.zergnet.com/zerg-lk.js?ref="+encodeURIComponent(document.location.href)+"&domain="+encodeURIComponent(ZERG.domain)+"&fb="+encodeURIComponent(fallback)+"&u="+encodeURIComponent(ZERG.user); document.getElementsByTagName("HEAD")[0].appendChild( zergnet ); })(); /*]]>*/</script>
<script>/*<![CDATA[*/ function evvntDiscoveryInit_975241() {
        evvnt_require("evvnt/discovery_plugin").init({
            publisher_id: "suncoastnews.com",
            discovery: {
                element: "#evvnt-calendar-975241",
                detail_page_enabled: true,
                widget: true,
                virtual: false,
                map: false,
                category_id: null, 
                orientation: "portrait",
                number: 3,
            },
            submission: {
                partner_name: "Suncoast News",
                text: "Promote your event",
            }
        });
    } /*]]>*/</script>
<script>/*<![CDATA[*/ (function (a, c, s, u){'Insticator'in a || (a.Insticator={ad:{loadAd: function (b){Insticator.ad.q.push(b)}, q: []}, helper:{}, embed:{}, version: '3.0', q: [], load: function (t, o){Insticator.q.push({t: t, o: o})}}); var b=c.createElement(s); b.src=u; b.async=!0; var d=c.getElementsByTagName(s)[0]; d.parentNode.insertBefore(b, d)})(window, document, 'script', '//d2na2p72vtqyok.cloudfront.net/client-embed/b1ad8512-0208-404a-8bef-42066664235a.js');
                            /*&lt;![CDATA[[*/Insticator.ad.loadAd('div-insticator-ad-1');Insticator.ad.loadAd('div-insticator-ad-2');Insticator.load('em',{id:'40c1ddd3-f53e-4cc2-99cf-8551b04a81fa'})/*]]&gt;*/ /*]]>*/</script></body>
</html>