
  






<!DOCTYPE html>
        <html lang="en">
        <head>
<base href="https://www.suncoastnews.com/content/tncms/live/" />
<meta name="tncms-access-version" content="" />
<meta name="keywords" content="pasco county, new port richey, new port richey city council, main street flood mart mural" />
<meta name="news_keywords" content="pasco county, new port richey, new port richey city council, main street flood mart mural" />
<meta name="description" content="NEW PORT RICHEY &mdash; After Richard Melton threatened to resign his position as chairman of the Cultural Affairs Committee, the New Port Richey City Council on Sept. 6 approved the" />
<meta name="author" content="BRITTANY &Oacute; RUACH&Aacute;INN Suncoast News" />
<meta name="viewport" content="width=device-width, initial-scale=1.0" />
<meta name="apple-mobile-web-app-capable" content="yes" />
<meta name="apple-mobile-web-app-status-bar-style" content="black-translucent" />
<meta property="og:type" content="article" />
<meta property="og:url" content="https://www.suncoastnews.com/news/discussion-over-new-port-richey-mural-gets-heated/article_154f2f64-339f-11ed-9e8b-3724e641c836.html" />
<meta property="og:image" content="https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/7/b6/7b65ce20-339f-11ed-9645-4b9017fd6c82/6320e2c874023.image.jpg?crop=757%2C397%2C0%2C82&amp;resize=757%2C397&amp;order=crop%2Cresize" />
<meta property="og:image:width" content="757" />
<meta property="og:image:height" content="397" />
<meta property="og:title" content="Discussion over New Port Richey mural gets heated" />
<meta property="og:description" content="NEW PORT RICHEY &mdash; After Richard Melton threatened to resign his position as chairman of the Cultural Affairs Committee, the New Port Richey City Council on Sept. 6 approved the" />
<meta property="og:site_name" content="Suncoast News" />
<meta property="og:section" content="News" />
<meta property="article:publisher" content="http://www.facebook.com/SuncoastNews" />
<meta name="twitter:image" content="https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/7/b6/7b65ce20-339f-11ed-9645-4b9017fd6c82/6320e2c874023.image.jpg?crop=757%2C397%2C0%2C82&amp;resize=438%2C230&amp;order=crop%2Cresize" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:site" content="@SuncoastNews" />
<meta name="twitter:image:alt" content="Mural" />
<meta property="tncms:ads" content="smart,lazyload,refresh" />
<link rel="stylesheet preload" as="style" href="https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/shared-content/art/tncms/templates/libraries/flex/components/bootstrap/resources/styles/bootstrap.min.c58a1beaa3640fa94c3db09673c4d95c.css"/>
<link rel="stylesheet preload" as="style" href="https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/styles/layout.112f7ff365cd43379f336b81d31a7128.css"/>
<link rel="stylesheet preload" as="style" href="https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/shared-content/art/tncms/templates/libraries/flex/components/themes/resources/styles/theme-basic.6ee2c17f3ef34e32b5fa02524f5978e7.css"/>
<link rel="stylesheet" href="https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/live/global/resources/styles/site.css?_dc=1472828967"/>
<link rel="stylesheet" href="https://fonts.googleapis.com/css?family=Oswald|PT+Serif:400,600,700"/>
<link rel="stylesheet preload" as="style" href="https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/shared-content/art/tncms/templates/libraries/flex/components/block/resources/styles/flex-classifieds-bulletins.a78f8be1f6e0dabcb5acb9a8939501f8.css"/>
<style>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</style>
<script type="text/javascript">(function(){var tnsrc=window.location.hash.match(/[&#]tncms-source=([^&]+)/);var dl = window.dataLayer = window.dataLayer || [];dl.push({"townnews":{"product":{"software":"BLOX","version":"1.62.7"},"crm":{"group_id":"224"}},"tncms":{"template":{"version":"3.155.0"},"page":{"grid":"simple","style":"default","path":"\/news","syndicated":"false","reaction":"false","app":"editorial","theme":"flex","skin":"flex-editorial","http_status":200},"subscription":{"required":"false"},"asset":{"type":"article","author":"BRITTANY \u00d3 RUACH\u00c1INN\nSuncoast News","start_hour":"08","id":"154f2f64-339f-11ed-9e8b-3724e641c836","app":"editorial","ga_page":"\/news\/article_154f2f64-339f-11ed-9e8b-3724e641c836.html"},"vendor":{"outbrain":"disabled","taboola":""},"system":{"render_time":309},"client":{"is_bot":"no","is_gdpr":"no"}}});if (tnsrc && tnsrc[1]) {dl.push({'tncms.campaign.internal_source': tnsrc[1]});}window.addEventListener("DOMContentLoaded", function(oEvent) {var oTest = document.createElement('div');oTest.innerHTML = '&nbsp;';oTest.className = 'adsbox';document.body.appendChild(oTest);var nTimeoutID = window.setTimeout(function() {if (oTest.offsetHeight === 0) {dl.push({'event': 'tncms.ad.blocked'});}document.body.removeChild(oTest);window.clearTimeout(nTimeoutID);}, 100);});var nWidth=Math.max(document.documentElement.clientWidth, window.innerWidth || 0),aBPs=[[300,"Extra small: Most smartphones."],[768,"Small: Tablet devices."],[992,"Medium: Laptops & landscape tablets."],[1200,"Large: Desktop computers."]],i,c,aThisBP,aBP;for(i=0,c=aBPs.length;i<c;i++){aThisBP=aBPs[i];if(aBP===undefined||aThisBP[0]<=nWidth){aBP=aThisBP;}}if(aBP!==undefined){dl.push({'tncms.client.breakpoint':aBP[1]});}(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'tncms.start':new Date().getTime(),event:'tncms.start'});var f=d.getElementsByTagName(s)[0],j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src='https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);})(window,document,'script','dataLayer','GTM-PDQV3N');})();</script>
<script type="module" async="async" src="/shared-content/art/tncms/api/access.js"></script>
<script src="/shared-content/art/tncms/api/access-legacy.js" defer="defer" nomodule="nomodule"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/shared-content/art/tncms/templates/libraries/flex/components/jquery/resources/scripts/jquery.min.d6d18fcf88750a16d256e72626e676a6.js"></script>
<script src="/shared-content/art/tncms/user/user.js"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/shared-content/art/tncms/templates/libraries/flex/components/bootstrap/resources/scripts/bootstrap.min.d457560d3dfbf1d56a225eb99d7b0702.js"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/common.08a61544f369cc43bf02e71b2d10d49f.js"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/tnt.f3739bd4d04bcee9e077d20b4f31f29c.js"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/application.cb897187c4718280fd69d2e6d6c3909d.js"></script>
<script src="https://polyfill.io/v3/polyfill.min.js?features=default,fetch,IntersectionObserver,NodeList.prototype.@@iterator,Element.prototype.classList|gated" nomodule="nomodule"></script>
<script async="async" src="https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/shared-content/art/tncms/templates/libraries/flex/components/block/resources/scripts/user-controls.578df3df79d812af55ab13bae47f9857.js"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/tnt.navigation.accessibility.7a9170240d21440159b9bd59db72933b.js"></script>
<script async="async" src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script>
<script>/*<![CDATA[*/ window.googletag = window.googletag || {cmd: []};
    window.gptAdSlots = window.gptAdSlots || [];

    window.__tnt = window.__tnt || {};
    __tnt.ads = __tnt.ads || {};
    __tnt.ads.dfp = __tnt.ads.dfp || {};

    __tnt.ads.dfp.targeting = __tnt.ads.dfp.targeting || {};

    __tnt.ads.dfp.targeting.asset_id = '154f2f64-339f-11ed-9e8b-3724e641c836';
    __tnt.ads.dfp.targeting.k = ["pasco county","new port richey","new port richey city council","main street flood mart mural"];

    __tnt.ads.dfp.targeting.page = ["asset","article","app-editorial"];
    __tnt.ads.dfp.templates = __tnt.ads.dfp.templates || {};
    __tnt.ads.dfp.templates = {
        cube:"https:\/\/bloximages.newyork1.vip.townnews.com\/suncoastnews.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads\/resources\/scripts\/templates\/cube.d862aac30e9cb24516c7474509403c47.js",
        interstitial:"https:\/\/bloximages.newyork1.vip.townnews.com\/suncoastnews.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads\/resources\/scripts\/templates\/interstitial.df40f87de692498682823c6773da5459.js",
        nativeArticle:"https:\/\/bloximages.newyork1.vip.townnews.com\/suncoastnews.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads\/resources\/scripts\/templates\/native-article.9b3cd3bb8591bed71346f4fe429b96dc.js",
        pageCurl:"https:\/\/bloximages.newyork1.vip.townnews.com\/suncoastnews.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads\/resources\/scripts\/templates\/page-curl.ca0c1a7372c29272ef1ccf504ced01a9.js",
        parallax:"https:\/\/bloximages.newyork1.vip.townnews.com\/suncoastnews.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads\/resources\/scripts\/templates\/parallax.0ce32932f3b4125f930bea8d431f8f03.js",
        paw:"https:\/\/bloximages.newyork1.vip.townnews.com\/suncoastnews.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads\/resources\/scripts\/templates\/paw.9ea074ccc913cb273a4b790e1e37460a.js",
        pencil:"https:\/\/bloximages.newyork1.vip.townnews.com\/suncoastnews.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads\/resources\/scripts\/templates\/pencil.2662e4159cdac4809283c5399d78644b.js",
        reveal:"https:\/\/bloximages.newyork1.vip.townnews.com\/suncoastnews.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads\/resources\/scripts\/templates\/reveal.e5d561a6b71aa2730a07fa90f5f4f6d6.js",
        roller:"https:\/\/bloximages.newyork1.vip.townnews.com\/suncoastnews.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads\/resources\/scripts\/templates\/roller.c699c542afb9f08b38613e8473ddf14f.js",
        slider:"https:\/\/bloximages.newyork1.vip.townnews.com\/suncoastnews.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads\/resources\/scripts\/templates\/slider.015001bff591d1665c6d0ec2a888b1ca.js",
        stickyAnchor:"https:\/\/bloximages.newyork1.vip.townnews.com\/suncoastnews.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads\/resources\/scripts\/templates\/sticky-anchor.fc1a4213adeec354910108f84bf0e732.js",
        video:"https:\/\/bloximages.newyork1.vip.townnews.com\/suncoastnews.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads\/resources\/scripts\/templates\/video-inline.9b0997ab77d1d69707d283848faeacdd.js",
        wallpaper:"https:\/\/bloximages.newyork1.vip.townnews.com\/suncoastnews.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads\/resources\/scripts\/templates\/wallpaper.dc1c1bace62343a130be3589fe0846f9.js"
    }; /*]]>*/</script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '/132916964,22674386519/suncoastnews.com/news';
            
                gptAdSlots['ad-1264906'] = googletag.defineSlot(adUnit, [2,1], 'ad-1264906').setCollapseEmptyDiv(true).addService(googletag.pubads());
                gptAdSlots['ad-1264906'].setTargeting('pos', ['impact-top']);
    });
 /*]]>*/</script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '/132916964,22674386519/suncoastnews.com/news';
            var mapping = googletag.sizeMapping().addSize([320, 0], [320, 50]).addSize([768, 0], [[728, 90], [320,50]]).addSize([992, 0], [[970, 90], [728, 90], [970, 250]]).addSize([1200, 0], [[1170, 90],[970, 90], [728, 90], [970, 250]]).build();
                gptAdSlots['ad-1264879'] = googletag.defineSlot(adUnit, [[320,50],[728,90],[970,90],[970,250],[1170,90]], 'ad-1264879').defineSizeMapping(mapping).setCollapseEmptyDiv(true).addService(googletag.pubads());
                gptAdSlots['ad-1264879'].setTargeting('pos', ['leaderboard-one']);
    });
 /*]]>*/</script>
<script async="async" src="https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/sms-link.8eefede3265fd6c6de07bc0cb5f3f779.js"></script>
<script async="async" src="https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/shared-content/art/tncms/templates/libraries/flex/components/asset/resources/scripts/tnt.nextPrev.283bfb49ef55c073fceda15ffbf58de8.js"></script>
<script>/*<![CDATA[*/ var ZERG = ZERG || {};
                    ZERG.domain = "suncoastnews.com";
                    ZERG.user = 57683; /*]]>*/</script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '/132916964,22674386519/suncoastnews.com/news';
            var mapping = googletag.sizeMapping().addSize([320, 0], [[300, 250], [320, 50]]).addSize([768, 0], [[300, 250], [320, 50]]).addSize([992, 0], [[300, 250], [300,600]]).addSize([1200, 0], [[300, 250], [300,600]]).build();
                gptAdSlots['ad-1264891'] = googletag.defineSlot(adUnit, [[300,250],[320,50],[300,600]], 'ad-1264891').defineSizeMapping(mapping).setCollapseEmptyDiv(true).addService(googletag.pubads());
                gptAdSlots['ad-1264891'].setTargeting('pos', ['rectangle-one']);
    });
 /*]]>*/</script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '/132916964,22674386519/suncoastnews.com/news';
            var mapping = googletag.sizeMapping().addSize([320, 0], [[300, 250], [320, 50]]).addSize([768, 0], [[300, 250], [320, 50]]).addSize([992, 0], [[300, 250], [300,600]]).addSize([1200, 0], [[300, 250], [300,600]]).build();
                gptAdSlots['ad-1264894'] = googletag.defineSlot(adUnit, [[300,250],[320,50],[300,600]], 'ad-1264894').defineSizeMapping(mapping).setCollapseEmptyDiv(true).addService(googletag.pubads());
                gptAdSlots['ad-1264894'].setTargeting('pos', ['rectangle-two']);
    });
 /*]]>*/</script>
<script>/*<![CDATA[*/ function evvntDiscoveryInit_975241() {
        evvnt_require("evvnt/discovery_plugin").init({
            publisher_id: "suncoastnews.com",
            discovery: {
                element: "#evvnt-calendar-975241",
                detail_page_enabled: true,
                widget: true,
                virtual: false,
                map: false,
                category_id: null, 
                orientation: "portrait",
                number: 3,
            },
            submission: {
                partner_name: "Suncoast News",
                text: "Promote your event",
            }
        });
    } /*]]>*/</script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '/132916964,22674386519/suncoastnews.com/news';
            var mapping = googletag.sizeMapping().addSize([320, 0], [[300, 250], [320, 50]]).addSize([768, 0], [[300, 250], [320, 50]]).addSize([992, 0], [[300, 250], [300,600]]).addSize([1200, 0], [[300, 250], [300,600]]).build();
                gptAdSlots['ad-1264900'] = googletag.defineSlot(adUnit, [[300,250],[320,50],[300,600]], 'ad-1264900').defineSizeMapping(mapping).setCollapseEmptyDiv(true).addService(googletag.pubads());
                gptAdSlots['ad-1264900'].setTargeting('pos', ['rectangle-three']);
    });
 /*]]>*/</script>
<script async="async" src="https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/ie.grid.placement.8d31e32afeebe4520bfab9638ef91435.js"></script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '/132916964,22674386519/suncoastnews.com/news';
            var mapping = googletag.sizeMapping().addSize([320, 0], [[300, 250], [320, 50]]).addSize([768, 0], [[300, 250], [320, 50]]).addSize([992, 0], [[300, 250], [300,600]]).addSize([1200, 0], [[300, 250], [300,600]]).build();
                gptAdSlots['ad-1264903'] = googletag.defineSlot(adUnit, [[300,250],[320,50],[300,600]], 'ad-1264903').defineSizeMapping(mapping).setCollapseEmptyDiv(true).addService(googletag.pubads());
                gptAdSlots['ad-1264903'].setTargeting('pos', ['rectangle-four']);
    });
 /*]]>*/</script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '/132916964,22674386519/suncoastnews.com/news';
            var mapping = googletag.sizeMapping().addSize([320, 0], [320, 50]).addSize([768, 0], [[728, 90], [320,50]]).addSize([992, 0], [[970, 90], [728, 90], [970, 250]]).addSize([1200, 0], [[1170, 90],[970, 90], [728, 90], [970, 250]]).build();
                gptAdSlots['ad-1264888'] = googletag.defineSlot(adUnit, [[320,50],[728,90],[970,90],[970,250],[1170,90]], 'ad-1264888').defineSizeMapping(mapping).setCollapseEmptyDiv(true).addService(googletag.pubads());
                gptAdSlots['ad-1264888'].setTargeting('pos', ['leaderboard-four']);
    });
 /*]]>*/</script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '/132916964,22674386519/suncoastnews.com/news';
            var mapping = googletag.sizeMapping().addSize([320, 0], [320, 50]).addSize([768, 0], [[728, 90], [320,50]]).addSize([992, 0], [[970, 90], [728, 90]]).addSize([1200, 0], [[1170, 90],[970, 90], [728, 90]]).build();
                gptAdSlots['ad-1264909'] = googletag.defineSlot(adUnit, [[320,50],[728,90],[970,90],[1170,90]], 'ad-1264909').defineSizeMapping(mapping).setCollapseEmptyDiv(true).addService(googletag.pubads());
                gptAdSlots['ad-1264909'].setTargeting('pos', ['sticky-anchor']);
    });
 /*]]>*/</script>
<script src="https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/shared-content/art/tncms/templates/libraries/flex/components/ads/resources/scripts/tnt.ads.adverts.66a3812a7b5c12fde8cd998fd691ad7d.js"></script>
<script src="/shared-content/art/tncms/tracking.js"></script>
<script>/*<![CDATA[*/ __tnt.recentFive = {
    /*
     * Gets the data stored in 'tnt:recent:five'
     * Returns Array
     */
        get:function(){
            if(window.localStorage && localStorage.getItem('tnt:recent:five')!=null){
                try{ return JSON.parse(localStorage.getItem('tnt:recent:five')); } catch {}
            }

            return [];
        },

    /*
     * Sets the 'tnt:recent:five' localStorage item
     * Returns boolean
     */
        set:function(data){
            if(window.localStorage){
                try{ 
                    localStorage.setItem('tnt:recent:five', JSON.stringify(data));
                    return true;
                } catch {}
            }

            return false;
        },

    /*
     * Adds the most recent item, prunes any duplicates, and trims the array down to 5 items
     * Returns Array on success, false on fail 
     */
        add:function(asset){
            var assets = __tnt.recentFive.get();
            assets.unshift(asset);

            if(assets.length > 1){
                assets = assets.filter(function(item, index, a){ return a.indexOf(item) == index });

                while(assets.length>5){
                    assets.pop();
                }
            }

            if(__tnt.recentFive.set(assets)){ return assets; }
            return false;
        }
    }; /*]]>*/</script>
<script>/*<![CDATA[*/ 

    googletag.cmd.push(function() {
        googletag.pubads().setTargeting('browser', __tnt.client.browser.name);
        if (__tnt.ads.dfp.targeting) {
            for (var k in __tnt.ads.dfp.targeting) {
                if (__tnt.ads.dfp.targeting.hasOwnProperty(k)) {
                    googletag.pubads().setTargeting(k,__tnt.ads.dfp.targeting[k]);
                }
            }
        }
            googletag.pubads().disableInitialLoad();
            googletag.pubads().addEventListener('impressionViewable', function(event) {
                for (var key in gptAdSlots) {
                    if (gptAdSlots[key] === event.slot && __tnt.ads.slots[key]) {
                        if (!__tnt.ads.slots[key].viewableImpression) __tnt.ads.slots[key].viewableImpression = true;
                    }
                }
            });

        googletag.pubads().enableSingleRequest();
        googletag.enableServices();
    });
 /*]]>*/</script>

            
            <title>Discussion over New Port Richey mural gets heated | News | suncoastnews.com</title>
            
    <style>body { background-color: #d5d4d0; color: #333333; }a, a:hover, .pagination>li>a, .pagination>li>a:hover, .btn-link, .dropdown-menu>li>a, blockquote, blockquote p, .asset .asset-body blockquote p { color: #4175aa; } #main-body-container .container, #main-body-container .container_fluid, .well-main { background-color: #ffffff; } .tnt-content-width-container > * { max-width: 1140px; margin-left: auto; margin-right: auto; } #site-navbar-container, #main-navigation { background-color: #f4f4f2; } .fixed-nav #main-navigation { background-color: #f4f4f2 !important; } #site-top-nav-container, #site-top-nav { background-color: #ffffff; } #site-footer { background-color: #ffffff; color: #333333; } .navbar-default .navbar-nav>li>a, .navbar-default .navbar-nav>li>a:hover, .navbar-default .navbar-nav>li>a:focus, .navbar-default .navbar-nav>.open>a, .navbar-default .navbar-nav>.open>a:hover, .navbar-default .navbar-nav>.open>a:focus, .navbar-default .navbar-nav>li>button.nav-link, .navbar-default .navbar-nav>li>button.nav-link:hover, .navbar-default .navbar-nav>li>button.nav-link:focus, .navbar-default .navbar-nav>.open>button.nav-link, .navbar-default .navbar-nav>.open>button.nav-link:hover, .navbar-default .navbar-nav>.open>button.nav-link:focus{ color: #666; } .navbar-toggle .icon-bar { background-color: #666 !important; } .navbar-toggle .sr-only-show { color: #666 !important; } #site-top-nav .list-inline>li>a { color: #4175aa; } .asset .asset-body p, .asset #asset-content p { color: #444; } #site-header { background-color: #ffffff; }/* remove full span bgs */ #site-navbar-container, #site-header-container, #site-top-nav-container { background-color: transparent !important; background-image: none !important; }/* remove full span bgs */ #site-footer-container { background-color: transparent !important; background-image: none !important; }@media (max-width: 991px){ .navbar-default .navbar-nav .open .dropdown-menu>li>a, .navbar-default .navbar-nav .open .dropdown-menu>li>a:hover, .navbar-default .navbar-nav .open .dropdown-menu>li>a:focus { color: #666; } }#site-copyright a, #site-footer a { color: #4175aa; }.search-redesign .top-breakout > .row { max-width: 1200px; }.nav-tabs>li.active>a, .nav-tabs>li.active>a:hover, .nav-tabs>li.active>a:focus { border-top-color: #005296; }#site-header{ border-bottom: 3px solid #005296; }#site-footer{ border-top: 3px solid #005296; } .tnt-bg-accent { background-color: #005296; } a .tnt-caret-down { color: #005296; } .block-title .block-title-inner { border-color: #005296; } a.thumbnail:hover, a.thumbnail:focus, a.thumbnail.active { border-color: #005296; } .form-control:focus { border-bottom-color: #005296; } /* Place site-wide CSS here */ /* Primary color: #1033e3Secondary color: #d6bd1a*/ a { color:#005296;} a:hover { color:#111111;} #weather-501439 .weather-expanded small { opacity: 0.8; color: #f4f4f2; } #site-header { border-bottom: 2px solid #cacaca;} .navbar-nav>li { border-left: 1px solid #e6e6e6; border-right: solid 1px #cacaca; } @media (min-width: 992px){ .sn-logo-block .img-responsive { max-width: 540px!important;} .nav>li>a { padding: 10px 20px;} } #main-navigation #navbar-collapse { box-shadow: 0px 10px 6px -6px rgba(0, 0, 0, 0.25); } .navbar { min-height: 40px;} .navbar-default .navbar-nav>.open>a, .navbar-default .navbar-nav>.open>a:hover { background-color: #111111!important; color: #ffffff!important; text-shadow: 1px 1px 1px #000000; } .site-search-form.input-group.pull-right.input-group-lg { box-shadow: 0px 10px 6px -6px rgba(0, 0, 0, 0.25); } #site-search-399654 .input-group-btn:last-child>.btn, .input-group-btn:last-child>.btn-group { color: #f5f0f0!important; background: #1f1a1c!important; } .navbar-default .navbar-nav>li>a:hover { background-color:#111111;color:#ffffff!important; text-shadow: 1px 1px 1px #000000;} .dropdown-menu { background-color:#111111;color:#f4f4f2!important;} .dropdown-menu>li>a { color:#f4f4f2!important;} .dropdown-menu>li>a:hover { background:#f7f7f7;color:#197DC0!important;} .btn-primary { color: #fff; background-color: #115588; border-color: #357ebd; } .btn-success { color: #564949; background-color: #b6eb07; border-color: #4cae4c; } .card figure .image .asset-icon { position: absolute; bottom: 0; left: 0; padding: 4px; color: #a4c8eb; } .block-title h1, .block-title h2, .block-title h3, .block-title h4, .block-title h5, .block-title h6 { /* font-family: 'Bevan', cursive; */ font-family: 'Oswald', sans-serif; margin: 0px; } .card-headline { font-family: 'PT Serif', serif!important; font-weight: bold; } .asset .asset-header h1 { font-family: 'PT Serif', serif;} .asset .asset-body p {color: #888887;} #site-footer { margin-bottom: 0px;} #site-copyright { color:#ffffff;background: #004d98;} #site-copyright a {color:#ffffff;} .dropdown-header { color: #8bbcea!important;} .datepicker.dropdown-menu th { color: #000000!important;} </style>
    
        <link rel="shortcut icon" type="image/x-icon" href="https://www.suncoastnews.com/content/tncms/site/icon.ico" />
    
        <link rel="preconnect" href="//www.google.com">
    
        <link rel="preconnect" href="//adservice.google.com">
    
        <link rel="preconnect" href="//securepubads.g.doubleclick.net">
    
        <link rel="preconnect" href="//stats.g.doubleclick.net">
    
        <link rel="preconnect" href="//tpc.googlesyndication.com">
    
        <link rel="preconnect" href="//pagead2.googlesyndication.com">
    
        <link rel="preconnect" href="//www.googletagmanager.com">
    
        <link rel="preconnect" href="//www.google-analytics.com">
    <link rel="alternate" type="application/rss+xml" title="Discussion over New Port Richey mural gets heated | News | suncoastnews.com" href="http://www.suncoastnews.com/search/?f=rss&amp;t=article&amp;c=news&amp;l=50&amp;s=start_time&amp;sd=desc" />
    <link rel="canonical" href="https://www.suncoastnews.com/news/discussion-over-new-port-richey-mural-gets-heated/article_154f2f64-339f-11ed-9e8b-3724e641c836.html" />
            <script defer src="https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/fontawesome.46a248d75dc687aa8d928092f6b77fc7.js"></script>
            
        </head>
        <body class="fixed-scroll-nav app-editorial grid-simple blox-asset uuid-154f2f64-339f-11ed-9e8b-3724e641c836  section-news type-article infinity-disabled" data-path="/news">
	<script type='text/javascript' src='/shared-content/art/stats/common/tracker.js'></script>
	<script type='text/javascript'>
	<!--
	if (typeof(TNStats_Tracker) !== 'undefined' && typeof(TNTracker) === 'undefined') { TNTracker = new TNStats_Tracker('www.suncoastnews.com'); TNTracker.trackPageView(); }
	// -->
	</script>
	<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-PDQV3N&amp;townnews.product.software=BLOX&amp;townnews.product.version=1.62.7&amp;townnews.crm.group_id=224&amp;tncms.template.version=3.155.0&amp;tncms.page.grid=simple&amp;tncms.page.style=default&amp;tncms.page.path=%2Fnews&amp;tncms.page.syndicated=false&amp;tncms.page.reaction=false&amp;tncms.page.app=editorial&amp;tncms.page.theme=flex&amp;tncms.page.skin=flex-editorial&amp;tncms.page.http_status=200&amp;tncms.subscription.required=false&amp;tncms.asset.type=article&amp;tncms.asset.author=BRITTANY+%C3%93+RUACH%C3%81INN%0ASuncoast+News&amp;tncms.asset.start_hour=08&amp;tncms.asset.id=154f2f64-339f-11ed-9e8b-3724e641c836&amp;tncms.asset.app=editorial&amp;tncms.asset.ga_page=%2Fnews%2Farticle_154f2f64-339f-11ed-9e8b-3724e641c836.html&amp;tncms.vendor.outbrain=disabled&amp;tncms.vendor.taboola=&amp;tncms.system.render_time=309&amp;tncms.client.is_bot=no&amp;tncms.client.is_gdpr=no&amp;tncms.client.noscript=yes" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
        <a href="#main-page-container" class="sr-only" onclick="document.getElementById('main-page-container').scrollIntoView(); return false">Skip to main content</a>
        
        
        <!-- Google Tag Manager -->
        <script>
            var dataLayer = window.dataLayer || [];
            dataLayer.push(
                {'user_id': __tnt.user.screenName},
                {'user_state': __tnt.user.loggedIn ? 'logged in' : 'anonymous'},
                {'utm_label': __tnt.urlHash('utm_label')}
            );
        </script>
        <noscript><iframe src="//www.googletagmanager.com/ns.html?id=" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
        <script>
            (function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
            new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
            j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
            '//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
            })(window,document,'script','dataLayer','');
        </script>
        <script>
            $(function(){
                var bloxServiceIDs = [];
                var bloxUserServiceIds = [];
                var dataLayer = window.dataLayer || [];

                

                if (__tnt.user.services){
                    var bloxUserServiceIDs = __tnt.user.services.replace('%2C',',').split(',');
                }

                // GTM tncms.subscription.paid_access_service_ids
                if(bloxServiceIDs){
                    dataLayer.push({'tncms':{'subscription':{'access_service_ids':bloxServiceIDs.toString()}}});
                }

                // GTM tncms.subscrption.user_service_ids
                if(bloxUserServiceIDs){
                    dataLayer.push({'tncms':{'subscription':{'user_service_ids':bloxUserServiceIDs.toString()}}});
                }
            });
        </script>
        
        <div id="site-container"><div id="asset-admin-bar" class="asset-edit-bar hidden-print">
                <div class="asset-edit-icon"><i class="fas tnt-lock-open tnt-fw"></i></div>
                <div class="asset-edit-message">You have permission to edit this article.</div>
                <div class="asset-edit-btns">
                    <a class="btn btn-primary btn-sm" target="_blank" rel="noopener" href="https://www.suncoastnews.com/tncms/admin/editorial-asset/?edit=154f2f64-339f-11ed-9e8b-3724e641c836"><i class="fas tnt-pencil-alt tnt-fw"></i> Edit</a>
                    <button class="asset-edit-close btn btn-link btn-sm"><i class="fas tnt-times"></i><span class="sr-only">Close</span></button>
                </div>
            </div>
        
    
        
        
           <aside class="hidden-print offcanvas-drawer offcanvas-drawer-right visible-sm visible-xs" aria-label="Right Main Menu" aria-expanded="false" tabindex="-1">
                <div id="tncms-region-mobile-nav-top-right-region" class="tncms-region "><div id="tncms-block-501437" class="tncms-block hidden-md hidden-lg"><div id="user-controls-501437" class="user-controls show-onload clearfix default"><div class="not-logged-in">
        <ul class="list-inline"><li>
                    <a href="https://www.suncoastnews.com/users/signup/?referer_url=https%3A%2F%2Fwww.suncoastnews.com%2Fnews%2Fdiscussion-over-new-port-richey-mural-gets-heated%2Farticle_154f2f64-339f-11ed-9e8b-3724e641c836.html" class="btn btn-link btn-sm user-control-link" rel="nofollow">
                        Sign Up
                    </a>
                </li><li>
                    <a href="https://www.suncoastnews.com/users/login/?referer_url=https%3A%2F%2Fwww.suncoastnews.com%2Fnews%2Fdiscussion-over-new-port-richey-mural-gets-heated%2Farticle_154f2f64-339f-11ed-9e8b-3724e641c836.html" class="btn btn-primary btn-sm login-btn user-control-link" rel="nofollow">
                        Log In
                    </a></li>
        </ul>
    </div>

    <div class="logged-in">
        
        
            <div class="hide show-offcanvas">
                <ul class="list-inline">
                    <li>
                        <a href="https://www.suncoastnews.com/users/admin/" class="btn btn-primary btn-sm login-btn user-control-link">
                            Dashboard
                        </a>
                    </li>
                    <li>
                        <a class="btn btn-link btn-sm user-control-link" onclick="document.getElementById('user-logout-form-501437').submit(); return false;" rel="nofollow">
                            Logout
                        </a>
                    </li>
                </ul>
            </div>
        
        <ul class="hide-offcanvas list-inline">
            <li class="dropdown pull-right">
                
                <div class="dropdown-toggle btn btn-link btn-sm user-dropdown" data-toggle="dropdown" data-hover="dropdown" data-hover-delay="250"><div class="tn-user-avatar pull-left"><!-- user avatar --></div><span class="tn-user-screenname pull-left"></span><b class="caret user-control-link"></b>
                </div>
                <ul class="dropdown-menu dropdown-menu-right" role="menu">
                    <li role="presentation" class="dropdown-header">My Account</li>
                    <li role="menuitem"><a href="https://www.suncoastnews.com/users/admin/" rel="nofollow"><i class="fas tnt-tachometer-alt tnt-fw"></i> Dashboard</a></li>
                    <li role="menuitem"><a class="tn-user-profile-url" href="" data-app="https://www.suncoastnews.com/users/"><i class="fas tnt-user tnt-fw"></i> Profile</a></li>
                    <li role="menuitem"><a href="https://www.suncoastnews.com/users/admin/list/" rel="nofollow"><i class="fas tnt-bookmark tnt-fw"></i> Saved items</a></li>
                    <li role="separator" class="divider"></li>
                    <li role="menuitem">
                        <a class="logout-btn" onclick="document.getElementById('user-logout-form-501437').submit(); return false;" rel="nofollow">
                        <i class="fas tnt-sign-out-alt tnt-fw"></i> Logout
                        </a>
                    </li>
                </ul>
            </li>
        </ul>
    </div>
</div>

<form method="post" action="https://www.suncoastnews.com/users/logout/" id="user-logout-form-501437"><input type="hidden" name="referer_url" value="https://www.suncoastnews.com/news/discussion-over-new-port-richey-mural-gets-heated/article_154f2f64-339f-11ed-9e8b-3724e641c836.html"><input type="submit" name="logout" value="Logout" class="hide">
</form></div></div>
                <div id="tncms-region-nav-mobile-nav-right" class="tncms-region-nav"><div id="mobile-nav-right_menu" class="panel-group nav navbar-nav" role="tablist" aria-hidden="true"><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" href="/news/pasco/"  class="nav-link tnt-section-pasco ">Pasco</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" href="/news/pinellas/"  class="nav-link tnt-section-pinellas ">Pinellas</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" href="/news/hernando/"  class="nav-link tnt-section-hernando ">Hernando</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" href="/sports/"  class="nav-link tnt-section-sports ">Sports</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" href="/business/"  class="nav-link tnt-section-business ">Business</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" href="/classifieds/"  class="nav-link tnt-section-classifieds ">Classifieds</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><span tabindex="-1" aria-hidden="true" data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-right_menu-child-7" data-target="#mobile-nav-right_menu-child-7">
                                    <i class="fas tnt-chevron-down"></i>
                                </span><a tabindex="-1" aria-hidden="true" href="/local-events/"  class="nav-link tnt-section-local-events ">Local Events</a>
                        </div>
                    </div><ul id="mobile-nav-right_menu-child-7" class="collapse nav navbar-nav"><li>
                                    <a tabindex="-1" aria-hidden="true" href="https://new.evvnt.com/?with_navbar&amp;force_snap_sell&amp;partner=SUNCOASTNEWS&amp;publisher_url:suncoastnews.com#/quick"  target="_blank" rel="noopener" class="nav-link tnt-section-promote-your-event">Promote Your Event</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" href="/multimedia/"  class="nav-link tnt-section-multimedia ">Multimedia</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" href="https://www.suncoastnews.com/classifieds/legal_notices/?l=25"  target="_blank" rel="noopener" class="nav-link tnt-section-legal-notices ">Legal Notices</a>
                        </div>
                    </div></div></div></div>
                
                <div id="tncms-region-mobile-nav-bottom-right-region" class="tncms-region "><div id="tncms-block-501422" class="tncms-block hidden-md hidden-lg"><section id="block-501422" class="block emphasis-h3   " >
    <div class="clearfix"></div>
    <div id="search-form-501422" class="search-form-container card clearfix text-center hidden-print ">
    <form id="site-search-501422" aria-label="Site search" action="/search/" method="GET" >
    <input type="hidden" name="l" value="25">
    
        
        <input type="hidden" name="sort" value="relevance">
    
    
    
    
    <input type="hidden" name="f" value="html">
    
        
        <input type="hidden" name="t" value="article,video,youtube,collection">
    
    <input type="hidden" name="app" value="editorial">
    <input type="hidden" name="nsa" value="eedition">
    <div id="site-search-form-501422" class="site-search-form input-group default normal form-control">
        <label for="site-search-501422-term" class="sr-only">Site search</label>
        <input id="site-search-501422-term" name="q" title="Site search" type="text" placeholder="Search..." class="form-control" autocomplete="off">
        <input type="submit" class="hide" value="Search">
        <span class="input-group-btn">
            <button id="site-search-501422-btn" class="btn btn-link" aria-label="Submit Site Search" type="submit">
                
                <span id="site-search-button-501422" class="hidden-xs hidden-sm sr-only">Search</span>
            </button>
        </span>
    </div>
    <div class="clearfix"></div>
</form>
        
        
        <div class="clearfix"></div>
    </div>
    </section></div></div>
            </aside>
        

        <div class="offcanvas-inner">
            <div class="offcanvas-close-btn hidden-md hidden-lg"></div>
    
    
    
    
    <div id="tncms-region-global-skyline" class="tncms-region "><div id="tncms-block-1264906" class="tncms-block"><div class="tnt-ads-container text-center  " >
        <div id="ad-1264906" class="tnt-ads dfp-ad margin-bottom-none" data-lazy="true" data-refresh="true" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('ad-1264906');
                        
                });
            </script>
        </div>
    </div>
</div></div>
    

    
        <div id="site-top-nav-container" class="hidden-sm hidden-xs hidden-print">
            <header id="site-top-nav" class="container">
                <div class="row">
                    <div id="topbar-col-one" class="col-md-6 col-sm-6"><div id="tncms-region-topbar-col-one" class="tncms-region "></div><div id="tncms-region-nav-topbar-col-one-nav" class="tncms-region-nav"><ul id="topbar-col-one-nav_menu" class="list-inline nav-list"><li>
                <a class="nav-link    tnt-section-about-us"  href="/site/about.html"  tabindex="0" >
                    <span class="nav-label ">About Us</span>
                </a></li><li>
                <a class="nav-link    tnt-section-contact-us"  href="/site/contact.html"  tabindex="0" >
                    <span class="nav-label ">Contact Us</span>
                </a></li><li>
                <a class="nav-link    tnt-section-advertising-information"  href="/advertise/"  tabindex="0" >
                    <span class="nav-label ">Advertising Information</span>
                </a></li><li>
                <a class="nav-link    tnt-section-subscribe"  href="/site/forms/subscription_services"  tabindex="0" >
                    <span class="nav-label ">Subscribe</span>
                </a></li></ul></div></div>
    <div id="topbar-col-two" class="col-md-6 col-sm-6"><div id="tncms-region-topbar-col-two" class="tncms-region "><div id="tncms-block-501436" class="tncms-block"><div id="user-controls-501436" class="user-controls show-onload clearfix pull-right"><div class="not-logged-in">
        <ul class="list-inline"><li>
                    <a href="https://www.suncoastnews.com/users/signup/?referer_url=https%3A%2F%2Fwww.suncoastnews.com%2Fnews%2Fdiscussion-over-new-port-richey-mural-gets-heated%2Farticle_154f2f64-339f-11ed-9e8b-3724e641c836.html" class="btn btn-link btn-sm user-control-link" rel="nofollow">
                        Sign Up
                    </a>
                </li><li>
                    <a href="https://www.suncoastnews.com/users/login/?referer_url=https%3A%2F%2Fwww.suncoastnews.com%2Fnews%2Fdiscussion-over-new-port-richey-mural-gets-heated%2Farticle_154f2f64-339f-11ed-9e8b-3724e641c836.html" class="btn btn-primary btn-sm login-btn user-control-link" rel="nofollow">
                        Log In
                    </a></li>
        </ul>
    </div>

    <div class="logged-in">
        
        
            <div class="hide show-offcanvas">
                <ul class="list-inline">
                    <li>
                        <a href="https://www.suncoastnews.com/users/admin/" class="btn btn-primary btn-sm login-btn user-control-link">
                            Dashboard
                        </a>
                    </li>
                    <li>
                        <a class="btn btn-link btn-sm user-control-link" onclick="document.getElementById('user-logout-form-501436').submit(); return false;" rel="nofollow">
                            Logout
                        </a>
                    </li>
                </ul>
            </div>
        
        <ul class="hide-offcanvas list-inline">
            <li class="dropdown pull-right">
                
                <div class="dropdown-toggle btn btn-link btn-sm user-dropdown" data-toggle="dropdown" data-hover="dropdown" data-hover-delay="250"><div class="tn-user-avatar pull-left"><!-- user avatar --></div><span class="tn-user-screenname pull-left"></span><b class="caret user-control-link"></b>
                </div>
                <ul class="dropdown-menu dropdown-menu-right" role="menu">
                    <li role="presentation" class="dropdown-header">My Account</li>
                    <li role="menuitem"><a href="https://www.suncoastnews.com/users/admin/" rel="nofollow"><i class="fas tnt-tachometer-alt tnt-fw"></i> Dashboard</a></li>
                    <li role="menuitem"><a class="tn-user-profile-url" href="" data-app="https://www.suncoastnews.com/users/"><i class="fas tnt-user tnt-fw"></i> Profile</a></li>
                    <li role="menuitem"><a href="https://www.suncoastnews.com/users/admin/list/" rel="nofollow"><i class="fas tnt-bookmark tnt-fw"></i> Saved items</a></li>
                    <li role="separator" class="divider"></li>
                    <li role="menuitem">
                        <a class="logout-btn" onclick="document.getElementById('user-logout-form-501436').submit(); return false;" rel="nofollow">
                        <i class="fas tnt-sign-out-alt tnt-fw"></i> Logout
                        </a>
                    </li>
                </ul>
            </li>
        </ul>
    </div>
</div>

<form method="post" action="https://www.suncoastnews.com/users/logout/" id="user-logout-form-501436"><input type="hidden" name="referer_url" value="https://www.suncoastnews.com/news/discussion-over-new-port-richey-mural-gets-heated/article_154f2f64-339f-11ed-9e8b-3724e641c836.html"><input type="submit" name="logout" value="Logout" class="hide">
</form></div><div id="tncms-block-501423" class="tncms-block"><div class="follow-links-501423 pull-right">
    
    <section id="block-501423" class="block emphasis-h3   " ><ul class="list-inline">
        
            <li>
                <a href="http://facebook.com/SuncoastNews/" title="Facebook" target="_blank" rel="noopener" class="btn btn-xs btn-link fb" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-facebook-f"></i>
                    <span class="sr-only">Facebook</span>
                </a>
            </li>
        
        
            <li>
                <a href="http://twitter.com/SuncoastNews/" title="Twitter" target="_blank" rel="noopener" class="btn btn-xs btn-link tw" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-twitter"></i>
                    <span class="sr-only">Twitter</span>
                </a>
            </li>
        
        
        
            <li>
                <a href="http://www.youtube.com/user/SCNPasco" title="Youtube" target="_blank" rel="noopener" class="btn btn-xs btn-link yt" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-youtube"></i>
                    <span class="sr-only">YouTube</span>
                </a>
            </li>
        
        
        
        
        
        
        
        
        
        
        
        
        
        
    </ul>
    </section>
</div>
<script type="application/ld+json">
{ "@context" : "https://schema.org",
  "@type" : "Organization",
  "url" : "http://www.suncoastnews.com",
  "sameAs" : ["http://facebook.com/SuncoastNews/","http://twitter.com/SuncoastNews/","http://www.youtube.com/user/SCNPasco"]
}
</script>
<div class="clearfix"></div></div></div></div>
                </div>
            </header>
        </div>
    

    
        <div id="site-header-container" class="hidden-sm hidden-xs hidden-print">
            <header id="site-header" class="container" role="banner">
                
                <div class="row">
                    <div id="masthead-full-top" class="col-lg-12"><div id="tncms-region-masthead-full-top" class="tncms-region "></div></div>
                </div>
                <div class="row">
                    
                    <div id="masthead-col-one" class="col-md-4 col-sm-4"><div id="tncms-region-masthead-col-one" class="tncms-region "><div id="tncms-block-501413" class="tncms-block sn-logo-block"><section id="block-501413" class="block emphasis-h3   " ><div class="block"><a href="/" rel="nofollow"  >
            <img 
                
                src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg==" 
                data-srcset="https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/custom/image/5410c17e-e9f6-11ec-8e4a-137100c16e3f.png?resize=150%2C54 150w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/custom/image/5410c17e-e9f6-11ec-8e4a-137100c16e3f.png?resize=200%2C72 200w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/custom/image/5410c17e-e9f6-11ec-8e4a-137100c16e3f.png?resize=225%2C80 225w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/custom/image/5410c17e-e9f6-11ec-8e4a-137100c16e3f.png?resize=300%2C107 300w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/custom/image/5410c17e-e9f6-11ec-8e4a-137100c16e3f.png?resize=400%2C143 400w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/custom/image/5410c17e-e9f6-11ec-8e4a-137100c16e3f.png?resize=540%2C193 540w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/custom/image/5410c17e-e9f6-11ec-8e4a-137100c16e3f.png?resize=640%2C229 640w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/custom/image/5410c17e-e9f6-11ec-8e4a-137100c16e3f.png?resize=750%2C268 750w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/custom/image/5410c17e-e9f6-11ec-8e4a-137100c16e3f.png?resize=990%2C354 990w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/custom/image/5410c17e-e9f6-11ec-8e4a-137100c16e3f.png?resize=1035%2C370 1035w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/custom/image/5410c17e-e9f6-11ec-8e4a-137100c16e3f.png?resize=1200%2C429 1200w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/custom/image/5410c17e-e9f6-11ec-8e4a-137100c16e3f.png?resize=1333%2C477 1333w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/custom/image/5410c17e-e9f6-11ec-8e4a-137100c16e3f.png?resize=1476%2C528 1476w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/custom/image/5410c17e-e9f6-11ec-8e4a-137100c16e3f.png?resize=2008%2C718 2008w" 
                data-sizes="auto" 
                class=" img-responsive lazyload tnt-prop-img"
                width="2130"
                height="762"
                alt=""
                aria-hidden="true"></a></div></section></div></div></div>
    <div id="masthead-col-two" class="col-md-4 col-sm-4"><div id="tncms-region-masthead-col-two" class="tncms-region "><div id="tncms-block-501439" class="tncms-block"><div id="weather-501439" class="weather-current size-medium pull-right">
    <ul class="list-unstyled">
        <li class="current-conditions dropdown">
            <a href="/weather/?weather_zip=34668" class="dropdown-toggle" data-toggle="dropdown" data-hover="dropdown" data-hover-delay="250" aria-label="Weather">
                <span class="icon pull-left">
                    
                        <span class="pull-left btn btn-xs btn-danger weather-alert-btn" data-toggle="tooltip" data-placement="right" title="Weather Alert"><i class="fas tnt-exclamation-triangle"></i></span>
                    
                    <span class="fas tnt-wi-cloudy"></span>
                </span>
                <span class="pull-left temp-desc medium">
                    <span class="temp">81&deg;</span>
                    
                        <span class="cond">Mostly Cloudy <i class="fas tnt-caret-down"></i></span>
                    
                </span>
                <span class="clearfix"></span>
            </a>
            
                <ul class="dropdown-menu" role="menu">
                    <li role="presentation">
                        <div class="weather-expanded">
                            <form action="/weather/" class="zip-update-form form-inline" method="get">
                                <input type="text" class="zip-update form-control" name="weather_zip" title="Weather Zip Code" value="34668">
                                <input class="btn btn-primary" type="submit" value="GO">
                            </form>

                            <a id="weather_zip_toggle_501439" class="pull-right zip-update-link" aria-label="weather_zip_toggle"><span class="fas tnt-cog"></span></a><h4 class="city-title"><i class="fas tnt-map-marker-alt"></i>
                                
                                    Port Richey, FL
                                
                                <small>(34668)</small>
                            </h4><h5>Today</h5>
                                <p>Mostly cloudy skies. A stray shower or thunderstorm is possible. Low 71F. Winds ENE at 5 to 10 mph..
                                </p>
                                <h5>Tonight</h5>
                                <p>Mostly cloudy skies. A stray shower or thunderstorm is possible. Low 71F. Winds ENE at 5 to 10 mph.</p>
                                <p class="text-center"><small><i class="fas tnt-info-circle"></i> Updated: September 14, 2022 @ 8:08 pm</small></p></div>
                    </li>
                    <li role="separator" class="divider"></li>
                    <li role="menuitem" class="forecast-link text-center">
                        <a href="/weather/?weather_zip=34668"><i class="fas tnt-caret-right"></i> Full Forecast</a>
                    </li>
                </ul>
            
        </li>
    </ul>
</div>

    <div class="clearfix"></div>
</div></div></div>
    <div id="masthead-col-three" class="col-md-4 col-sm-4"><div id="tncms-region-masthead-col-three" class="tncms-region "><div id="tncms-block-501420" class="tncms-block"><section id="block-501420" class="block emphasis-h3   " >
    <div class="clearfix"></div>
    <div id="search-form-501420" class="search-form-container card clearfix text-center hidden-print well">
    <form id="site-search-501420" aria-label="Site search" action="/search/" method="GET" >
    <input type="hidden" name="l" value="25">
    
        
        <input type="hidden" name="sort" value="relevance">
    
    
    
    
    <input type="hidden" name="f" value="html">
    
        
        <input type="hidden" name="t" value="article,video,youtube,collection">
    
    <input type="hidden" name="app" value="editorial">
    <input type="hidden" name="nsa" value="eedition">
    <div id="site-search-form-501420" class="site-search-form input-group pull-right input-group-lg ">
        <label for="site-search-501420-term" class="sr-only">Site search</label>
        <input id="site-search-501420-term" name="q" title="Site search" type="text" placeholder="Search..." class="form-control" autocomplete="off">
        <input type="submit" class="hide" value="Search">
        <span class="input-group-btn">
            <button id="site-search-501420-btn" class="btn btn-primary" aria-label="Submit Site Search" type="submit">
                
	                <span class="hidden-xl hidden-lg hidden-md fas tnt-search"></span>
	            
                <span id="site-search-button-501420" class="hidden-xs hidden-sm ">Search</span>
            </button>
        </span>
    </div>
    <div class="clearfix"></div>
</form>
        
        
        <div class="clearfix"></div>
    </div>
    </section></div></div></div>
                </div>
                <div class="row">
                    <div id="masthead-full-bottom" class="col-lg-12"><div id="tncms-region-masthead-full-bottom" class="tncms-region "></div></div>
                </div>
                
            </header>
        </div>
    

    
    
        <div id="site-navbar-container" class="hidden-print affix-top">
            
            <nav id="main-navigation" aria-label="Main" class="navbar yamm navbar-default container navbar-static">
                
                
                <div class="navbar-header">
                    
                    
                    
                        <button  type="button" class="visible-sm visible-xs navbar-toggle pull-right" data-toggle="offcanvas" data-target="right" aria-label="Right Main Menu" aria-expanded="false" >
                            <span class="sr-only">Toggle navigation</span>
                            <span class="icon-bar"></span>
                            <span class="icon-bar"></span>
                            <span class="icon-bar"></span>
                        </button>

                    

                    
                        <div class="navbar-brand hidden-md hidden-lg pos_right">
                            
                                <div id="tncms-region-main-nav-brand" class="tncms-region "><div id="tncms-block-501414" class="tncms-block"><section id="block-501414" class="block emphasis-h3   " ><div class="block"><a href="/" rel="nofollow"  >
            <img 
                
                src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg==" 
                data-srcset="https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/custom/image/f1fb4ad8-e9f8-11ec-9df5-a3055722f8b3.png?resize=150%2C24 150w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/custom/image/f1fb4ad8-e9f8-11ec-9df5-a3055722f8b3.png?resize=200%2C32 200w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/custom/image/f1fb4ad8-e9f8-11ec-9df5-a3055722f8b3.png?resize=225%2C36 225w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/custom/image/f1fb4ad8-e9f8-11ec-9df5-a3055722f8b3.png?resize=300%2C48 300w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/custom/image/f1fb4ad8-e9f8-11ec-9df5-a3055722f8b3.png?resize=400%2C64 400w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/custom/image/f1fb4ad8-e9f8-11ec-9df5-a3055722f8b3.png?resize=540%2C87 540w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/custom/image/f1fb4ad8-e9f8-11ec-9df5-a3055722f8b3.png?resize=640%2C103 640w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/custom/image/f1fb4ad8-e9f8-11ec-9df5-a3055722f8b3.png?resize=750%2C121 750w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/custom/image/f1fb4ad8-e9f8-11ec-9df5-a3055722f8b3.png?resize=990%2C159 990w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/custom/image/f1fb4ad8-e9f8-11ec-9df5-a3055722f8b3.png?resize=1035%2C166 1035w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/custom/image/f1fb4ad8-e9f8-11ec-9df5-a3055722f8b3.png?resize=1200%2C193 1200w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/custom/image/f1fb4ad8-e9f8-11ec-9df5-a3055722f8b3.png?resize=1333%2C214 1333w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/custom/image/f1fb4ad8-e9f8-11ec-9df5-a3055722f8b3.png?resize=1476%2C237 1476w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/custom/image/f1fb4ad8-e9f8-11ec-9df5-a3055722f8b3.png?resize=2008%2C323 2008w" 
                data-sizes="auto" 
                class=" img-responsive lazyload tnt-prop-img"
                width="3198"
                height="514"
                alt=""
                aria-hidden="true"></a></div></section></div></div>
                            
                        </div>
                    

                    
                </div>

                
                    <div id="navbar-collapse" class="navbar-collapse collapse">
                        
                            <div class="pull-right">
                                <div id="tncms-region-main-nav-right-region" class="tncms-region "></div>
                                
                            </div>
                        
                        <div class="navbar-left">
                            <div id="tncms-region-nav-main-nav" class="tncms-region-nav"><ul id="main-nav_menu" class="nav navbar-nav"><li>
                <a class="nav-link    tnt-section-pasco"  href="/news/pasco/"  tabindex="0" >
                    <span class="nav-label ">Pasco</span>
                </a></li><li>
                <a class="nav-link    tnt-section-pinellas"  href="/news/pinellas/"  tabindex="0" >
                    <span class="nav-label ">Pinellas</span>
                </a></li><li>
                <a class="nav-link    tnt-section-hernando"  href="/news/hernando/"  tabindex="0" >
                    <span class="nav-label ">Hernando</span>
                </a></li><li>
                <a class="nav-link    tnt-section-sports"  href="/sports/"  tabindex="0" >
                    <span class="nav-label ">Sports</span>
                </a></li><li>
                <a class="nav-link    tnt-section-business"  href="/business/"  tabindex="0" >
                    <span class="nav-label ">Business</span>
                </a></li><li>
                <a class="nav-link    tnt-section-classifieds"  href="/classifieds/"  tabindex="0" >
                    <span class="nav-label ">Classifieds</span>
                </a></li><li class="dropdown" aria-expanded="false">
                <a class="nav-link   dropdown-toggle  tnt-section-local-events"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/local-events/"  tabindex="0" >
                    <span class="nav-label ">Local Events</span>
                </a><ul id="main-nav_menu-child-7" class="dropdown-menu"><li>
                <a class="nav-link    tnt-section-promote-your-event"  href="https://new.evvnt.com/?with_navbar&amp;force_snap_sell&amp;partner=SUNCOASTNEWS&amp;publisher_url:suncoastnews.com#/quick"  target="_blank" rel="noopener" tabindex="0" >
                    <span class="nav-label ">Promote Your Event</span>
                </a></li></ul></li><li>
                <a class="nav-link    tnt-section-multimedia"  href="/multimedia/"  tabindex="0" >
                    <span class="nav-label ">Multimedia</span>
                </a></li><li>
                <a class="nav-link    tnt-section-legal-notices"  href="https://www.suncoastnews.com/classifieds/legal_notices/?l=25"  target="_blank" rel="noopener" tabindex="0" >
                    <span class="nav-label ">Legal Notices</span>
                </a></li></ul></div>
                        </div>
                    </div>
                

                
            </nav>
            
            
        </div>
        
            
        
    
    
    <div id="main-body-container">
    <section id="main-top-container" class="container-fullscreen-region container-fluid">
        
        <div class="fullscreen-region"><div id="tncms-region-global-container-top-fullscreen" class="tncms-region "></div></div>
    </section>
    <section id="main-page-container" class="container">
        <div class="row">
                <div id="asset-container-top" class="col-md-12"><div id="tncms-region-asset_container_top" class="tncms-region hidden-print"></div></div>
            
            <div class="col-md-12"><div id="tncms-region-global-container-top" class="tncms-region "><div id="tncms-block-1264879" class="tncms-block"><div class="tnt-ads-container text-center  " >
        <div id="ad-1264879" class="tnt-ads dfp-ad" data-lazy="true" data-refresh="true" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('ad-1264879');
                        
                });
            </script>
        </div>
    </div>
</div></div></div>
        </div><div id="modal-image-7b65ce20-339f-11ed-9645-4b9017fd6c82" class="modal fullscreen in modal-image image-default modal-7b65ce20-339f-11ed-9645-4b9017fd6c82" role="dialog" aria-hidden="true" data-lazy-content>
        <template>
            <button type="button" class="close hidden-print" data-dismiss="modal">
                <span aria-hidden="true" class="control-left fas tnt-times-circle"></span>
                <span class="sr-only">Close</span>
            </button>
            <div class="modal-dialog modal-lg">
                <div class="modal-content">
                    <div class="modal-body">
                        <div class="modal-image-container"><figure class="photo layout-horizontal letterbox-style-default">
            <div class="image" 
                >
                
                
                
                <img
                        src="https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/7/b6/7b65ce20-339f-11ed-9645-4b9017fd6c82/6320e2c874023.image.jpg?resize=400%2C297"
                        srcset="https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/7/b6/7b65ce20-339f-11ed-9645-4b9017fd6c82/6320e2c874023.image.jpg?resize=150%2C112 150w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/7/b6/7b65ce20-339f-11ed-9645-4b9017fd6c82/6320e2c874023.image.jpg?resize=200%2C149 200w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/7/b6/7b65ce20-339f-11ed-9645-4b9017fd6c82/6320e2c874023.image.jpg?resize=225%2C167 225w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/7/b6/7b65ce20-339f-11ed-9645-4b9017fd6c82/6320e2c874023.image.jpg?resize=300%2C223 300w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/7/b6/7b65ce20-339f-11ed-9645-4b9017fd6c82/6320e2c874023.image.jpg?resize=400%2C297 400w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/7/b6/7b65ce20-339f-11ed-9645-4b9017fd6c82/6320e2c874023.image.jpg?resize=540%2C402 540w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/7/b6/7b65ce20-339f-11ed-9645-4b9017fd6c82/6320e2c874023.image.jpg?resize=640%2C476 640w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/7/b6/7b65ce20-339f-11ed-9645-4b9017fd6c82/6320e2c874023.image.jpg?resize=750%2C558 750w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/7/b6/7b65ce20-339f-11ed-9645-4b9017fd6c82/6320e2c874023.image.jpg?resize=757%2C563 990w"
                        sizes="100vw"
                        
                        width="757"
                        height="563"
                        alt="Mural"
                        class="img-responsive true-size default" />
                
                
            </div>
            
                
                
            
        </figure></div>
                    </div>
                </div>
            </div>
            <div class="modal-caption">
        <div class="caption-container">
                <span class="pull-right photo-carousel-caption-toggle" data-toggle="collapse" data-instance="#carousel-modal-image-7b65ce20-339f-11ed-9645-4b9017fd6c82" data-target=".caption-inner-modal-image-7b65ce20-339f-11ed-9645-4b9017fd6c82">
                    <i class="fas tnt-minus-circle"></i>
                </span>
            <div class="caption-inner-modal-image-7b65ce20-339f-11ed-9645-4b9017fd6c82 collapse in"><div class="caption-text"><p>A colorful sunburst mural will be depicted at Main Street Food Mart.</p></div><div class="card-meta">
                        <ul class="list-inline">
                                    
                                    
                                        <li class="credit"><span  class="tnt-byline">Photo SUBMITTED</span></li>
                                    
                                
                            
                        </ul>
                    </div>
                    <div class="photo-share">
                        <ul class="social-share-links hidden-print list-inline icon"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.suncoastnews.com%2Fmural%2Fimage_7b65ce20-339f-11ed-9645-4b9017fd6c82.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/mural/image_7b65ce20-339f-11ed-9645-4b9017fd6c82.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"7b65ce20-339f-11ed-9645-4b9017fd6c82"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=Mural&via=SuncoastNews&url=https%3A%2F%2Fwww.suncoastnews.com%2Fmural%2Fimage_7b65ce20-339f-11ed-9645-4b9017fd6c82.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/mural/image_7b65ce20-339f-11ed-9645-4b9017fd6c82.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"7b65ce20-339f-11ed-9645-4b9017fd6c82"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=https://www.suncoastnews.com/mural/image_7b65ce20-339f-11ed-9645-4b9017fd6c82.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/mural/image_7b65ce20-339f-11ed-9645-4b9017fd6c82.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"7b65ce20-339f-11ed-9645-4b9017fd6c82"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-whatsapp tnt-stack-1x"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.suncoastnews.com/tncms/asset/editorial/7b65ce20-339f-11ed-9645-4b9017fd6c82" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-image","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"7b65ce20-339f-11ed-9645-4b9017fd6c82"}'  rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5Bsuncoastnews.com%5D%20Mural&body=https%3A%2F%2Fwww.suncoastnews.com%2Fmural%2Fimage_7b65ce20-339f-11ed-9645-4b9017fd6c82.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-image","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"7b65ce20-339f-11ed-9645-4b9017fd6c82"}'  rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li><li class="social-share-link pr">
                <a href="javascript:window.print()" class="pr" title="Print" data-track='{"network":"Print","socialAction":"print","url":"/mural/image_7b65ce20-339f-11ed-9645-4b9017fd6c82.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"7b65ce20-339f-11ed-9645-4b9017fd6c82"}'  rel="nofollow">
                    <span class="tnt-stack" >
                        
                        <i class="fas tnt-print tnt-stack-1x"></i>
                    </span>
                    <span class="sr-only">Print</span>
                </a>
            </li><li class="social-share-link copy">
                <button
                    id="copy-asset-link"
                    class="copy btn-link" 
                    data-copy-asset-link
                    onclick="copyLink('https://www.suncoastnews.com/mural/image_7b65ce20-339f-11ed-9645-4b9017fd6c82.html')"
                    data-container="body" 
                    data-toggle="manual" 
                    data-placement="top" 
                    data-content="Image link copied to clipboard"
                >
                    <span class="tnt-stack" title="Copy image link to clipboard" >
                        
                        <i class="fas tnt-copy tnt-stack-1x"></i>
                    </span>
                    <span class="sr-only">Copy article link</span>
                </button>
            </li><li class="social-share-link sv">
        <a class="save-list-7b65ce20-339f-11ed-9645-4b9017fd6c82-btn save-asset " title="Save to list" href="#"  role="button" rel="nofollow" data-asset-uuid="7b65ce20-339f-11ed-9645-4b9017fd6c82" >
            
                <span class="tnt-stack">
                    
                    <i class="asset-save-icon far tnt-bookmark tnt-stack-1x "></i>
                </span>
            
            
                <span class="sr-only">Save</span>
            
        </a>
        </li>
        
    </ul><form method="post" data-uuid="7b65ce20-339f-11ed-9645-4b9017fd6c82" class="save-list-7b65ce20-339f-11ed-9645-4b9017fd6c82-form save-asset-to-list" action="/users/admin/list/">
        <input type="hidden" name="action" value="addasset" />
        <input type="hidden" name="format" value="json" />
        <input type="hidden" name="listasset" value="7b65ce20-339f-11ed-9645-4b9017fd6c82" />
        <input type="hidden" name="listapp" value="editorial" />
        <input type="hidden" name="autocreate" value="true" />
        <input type="hidden" name="listname" value="images" />
        <input class="hide" type="submit" name="submit" value="Save" />
    </form>

                    </div>
            </div>
        </div>
    </div>
            <style>
                #modal-image-7b65ce20-339f-11ed-9645-4b9017fd6c82 img { max-height: 563px; }
            </style>
        </template>
    </div><article itemscope itemtype="https://schema.org/Article" id="asset-154f2f64-339f-11ed-9e8b-3724e641c836" class="asset article-default"  data-url="https://www.suncoastnews.com/news/discussion-over-new-port-richey-mural-gets-heated/article_154f2f64-339f-11ed-9e8b-3724e641c836.html">
    <span itemscope itemtype="http://schema.org/SpeakableSpecification">
        <meta itemprop="cssSelector" content=".asset-header .headline" />
        <meta itemprop="cssSelector" content=".asset-content p:first-of-type" />
    </span>
    <meta itemprop="description" content="NEW PORT RICHEY — After Richard Melton threatened to resign his position as chairman of the Cultural Affairs Committee, the New Port Richey City Council on Sept. 6 approved the design for a mural on Jefferson Street. "/><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
        <div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
            <meta itemprop="url" content="https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/7/b6/7b65ce20-339f-11ed-9645-4b9017fd6c82/6320e2c874023.image.jpg?crop=757%2C397%2C0%2C82&resize=757%2C397&order=crop%2Cresize">
            <meta itemprop="width" content="757">
            <meta itemprop="height" content="397">
        </div>
        <meta itemprop="name" content="suncoastnews.com">
    </div>
    <link itemprop="mainEntityOfPage" href="https://www.suncoastnews.com/news/discussion-over-new-port-richey-mural-gets-heated/article_154f2f64-339f-11ed-9e8b-3724e641c836.html" />
    <style>
                .asset-paging .direction {
                    color: #005296;
                }
            </style><div class="asset-paging-container hidden-print" data-settings='{"assetType":"article","hasPageBreak":false,"isObit":false,"nextUrl":"https:\/\/www.suncoastnews.com\/tncms\/search\/mlt\/?origin=154f2f64-339f-11ed-9e8b-3724e641c836&app=editorial&preview=1&type=article%2Ccollection%2Cvideo%2Cyoutube","uuid":"154f2f64-339f-11ed-9e8b-3724e641c836","isFluid":false,"isAdminVenue":false}'>
            <div id="asset-paging-154f2f64-339f-11ed-9e8b-3724e641c836" class="asset-paging">
                <div id="paging-prev-154f2f64-339f-11ed-9e8b-3724e641c836" class="paging-link prev offset"></div>
                <div id="paging-next-154f2f64-339f-11ed-9e8b-3724e641c836" class="paging-link next offset"></div>
                <div class="clearfix"></div>
            </div>
        </div>
        <template id="asset-paging-template">
            <a class="animate arrow text-center">
                <span class=""></span>
                <span class="animate direction hidden-sm hidden-xs text-primary"></span>
            </a>
            <div class="animate item">
                <div class="dismiss" onclick="document.body.classList.add('trigger-disabled'); document.body.classList.remove('trigger-next'); return false;">
                    <span class="tnt-stack" aria-hidden="true">
                        <i class="fas tnt-circle tnt-inverse tnt-stack-1x"></i>
                        <i class="fas tnt-times-circle tnt-stack-1x"></i>
                    </span>
                </div>
                <div class="inner">
                    <a class="overlay">
                        <span class="sr-only"></span>
                    </a>
                    <div class="head text-uppercase">
                        <small></small>
                    </div>
                    <div class="media">
                        <div class="media-body">
                            <h6 class="media-heading"></h6>
                            <p class="hidden-xs"></p>
                        </div>
                    </div>
                    <div class="clearfix"></div>
                </div>
            </div>
        </template><div class="asset-masthead ">
        <header class="asset-header">
    <div class="tow-wrapper no-flags">
        
        
    </div>
    <h1 itemprop="headline" class="headline">
        <span>
            
            Discussion over New Port Richey mural gets heated
        </span>
    </h1>
    <div class="meta">
        <span>
            <ul class="list-inline">
        <li><span itemprop="author" class="tnt-byline">By BRITTANY Ó RUACHÁINN
Suncoast News</span></li>
        
        
            <li class="visible-print">
        <time datetime="2022-09-14T08:00:00-04:00" class="tnt-date asset-date text-muted">
            Sep 14, 2022
        </time></li>
            <li class="hidden-print">
        <time datetime="2022-09-14T08:00:00-04:00" class="tnt-date asset-date text-muted">12 hrs ago</time></li>
        
        
            <li class="hidden-print"></li>
        
        
    </ul>
        </span>
    </div>
    <meta itemprop="dateCreated" content="2022-09-14T08:00:00-04:00">
    <meta itemprop="datePublished" content="2022-09-14T08:00:00-04:00">
    <meta itemprop="dateModified" content="2022-09-14T08:00:00-04:00">
</header>
        
        
            <div class="share-container headline-right pull-right hidden-xs" data-subscription-required-remove><ul class="social-share-links hidden-print list-unstyled stacked icon"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.suncoastnews.com%2Fnews%2Fdiscussion-over-new-port-richey-mural-gets-heated%2Farticle_154f2f64-339f-11ed-9e8b-3724e641c836.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/news/discussion-over-new-port-richey-mural-gets-heated/article_154f2f64-339f-11ed-9e8b-3724e641c836.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"154f2f64-339f-11ed-9e8b-3724e641c836"}' >
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="Share">
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=Discussion%20over%20New%20Port%20Richey%20mural%20gets%20heated&via=SuncoastNews&url=https%3A%2F%2Fwww.suncoastnews.com%2Fnews%2Fdiscussion-over-new-port-richey-mural-gets-heated%2Farticle_154f2f64-339f-11ed-9e8b-3724e641c836.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/news/discussion-over-new-port-richey-mural-gets-heated/article_154f2f64-339f-11ed-9e8b-3724e641c836.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"154f2f64-339f-11ed-9e8b-3724e641c836"}' >
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="Tweet">
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=https://www.suncoastnews.com/news/discussion-over-new-port-richey-mural-gets-heated/article_154f2f64-339f-11ed-9e8b-3724e641c836.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/news/discussion-over-new-port-richey-mural-gets-heated/article_154f2f64-339f-11ed-9e8b-3724e641c836.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"154f2f64-339f-11ed-9e8b-3724e641c836"}' >
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="WhatsApp">
                    
                    <i class="fab tnt-whatsapp tnt-stack-1x"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.suncoastnews.com/tncms/asset/editorial/154f2f64-339f-11ed-9e8b-3724e641c836" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"154f2f64-339f-11ed-9e8b-3724e641c836"}'  rel="nofollow">
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="SMS">
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5Bsuncoastnews.com%5D%20Discussion%20over%20New%20Port%20Richey%20mural%20gets%20heated&body=https%3A%2F%2Fwww.suncoastnews.com%2Fnews%2Fdiscussion-over-new-port-richey-mural-gets-heated%2Farticle_154f2f64-339f-11ed-9e8b-3724e641c836.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"154f2f64-339f-11ed-9e8b-3724e641c836"}'  rel="nofollow">
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="Email">
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li></ul></div>
        
    </div>

    

    <div class="row">
        <div class="main-content col-lg-8 col-md-7 has-sidebar"><div class="main-content-wrap">
            <div id="tncms-region-article_top" class="tncms-region hidden-print"></div>
            
            <div class="asset-photo card"><figure class="photo layout-horizontal hover-expand letterbox-style-default"><span class="expand hidden-print"
               
               data-toggle="modal"
                
                    data-target=".modal-7b65ce20-339f-11ed-9645-4b9017fd6c82" 
                    >
                       <span class="fas tnt-expand"></span>
                   </span>
            
            <div class="image" 
                 
                    data-toggle="modal" 
                     
                    data-target=".modal-7b65ce20-339f-11ed-9645-4b9017fd6c82" 
                    >
                
                
                
                
        <div itemprop="image" itemscope itemtype="https://schema.org/ImageObject">
            <meta itemprop="width" content="757">
            <meta itemprop="height" content="563">
            <meta itemprop="contentUrl" content="https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/7/b6/7b65ce20-339f-11ed-9645-4b9017fd6c82/6320e2c874023.image.jpg">
            <meta itemprop="url" content="https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/7/b6/7b65ce20-339f-11ed-9645-4b9017fd6c82/6320e2c874023.image.jpg"><img
                        src="https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/7/b6/7b65ce20-339f-11ed-9645-4b9017fd6c82/6320e2c874023.image.jpg?resize=400%2C297"
                        srcset="https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/7/b6/7b65ce20-339f-11ed-9645-4b9017fd6c82/6320e2c874023.image.jpg?resize=150%2C112 150w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/7/b6/7b65ce20-339f-11ed-9645-4b9017fd6c82/6320e2c874023.image.jpg?resize=200%2C149 200w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/7/b6/7b65ce20-339f-11ed-9645-4b9017fd6c82/6320e2c874023.image.jpg?resize=225%2C167 225w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/7/b6/7b65ce20-339f-11ed-9645-4b9017fd6c82/6320e2c874023.image.jpg?resize=300%2C223 300w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/7/b6/7b65ce20-339f-11ed-9645-4b9017fd6c82/6320e2c874023.image.jpg?resize=400%2C297 400w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/7/b6/7b65ce20-339f-11ed-9645-4b9017fd6c82/6320e2c874023.image.jpg?resize=540%2C402 540w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/7/b6/7b65ce20-339f-11ed-9645-4b9017fd6c82/6320e2c874023.image.jpg?resize=640%2C476 640w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/7/b6/7b65ce20-339f-11ed-9645-4b9017fd6c82/6320e2c874023.image.jpg?resize=750%2C558 750w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/7/b6/7b65ce20-339f-11ed-9645-4b9017fd6c82/6320e2c874023.image.jpg?resize=757%2C563 990w"
                        sizes="(min-width: 1200px) 750px, (min-width: 992px) calc(66.70vw - 60px), calc(100vw - 30px)"
                        
                        width="757"
                        height="563"
                        alt="Mural"
                        class="img-responsive full tnt-restrict-img-7b65ce20-339f-11ed-9645-4b9017fd6c82 default" />
            </div><style>
                .tnt-restrict-img-7b65ce20-339f-11ed-9645-4b9017fd6c82 {
                    max-width: 757px;
                }
            </style>
                
                
            </div>
            
                
                
                    <figcaption class="caption">
                            
                                <span class="caption-text">
                                    <p>A colorful sunburst mural will be depicted at Main Street Food Mart.</p>
                                </span>
                            
                        
                            
                                <span class="credit">
                                    <span  class="tnt-byline">Photo SUBMITTED</span>
                                </span>
                            
                        
                        <span class="clearfix"></span>
                    </figcaption>
                
            
        </figure></div>

            <div id="tncms-region-article_top_content" class="tncms-region hidden-print"></div>

            <div id="asset-content" data-asset-uuid="154f2f64-339f-11ed-9e8b-3724e641c836" data-smart-adunit="/132916964,22674386519/suncoastnews.com/news">
                

                <div class="row">
                    <div class="col-lg-12 col-md-12 col-sm-12" data-subscription-required-class="col-xs-12">
                        
                        <div class="asset-body" data-subscription-required-class="asset-body">
                            
                                <div class="share-container content-above" data-subscription-required-remove><ul class="social-share-links hidden-print list-inline icon"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.suncoastnews.com%2Fnews%2Fdiscussion-over-new-port-richey-mural-gets-heated%2Farticle_154f2f64-339f-11ed-9e8b-3724e641c836.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/news/discussion-over-new-port-richey-mural-gets-heated/article_154f2f64-339f-11ed-9e8b-3724e641c836.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"154f2f64-339f-11ed-9e8b-3724e641c836"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=Discussion%20over%20New%20Port%20Richey%20mural%20gets%20heated&via=SuncoastNews&url=https%3A%2F%2Fwww.suncoastnews.com%2Fnews%2Fdiscussion-over-new-port-richey-mural-gets-heated%2Farticle_154f2f64-339f-11ed-9e8b-3724e641c836.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/news/discussion-over-new-port-richey-mural-gets-heated/article_154f2f64-339f-11ed-9e8b-3724e641c836.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"154f2f64-339f-11ed-9e8b-3724e641c836"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=https://www.suncoastnews.com/news/discussion-over-new-port-richey-mural-gets-heated/article_154f2f64-339f-11ed-9e8b-3724e641c836.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/news/discussion-over-new-port-richey-mural-gets-heated/article_154f2f64-339f-11ed-9e8b-3724e641c836.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"154f2f64-339f-11ed-9e8b-3724e641c836"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-whatsapp tnt-stack-1x"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.suncoastnews.com/tncms/asset/editorial/154f2f64-339f-11ed-9e8b-3724e641c836" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"154f2f64-339f-11ed-9e8b-3724e641c836"}'  rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5Bsuncoastnews.com%5D%20Discussion%20over%20New%20Port%20Richey%20mural%20gets%20heated&body=https%3A%2F%2Fwww.suncoastnews.com%2Fnews%2Fdiscussion-over-new-port-richey-mural-gets-heated%2Farticle_154f2f64-339f-11ed-9e8b-3724e641c836.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"154f2f64-339f-11ed-9e8b-3724e641c836"}'  rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li><li class="social-share-link pr">
                <a href="javascript:window.print()" class="pr" title="Print" data-track='{"network":"Print","socialAction":"print","url":"/news/discussion-over-new-port-richey-mural-gets-heated/article_154f2f64-339f-11ed-9e8b-3724e641c836.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"154f2f64-339f-11ed-9e8b-3724e641c836"}'  rel="nofollow">
                    <span class="tnt-stack" >
                        
                        <i class="fas tnt-print tnt-stack-1x"></i>
                    </span>
                    <span class="sr-only">Print</span>
                </a>
            </li><li class="social-share-link copy">
                <button
                    id="copy-asset-link"
                    class="copy btn-link" 
                    data-copy-asset-link
                    onclick="copyLink('https://www.suncoastnews.com/news/discussion-over-new-port-richey-mural-gets-heated/article_154f2f64-339f-11ed-9e8b-3724e641c836.html')"
                    data-container="body" 
                    data-toggle="manual" 
                    data-placement="top" 
                    data-content="Article link copied to clipboard"
                >
                    <span class="tnt-stack" title="Copy article link to clipboard" >
                        
                        <i class="fas tnt-copy tnt-stack-1x"></i>
                    </span>
                    <span class="sr-only">Copy article link</span>
                </button>
            </li><li class="social-share-link sv">
        <a class="save-list-154f2f64-339f-11ed-9e8b-3724e641c836-btn save-asset " title="Save to list" href="#"  role="button" rel="nofollow" data-asset-uuid="154f2f64-339f-11ed-9e8b-3724e641c836" >
            
                <span class="tnt-stack">
                    
                    <i class="asset-save-icon far tnt-bookmark tnt-stack-1x "></i>
                </span>
            
            
                <span class="sr-only">Save</span>
            
        </a>
        </li>
        
    </ul><form method="post" data-uuid="154f2f64-339f-11ed-9e8b-3724e641c836" class="save-list-154f2f64-339f-11ed-9e8b-3724e641c836-form save-asset-to-list" action="/users/admin/list/">
        <input type="hidden" name="action" value="addasset" />
        <input type="hidden" name="format" value="json" />
        <input type="hidden" name="listasset" value="154f2f64-339f-11ed-9e8b-3724e641c836" />
        <input type="hidden" name="listapp" value="editorial" />
        <input type="hidden" name="autocreate" value="true" />
        <input type="hidden" name="listname" value="articles" />
        <input class="hide" type="submit" name="submit" value="Save" />
    </form>
</div>
                            

                            <div id="tncms-region-article_body_top" class="tncms-region hidden-print"></div>

                            <div id="article-body"  itemprop="articleBody" class="asset-content  subscriber-premium">
                                <meta itemprop="isAccessibleForFree" content="true"/>
                                
                                
                                <p>NEW PORT RICHEY — After Richard Melton threatened to resign his position as chairman of the Cultural Affairs Committee, the New Port Richey City Council on Sept. 6 approved the design for a mural on Jefferson Street.</p><p>The Main Street Flood Mart Mural would depict a colorful sunburst with the words “It’s a Sunny Day!” The Design Committee of the New Port Richey Main Street organization has accepted the mural design and it was up to the city to approve funding of $3,000 for the installation.</p><p>The only issue was that Deputy Mayor Mike Peters did not like the wording and he wanted to discuss its removal.</p><div id="tncms-region-article_instory_top" class="tncms-region hidden-print"></div><p>“I’m just a little bit cautious about the verbiage on there,” Peters said. “I would be more inclined to be a supporter of this if maybe the wording wasn't on there. We don’t have any wording on our other murals and that would leave a more artistic interpretation and design.”</p><p>Peters told the Suncoast News he didn’t have an objection to the artwork itself, but he was concerned about setting a precedent.</p><p>“I would have preferred it not to have any lettering to be on there so it doesn’t lead to future murals having different message points and leaving interpretation for whoever looks at it,” he said.</p><p>Council member Peter Altman offered to amend his motion by suggesting minimizing the size of the font in the mural, or to kick it back and get some other recommendation.</p><p>Council member Kelly Mothershead added, “I like all the colors in it. I think something that’s that bright and colorful would make people smile when they walk by, and that’s not a bad thing. I can see why you’d want the wording a bit smaller, but I like the mural.”</p><div id="tncms-region-article_instory_middle" class="tncms-region hidden-print"></div><p>Mayor Rob Marlowe agreed with Mothershead and said that he thinks the mural looks nice.</p><p>“The Cultural Affairs Chair and our committee has made huge strides to make this happen,” Melton said. “In the amount of time that it has taken to get it this far to be kicked down the road again, if it gets kicked down the road again, I’m telling you right now, you will have my resignation today.”</p><p>After a brief discussion whether the verbiage stays but is minimized, Melton said that would only further postpone the project and was not happy about it. He again was prepared to submit his resignation, resulting in the City Council moving to approve the mural as is. </p><p><strong>In other news</strong></p><p>The council agreed to use Stroud Engineering Consultants Inc. for engineering services for the proposed North River Road improvements.</p><p>City Manager Debbie Manns said the city was originally planning to work with Wannemacher Jensen Architects, but it was cost prohibitive to the city. Instead, the city found an engineer who could perform work for the city within its budget for $167,580.</p><p>The improvement project would involve the removal and replacement of the existing sidewalk on the east side of North River Road, in addition to hardscape, landscape, roadway striping and the installation of an LED crosswalk system for pedestrian crossings, traffic lane narrowing, bike lane symbols, and straightening of the intersections at North River Road and Veterans Drive, and Legion Place and Veterans Drive.</p><div id="tncms-region-article_instory_bottom" class="tncms-region hidden-print"></div>
                                <div id="tncms-region-article_bottom_content" class="tncms-region hidden-print"></div>
                                
                            </div>

                            

                            
    


                            
                                <div class="share-container content-below" data-subscription-required-remove><ul class="social-share-links hidden-print list-inline icon"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.suncoastnews.com%2Fnews%2Fdiscussion-over-new-port-richey-mural-gets-heated%2Farticle_154f2f64-339f-11ed-9e8b-3724e641c836.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/news/discussion-over-new-port-richey-mural-gets-heated/article_154f2f64-339f-11ed-9e8b-3724e641c836.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"154f2f64-339f-11ed-9e8b-3724e641c836"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=Discussion%20over%20New%20Port%20Richey%20mural%20gets%20heated&via=SuncoastNews&url=https%3A%2F%2Fwww.suncoastnews.com%2Fnews%2Fdiscussion-over-new-port-richey-mural-gets-heated%2Farticle_154f2f64-339f-11ed-9e8b-3724e641c836.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/news/discussion-over-new-port-richey-mural-gets-heated/article_154f2f64-339f-11ed-9e8b-3724e641c836.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"154f2f64-339f-11ed-9e8b-3724e641c836"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=https://www.suncoastnews.com/news/discussion-over-new-port-richey-mural-gets-heated/article_154f2f64-339f-11ed-9e8b-3724e641c836.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/news/discussion-over-new-port-richey-mural-gets-heated/article_154f2f64-339f-11ed-9e8b-3724e641c836.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"154f2f64-339f-11ed-9e8b-3724e641c836"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-whatsapp tnt-stack-1x"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.suncoastnews.com/tncms/asset/editorial/154f2f64-339f-11ed-9e8b-3724e641c836" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"154f2f64-339f-11ed-9e8b-3724e641c836"}'  rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5Bsuncoastnews.com%5D%20Discussion%20over%20New%20Port%20Richey%20mural%20gets%20heated&body=https%3A%2F%2Fwww.suncoastnews.com%2Fnews%2Fdiscussion-over-new-port-richey-mural-gets-heated%2Farticle_154f2f64-339f-11ed-9e8b-3724e641c836.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"154f2f64-339f-11ed-9e8b-3724e641c836"}'  rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li><li class="social-share-link pr">
                <a href="javascript:window.print()" class="pr" title="Print" data-track='{"network":"Print","socialAction":"print","url":"/news/discussion-over-new-port-richey-mural-gets-heated/article_154f2f64-339f-11ed-9e8b-3724e641c836.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"154f2f64-339f-11ed-9e8b-3724e641c836"}'  rel="nofollow">
                    <span class="tnt-stack" >
                        
                        <i class="fas tnt-print tnt-stack-1x"></i>
                    </span>
                    <span class="sr-only">Print</span>
                </a>
            </li><li class="social-share-link copy">
                <button
                    id="copy-asset-link"
                    class="copy btn-link" 
                    data-copy-asset-link
                    onclick="copyLink('https://www.suncoastnews.com/news/discussion-over-new-port-richey-mural-gets-heated/article_154f2f64-339f-11ed-9e8b-3724e641c836.html')"
                    data-container="body" 
                    data-toggle="manual" 
                    data-placement="top" 
                    data-content="Article link copied to clipboard"
                >
                    <span class="tnt-stack" title="Copy article link to clipboard" >
                        
                        <i class="fas tnt-copy tnt-stack-1x"></i>
                    </span>
                    <span class="sr-only">Copy article link</span>
                </button>
            </li><li class="social-share-link sv">
        <a class="save-list-154f2f64-339f-11ed-9e8b-3724e641c836-btn save-asset " title="Save to list" href="#"  role="button" rel="nofollow" data-asset-uuid="154f2f64-339f-11ed-9e8b-3724e641c836" >
            
                <span class="tnt-stack">
                    
                    <i class="asset-save-icon far tnt-bookmark tnt-stack-1x "></i>
                </span>
            
            
                <span class="sr-only">Save</span>
            
        </a>
        </li>
        
    </ul><form method="post" data-uuid="154f2f64-339f-11ed-9e8b-3724e641c836" class="save-list-154f2f64-339f-11ed-9e8b-3724e641c836-form save-asset-to-list" action="/users/admin/list/">
        <input type="hidden" name="action" value="addasset" />
        <input type="hidden" name="format" value="json" />
        <input type="hidden" name="listasset" value="154f2f64-339f-11ed-9e8b-3724e641c836" />
        <input type="hidden" name="listapp" value="editorial" />
        <input type="hidden" name="autocreate" value="true" />
        <input type="hidden" name="listname" value="articles" />
        <input class="hide" type="submit" name="submit" value="Save" />
    </form>
</div>
                            
                        </div>
                        
                    </div></div><!-- /asset-content -->

                <div id="asset-below">
                    

                    

                    

                    

                    

                    
                        <div class="asset-tags hidden-print">
                            <h4>Tags</h4>
                            <ul class="list-inline"><li>
                    <a href="/search/?k=%22pasco%20county%22#tncms-source=keyword" class="tag-pasco-county label label-default"  rel="nofollow">Pasco County</a>
                </li> <li>
                    <a href="/search/?k=%22new%20port%20richey%22#tncms-source=keyword" class="tag-new-port-richey label label-default"  rel="nofollow">New Port Richey</a>
                </li> <li>
                    <a href="/search/?k=%22new%20port%20richey%20city%20council%22#tncms-source=keyword" class="tag-new-port-richey-city-council label label-default"  rel="nofollow">New Port Richey City Council</a>
                </li> <li>
                    <a href="/search/?k=%22main%20street%20flood%20mart%20mural%22#tncms-source=keyword" class="tag-main-street-flood-mart-mural label label-default"  rel="nofollow">Main Street Flood Mart Mural</a>
                </li> </ul>
                        </div>
                    

                    

                    

                    

                    <div id="tncms-region-article_bottom" class="tncms-region hidden-print"><div id="tncms-block-1044046" class="tncms-block"><div class="zergnet-widget" id="zergnet-widget-loader"></div></div></div>

                    <div class="asset-comments hidden-print"></div>
                    
                    <div id="tncms-region-article_container_bottom" class="tncms-region hidden-print"><div id="tncms-block-1397577" class="tncms-block"><div id="rc-widget-df962e" data-rc-widget data-widget-host="habitat" data-endpoint="//trends.revcontent.com" data-widget-id="217028"></div>
<script type="text/javascript" src="https://assets.revcontent.com/master/delivery.js" defer></script></div></div></div>
            </div>

            

            </div>
        </div><div class="main-sidebar col-lg-4 col-md-5 hidden-print">
                <div class="main-sidebar-wrap">
                    <div id="tncms-region-article_side_top" class="tncms-region hidden-print"></div><div id="tncms-region-asset_side_top" class="tncms-region hidden-print"></div><div id="tncms-region-global-side-primary" class="tncms-region "><div id="tncms-block-1264891" class="tncms-block"><div class="tnt-ads-container text-center  " >
        <div id="ad-1264891" class="tnt-ads dfp-ad" data-lazy="true" data-refresh="true" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('ad-1264891');
                        
                });
            </script>
        </div>
    </div>
</div><div id="tncms-block-501366" class="tncms-block visible-lg visible-md"><section id="block-501366" class="block emphasis-h4 dark  " ><div class="clearfix">
    
    <div class="block-title title-501366 ">
        <div class="block-title-inner">
            <h4>
                
                Latest News
                
            </h4>
        </div>
    </div></div>
    <div class=" card-bg-color"><div class="card-panel panel">
            <div class="panel-body"><ul class="card headline-list bullet-square border border-dashed"><li class="">
            <span class="tnt-headline ">
        
             <a href="/crime_crashes_fires/pasco-sheriff-s-office-investigates-skeletal-remains/article_bbafda8c-3469-11ed-8a5c-5f92bc4c3b13.html" class="tnt-asset-link" aria-label="Pasco Sheriff’s Office investigates skeletal remains">
        

        
            Pasco Sheriff’s Office investigates skeletal remains</a></span>
        </li><li class="">
            <span class="tnt-headline ">
        
             <a href="/news/have-coffee-with-sheriff-nienhuis-on-sept-19/article_8727ebd0-3467-11ed-aca5-b345992f4c05.html" class="tnt-asset-link" aria-label="Have coffee with Sheriff Nienhuis on Sept. 19">
        

        
            Have coffee with Sheriff Nienhuis on Sept. 19</a></span>
        </li><li class="">
            <span class="tnt-headline ">
        
             <a href="/news/pasco-sheriff-s-office-urges-citizens-to-be-safe-in-flooded-areas/article_85c5eb24-3431-11ed-9e84-0fcf79b41fc8.html" class="tnt-asset-link" aria-label="Pasco Sheriff’s Office urges citizens to be safe in flooded areas">
        

        
            Pasco Sheriff’s Office urges citizens to be safe in flooded areas</a></span>
        </li><li class="">
            <span class="tnt-headline ">
        
             <a href="/news/discussion-over-new-port-richey-mural-gets-heated/article_154f2f64-339f-11ed-9e8b-3724e641c836.html" class="tnt-asset-link" aria-label="Discussion over New Port Richey mural gets heated">
        

        
            Discussion over New Port Richey mural gets heated</a></span>
        </li><li class="">
            <span class="tnt-headline ">
        
             <a href="/news/pasco-community-calendar/article_3265bed0-339d-11ed-9a40-bba40ec3db36.html" class="tnt-asset-link" aria-label="Pasco Community Calendar">
        

        
            Pasco Community Calendar</a></span>
        </li><li class="">
            <span class="tnt-headline ">
        
             <a href="/news/annual-cleanup-spreads-awareness-of-pasco-s-natural-beauty/article_bfbe178c-339d-11ed-a3a3-1fb5d1e1c8a9.html" class="tnt-asset-link" aria-label="Annual cleanup spreads awareness of Pasco’s natural beauty">
        

        
            Annual cleanup spreads awareness of Pasco’s natural beauty</a></span>
        </li><li class="">
            <span class="tnt-headline ">
        
             <a href="/news/bigger-va-clinic-will-offer-multiple-expanded-services-under-one-roof-in-new-port-richey/article_39840b94-339e-11ed-b91a-63ed3726deb9.html" class="tnt-asset-link" aria-label="Bigger VA clinic will offer multiple, expanded services under one roof in New Port Richey">
        

        
            Bigger VA clinic will offer multiple, expanded services under one roof in New Port Richey</a></span>
        </li><li class="">
            <span class="tnt-headline ">
        
             <a href="/news/pasta-extravaganza-this-weekend-to-benefit-cindy-s-pets/article_92750dec-339f-11ed-88a1-8b148c2f71f0.html" class="tnt-asset-link" aria-label="Pasta Extravaganza this weekend to benefit Cindy’s Pets">
        

        
            Pasta Extravaganza this weekend to benefit Cindy’s Pets</a></span>
        </li><li class="">
            <span class="tnt-headline ">
        
             <a href="/news/pasco-commissioners-ink-contract-with-new-administrator-finalize-jail-transfer/article_b57ec018-339e-11ed-a138-ef92c7bad5e4.html" class="tnt-asset-link" aria-label="Pasco commissioners ink contract with new administrator, finalize jail transfer">
        

        
            Pasco commissioners ink contract with new administrator, finalize jail transfer</a></span>
        </li><li class="">
            <span class="tnt-headline ">
        
             <a href="/news/pasco-news-briefs/article_96335c34-339c-11ed-a710-b73ebf9a8069.html" class="tnt-asset-link" aria-label="Pasco News Briefs">
        

        
            Pasco News Briefs</a></span>
        </li></ul></div>
        </div></div></section></div><div id="tncms-block-1264894" class="tncms-block"><div class="tnt-ads-container text-center  " >
        <div id="ad-1264894" class="tnt-ads dfp-ad" data-lazy="true" data-refresh="true" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('ad-1264894');
                        
                });
            </script>
        </div>
    </div>
</div><div id="tncms-block-501416" class="tncms-block"><section id="block-501416" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-501416 ">
        <div class="block-title-inner">
            <h4>
                
                Most Popular
                
            </h4>
        </div>
    </div></div><div class="most-popular">
    <ul class="nav nav-tabs nav-tabs-popular">
        
            <li class="active">
                <a href="#articles-501416" data-toggle="tab"><i class="far tnt-file-alt" title="Articles"></i><span class="tab-text"> Articles</span></a>
            </li>
        
        
            <li >
                <a href="#images-501416" data-toggle="tab"><i class="far tnt-image" title="images"></i><span class="tab-text"> Images</span></a>
            </li>
        
        
            <li >
                <a href="#videos-501416" data-toggle="tab"><i class="fas tnt-play-circle" title="Videos"></i><span class="tab-text"> Videos</span></a>
            </li>
        
        
        
        
            <li >
                <a href="#commented-501416" data-toggle="tab"><i class="far tnt-comments" title="Commented"></i><span class="tab-text"> Commented</span></a>
            </li>
        
    </ul>
    <div class="tab-content">
        
            <div id="articles-501416" class="tab-pane tab-pane-articles fade in active">
                <h4 class="tab-content-heading">Articles</h4><ul class="tab-content-list bullet-disc "><li><a href="/crime_crashes_fires/two-arrested-after-detectives-find-illegal-narcotics-firearms-and-cash/article_8c622f32-2f96-11ed-b460-b37caf5d3d7f.html">Two arrested after detectives find illegal narcotics, firearms, and cash</a></li><li><a href="/news/discussion-over-new-port-richey-mural-gets-heated/article_154f2f64-339f-11ed-9e8b-3724e641c836.html">Discussion over New Port Richey mural gets heated</a></li><li><a href="/news/case-of-monkeypox-confirmed-in-hernando-county/article_c6a01956-305a-11ed-902b-1be066985f48.html">Case of monkeypox confirmed in Hernando County</a></li><li><a href="/news/traveling-9-11-exhibit-to-stop-in-sims-park-concludes-with-city-ceremony/article_cf991d80-2f03-11ed-92d3-e74200867b78.html">Traveling 9/11 exhibit to stop in Sims Park, concludes with city ceremony</a></li><li><a href="/news/pasco-residents-will-wait-a-little-longer-to-pay-the-bill-to-protect-oaks-park/article_064b75a2-2f05-11ed-b191-bb47910f3ed9.html">Pasco residents will wait a little longer to pay the bill to protect Oaks Park</a></li><li><a href="/news/bigger-va-clinic-will-offer-multiple-expanded-services-under-one-roof-in-new-port-richey/article_39840b94-339e-11ed-b91a-63ed3726deb9.html">Bigger VA clinic will offer multiple, expanded services under one roof in New Port Richey</a></li><li><a href="/news/sheriff-s-office-reports-telephone-outage-has-ended/article_739e2014-32a7-11ed-99ff-37be31e55261.html">Sheriff’s Office reports telephone outage has ended</a></li><li><a href="/news/weather-service-warns-of-heavy-rain-floods-in-area/article_35d6cece-3064-11ed-8479-9bae415459c7.html">Weather service warns of heavy rain, floods in area</a></li><li><a href="/crime_crashes_fires/woman-found-dead-near-anderson-snow-sports-complex/article_742d1c4c-2dd9-11ed-b998-b7f345d0fe12.html">Woman found dead near Anderson Snow Sports complex</a></li><li><a href="/news/plenty-of-hard-work-went-into-creating-downtown-tarpon-springs-coffee-lounge/article_fe5ca152-3393-11ed-8a5b-03e84beeed1c.html">Plenty of hard work went into creating downtown Tarpon Springs coffee lounge</a></li></ul></div>
        
        
            <div id="images-501416" class="tab-pane tab-pane-images fade in ">
                <h4 class="tab-content-heading">Images</h4><ul class="tab-content-list">
                            <li><figure class="photo layout-square letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/two-arrested-after-detectives-find-illegal-narcotics-firearms-and-cash/image_07a2a8fc-2f97-11ed-80e5-2b3e8a6ed073.html" class="tnt-asset-link"  aria-label="Two arrested after detectives find illegal narcotics, firearms, and cash">
                
                
                
                
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="Two arrested after detectives find illegal narcotics, firearms, and cash"
                            class="img-responsive lazyload full default"
                            width="546"
                            height="546"
                            data-sizes="auto"
                            data-srcset="https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/0/7a/07a2a8fc-2f97-11ed-80e5-2b3e8a6ed073/631a1e7b49e34.image.jpg?crop=546%2C546%2C0%2C82&resize=150%2C150&order=crop%2Cresize 150w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/0/7a/07a2a8fc-2f97-11ed-80e5-2b3e8a6ed073/631a1e7b49e34.image.jpg?crop=546%2C546%2C0%2C82&resize=200%2C200&order=crop%2Cresize 200w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/0/7a/07a2a8fc-2f97-11ed-80e5-2b3e8a6ed073/631a1e7b49e34.image.jpg?crop=546%2C546%2C0%2C82&resize=225%2C225&order=crop%2Cresize 225w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/0/7a/07a2a8fc-2f97-11ed-80e5-2b3e8a6ed073/631a1e7b49e34.image.jpg?crop=546%2C546%2C0%2C82&resize=300%2C300&order=crop%2Cresize 300w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/0/7a/07a2a8fc-2f97-11ed-80e5-2b3e8a6ed073/631a1e7b49e34.image.jpg?crop=546%2C546%2C0%2C82&resize=400%2C400&order=crop%2Cresize 400w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/0/7a/07a2a8fc-2f97-11ed-80e5-2b3e8a6ed073/631a1e7b49e34.image.jpg?crop=546%2C546%2C0%2C82&resize=540%2C540&order=crop%2Cresize 540w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/0/7a/07a2a8fc-2f97-11ed-80e5-2b3e8a6ed073/631a1e7b49e34.image.jpg?crop=546%2C546%2C0%2C82&resize=546%2C546&order=crop%2Cresize 640w" />
                </a>
                
            </div>
            
        </figure></li>
                        
                            <li><figure class="photo layout-square letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/arrest-made-in-fatal-brooksville-shooting/image_49f7a992-2ea6-11ed-9b97-6f4bd9da7b6a.html" class="tnt-asset-link"  aria-label="Arrest made in fatal Brooksville shooting">
                
                
                
                
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="Arrest made in fatal Brooksville shooting"
                            class="img-responsive lazyload full default"
                            width="316"
                            height="316"
                            data-sizes="auto"
                            data-srcset="https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/4/9f/49f7a992-2ea6-11ed-9b97-6f4bd9da7b6a/63188ac9ae2a7.image.jpg?crop=316%2C316%2C0%2C47&resize=150%2C150&order=crop%2Cresize 150w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/4/9f/49f7a992-2ea6-11ed-9b97-6f4bd9da7b6a/63188ac9ae2a7.image.jpg?crop=316%2C316%2C0%2C47&resize=200%2C200&order=crop%2Cresize 200w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/4/9f/49f7a992-2ea6-11ed-9b97-6f4bd9da7b6a/63188ac9ae2a7.image.jpg?crop=316%2C316%2C0%2C47&resize=225%2C225&order=crop%2Cresize 225w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/4/9f/49f7a992-2ea6-11ed-9b97-6f4bd9da7b6a/63188ac9ae2a7.image.jpg?crop=316%2C316%2C0%2C47&resize=300%2C300&order=crop%2Cresize 300w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/4/9f/49f7a992-2ea6-11ed-9b97-6f4bd9da7b6a/63188ac9ae2a7.image.jpg?crop=316%2C316%2C0%2C47&resize=316%2C316&order=crop%2Cresize 400w" />
                </a>
                
            </div>
            
        </figure></li>
                        
                            <li><figure class="photo layout-square letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/man-in-custody-after-victim-beat-up-at-subway-store/image_2d0930f8-305e-11ed-861a-17409c5822a7.html" class="tnt-asset-link"  aria-label="Man in custody after victim beat up at Subway store">
                
                
                
                
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="Man in custody after victim beat up at Subway store"
                            class="img-responsive lazyload full default"
                            width="384"
                            height="384"
                            data-sizes="auto"
                            data-srcset="https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/2/d0/2d0930f8-305e-11ed-861a-17409c5822a7/631b6ce2b9dae.image.jpg?crop=384%2C384%2C0%2C47&resize=150%2C150&order=crop%2Cresize 150w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/2/d0/2d0930f8-305e-11ed-861a-17409c5822a7/631b6ce2b9dae.image.jpg?crop=384%2C384%2C0%2C47&resize=200%2C200&order=crop%2Cresize 200w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/2/d0/2d0930f8-305e-11ed-861a-17409c5822a7/631b6ce2b9dae.image.jpg?crop=384%2C384%2C0%2C47&resize=225%2C225&order=crop%2Cresize 225w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/2/d0/2d0930f8-305e-11ed-861a-17409c5822a7/631b6ce2b9dae.image.jpg?crop=384%2C384%2C0%2C47&resize=300%2C300&order=crop%2Cresize 300w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/2/d0/2d0930f8-305e-11ed-861a-17409c5822a7/631b6ce2b9dae.image.jpg?crop=384%2C384%2C0%2C47&resize=384%2C384&order=crop%2Cresize 400w" />
                </a>
                
            </div>
            
        </figure></li>
                        
                            <li><figure class="photo layout-square letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/fdle-3-teachers-helped-students-cheat-on-agricultural-exams-at-hudson-high/image_642286be-3132-11ed-a591-237798ef8c33.html" class="tnt-asset-link"  aria-label="FDLE: 3 teachers helped students cheat on agricultural exams at Hudson High">
                
                
                
                
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="FDLE: 3 teachers helped students cheat on agricultural exams at Hudson High"
                            class="img-responsive lazyload full default"
                            width="532"
                            height="532"
                            data-sizes="auto"
                            data-srcset="https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/6/42/642286be-3132-11ed-a591-237798ef8c33/631cd14005f23.image.jpg?crop=532%2C532%2C195%2C20&resize=150%2C150&order=crop%2Cresize 150w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/6/42/642286be-3132-11ed-a591-237798ef8c33/631cd14005f23.image.jpg?crop=532%2C532%2C195%2C20&resize=200%2C200&order=crop%2Cresize 200w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/6/42/642286be-3132-11ed-a591-237798ef8c33/631cd14005f23.image.jpg?crop=532%2C532%2C195%2C20&resize=225%2C225&order=crop%2Cresize 225w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/6/42/642286be-3132-11ed-a591-237798ef8c33/631cd14005f23.image.jpg?crop=532%2C532%2C195%2C20&resize=300%2C300&order=crop%2Cresize 300w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/6/42/642286be-3132-11ed-a591-237798ef8c33/631cd14005f23.image.jpg?crop=532%2C532%2C195%2C20&resize=400%2C400&order=crop%2Cresize 400w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/6/42/642286be-3132-11ed-a591-237798ef8c33/631cd14005f23.image.jpg?crop=532%2C532%2C195%2C20&resize=532%2C532&order=crop%2Cresize 540w" />
                </a>
                
            </div>
            
        </figure></li>
                        
                            <li><figure class="photo layout-square letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/man-charged-with-dealing-drugs-from-home-in-masaryktown/image_08514f1c-2a31-11ed-8e60-a7152ee8f3be.html" class="tnt-asset-link"  aria-label="Man charged with dealing drugs from home in Masaryktown">
                
                
                
                
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="Man charged with dealing drugs from home in Masaryktown"
                            class="img-responsive lazyload full default"
                            width="348"
                            height="348"
                            data-sizes="auto"
                            data-srcset="https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/0/85/08514f1c-2a31-11ed-8e60-a7152ee8f3be/6311102500673.image.jpg?crop=348%2C348%2C0%2C53&resize=150%2C150&order=crop%2Cresize 150w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/0/85/08514f1c-2a31-11ed-8e60-a7152ee8f3be/6311102500673.image.jpg?crop=348%2C348%2C0%2C53&resize=200%2C200&order=crop%2Cresize 200w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/0/85/08514f1c-2a31-11ed-8e60-a7152ee8f3be/6311102500673.image.jpg?crop=348%2C348%2C0%2C53&resize=225%2C225&order=crop%2Cresize 225w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/0/85/08514f1c-2a31-11ed-8e60-a7152ee8f3be/6311102500673.image.jpg?crop=348%2C348%2C0%2C53&resize=300%2C300&order=crop%2Cresize 300w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/0/85/08514f1c-2a31-11ed-8e60-a7152ee8f3be/6311102500673.image.jpg?crop=348%2C348%2C0%2C53&resize=348%2C348&order=crop%2Cresize 400w" />
                </a>
                
            </div>
            
        </figure></li>
                        
                            <li><figure class="photo layout-square letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/pasco-detention-center/image_f322432c-339e-11ed-a970-e3ea3e345cf9.html" class="tnt-asset-link"  aria-label="Pasco Detention Center">
                
                
                
                
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="Pasco Detention Center"
                            class="img-responsive lazyload full default"
                            width="349"
                            height="349"
                            data-sizes="auto"
                            data-srcset="https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/f/32/f322432c-339e-11ed-a970-e3ea3e345cf9/6320e1f71f0f1.image.jpg?crop=349%2C349%2C135%2C0&resize=150%2C150&order=crop%2Cresize 150w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/f/32/f322432c-339e-11ed-a970-e3ea3e345cf9/6320e1f71f0f1.image.jpg?crop=349%2C349%2C135%2C0&resize=200%2C200&order=crop%2Cresize 200w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/f/32/f322432c-339e-11ed-a970-e3ea3e345cf9/6320e1f71f0f1.image.jpg?crop=349%2C349%2C135%2C0&resize=225%2C225&order=crop%2Cresize 225w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/f/32/f322432c-339e-11ed-a970-e3ea3e345cf9/6320e1f71f0f1.image.jpg?crop=349%2C349%2C135%2C0&resize=300%2C300&order=crop%2Cresize 300w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/f/32/f322432c-339e-11ed-a970-e3ea3e345cf9/6320e1f71f0f1.image.jpg?crop=349%2C349%2C135%2C0&resize=349%2C349&order=crop%2Cresize 400w" />
                </a>
                
            </div>
            
        </figure></li>
                        
                            <li><figure class="photo layout-square letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/baycare-adds-new-outpatient-urgent-and-primary-care-clinic-in-trinity/image_5873b07a-2568-11ed-858f-8759a09af79c.html" class="tnt-asset-link"  aria-label="BayCare adds new outpatient urgent and primary care clinic in Trinity">
                
                
                
                
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="BayCare adds new outpatient urgent and primary care clinic in Trinity"
                            class="img-responsive lazyload full default"
                            width="1253"
                            height="1253"
                            data-sizes="auto"
                            data-srcset="https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/5/87/5873b07a-2568-11ed-858f-8759a09af79c/63090930dfdae.image.jpg?crop=1253%2C1253%2C200%2C0&resize=150%2C150&order=crop%2Cresize 150w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/5/87/5873b07a-2568-11ed-858f-8759a09af79c/63090930dfdae.image.jpg?crop=1253%2C1253%2C200%2C0&resize=200%2C200&order=crop%2Cresize 200w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/5/87/5873b07a-2568-11ed-858f-8759a09af79c/63090930dfdae.image.jpg?crop=1253%2C1253%2C200%2C0&resize=225%2C225&order=crop%2Cresize 225w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/5/87/5873b07a-2568-11ed-858f-8759a09af79c/63090930dfdae.image.jpg?crop=1253%2C1253%2C200%2C0&resize=300%2C300&order=crop%2Cresize 300w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/5/87/5873b07a-2568-11ed-858f-8759a09af79c/63090930dfdae.image.jpg?crop=1253%2C1253%2C200%2C0&resize=400%2C400&order=crop%2Cresize 400w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/5/87/5873b07a-2568-11ed-858f-8759a09af79c/63090930dfdae.image.jpg?crop=1253%2C1253%2C200%2C0&resize=540%2C540&order=crop%2Cresize 540w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/5/87/5873b07a-2568-11ed-858f-8759a09af79c/63090930dfdae.image.jpg?crop=1253%2C1253%2C200%2C0&resize=640%2C640&order=crop%2Cresize 640w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/5/87/5873b07a-2568-11ed-858f-8759a09af79c/63090930dfdae.image.jpg?crop=1253%2C1253%2C200%2C0&resize=750%2C750&order=crop%2Cresize 750w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/5/87/5873b07a-2568-11ed-858f-8759a09af79c/63090930dfdae.image.jpg?crop=1253%2C1253%2C200%2C0&resize=990%2C990&order=crop%2Cresize 990w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/5/87/5873b07a-2568-11ed-858f-8759a09af79c/63090930dfdae.image.jpg?crop=1253%2C1253%2C200%2C0&resize=1035%2C1035&order=crop%2Cresize 1035w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/5/87/5873b07a-2568-11ed-858f-8759a09af79c/63090930dfdae.image.jpg?crop=1253%2C1253%2C200%2C0&resize=1200%2C1200&order=crop%2Cresize 1200w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/5/87/5873b07a-2568-11ed-858f-8759a09af79c/63090930dfdae.image.jpg?crop=1253%2C1253%2C200%2C0&resize=1253%2C1253&order=crop%2Cresize 1333w" />
                </a>
                
            </div>
            
        </figure></li>
                        
                            <li><figure class="photo layout-square letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/brooksville-man-four-others-charged-after-investigation/image_0e477858-278c-11ed-9aee-6f671d555795.html" class="tnt-asset-link"  aria-label="Brooksville man, four others charged after investigation">
                
                
                
                
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="Brooksville man, four others charged after investigation"
                            class="img-responsive lazyload full default"
                            width="321"
                            height="321"
                            data-sizes="auto"
                            data-srcset="https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/0/e4/0e477858-278c-11ed-9aee-6f671d555795/630ca018a6baa.image.jpg?crop=321%2C321%2C3%2C56&resize=150%2C150&order=crop%2Cresize 150w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/0/e4/0e477858-278c-11ed-9aee-6f671d555795/630ca018a6baa.image.jpg?crop=321%2C321%2C3%2C56&resize=200%2C200&order=crop%2Cresize 200w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/0/e4/0e477858-278c-11ed-9aee-6f671d555795/630ca018a6baa.image.jpg?crop=321%2C321%2C3%2C56&resize=225%2C225&order=crop%2Cresize 225w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/0/e4/0e477858-278c-11ed-9aee-6f671d555795/630ca018a6baa.image.jpg?crop=321%2C321%2C3%2C56&resize=300%2C300&order=crop%2Cresize 300w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/0/e4/0e477858-278c-11ed-9aee-6f671d555795/630ca018a6baa.image.jpg?crop=321%2C321%2C3%2C56&resize=321%2C321&order=crop%2Cresize 400w" />
                </a>
                
            </div>
            
        </figure></li>
                        </ul></div>
        
        <div id="videos-501416" class="tab-pane tab-pane-videos fade in ">
                <h4 class="tab-content-heading">Videos</h4><p class="no-results text-muted">Sorry, there are no recent results for popular videos.</p></div>
        
        
        
        
            <div id="commented-501416" class="tab-pane tab-pane-commented fade in ">
                <h4 class="tab-content-heading">Commented</h4><p class="no-results text-muted">Sorry, there are no recent results for popular commented articles.</p></div>
        
    </div>
</div></section></div><div id="tncms-block-501418" class="tncms-block"><section id="block-501418" class="block emphasis-h3   " ><div class="clearfix">
    
    <div class="block-title title-501418 ">
        <div class="block-title-inner">
            <h3>
                
                Latest e-Editions
                
            </h3>
        </div>
    </div></div>
    
        
            <div class="card-panel panel">
                <div class="panel-body">
        <article id="card-summary-fc751931-40eb-5c38-ada4-bcbe93067a6c" class="clearfix card summary">
                <div class="card-container">
                        <div class="card-image">
                            <div class="media-preview-fc751931-40eb-5c38-ada4-bcbe93067a6c media-preview edition-asset " data-aspect=""><figure class="photo layout-square letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/eedition/discover-the-suncoast/edition_fc751931-40eb-5c38-ada4-bcbe93067a6c.html" class="tnt-asset-link"  aria-label="Discover the Suncoast">
                
                
                    <div class="asset-icon"><i class="far tnt-newspaper tnt-fw" title="e-Edition"></i></div>
                
                
                
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg=="
                            alt="Discover the Suncoast"
                            class="img-responsive lazyload full default"
                            width="300"
                            height="300"
                            data-sizes="auto"
                            data-srcset="https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/eedition/e/21/e218c497-02e2-56dc-9c7d-120758982300/62fbe5e4cf7b0.preview-300.jpg?resize=150%2C150 150w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/eedition/e/21/e218c497-02e2-56dc-9c7d-120758982300/62fbe5e4cf7b0.preview-300.jpg?resize=200%2C200 200w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/eedition/e/21/e218c497-02e2-56dc-9c7d-120758982300/62fbe5e4cf7b0.preview-300.jpg?resize=225%2C225 225w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/eedition/e/21/e218c497-02e2-56dc-9c7d-120758982300/62fbe5e4cf7b0.preview-300.jpg?resize=300%2C300 300w" />
                </a>
                
            </div>
            
        </figure></div>
                        </div>
                    <div class="card-body">
                        <div class="card-headline">
                            <h3 class="tnt-headline ">
        
             <a href="/eedition/discover-the-suncoast/edition_fc751931-40eb-5c38-ada4-bcbe93067a6c.html" class="tnt-asset-link" aria-label="Discover the Suncoast">
        

        
            Discover the Suncoast</a></h3>
                        </div>
                            <div class="card-meta">
                                <ul class="list-inline">
                                    
                                    
                                        <li style="padding-bottom:10px;">To view our latest e-Edition click the image on the left.</li>
                                    </ul>
                            </div>
                    </div>
                </div>
                <div class="clearfix"></div>
            </article>
                </div>
            </div>
        
    
        
            <div class="card-panel panel">
                <div class="panel-body">
        <article id="card-summary-abbf2d74-2c36-53ea-b03f-0f2663a01735" class="clearfix card summary">
                <div class="card-container">
                        <div class="card-image">
                            <div class="media-preview-abbf2d74-2c36-53ea-b03f-0f2663a01735 media-preview edition-asset " data-aspect=""><figure class="photo layout-square letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/eedition/best-of-hernando-2022/edition_abbf2d74-2c36-53ea-b03f-0f2663a01735.html" class="tnt-asset-link"  aria-label="Best of Hernando 2022">
                
                
                    <div class="asset-icon"><i class="far tnt-newspaper tnt-fw" title="e-Edition"></i></div>
                
                
                
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg=="
                            alt="Best of Hernando 2022"
                            class="img-responsive lazyload full default"
                            width="300"
                            height="300"
                            data-sizes="auto"
                            data-srcset="https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/eedition/2/88/2889d6ba-35a1-54ce-9b10-ed76252cd63c/62d813e0bd0a1.preview-300.jpg?resize=150%2C150 150w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/eedition/2/88/2889d6ba-35a1-54ce-9b10-ed76252cd63c/62d813e0bd0a1.preview-300.jpg?resize=200%2C200 200w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/eedition/2/88/2889d6ba-35a1-54ce-9b10-ed76252cd63c/62d813e0bd0a1.preview-300.jpg?resize=225%2C225 225w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/eedition/2/88/2889d6ba-35a1-54ce-9b10-ed76252cd63c/62d813e0bd0a1.preview-300.jpg?resize=300%2C300 300w" />
                </a>
                
            </div>
            
        </figure></div>
                        </div>
                    <div class="card-body">
                        <div class="card-headline">
                            <h3 class="tnt-headline ">
        
             <a href="/eedition/best-of-hernando-2022/edition_abbf2d74-2c36-53ea-b03f-0f2663a01735.html" class="tnt-asset-link" aria-label="Best of Hernando 2022">
        

        
            Best of Hernando 2022</a></h3>
                        </div>
                            <div class="card-meta">
                                <ul class="list-inline">
                                    
                                    
                                        <li style="padding-bottom:10px;">To view our latest e-Edition click the image on the left.</li>
                                    </ul>
                            </div>
                    </div>
                </div>
                <div class="clearfix"></div>
            </article>
                </div>
            </div>
        
    
        
            <div class="card-panel panel">
                <div class="panel-body">
        <article id="card-summary-6be21251-df96-58c1-84b9-0586325ab5e6" class="clearfix card summary">
                <div class="card-container">
                        <div class="card-image">
                            <div class="media-preview-6be21251-df96-58c1-84b9-0586325ab5e6 media-preview edition-asset " data-aspect=""><figure class="photo layout-square letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/eedition/best-of-the-suncoast-2022/edition_6be21251-df96-58c1-84b9-0586325ab5e6.html" class="tnt-asset-link"  aria-label="Best of the Suncoast 2022">
                
                
                    <div class="asset-icon"><i class="far tnt-newspaper tnt-fw" title="e-Edition"></i></div>
                
                
                
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg=="
                            alt="Best of the Suncoast 2022"
                            class="img-responsive lazyload full default"
                            width="300"
                            height="300"
                            data-sizes="auto"
                            data-srcset="https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/eedition/7/1d/71d7c69c-2e6f-52c0-bbed-7622994d3796/62b49af917456.preview-300.jpg?resize=150%2C150 150w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/eedition/7/1d/71d7c69c-2e6f-52c0-bbed-7622994d3796/62b49af917456.preview-300.jpg?resize=200%2C200 200w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/eedition/7/1d/71d7c69c-2e6f-52c0-bbed-7622994d3796/62b49af917456.preview-300.jpg?resize=225%2C225 225w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/eedition/7/1d/71d7c69c-2e6f-52c0-bbed-7622994d3796/62b49af917456.preview-300.jpg?resize=300%2C300 300w" />
                </a>
                
            </div>
            
        </figure></div>
                        </div>
                    <div class="card-body">
                        <div class="card-headline">
                            <h3 class="tnt-headline ">
        
             <a href="/eedition/best-of-the-suncoast-2022/edition_6be21251-df96-58c1-84b9-0586325ab5e6.html" class="tnt-asset-link" aria-label="Best of the Suncoast 2022">
        

        
            Best of the Suncoast 2022</a></h3>
                        </div>
                            <div class="card-meta">
                                <ul class="list-inline">
                                    
                                    
                                        <li style="padding-bottom:10px;">To view our latest e-Edition click the image on the left.</li>
                                    </ul>
                            </div>
                    </div>
                </div>
                <div class="clearfix"></div>
            </article>
                </div>
            </div>
        
    
    </section></div><div id="tncms-block-501393" class="tncms-block"></div><div id="tncms-block-501355" class="tncms-block"></div><div id="tncms-block-975241" class="tncms-block"><section id="block-975241" class="block emphasis-h3   " ><div id="evvnt-calendar-975241"></div>
<script async defer src="//discovery.evvnt.com/prd/evvnt_discovery_plugin-latest.min.js" onload="evvntDiscoveryInit_975241();"></script></section></div><div id="tncms-block-1264900" class="tncms-block"><div class="tnt-ads-container text-center  " >
        <div id="ad-1264900" class="tnt-ads dfp-ad" data-lazy="true" data-refresh="true" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('ad-1264900');
                        
                });
            </script>
        </div>
    </div>
</div><div id="tncms-block-633912" class="tncms-block"></div></div><div id="tncms-region-asset_side_middle" class="tncms-region hidden-print"></div><div id="tncms-region-article_side_middle" class="tncms-region hidden-print"></div><div id="tncms-region-global-side-secondary" class="tncms-region hidden-print"><div id="tncms-block-501387" class="tncms-block"></div></div><div id="tncms-region-asset_side_bottom" class="tncms-region hidden-print"></div><div id="tncms-region-global-side-tertiary" class="tncms-region "><div id="tncms-block-1264903" class="tncms-block"><div class="tnt-ads-container text-center  " >
        <div id="ad-1264903" class="tnt-ads dfp-ad" data-lazy="true" data-refresh="true" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('ad-1264903');
                        
                });
            </script>
        </div>
    </div>
</div></div><div id="tncms-region-article_side_bottom" class="tncms-region hidden-print"></div><div id="insticator-container" style="position:relative;margin-left:auto;margin-right:auto;width:300px;margin-bottom:40px;">
                    <div id="div-insticator-ad-1" style="height: 280px; margin-bottom: 20px;"></div>
                    <div id="insticator-embed"></div>
                    <div id="div-insticator-ad-2"></div>
                </div>
                <div id="sticky-right-rail-spacer">
                    <div id="sticky-right-rail"><div id="tncms-region-global-side-sticky" class="tncms-region hidden-print"></div><div id="tncms-region-asset_side_sticky" class="tncms-region hidden-print"></div></div>
                </div>
                </div>
            </div></div>
</article>
<div class="row">
            <div class="col-md-12"><div id="tncms-region-global-container-bottom" class="tncms-region "><div id="tncms-block-1264888" class="tncms-block"><div class="tnt-ads-container text-center  " >
        <div id="ad-1264888" class="tnt-ads dfp-ad" data-lazy="true" data-refresh="true" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('ad-1264888');
                        
                });
            </script>
        </div>
    </div>
</div></div></div>
        </div></section>
    <section id="main-bottom-container" class="container-fullscreen-region container-fluid">
        <div class="fullscreen-region"><div id="tncms-region-global-container-bottom-fullscreen" class="tncms-region "></div></div>
    </section><!-- / main-body-container -->
    </div>
    <div id="site-footer-container" class="hidden-print">
         
            <div class="container">
                <div id="asset-container-bottom" class="col-md-12">
                    <div id="tncms-region-asset_container_bottom" class="tncms-region hidden-print"></div> 
                </div>
            </div>
        

        
            <footer id="site-footer" class="container well-main">
                
                <div id="tncms-region-footer-top-col-full" class="tncms-region "></div>
                <div class="row">
                    <div id="footer-col-one" class="col-md-4 col-sm-4"><div id="tncms-region-footer-col-one" class="tncms-region "><div id="tncms-block-501401" class="tncms-block"><section id="block-501401" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-501401 ">
        <div class="block-title-inner">
            <h4>
                
                Sections
                
            </h4>
        </div>
    </div></div></section></div></div><div id="tncms-region-nav-footer-col-one-nav" class="tncms-region-nav"><ul id="footer-col-one-nav_menu" class="bullet-nav nav-list"><li>
                <a class="nav-link   nav-home  tnt-section-home"  href="/"  tabindex="0" >
                    <span class="nav-icon fas tnt-home tnt-fw"></span> <span class="nav-label sr-only">Home</span>
                </a></li><li>
                <a class="nav-link    tnt-section-news"  href="/news/"  tabindex="0" >
                    <span class="nav-label ">News</span>
                </a></li><li>
                <a class="nav-link    tnt-section-sports"  href="/sports/"  tabindex="0" >
                    <span class="nav-label ">Sports</span>
                </a></li><li>
                <a class="nav-link    tnt-section-business"  href="/business/"  tabindex="0" >
                    <span class="nav-label ">Business</span>
                </a></li><li>
                <a class="nav-link    tnt-section-obituaries"  href="/obituaries/"  tabindex="0" >
                    <span class="nav-label ">Obituaries</span>
                </a></li><li>
                <a class="nav-link    tnt-section-local-events"  href="/local-events/"  tabindex="0" >
                    <span class="nav-label ">Local Events</span>
                </a></li><li>
                <a class="nav-link    tnt-section-multimedia"  href="/multimedia/"  tabindex="0" >
                    <span class="nav-label ">Multimedia</span>
                </a></li></ul></div></div>
    <div id="footer-col-two" class="col-md-4 col-sm-4"><div id="tncms-region-footer-col-two" class="tncms-region "><div id="tncms-block-501402" class="tncms-block"><section id="block-501402" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-501402 ">
        <div class="block-title-inner">
            <h4>
                
                Services
                
            </h4>
        </div>
    </div></div></section></div></div><div id="tncms-region-nav-footer-col-two-nav" class="tncms-region-nav"><ul id="footer-col-two-nav_menu" class="bullet-nav nav-list"><li>
                <a class="nav-link    tnt-section-subscription-services"  href="/site/forms/subscription_services/"  tabindex="0" >
                    <span class="nav-label ">Subscription Services</span>
                </a></li><li>
                <a class="nav-link    tnt-section-submission-forms"  href="/site/forms/"  tabindex="0" >
                    <span class="nav-label ">Submission Forms</span>
                </a></li><li>
                <a class="nav-link    tnt-section-classifieds"  href="/classifieds/"  tabindex="0" >
                    <span class="nav-label ">Classifieds</span>
                </a></li><li>
                <a class="nav-link    tnt-section-place-an-ad"  href="http://www.suncoastnews.com/site/contact.html"  target="_blank" rel="noopener" tabindex="0" >
                    <span class="nav-label ">Place an Ad</span>
                </a></li><li>
                <a class="nav-link    tnt-section-promote-your-event"  href="https://new.evvnt.com/?with_navbar&amp;force_snap_sell&amp;partner=SUNCOASTNEWS&amp;publisher_url:suncoastnews.com#/quick"  target="_blank" rel="noopener" tabindex="0" >
                    <span class="nav-label ">Promote Your Event</span>
                </a></li><li>
                <a class="nav-link    tnt-section-search"  href="/search/"  tabindex="0" >
                    <span class="nav-label ">Search</span>
                </a></li><li>
                <a class="nav-link    tnt-section-weather"  href="/weather/"  tabindex="0" >
                    <span class="nav-label ">Weather</span>
                </a></li><li>
                <a class="nav-link    tnt-section-legal-notices"  href="https://www.suncoastnews.com/classifieds/legal_notices/?l=25"  target="_blank" rel="noopener" tabindex="0" >
                    <span class="nav-label ">Legal Notices</span>
                </a></li></ul></div></div>
    <div id="footer-col-three" class="col-md-4 col-sm-4"><div id="tncms-region-footer-col-three" class="tncms-region "><div id="tncms-block-501415" class="tncms-block padding-bottom"><section id="block-501415" class="block emphasis-h3   " ><div class="block"><a href="/" rel="nofollow"  >
            <img 
                
                src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg==" 
                data-srcset="https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/custom/image/17727cd0-7120-11e6-8a40-33d15f4612ac.jpg?resize=150%2C64 150w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/custom/image/17727cd0-7120-11e6-8a40-33d15f4612ac.jpg?resize=200%2C86 200w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/custom/image/17727cd0-7120-11e6-8a40-33d15f4612ac.jpg?resize=225%2C96 225w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/custom/image/17727cd0-7120-11e6-8a40-33d15f4612ac.jpg?resize=300%2C128 300w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/custom/image/17727cd0-7120-11e6-8a40-33d15f4612ac.jpg?resize=400%2C171 400w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/custom/image/17727cd0-7120-11e6-8a40-33d15f4612ac.jpg?resize=540%2C231 540w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/custom/image/17727cd0-7120-11e6-8a40-33d15f4612ac.jpg?resize=640%2C274 640w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/custom/image/17727cd0-7120-11e6-8a40-33d15f4612ac.jpg 750w" 
                data-sizes="auto" 
                class=" img-responsive lazyload tnt-prop-img"
                width="750"
                height="321"
                alt=""
                aria-hidden="true"></a></div></section></div><div id="tncms-block-501407" class="tncms-block"><section id="block-501407" class="block emphasis-h4   " ><address>
    <strong>www.SuncoastNews.com</strong><br>
    11321 U.S. Hwy 19 North<br>
    Port Richey, FL. 34668
    <br>
    
        <strong>Phone:</strong> 727-815-1023<br>
        <strong>Email:</strong> <a href="mailto:dpleus@SuncoastNews.com">dpleus@SuncoastNews.com</a><br>
    
</address></section></div><div id="tncms-block-501424" class="tncms-block padding-bottom"><div class="follow-links-501424 default">
    
    <section id="block-501424" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-501424 ">
        <div class="block-title-inner">
            <h4>
                
                Follow Us
                
            </h4>
        </div>
    </div></div><ul class="list-inline">
        
            <li>
                <a href="http://facebook.com/SuncoastNews/" title="Facebook" target="_blank" rel="noopener" class="btn btn-md btn-link fb" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-facebook-f"></i>
                    <span class="sr-only">Facebook</span>
                </a>
            </li>
        
        
            <li>
                <a href="http://twitter.com/SuncoastNews/" title="Twitter" target="_blank" rel="noopener" class="btn btn-md btn-link tw" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-twitter"></i>
                    <span class="sr-only">Twitter</span>
                </a>
            </li>
        
        
        
            <li>
                <a href="http://www.youtube.com/user/SCNPasco" title="Youtube" target="_blank" rel="noopener" class="btn btn-md btn-link yt" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-youtube"></i>
                    <span class="sr-only">YouTube</span>
                </a>
            </li>
        
        
        
        
        
        
        
        
        
        
        
        
        
        
    </ul>
    </section>
</div>
<script type="application/ld+json">
{ "@context" : "https://schema.org",
  "@type" : "Organization",
  "url" : "http://www.suncoastnews.com",
  "sameAs" : ["http://facebook.com/SuncoastNews/","http://twitter.com/SuncoastNews/","http://www.youtube.com/user/SCNPasco"]
}
</script>
<div class="clearfix"></div></div></div></div>
                </div>
                <div id="tncms-region-footer-bottom-col-full" class="tncms-region "></div>
                
            </footer>
        

        <div id="site-copyright-container" class="container">
            <div id="tncms-region-footer-copyright" class="tncms-region "><div id="tncms-block-501408" class="tncms-block"><div id="site-copyright" class="row">
    <section id="block-501408"><div class="col-md-7"><small>&copy; Copyright 2022 <a href="/">suncoastnews.com</a>, 9911 Seminole Blvd. Seminole, FL</small><small>&nbsp;| <a href="/site/terms.html">Terms of Use</a></small><small>&nbsp;| <a href="/site/privacy.html">Privacy Policy</a></small></div>
        <div class="col-md-5"><small>Powered by <a href="https://bloxcms.com" title="BLOX Content Management System" target="_blank" rel="noopener">BLOX Content Management System</a> from <a href="https://townnews.com/" title="TownNews.com BLOX Newspaper Content Management" target="_blank" rel="noopener">TownNews.com</a>.</small></div>
    </section>
</div></div></div>
        </div>
    </div>
    
    
        </div><!-- / offcanvas close  -->
    

    
    <div id="sticky-anchor"><div id="tncms-region-page_sticky_anchor" class="tncms-region hidden-print collapse in"><div id="tncms-block-1264909" class="tncms-block"><div class="tnt-ads-container text-center  " >
        <div id="ad-1264909" class="tnt-ads dfp-ad" data-lazy="true" data-refresh="true" data-mobile-refresh="true" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('ad-1264909');
                        
                });
            </script>
        </div>
    </div>
</div></div></div>
    <!-- / site-container close -->
    </div>
    
    
    <script>
        window.__tnt = window.__tnt || {};
        __tnt.compatibility = __tnt.compatibility || {};

        __tnt.compatibility.status = '';
        __tnt.compatibility.check = function() {
            if (typeof __tnt.advertisements == 'undefined') {
                __tnt.compatibility.status = 'FAIL: object 0 undefined';
                return false;
            }
            return true;
        };
        __tnt.compatibility.notification = function() {
            if (!document.getElementById('notification-area')) {
                    var el = document.createElement('div');
                    el.id = 'notification-area';
                    document.querySelector('#asset-content .asset-body').appendChild(el);
                }
                __tnt.template(
                    document.getElementById('template-blox-message-incompatible'),
                    document.getElementById('notification-area'),
                    true,
                    [],
                    function(el) {
                        setTimeout(function() {
                            var message = document.getElementById('blox-message-incompatible');
                            var authStatusCls = (__tnt.user.authToken) ? 'logged-in' : 'not-logged-in';
                                Array.from(message.getElementsByClassName(authStatusCls)).forEach(function(el) {
                                    el.style.display = 'block';
                                });
                            
                            if (__tnt.user.services) {
                                message.parentNode.removeChild(message);
                            } else {
                                message.style.display = 'block';
                                }
                        }, 100);
                    }
                );
            };
        (function() {
            function compatibilityCheck() {
                if (!__tnt.compatibility.check()) {
                    __tnt.trackEvent({
                        'category':'subscription',
                        'action':'adblock',
                        'label':'adblock detected',
                        'value':'1'
                    });
                    __tnt.compatibility.notification();
                }
            }

            if (document.readyState != 'loading') {
                compatibilityCheck();
            } else {
                document.addEventListener('DOMContentLoaded', compatibilityCheck);
            }
        })();
    </script>
    <template id="template-blox-message-incompatible">
            </template>
    
    
    <script>
        jQuery(function() {
            if(typeof TNCMS.Tracking != 'undefined'){
                jQuery(TNCMS.Tracking.trackDeclarativeEvents);
            }dataLayer.push({'tncms.client.recent_five':__tnt.recentFive.add("154f2f64-339f-11ed-9e8b-3724e641c836")});});
    </script>

    <script>
        __tnt.trackEvent = function(obj) {
            if (typeof obj === 'object') {
                    if (obj.category && obj.action) {
                        __tnt.googleEvent(obj);
                    } else if (obj.network && obj.socialAction) {
                        __tnt.googleSocial(obj);
                    } else if (obj.url) {
                        __tnt.googlePageView(obj);
                    }
                    if (typeof TNCMS.Tracking != 'undefined' && obj.metric) {
                        TNCMS.Tracking.addEvent({
                            app: obj.app,
                            metric: obj.metric,
                            id: obj.uuid
                        });
                    }
            }
        };

        if (__tnt.trackEventLater.length > 0) {
            __tnt.trackEventLater.forEach(function(obj) {
                __tnt.trackEvent(obj);
            });
        }

        Array.from(document.querySelectorAll('body [data-track]')).forEach(function(el) {
            el.addEventListener(__tnt.client.clickEvent, function() {
                __tnt.trackEvent(JSON.parse(el.dataset.track));
            });
        });
        Array.from(document.querySelectorAll('body [data-tncms-track-event]')).forEach(function(el) {
            el.addEventListener(__tnt.client.clickEvent, function() {
                __tnt.trackEvent(JSON.parse(el.dataset.tncmsTrackEvent));
            });
        });
        
        Array.from(document.querySelectorAll('body [data-tncms-track-dmp]')).forEach(function(el) {
            el.addEventListener(__tnt.client.clickEvent, function() {
                var dmpData = el.dataset.tncmsTrackDmp;
                
            });
        });
    
    </script>
    
    
<script>/*<![CDATA[*/ dataLayer.push({
            'tncms.asset.sections': ["news", "news/pasco"],
            'tncms.asset.flags': [""],
            'tncms.asset.keywords': ["pasco county", "new port richey", "new port richey city council", "main street flood mart mural"]
        }); /*]]>*/</script>
<script>/*<![CDATA[*/ 
                __tnt.googleEvent = function(obj) {
                    dataLayer.push({
                        'event': 'tncms.event.trigger',
                             'tncms.event.trigger.category': obj.category,
                             'tncms.event.trigger.action': obj.action,
                             'tncms.event.trigger.label': obj.label, 
                             'tncms.event.trigger.value': obj.value
                    });
                }
                /* Virtual page view */
                __tnt.googlePageView = function(obj) {
                    var sURL = obj.url.replace(/^.*\/\/[^\/]+/, '');
                    dataLayer.push({
                        'event': 'tncms.event.virtual_pageview',
                            'tncms.event.virtual_pageview.url': sURL,
                            'tncms.event.virtual_pageview.title': obj.title
                    });
                }
                /* Social event */
                __tnt.googleSocial = function(obj) {
                    dataLayer.push({
                        'event': 'tncms.event.social',
                            'tncms.event.social.network': obj.network,
                            'tncms.event.social.action': obj.socialAction,
                            'tncms.event.social.target': obj.url
                    });
                } /*]]>*/</script>
<script src="https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/asset-edit.60e8e67e04be1194326dcfbe7f00b8c3.js"></script>
<script>/*<![CDATA[*/ (function(d) {
        
        var form = d.getElementById('site-search-501422'),
            query_input = d.getElementById('site-search-501422-term'),
            search_dropdown = d.getElementById('site-search-501422-dropdown');
        
        /** Input focus */
        try {
            search_dropdown.onmouseenter = function(){
                setTimeout(function(){
                    query_input.focus();
                }, 700);
            };
        } catch (error) { 
            // No dropdown behavior
        }
        
        /** Submit handler */
        form.onsubmit = function(){
            // Filter query
            var elem = document.querySelector("#site-search-501422 input[name=q]"),
        sQueryFiltered = elem.value.replace(/\?/g, '');
    elem.value = sQueryFiltered;
    
            // No submit if empty input
            if( query_input.val() ){
                return true;
            } else{
                return false;
            }
        };})(document); /*]]>*/</script>
<script src="https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/shared-content/art/tncms/templates/libraries/flex/components/ads/resources/scripts/tnt.ads.core.eb2d788dd02bb4634ca3eb2ee783cd11.js"></script>
<script>/*<![CDATA[*/ jQuery(document).ready(function($){
                                    $('#weather_zip_toggle_501439').click(function(e){
                                        $('#weather-501439 .zip-update-form').toggle('fast');
                                        return false; 
                                    });
                                }); /*]]>*/</script>
<script>/*<![CDATA[*/ (function(d) {
        
        var form = d.getElementById('site-search-501420'),
            query_input = d.getElementById('site-search-501420-term'),
            search_dropdown = d.getElementById('site-search-501420-dropdown');
        
        /** Input focus */
        try {
            search_dropdown.onmouseenter = function(){
                setTimeout(function(){
                    query_input.focus();
                }, 700);
            };
        } catch (error) { 
            // No dropdown behavior
        }
        
        /** Submit handler */
        form.onsubmit = function(){
            // Filter query
            var elem = document.querySelector("#site-search-501420 input[name=q]"),
        sQueryFiltered = elem.value.replace(/\?/g, '');
    elem.value = sQueryFiltered;
    
            // No submit if empty input
            if( query_input.val() ){
                return true;
            } else{
                return false;
            }
        };})(document); /*]]>*/</script>
<script>/*<![CDATA[*/ 
                        !function(t,i,n){var e,a,s,o,c,d={init:function(){a=i.getElementById("site-navbar-container"),n.client.platform.ios?a.classList.add("affix-sticky"):(e=i.getElementById("main-body-container"),s=a.offsetHeight||a.clientHeight,o=!1,c=0,t.addEventListener("scroll",d.navPosition,!1),t.addEventListener("mousewheel",d.navPosition,!1))},navPosition:function(){o||(o=!0,setTimeout(function(){var n=a.getBoundingClientRect(),d=t.pageYOffset||i.documentElement.scrollTop,f=n.top+d;d>=f&&d>c?a.classList.contains("affix")||(c=f,a.classList.add("affix"),a.classList.remove("affix-top"),e.style.marginTop=s+"px"):a.classList.contains("affix-top")||(a.classList.remove("affix"),a.classList.add("affix-top"),e.style.marginTop="0px"),o=!1},25))}};"loading"==i.readyState?i.addEventListener("DOMContentLoaded",d.init,!1):d.init()}(window,document,__tnt);
                    document.addEventListener('DOMContentLoaded', function() {
                        var isIOS = /iPad|iPhone|iPod/.test(navigator.userAgent) && !window.MSStream;
                        if (isIOS) {
                            Array.from(document.querySelectorAll('[data-toggle="offcanvas"]')).forEach(function(drawer) {
                                drawer.addEventListener("mouseover", function(e) {
                                    var drawerCls = drawer.dataset.target === 'left' ? 'active-left' : 'active-right';
                                    document.documentElement.classList.add('drawer-open', drawerCls);
                                })
                            })
                        }
                    }); /*]]>*/</script>
<script>/*<![CDATA[*/ 
            // Observer callback
            var callback = function(entries, io) {
                entries.forEach(function(e) {
                    if (e.isIntersecting === true) {
                        __tnt.template(
                            document.querySelector('#' + e.target.id + ' template'),
                            document.getElementById(e.target.id),
                            false,
                            objectFitImages('#' + e.target.id + ' img') // IE11 objectfit polyfill
                        );
                        // Kill observer
                        io.unobserve(e.target);
                    }
                });
            };
            // Initialize observer
            window.addEventListener('load', function() {
                var io = new IntersectionObserver(callback),
                    targets = Array.from(document.querySelectorAll('[data-lazy-content]')); // IE11 forEach support
                targets.forEach(function(e){
                    io.observe(e);
                });
            }, false) /*]]>*/</script>
<script>/*<![CDATA[*/ 
                    /* Copy url to clipboard */
                    function copyLink(url) {
                        /* Populate clipboard */
                        navigator.clipboard.writeText(url);
                        
                        /* Bootstrap popover */
                        $("[data-copy-asset-link]").popover().popover("show").prop("disabled", true);
                        
                        /* Hide popover after timeout */
                        setTimeout(
                            function() {
                               $("[data-copy-asset-link]").popover("hide").popover("destroy").prop("disabled", false);
                            }, 2000);
                    } /*]]>*/</script>
<script>/*<![CDATA[*/ (function(){ var fallback = 72508; let zergnet = document.createElement("SCRIPT"); zergnet.type = 'text/javascript'; zergnet.async = true; zergnet.src = "https://www.zergnet.com/zerg-lk.js?ref="+encodeURIComponent(document.location.href)+"&domain="+encodeURIComponent(ZERG.domain)+"&fb="+encodeURIComponent(fallback)+"&u="+encodeURIComponent(ZERG.user); document.getElementsByTagName("HEAD")[0].appendChild( zergnet ); })(); /*]]>*/</script>
<script>/*<![CDATA[*/ (function (a, c, s, u){'Insticator'in a || (a.Insticator={ad:{loadAd: function (b){Insticator.ad.q.push(b)}, q: []}, helper:{}, embed:{}, version: '3.0', q: [], load: function (t, o){Insticator.q.push({t: t, o: o})}}); var b=c.createElement(s); b.src=u; b.async=!0; var d=c.getElementsByTagName(s)[0]; d.parentNode.insertBefore(b, d)})(window, document, 'script', '//d2na2p72vtqyok.cloudfront.net/client-embed/b1ad8512-0208-404a-8bef-42066664235a.js');
                            /*&lt;![CDATA[[*/Insticator.ad.loadAd('div-insticator-ad-1');Insticator.ad.loadAd('div-insticator-ad-2');Insticator.load('em',{id:'40c1ddd3-f53e-4cc2-99cf-8551b04a81fa'})/*]]&gt;*/ /*]]>*/</script>
<script src="https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/tnt.regions.b44801b45845a81b995eeaad12f4f276.js"></script>
<script>/*<![CDATA[*/ __tnt.regions.stickyAnchor.init(); /*]]>*/</script></body>
</html>