
  







<!DOCTYPE html>
        <html lang="en">
        <head>
<base href="https://www.suncoastnews.com/content/tncms/live/" />
<meta name="keywords" content="hernando county, brooksville, broad street, fhp, florida highway patrol, wreck, accident, death, fatal, injuries" />
<meta name="news_keywords" content="hernando county, brooksville, broad street, fhp, florida highway patrol, wreck, accident, death, fatal, injuries" />
<meta name="description" content="Accident occurred Thursday afternoon on Broad Street" />
<meta name="author" content="Suncoast News staff" />
<meta name="viewport" content="width=device-width, initial-scale=1.0" />
<meta name="apple-mobile-web-app-capable" content="yes" />
<meta name="apple-mobile-web-app-status-bar-style" content="black-translucent" />
<meta property="og:type" content="article" />
<meta property="og:url" content="https://www.suncoastnews.com/crime_crashes_fires/one-dead-another-seriously-injured-in-hernando-wreck/article_2036e138-c50f-11eb-9ea7-13485452bf68.html" />
<meta property="og:image" content="https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/custom/image/15bced60-7122-11e6-b2b7-ebc3cb2a0c81.jpg" />
<meta property="og:image:width" content="1200" />
<meta property="og:image:height" content="630" />
<meta property="og:title" content="One dead, another seriously injured in Hernando wreck" />
<meta property="og:description" content="Accident occurred Thursday afternoon on Broad Street" />
<meta property="og:site_name" content="Suncoast News" />
<meta property="og:section" content="Crime Crashes Fires" />
<meta property="article:publisher" content="http://www.facebook.com/SuncoastNews" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:site" content="@SuncoastNews" />
<link rel="stylesheet preload" as="style" href="https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/shared-content/art/tncms/templates/libraries/flex/components/bootstrap/resources/styles/bootstrap.min.44f4ed00052aeaf66307fd409db0d101.css"/>
<link rel="stylesheet preload" as="style" href="https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/styles/layout.e9cfb715585954cc5edc7d7c1ca6ea21.css"/>
<link rel="stylesheet preload" as="style" href="https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/shared-content/art/tncms/templates/libraries/flex/components/themes/resources/styles/theme-basic.da34fee69fbd9a506f70c74c56e2ccfa.css"/>
<link rel="stylesheet" href="https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/live/global/resources/styles/site.css?_dc=1472828967"/>
<link rel="stylesheet" href="https://fonts.googleapis.com/css?family=Oswald|PT+Serif:400,600,700"/>
<link rel="stylesheet preload" as="style" href="https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/shared-content/art/tncms/templates/libraries/flex/components/block/resources/styles/flex-classifieds-bulletins.a78f8be1f6e0dabcb5acb9a8939501f8.css"/>
<style>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</style>
<script type="text/javascript">(function(){var tnsrc=window.location.hash.match(/[&#]tncms-source=([^&]+)/);var dl = window.dataLayer = window.dataLayer || [];dl.push({"townnews":{"product":{"software":"BLOX","version":"1.58.0"}},"tncms":{"template":{"version":"3.155.0"},"page":{"grid":"simple","style":"default","path":"\/crime_crashes_fires","syndicated":"false","reaction":"false","app":"editorial","theme":"flex","skin":"flex-editorial","http_status":200},"subscription":{"required":"false"},"asset":{"author":"Suncoast News staff","id":"2036e138-c50f-11eb-9ea7-13485452bf68","app":"editorial"},"vendor":{"outbrain":"Headlines and photo grid","taboola":""},"ad":{"vendor":"blox"},"system":{"render_time":228},"client":{"is_bot":"no","is_gdpr":"no"}}});if (tnsrc && tnsrc[1]) {dl.push({'tncms.campaign.internal_source': tnsrc[1]});}window.addEventListener("DOMContentLoaded", function(oEvent) {var oTest = document.createElement('div');oTest.innerHTML = '&nbsp;';oTest.className = 'adsbox';document.body.appendChild(oTest);var nTimeoutID = window.setTimeout(function() {if (oTest.offsetHeight === 0) {dl.push({'event': 'tncms.ad.blocked'});}document.body.removeChild(oTest);window.clearTimeout(nTimeoutID);}, 100);});var nWidth=Math.max(document.documentElement.clientWidth, window.innerWidth || 0),aBPs=[[300,"Extra small: Most smartphones."],[768,"Small: Tablet devices."],[992,"Medium: Laptops & landscape tablets."],[1200,"Large: Desktop computers."]],i,c,aThisBP,aBP;for(i=0,c=aBPs.length;i<c;i++){aThisBP=aBPs[i];if(aBP===undefined||aThisBP[0]<=nWidth){aBP=aThisBP;}}if(aBP!==undefined){dl.push({'tncms.client.breakpoint':aBP[1]});}(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'tncms.start':new Date().getTime(),event:'tncms.start'});var f=d.getElementsByTagName(s)[0],j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src='https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);})(window,document,'script','dataLayer','GTM-PDQV3N');})();</script>
<script src="https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/shared-content/art/tncms/templates/libraries/flex/components/jquery/resources/scripts/jquery.min.6edb5af3e93b0a377ec925c5f1c6ddde.js"></script>
<script src="/shared-content/art/tncms/user/user.js"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/shared-content/art/tncms/templates/libraries/flex/components/bootstrap/resources/scripts/bootstrap.min.d457560d3dfbf1d56a225eb99d7b0702.js"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/common.08a61544f369cc43bf02e71b2d10d49f.js"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/tnt.cdac7b520f2b182a14aa115daac4a535.js"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/application.cb897187c4718280fd69d2e6d6c3909d.js"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/tnt.navigation.accessibility.3184e9304073379bbe4e2c6500858bb1.js"></script>
<script src="https://polyfill.io/v3/polyfill.min.js?features=default,fetch,IntersectionObserver,NodeList.prototype.@@iterator,Element.prototype.classList|gated" nomodule="nomodule"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/shared-content/art/tncms/templates/libraries/flex/components/ads_blox/resources/scripts/tnt.ads.init.c2b9574823d0d16ffc6f20eef83f4232.js"></script>
<script async="async" src="https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/shared-content/art/tncms/templates/libraries/flex/components/ads_blox/resources/scripts/tnt.ads.load.6a3c47703ee96f20ef132e36033ca1bc.js"></script>
<script src="/shared-content/art/tncms/tracking.js"></script>
<script src="/shared-content/art/tncms-ad-manager/admanager.js"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/ads/impressions.js?_dc=1622826334"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/ads/traffic.js?_dc=1622781334"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/ads/settings.js?_dc=1617910121"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/ads/fixed-impact-top/1.js?_dc=1622620866"></script>
<script async="async" src="https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/shared-content/art/tncms/templates/libraries/flex/components/block/resources/scripts/user-controls.578df3df79d812af55ab13bae47f9857.js"></script>
<script async="async" src="https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/shared-content/art/tncms/templates/libraries/flex/components/asset/resources/scripts/tnt.nextPrev.f1660ccf5d097410b8b72737d216878c.js"></script>
<script async="async" src="https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/sms-link.8eefede3265fd6c6de07bc0cb5f3f779.js"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/ads/fixed-big-ad-top-asset/1.js?_dc=1622620868"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/ads/fixed-big-ad-bottom-asset/1.js?_dc=1622620868"></script>
<script>/*<![CDATA[*/ var ZERG = ZERG || {};
                    ZERG.domain = "suncoastnews.com";
                    ZERG.user = 57683; /*]]>*/</script>
<script async="async" src="https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/shared-content/art/tncms/templates/libraries/flex/components/ads/resources/scripts/vendor.taboola.0f7d1c50406b868f466f9143671a50f4.js"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/ads/fixed-big-ad-top/1.js?_dc=1621522580"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/ads/fixed-big-ad-middle/1.js?_dc=1622620868"></script>
<script async="async" src="https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/ie.grid.placement.8d31e32afeebe4520bfab9638ef91435.js"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/shared-content/art/tncms/templates/libraries/flex/components/ads/resources/scripts/tnt.ads.adverts.66a3812a7b5c12fde8cd998fd691ad7d.js"></script>
<script>/*<![CDATA[*/ __tnt.recentFive = {
    /*
     * Gets the data stored in 'tnt:recent:five'
     * Returns Array
     */
        get:function(){
            if(window.localStorage && localStorage.getItem('tnt:recent:five')!=null){
                try{ return JSON.parse(localStorage.getItem('tnt:recent:five')); } catch {}
            }

            return [];
        },

    /*
     * Sets the 'tnt:recent:five' localStorage item
     * Returns boolean
     */
        set:function(data){
            if(window.localStorage){
                try{ 
                    localStorage.setItem('tnt:recent:five', JSON.stringify(data));
                    return true;
                } catch {}
            }

            return false;
        },

    /*
     * Adds the most recent item, prunes any duplicates, and trims the array down to 5 items
     * Returns Array on success, false on fail 
     */
        add:function(asset){
            var assets = __tnt.recentFive.get();
            assets.unshift(asset);

            if(assets.length > 1){
                assets = assets.filter(function(item, index, a){ return a.indexOf(item) == index });

                while(assets.length>5){
                    assets.shift();
                }
            }

            if(__tnt.recentFive.set(assets)){ return assets; }
            return false;
        }
    }; /*]]>*/</script>

            
            <title>One dead, another seriously injured in Hernando wreck | Crime Crashes Fires | suncoastnews.com</title>
            
    <style>body { background-color: #d5d4d0; color: #333333; }a, a:hover, .pagination>li>a, .pagination>li>a:hover, .btn-link, .dropdown-menu>li>a, blockquote, blockquote p, .asset .asset-body blockquote p { color: #4175aa; } #main-body-container .container, #main-body-container .container_fluid, .well-main { background-color: #ffffff; } .tnt-content-width-container > * { max-width: 1140px; margin-left: auto; margin-right: auto; } #site-navbar-container, #main-navigation { background-color: #f4f4f2; } .fixed-nav #main-navigation { background-color: #f4f4f2 !important; } #site-top-nav-container, #site-top-nav { background-color: #ffffff; } #site-footer { background-color: #ffffff; color: #333333; } .navbar-default .navbar-nav>li>a, .navbar-default .navbar-nav>li>a:hover, .navbar-default .navbar-nav>li>a:focus, .navbar-default .navbar-nav>.open>a, .navbar-default .navbar-nav>.open>a:hover, .navbar-default .navbar-nav>.open>a:focus { color: #666; } .navbar-toggle .icon-bar { background-color: #666 !important; } .navbar-toggle .sr-only-show { color: #666 !important; } #site-top-nav .list-inline>li>a { color: #4175aa; } .asset .asset-body p, .asset #asset-content p { color: #444; } #site-header { background-color: #ffffff; }/* remove full span bgs */ #site-navbar-container, #site-header-container, #site-top-nav-container { background-color: transparent !important; background-image: none !important; }/* remove full span bgs */ #site-footer-container { background-color: transparent !important; background-image: none !important; }@media (max-width: 991px){ .navbar-default .navbar-nav .open .dropdown-menu>li>a, .navbar-default .navbar-nav .open .dropdown-menu>li>a:hover, .navbar-default .navbar-nav .open .dropdown-menu>li>a:focus { color: #666; } }#site-copyright a, #site-footer a { color: #4175aa; }.nav-tabs>li.active>a, .nav-tabs>li.active>a:hover, .nav-tabs>li.active>a:focus { border-top-color: #005296; }#site-header{ border-bottom: 3px solid #005296; }#site-footer{ border-top: 3px solid #005296; } .tnt-bg-accent { background-color: #005296; } a .tnt-caret-down { color: #005296; } .block-title .block-title-inner { border-color: #005296; } a.thumbnail:hover, a.thumbnail:focus, a.thumbnail.active { border-color: #005296; } .form-control:focus { border-bottom-color: #005296; } /* Place site-wide CSS here */ /* Primary color: #1033e3Secondary color: #d6bd1a*/ a { color:#005296;} a:hover { color:#111111;} #weather-501439 .weather-expanded small { opacity: 0.8; color: #f4f4f2; } #site-header { border-bottom: 2px solid #cacaca;} .navbar-nav>li { border-left: 1px solid #e6e6e6; border-right: solid 1px #cacaca; } @media (min-width: 992px){ .sn-logo-block .img-responsive { max-width: 540px!important;} .nav>li>a { padding: 10px 20px;} } #main-navigation #navbar-collapse { box-shadow: 0px 10px 6px -6px rgba(0, 0, 0, 0.25); } .navbar { min-height: 40px;} .navbar-default .navbar-nav>.open>a, .navbar-default .navbar-nav>.open>a:hover { background-color: #111111!important; color: #ffffff!important; text-shadow: 1px 1px 1px #000000; } .site-search-form.input-group.pull-right.input-group-lg { box-shadow: 0px 10px 6px -6px rgba(0, 0, 0, 0.25); } #site-search-399654 .input-group-btn:last-child>.btn, .input-group-btn:last-child>.btn-group { color: #f5f0f0!important; background: #1f1a1c!important; } .navbar-default .navbar-nav>li>a:hover { background-color:#111111;color:#ffffff!important; text-shadow: 1px 1px 1px #000000;} .dropdown-menu { background-color:#111111;color:#f4f4f2!important;} .dropdown-menu>li>a { color:#f4f4f2!important;} .dropdown-menu>li>a:hover { background:#f7f7f7;color:#197DC0!important;} .btn-primary { color: #fff; background-color: #115588; border-color: #357ebd; } .btn-success { color: #564949; background-color: #b6eb07; border-color: #4cae4c; } .card figure .image .asset-icon { position: absolute; bottom: 0; left: 0; padding: 4px; color: #a4c8eb; } .block-title h1, .block-title h2, .block-title h3, .block-title h4, .block-title h5, .block-title h6 { /* font-family: 'Bevan', cursive; */ font-family: 'Oswald', sans-serif; margin: 0px; } .card-headline { font-family: 'PT Serif', serif!important; font-weight: bold; } .asset .asset-header h1 { font-family: 'PT Serif', serif;} .asset .asset-body p {color: #888887;} #site-footer { margin-bottom: 0px;} #site-copyright { color:#ffffff;background: #004d98;} #site-copyright a {color:#ffffff;} .dropdown-header { color: #8bbcea!important;} .datepicker.dropdown-menu th { color: #000000!important;} </style>
    
        <link rel="shortcut icon" type="image/x-icon" href="https://www.suncoastnews.com/content/tncms/site/icon.ico" />
    
        <link rel="preconnect" href="//cdn.taboola.com">
    
        <link rel="preconnect" href="//www.googletagmanager.com">
    
        <link rel="preconnect" href="//www.google-analytics.com">
    <link rel="alternate" type="application/rss+xml" title="One dead, another seriously injured in Hernando wreck | Crime Crashes Fires | suncoastnews.com" href="http://www.suncoastnews.com/search/?f=rss&amp;t=article&amp;c=crime_crashes_fires&amp;l=50&amp;s=start_time&amp;sd=desc" />
    <link rel="canonical" href="https://www.suncoastnews.com/crime_crashes_fires/one-dead-another-seriously-injured-in-hernando-wreck/article_2036e138-c50f-11eb-9ea7-13485452bf68.html" />
            <script defer src="https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/fontawesome.edd147e4c2830f416874012247117438.js"></script>
            
        </head>
        <body class="fixed-scroll-nav app-editorial grid-simple blox-asset uuid-2036e138-c50f-11eb-9ea7-13485452bf68  section-crime-crashes-fires type-article infinity-disabled" data-path="/crime_crashes_fires">
	<script type='text/javascript' src='/shared-content/art/stats/common/tracker.js'></script>
	<script type='text/javascript'>
	<!--
	if (typeof(TNStats_Tracker) !== 'undefined' && typeof(TNTracker) === 'undefined') { TNTracker = new TNStats_Tracker('www.suncoastnews.com'); TNTracker.trackPageView(); }
	// -->
	</script>
	<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-PDQV3N&amp;townnews.product.software=BLOX&amp;townnews.product.version=1.58.0&amp;tncms.template.version=3.155.0&amp;tncms.page.grid=simple&amp;tncms.page.style=default&amp;tncms.page.path=%2Fcrime_crashes_fires&amp;tncms.page.syndicated=false&amp;tncms.page.reaction=false&amp;tncms.page.app=editorial&amp;tncms.page.theme=flex&amp;tncms.page.skin=flex-editorial&amp;tncms.page.http_status=200&amp;tncms.subscription.required=false&amp;tncms.asset.author=Suncoast+News+staff&amp;tncms.asset.id=2036e138-c50f-11eb-9ea7-13485452bf68&amp;tncms.asset.app=editorial&amp;tncms.vendor.outbrain=Headlines+and+photo+grid&amp;tncms.vendor.taboola=&amp;tncms.ad.vendor=blox&amp;tncms.system.render_time=228&amp;tncms.client.is_bot=no&amp;tncms.client.is_gdpr=no&amp;tncms.client.noscript=yes" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
        
        <script type="text/javascript">
TNCMS.AdManager.init
({
  domain: "www.suncoastnews.com",
  secureDomain: "suncoastnews.com",
  virtualregion: {
            popup: __tnt.ads.popup
        },
  callback: {
            expandable: __tnt.ads.expandable,
            html: __tnt.ads.html,
            image: __tnt.ads.image,
            pagecurl: __tnt.ads.curl,
            text: __tnt.ads.text,
            video: __tnt.ads.video
        }
});
</script>

        <div data-tnt-ads-tmp='{"vendor":"blox","type":"region","region":"page-curl","id":"page-curl","pos":"page-curl, atf","fold":"above","size":"[[75,75]]","height":"75","width":"75","not_mobile":true,"refresh":false}' style="display:none;"></div>
        <!-- Google Tag Manager -->
        <script>
            var dataLayer = window.dataLayer || [];
            dataLayer.push(
                {'user_id': __tnt.user.screenName},
                {'user_state': __tnt.user.loggedIn ? 'logged in' : 'anonymous'},
                {'utm_label': __tnt.urlHash('utm_label')}
            );
        </script>
        <noscript><iframe src="//www.googletagmanager.com/ns.html?id=" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
        <script>
            (function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
            new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
            j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
            '//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
            })(window,document,'script','dataLayer','');
        </script>
        <script>
            $(function(){
                var bloxServiceIDs = [];
                var bloxUserServiceIds = [];
                var dataLayer = window.dataLayer || [];

                

                if (__tnt.user.services){
                    var bloxUserServiceIDs = __tnt.user.services.replace('%2C',',').split(',');
                }

                // GTM tncms.subscription.paid_access_service_ids
                if(bloxServiceIDs){
                    dataLayer.push({'tncms':{'subscription':{'access_service_ids':bloxServiceIDs.toString()}}});
                }

                // GTM tncms.subscrption.user_service_ids
                if(bloxUserServiceIDs){
                    dataLayer.push({'tncms':{'subscription':{'user_service_ids':bloxUserServiceIDs.toString()}}});
                }
            });
        </script>
        
        <div data-tnt-ads-tmp='{"vendor":"blox","type":"region","region":"fixed-impact-top","id":"fixed-impact-top","pos":"fixed-impact-top, atf","fold":"above","include_domain":null,"size":"[2,1]","height":"1","width":"2","js":{"video":"https:\/\/bloximages.newyork1.vip.townnews.com\/suncoastnews.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"index_slug":null,"url":"\/crime_crashes_fires","refresh":false}' style="display:none;"></div><div id="tncms-region-ads-fixed-impact-top" class="tncms-region-ads">

<div id="blox-ad-position-fixed-impact-top1">
<script type="text/javascript">TNCMS.AdManager.render({region: 'fixed-impact-top', slot: 1, fold: "above"});</script>

</div>
</div>

        <div id="blox-ad-position-_popup1" data-tnt-ads='{"vendor":"blox","type":"position","region":"_popup","id":"_popup","slot":1,"pos":"_popup, atf","size":"[[900,900]]","height":"900","width":"900","display":"popup","refresh":false}' class="blox-ad tnt-ads-container ">
        
        </div>
        <div id="site-container"><div id="asset-admin-bar" class="asset-edit-bar hidden-print">
                <div class="asset-edit-icon"><i class="fas tnt-lock-open tnt-fw"></i></div>
                <div class="asset-edit-message">You have permission to edit this article.</div>
                <div class="asset-edit-btns">
                    <a class="btn btn-primary btn-sm" target="_blank" rel="noopener" href="https://www.suncoastnews.com/tncms/admin/editorial-asset/?edit=2036e138-c50f-11eb-9ea7-13485452bf68"><i class="fas tnt-pencil-alt tnt-fw"></i> Edit</a>
                    <button class="asset-edit-close btn btn-link btn-sm"><i class="fas tnt-times"></i><span class="sr-only">Close</span></button>
                </div>
            </div>
        
    
        
        
           <aside class="hidden-print offcanvas-drawer offcanvas-drawer-right visible-sm visible-xs" aria-label="Right Main Menu" aria-expanded="false" tabindex="-1">
                <div id="tncms-region-mobile-nav-top-right-region" class="tncms-region "><div id="tncms-block-501437" class="tncms-block hidden-md hidden-lg"><div id="user-controls-501437" class="user-controls show-onload clearfix default"><div class="not-logged-in">
        <ul class="list-inline"><li><a href="https://www.suncoastnews.com/users/signup/?referer_url=https%3A%2F%2Fwww.suncoastnews.com%2Fcrime_crashes_fires%2Fone-dead-another-seriously-injured-in-hernando-wreck%2Farticle_2036e138-c50f-11eb-9ea7-13485452bf68.html" class="btn btn-link btn-sm user-control-link" rel="nofollow">Sign Up</a></li><li>
                    <a href="https://www.suncoastnews.com/users/login/?referer_url=https%3A%2F%2Fwww.suncoastnews.com%2Fcrime_crashes_fires%2Fone-dead-another-seriously-injured-in-hernando-wreck%2Farticle_2036e138-c50f-11eb-9ea7-13485452bf68.html" class="btn btn-primary btn-sm login-btn user-control-link" rel="nofollow">
                        Log In
                    </a></li>
        </ul>
    </div>

    <div class="logged-in">
        
        
            <div class="hide show-offcanvas">
                <ul class="list-inline">
                    <li><a href="https://www.suncoastnews.com/users/admin/" class="btn btn-primary btn-sm login-btn user-control-link">Dashboard</a></li>
                    <li> <a class="btn btn-link btn-sm user-control-link" onclick="document.getElementById('user-logout-form-501437').submit(); return false;" rel="nofollow"> Logout</a></li>
                </ul>
            </div>
        
        <ul class="hide-offcanvas list-inline">
            <li class="dropdown pull-right">
                
                <div class="dropdown-toggle btn btn-link btn-sm user-dropdown" data-toggle="dropdown" data-hover="dropdown" data-hover-delay="250"><div class="tn-user-avatar pull-left"><!-- user avatar --></div><span class="tn-user-screenname pull-left"></span><b class="caret user-control-link"></b>
                </div>
                <ul class="dropdown-menu dropdown-menu-right" role="menu">
                    <li role="presentation" class="dropdown-header">My Account</li>
                    <li role="menuitem"><a href="https://www.suncoastnews.com/users/admin/" rel="nofollow"><i class="fas tnt-tachometer-alt tnt-fw"></i> Dashboard</a></li>
                    <li role="menuitem"><a class="tn-user-profile-url" href="" data-app="https://www.suncoastnews.com/users/"><i class="fas tnt-user tnt-fw"></i> Profile</a></li>
                    <li role="menuitem"><a href="https://www.suncoastnews.com/users/admin/list/" rel="nofollow"><i class="fas tnt-bookmark tnt-fw"></i> Saved items</a></li>
                    <li role="separator" class="divider"></li>
                    <li role="menuitem"><a class="logout-btn" onclick="document.getElementById('user-logout-form-501437').submit(); return false;" rel="nofollow"><i class="fas tnt-power-off tnt-fw"></i> Logout</a></li>
                </ul>
            </li>
        </ul>
    </div>
</div>

<form method="post" action="https://www.suncoastnews.com/users/logout/" id="user-logout-form-501437"><input type="hidden" name="referer_url" value="https://www.suncoastnews.com/crime_crashes_fires/one-dead-another-seriously-injured-in-hernando-wreck/article_2036e138-c50f-11eb-9ea7-13485452bf68.html"><input type="submit" name="logout" value="Logout" class="hide">
</form></div></div>
                <div id="tncms-region-nav-mobile-nav-right" class="tncms-region-nav"><div id="mobile-nav-right_menu" class="panel-group nav navbar-nav" role="tablist" aria-hidden="true"><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" href="/news/pasco/"  class="nav-link tnt-section-pasco">Pasco</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" href="/news/pinellas/"  class="nav-link tnt-section-pinellas">Pinellas</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" href="/news/hernando/"  class="nav-link tnt-section-hernando">Hernando</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" href="/sports/"  class="nav-link tnt-section-sports">Sports</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" href="/business/"  class="nav-link tnt-section-business">Business</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" href="/classifieds/"  class="nav-link tnt-section-classifieds">Classifieds</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" href="/calendar/"  class="nav-link tnt-section-calendar">Calendar</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" href="/multimedia/"  class="nav-link tnt-section-multimedia">Multimedia</a>
                        </div>
                    </div></div></div></div>
                
                <div id="tncms-region-mobile-nav-bottom-right-region" class="tncms-region "><div id="tncms-block-501422" class="tncms-block hidden-md hidden-lg"><section id="block-501422" class="block emphasis-h3   " >
    <div class="clearfix"></div>
    <div id="search-form-501422" class="search-form-container card clearfix text-center hidden-print ">
    <form id="site-search-501422" aria-labelledby="site-search-button-501422" action="/search/" method="GET" >
    <input type="hidden" name="l" value="25">
    
        
        <input type="hidden" name="sort" value="relevance">
    
    
    
    
    <input type="hidden" name="f" value="html">
    
        
        <input type="hidden" name="t" value="article,video,youtube,collection">
    
    <input type="hidden" name="app" value="editorial">
    <input type="hidden" name="nsa" value="eedition">
    <div class="site-search-form input-group default normal form-control">
        <input id="site-search-501422-term" name="q" title="Site Search" type="text" placeholder="Search..." class="form-control" autocomplete="off">
        <input type="submit" class="hide" value="Search">
        <span class="input-group-btn">
            <button id="site-search-501422-btn" class="btn btn-link" aria-label="Submit Site Search" type="submit">
                
            </button>
        </span>
    </div>
    <div class="clearfix"></div>
</form>
        
        
        <div class="clearfix"></div>
    </div>
    </section> 

<script>
    $('#site-search-501422-btn').on(__tnt.client.clickEvent, function(){
        $('#site-search-501422').submit();
        return false;
    });

    $('#site-search-501422').on('submit', function(){
        // Filter query
        var sQueryFiltered = $("#site-search-501422 input[name=q]").val().replace(/\?/g, '');
    $("#site-search-501422 input[name=q]").val( sQueryFiltered );

        if( $('#site-search-501422-term').val() ){
            return true;
        }else{
            return false;
        }
    });</script>
</div></div>
            </aside>
        

        <div class="offcanvas-inner">
            <div class="offcanvas-close-btn hidden-md hidden-lg"></div>
    
    
    
    
    <div id="tncms-region-global-skyline" class="tncms-region "></div>
    

    
        <div id="site-top-nav-container" class="hidden-sm hidden-xs hidden-print">
            <header id="site-top-nav" class="container">
                <div class="row">
                    <div id="topbar-col-one" class="col-md-6 col-sm-6"><div id="tncms-region-topbar-col-one" class="tncms-region "></div><div id="tncms-region-nav-topbar-col-one-nav" class="tncms-region-nav"><ul id="topbar-col-one-nav_menu" class="list-inline nav-list" ><li>
                <a class="nav-link   tnt-section-about-us"  href="/site/about.html"  tabindex="0">
                    <span class="nav-label">About Us</span>
                </a></li><li>
                <a class="nav-link   tnt-section-contact-us"  href="/site/contact.html"  tabindex="0">
                    <span class="nav-label">Contact Us</span>
                </a></li><li>
                <a class="nav-link   tnt-section-advertising-information"  href="/advertise/"  tabindex="0">
                    <span class="nav-label">Advertising Information</span>
                </a></li><li>
                <a class="nav-link   tnt-section-subscribe"  href="/site/forms/subscription_services/"  tabindex="0">
                    <span class="nav-label">Subscribe</span>
                </a></li></ul></div></div>
    <div id="topbar-col-two" class="col-md-6 col-sm-6"><div id="tncms-region-topbar-col-two" class="tncms-region "><div id="tncms-block-501436" class="tncms-block"><div id="user-controls-501436" class="user-controls show-onload clearfix pull-right"><div class="not-logged-in">
        <ul class="list-inline"><li><a href="https://www.suncoastnews.com/users/signup/?referer_url=https%3A%2F%2Fwww.suncoastnews.com%2Fcrime_crashes_fires%2Fone-dead-another-seriously-injured-in-hernando-wreck%2Farticle_2036e138-c50f-11eb-9ea7-13485452bf68.html" class="btn btn-link btn-sm user-control-link" rel="nofollow">Sign Up</a></li><li>
                    <a href="https://www.suncoastnews.com/users/login/?referer_url=https%3A%2F%2Fwww.suncoastnews.com%2Fcrime_crashes_fires%2Fone-dead-another-seriously-injured-in-hernando-wreck%2Farticle_2036e138-c50f-11eb-9ea7-13485452bf68.html" class="btn btn-primary btn-sm login-btn user-control-link" rel="nofollow">
                        Log In
                    </a></li>
        </ul>
    </div>

    <div class="logged-in">
        
        
            <div class="hide show-offcanvas">
                <ul class="list-inline">
                    <li><a href="https://www.suncoastnews.com/users/admin/" class="btn btn-primary btn-sm login-btn user-control-link">Dashboard</a></li>
                    <li> <a class="btn btn-link btn-sm user-control-link" onclick="document.getElementById('user-logout-form-501436').submit(); return false;" rel="nofollow"> Logout</a></li>
                </ul>
            </div>
        
        <ul class="hide-offcanvas list-inline">
            <li class="dropdown pull-right">
                
                <div class="dropdown-toggle btn btn-link btn-sm user-dropdown" data-toggle="dropdown" data-hover="dropdown" data-hover-delay="250"><div class="tn-user-avatar pull-left"><!-- user avatar --></div><span class="tn-user-screenname pull-left"></span><b class="caret user-control-link"></b>
                </div>
                <ul class="dropdown-menu dropdown-menu-right" role="menu">
                    <li role="presentation" class="dropdown-header">My Account</li>
                    <li role="menuitem"><a href="https://www.suncoastnews.com/users/admin/" rel="nofollow"><i class="fas tnt-tachometer-alt tnt-fw"></i> Dashboard</a></li>
                    <li role="menuitem"><a class="tn-user-profile-url" href="" data-app="https://www.suncoastnews.com/users/"><i class="fas tnt-user tnt-fw"></i> Profile</a></li>
                    <li role="menuitem"><a href="https://www.suncoastnews.com/users/admin/list/" rel="nofollow"><i class="fas tnt-bookmark tnt-fw"></i> Saved items</a></li>
                    <li role="separator" class="divider"></li>
                    <li role="menuitem"><a class="logout-btn" onclick="document.getElementById('user-logout-form-501436').submit(); return false;" rel="nofollow"><i class="fas tnt-power-off tnt-fw"></i> Logout</a></li>
                </ul>
            </li>
        </ul>
    </div>
</div>

<form method="post" action="https://www.suncoastnews.com/users/logout/" id="user-logout-form-501436"><input type="hidden" name="referer_url" value="https://www.suncoastnews.com/crime_crashes_fires/one-dead-another-seriously-injured-in-hernando-wreck/article_2036e138-c50f-11eb-9ea7-13485452bf68.html"><input type="submit" name="logout" value="Logout" class="hide">
</form></div><div id="tncms-block-501423" class="tncms-block"><div class="follow-links-501423 pull-right">
    
    <section id="block-501423" class="block emphasis-h3   " ><ul class="list-inline">
        
            <li>
                <a href="http://facebook.com/SuncoastNews/" title="Facebook" target="_blank" rel="noopener" class="btn btn-xs btn-link fb" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-facebook-f"></i>
                    <span class="sr-only">Facebook</span>
                </a>
            </li>
        
        
            <li>
                <a href="http://twitter.com/SuncoastNews/" title="Twitter" target="_blank" rel="noopener" class="btn btn-xs btn-link tw" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-twitter"></i>
                    <span class="sr-only">Twitter</span>
                </a>
            </li>
        
        
        
            <li>
                <a href="http://www.youtube.com/user/SCNPasco" title="Youtube" target="_blank" rel="noopener" class="btn btn-xs btn-link yt" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-youtube"></i>
                    <span class="sr-only">YouTube</span>
                </a>
            </li>
        
        
        
        
        
        
        
        
        
        
        
        
        
        
    </ul>
    </section>
</div>
<script type="application/ld+json">
{ "@context" : "https://schema.org",
  "@type" : "Organization",
  "url" : "http://www.suncoastnews.com",
  "sameAs" : ["http://facebook.com/SuncoastNews/","http://twitter.com/SuncoastNews/","http://www.youtube.com/user/SCNPasco"]
}
</script>
<div class="clearfix"></div></div></div></div>
                </div>
            </header>
        </div>
    

    
        <div id="site-header-container" class="hidden-sm hidden-xs hidden-print">
            <header id="site-header" class="container" role="banner">
                
                <div class="row">
                    <div id="masthead-full-top" class="col-lg-12"><div id="tncms-region-masthead-full-top" class="tncms-region "></div></div>
                </div>
                <div class="row">
                    
                    <div id="masthead-col-one" class="col-md-4 col-sm-4"><div id="tncms-region-masthead-col-one" class="tncms-region "><div id="tncms-block-501413" class="tncms-block sn-logo-block"><section id="block-501413" class="block emphasis-h3   " ><div class="block"><a href="/" rel="nofollow" >
            <img 
                
                src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg==" 
                data-srcset="https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/custom/image/8f3f1b20-711f-11e6-9722-db0c86971413.jpg?resize=150%2C26 150w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/custom/image/8f3f1b20-711f-11e6-9722-db0c86971413.jpg?resize=200%2C34 200w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/custom/image/8f3f1b20-711f-11e6-9722-db0c86971413.jpg?resize=225%2C38 225w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/custom/image/8f3f1b20-711f-11e6-9722-db0c86971413.jpg?resize=300%2C51 300w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/custom/image/8f3f1b20-711f-11e6-9722-db0c86971413.jpg?resize=400%2C68 400w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/custom/image/8f3f1b20-711f-11e6-9722-db0c86971413.jpg?resize=540%2C92 540w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/custom/image/8f3f1b20-711f-11e6-9722-db0c86971413.jpg?resize=640%2C109 640w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/custom/image/8f3f1b20-711f-11e6-9722-db0c86971413.jpg 750w" 
                data-sizes="auto" 
                class=" img-responsive lazyload tnt-prop-img"
                width="750"
                height="128"
                alt=""></a></div></section></div></div></div>
    <div id="masthead-col-two" class="col-md-4 col-sm-4"><div id="tncms-region-masthead-col-two" class="tncms-region "><div id="tncms-block-501439" class="tncms-block"><div id="weather-501439" class="weather-current size-medium pull-right">
    <ul class="list-unstyled">
        <li class="current-conditions dropdown">
            <a href="/weather/?weather_zip=34668" class="dropdown-toggle" data-toggle="dropdown" data-hover="dropdown" data-hover-delay="250">
                <span class="icon pull-left">
                    
                    <span class="fas tnt-wi-cloudy"></span>
                </span>
                <span class="pull-left temp-desc medium">
                    <span class="temp">87&deg;</span>
                    
                        <span class="cond">Mostly Cloudy <i class="fas tnt-caret-down"></i></span>
                    
                </span>
                <span class="clearfix"></span>
            </a>
            
                <ul class="dropdown-menu" role="menu">
                    <li role="presentation">
                        <div class="weather-expanded">
                            <form action="/weather/" class="zip-update-form form-inline" method="get">
                                <input type="text" class="zip-update form-control" name="weather_zip" title="Weather ZIP Code" value="34668"> <input class="btn btn-primary" type="submit" value="GO">
                            </form>

                            <a href="javascript:;" class="pull-right zip-update-link" aria-label="weather_zip_toggle" onclick="jQuery('#weather-501439 .zip-update-form').toggle('fast'); return false;"><span class="fas tnt-cog"></span></a>

                            <h4 class="city-title"><i class="fas tnt-map-marker-alt"></i>
                                
                                    Port Richey, FL
                                
                                 <small>(34668)</small>
                            </h4>
                            <h5>Today</h5>
                            <p>Mainly cloudy. A few peeks of sunshine possible. High 88F. Winds W at 5 to 10 mph..</p>
                            <h5>Tonight</h5>
                            <p>Mostly cloudy. A stray shower or thunderstorm is possible. Low 72F. Winds light and variable.</p>
                            <p class="text-center"><small><i class="fas tnt-info-circle"></i> Updated: June 4, 2021 @ 1:07 pm</small></p>
                        </div>
                    </li>
                    <li role="separator" class="divider"></li>
                    <li role="menuitem" class="forecast-link text-center"><a href="/weather/?weather_zip=34668"><i class="fas tnt-caret-right"></i> Full Forecast</a></li>
                </ul>
            
        </li>
    </ul>
</div>

    <div class="clearfix"></div>
</div><div id="tncms-block-598965" class="tncms-block visible-lg visible-md hidden-sm hidden xs">
        <div id="blox-ad-position-micro-bar1" data-tnt-ads='{"vendor":"blox","type":"position","display":"default","region":"micro-bar","slot":"1","fold":"above","width":"88","js":{"video":"https:\/\/bloximages.newyork1.vip.townnews.com\/suncoastnews.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":"","refresh":false}' class="blox-ad tnt-ads-container ">
        
        </div></div></div></div>
    <div id="masthead-col-three" class="col-md-4 col-sm-4"><div id="tncms-region-masthead-col-three" class="tncms-region "><div id="tncms-block-501420" class="tncms-block"><section id="block-501420" class="block emphasis-h3   " >
    <div class="clearfix"></div>
    <div id="search-form-501420" class="search-form-container card clearfix text-center hidden-print well">
    <form id="site-search-501420" aria-labelledby="site-search-button-501420" action="/search/" method="GET" >
    <input type="hidden" name="l" value="25">
    
        
        <input type="hidden" name="sort" value="relevance">
    
    
    
    
    <input type="hidden" name="f" value="html">
    
        
        <input type="hidden" name="t" value="article,video,youtube,collection">
    
    <input type="hidden" name="app" value="editorial">
    <input type="hidden" name="nsa" value="eedition">
    <div class="site-search-form input-group pull-right input-group-lg ">
        <input id="site-search-501420-term" name="q" title="Site Search" type="text" placeholder="Search..." class="form-control" autocomplete="off">
        <input type="submit" class="hide" value="Search">
        <span class="input-group-btn">
            <button id="site-search-501420-btn" class="btn btn-primary" aria-label="Submit Site Search" type="submit">
                
	                <span class="hidden-xl hidden-lg hidden-md fas tnt-search"></span>
	                <span id="site-search-button-501420" class="hidden-xs hidden-sm">Search</span>
                
            </button>
        </span>
    </div>
    <div class="clearfix"></div>
</form>
        
        
        <div class="clearfix"></div>
    </div>
    </section> 

<script>
    $('#site-search-501420-btn').on(__tnt.client.clickEvent, function(){
        $('#site-search-501420').submit();
        return false;
    });

    $('#site-search-501420').on('submit', function(){
        // Filter query
        var sQueryFiltered = $("#site-search-501420 input[name=q]").val().replace(/\?/g, '');
    $("#site-search-501420 input[name=q]").val( sQueryFiltered );

        if( $('#site-search-501420-term').val() ){
            return true;
        }else{
            return false;
        }
    });</script>
</div></div></div>
                </div>
                <div class="row">
                    <div id="masthead-full-bottom" class="col-lg-12"><div id="tncms-region-masthead-full-bottom" class="tncms-region "></div></div>
                </div>
                
            </header>
        </div>
    

    
    
        <div id="site-navbar-container" class="hidden-print affix-top">
            
            <nav id="main-navigation" class="navbar yamm navbar-default container navbar-static">
                
                
                <div class="navbar-header">
                    
                    
                    
                        <button  type="button" class="visible-sm visible-xs navbar-toggle pull-right" data-toggle="offcanvas" data-target="right" aria-label="Right Main Menu" aria-expanded="false" >
                            <span class="sr-only">Toggle navigation</span>
                            <span class="icon-bar"></span>
                            <span class="icon-bar"></span>
                            <span class="icon-bar"></span>
                        </button>

                    

                    
                        <div class="navbar-brand hidden-md hidden-lg pos_right">
                            
                                <div id="tncms-region-main-nav-brand" class="tncms-region "><div id="tncms-block-501414" class="tncms-block"><section id="block-501414" class="block emphasis-h3   " ><div class="block"><a href="/" rel="nofollow" >
            <img 
                
                src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg==" 
                data-srcset="https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/custom/image/5f885670-7120-11e6-9fb9-e751a398bc1e.jpg?resize=150%2C64 150w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/custom/image/5f885670-7120-11e6-9fb9-e751a398bc1e.jpg?resize=200%2C86 200w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/custom/image/5f885670-7120-11e6-9fb9-e751a398bc1e.jpg?resize=225%2C96 225w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/custom/image/5f885670-7120-11e6-9fb9-e751a398bc1e.jpg?resize=300%2C128 300w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/custom/image/5f885670-7120-11e6-9fb9-e751a398bc1e.jpg?resize=400%2C171 400w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/custom/image/5f885670-7120-11e6-9fb9-e751a398bc1e.jpg?resize=540%2C231 540w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/custom/image/5f885670-7120-11e6-9fb9-e751a398bc1e.jpg?resize=640%2C274 640w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/custom/image/5f885670-7120-11e6-9fb9-e751a398bc1e.jpg 750w" 
                data-sizes="auto" 
                class=" img-responsive lazyload tnt-prop-img"
                width="750"
                height="321"
                alt=""></a></div></section></div></div>
                            
                        </div>
                    

                    
                </div>

                
                    <div id="navbar-collapse" class="navbar-collapse collapse">
                        
                            <div class="pull-right">
                                <div id="tncms-region-main-nav-right-region" class="tncms-region "></div>
                                
                            </div>
                        
                        <div class="navbar-left">
                            <div id="tncms-region-nav-main-nav" class="tncms-region-nav"><ul id="main-nav_menu" class="nav navbar-nav" role="navigation" aria-label="Main"><li>
                <a class="nav-link   tnt-section-pasco"  href="/news/pasco/"  tabindex="0">
                    <span class="nav-label">Pasco</span>
                </a></li><li>
                <a class="nav-link   tnt-section-pinellas"  href="/news/pinellas/"  tabindex="0">
                    <span class="nav-label">Pinellas</span>
                </a></li><li>
                <a class="nav-link   tnt-section-hernando"  href="/news/hernando/"  tabindex="0">
                    <span class="nav-label">Hernando</span>
                </a></li><li>
                <a class="nav-link   tnt-section-sports"  href="/sports/"  tabindex="0">
                    <span class="nav-label">Sports</span>
                </a></li><li>
                <a class="nav-link   tnt-section-business"  href="/business/"  tabindex="0">
                    <span class="nav-label">Business</span>
                </a></li><li>
                <a class="nav-link   tnt-section-classifieds"  href="/classifieds/"  tabindex="0">
                    <span class="nav-label">Classifieds</span>
                </a></li><li>
                <a class="nav-link   tnt-section-calendar"  href="/calendar/"  tabindex="0">
                    <span class="nav-label">Calendar</span>
                </a></li><li>
                <a class="nav-link   tnt-section-multimedia"  href="/multimedia/"  tabindex="0">
                    <span class="nav-label">Multimedia</span>
                </a></li></ul></div>
                        </div>
                    </div>
                

                
            </nav>
            
            
        </div>
        
            
        
    
    
    <div id="main-body-container">
    <section id="main-top-container" class="container-fullscreen-region container-fluid">
        
        <div class="fullscreen-region"><div id="tncms-region-global-container-top-fullscreen" class="tncms-region "></div></div>
    </section>
    <section id="main-page-container" class="container">
        <div class="row">
                <div id="asset-container-top" class="col-md-12"><div id="tncms-region-asset_container_top" class="tncms-region hidden-print"></div></div>
            
            <div class="col-md-12"><div id="tncms-region-global-container-top" class="tncms-region "><div id="tncms-block-501337" class="tncms-block hidden-xs">
        <div id="blox-ad-position-block-leaderboard-top1" data-tnt-ads='{"vendor":"blox","type":"position","display":"default","region":"block-leaderboard-top","slot":"1","fold":"above","width":"728","js":{"video":"https:\/\/bloximages.newyork1.vip.townnews.com\/suncoastnews.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":"","refresh":false}' class="blox-ad tnt-ads-container ">
        
        </div></div></div></div>
        </div><article itemscope itemtype="https://schema.org/Article" id="asset-2036e138-c50f-11eb-9ea7-13485452bf68" class="asset article-default"  data-url="https://www.suncoastnews.com/crime_crashes_fires/one-dead-another-seriously-injured-in-hernando-wreck/article_2036e138-c50f-11eb-9ea7-13485452bf68.html">
    <span itemscope itemtype="http://schema.org/SpeakableSpecification">
        <meta itemprop="cssSelector" content=".asset-header .headline" />
        <meta itemprop="cssSelector" content=".asset-content p:first-of-type" />
    </span>
    <meta itemprop="description" content="<p>Accident occurred Thursday afternoon on Broad Street</p>"/><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
        <div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
            <meta itemprop="url" content="https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/custom/image/15bced60-7122-11e6-b2b7-ebc3cb2a0c81.jpg">
            <meta itemprop="width" content="1200">
            <meta itemprop="height" content="630">
        </div>
        <meta itemprop="name" content="suncoastnews.com">
    </div>
    <link itemprop="mainEntityOfPage" href="https://www.suncoastnews.com/crime_crashes_fires/one-dead-another-seriously-injured-in-hernando-wreck/article_2036e138-c50f-11eb-9ea7-13485452bf68.html" />
    <style>
                .asset-paging .direction {
                    color: #005296;
                }
            </style><div class="asset-paging-container hidden-print" data-settings='{"assetType":"article","hasPageBreak":false,"isObit":false,"nextUrl":"https:\/\/www.suncoastnews.com\/tncms\/search\/mlt\/?origin=2036e138-c50f-11eb-9ea7-13485452bf68&app=editorial&preview=1&type=article%2Ccollection%2Cvideo%2Cyoutube","uuid":"2036e138-c50f-11eb-9ea7-13485452bf68","isFluid":false,"isAdminVenue":false}'>
            <div id="asset-paging-2036e138-c50f-11eb-9ea7-13485452bf68" class="asset-paging">
                <div id="paging-prev-2036e138-c50f-11eb-9ea7-13485452bf68" class="paging-link prev offset"></div>
                <div id="paging-next-2036e138-c50f-11eb-9ea7-13485452bf68" class="paging-link next offset"></div>
                <div class="clearfix"></div>
            </div>
        </div>
        <template id="asset-paging-template">
            <a class="animate arrow text-center">
                <span class=""></span>
                <span class="animate direction hidden-sm hidden-xs text-primary"></span>
            </a>
            <div class="animate item">
                <div class="dismiss" onclick="document.body.classList.add('trigger-disabled'); document.body.classList.remove('trigger-next'); return false;">
                    <span class="tnt-stack" aria-hidden="true">
                        <i class="fas tnt-circle tnt-inverse tnt-stack-1x"></i>
                        <i class="fas tnt-times-circle tnt-stack-1x"></i>
                    </span>
                </div>
                <div class="inner">
                    <a class="overlay">
                        <span class="sr-only"></span>
                    </a>
                    <div class="head text-uppercase">
                        <small></small>
                    </div>
                    <div class="media">
                        <div class="media-body">
                            <h6 class="media-heading"></h6>
                            <p class="hidden-xs"></p>
                        </div>
                    </div>
                    <div class="clearfix"></div>
                </div>
            </div>
        </template><div class="asset-masthead ">
        <header class="asset-header">
    <div class="tow-wrapper no-flags">
        
        
    </div>
    <h1 itemprop="headline" class="headline">
        <span>
            
            One dead, another seriously injured in Hernando wreck
        </span>
    </h1>
    
    <div class="meta">
        <span>
            <ul class="list-inline">
        <li><span itemprop="author" class="tnt-byline">Suncoast News staff</span></li>
        
        
            <li class="visible-print">
        <time datetime="2021-06-04T04:30:00-04:00" class="tnt-date asset-date text-muted">
            Jun 4, 2021
        </time></li>
            <li class="hidden-print">
        <time datetime="2021-06-04T04:30:00-04:00" class="tnt-date asset-date text-muted">8 hrs ago</time></li>
        
        
            <li class="hidden-print"></li>
        
        
    </ul>
        </span>
    </div>
    <meta itemprop="dateCreated" content="2021-06-04T04:30:00-04:00">
    <meta itemprop="datePublished" content="2021-06-04T04:30:00-04:00">
    <meta itemprop="dateModified" content="2021-06-04T04:30:00-04:00">
</header>
        
        
            <div class="share-container headline-right pull-right hidden-xs" data-subscription-required-remove><ul class="social-share-links hidden-print list-unstyled stacked icon"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.suncoastnews.com%2Fcrime_crashes_fires%2Fone-dead-another-seriously-injured-in-hernando-wreck%2Farticle_2036e138-c50f-11eb-9ea7-13485452bf68.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/crime_crashes_fires/one-dead-another-seriously-injured-in-hernando-wreck/article_2036e138-c50f-11eb-9ea7-13485452bf68.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"2036e138-c50f-11eb-9ea7-13485452bf68"}' >
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="Share">
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=One%20dead%2C%20another%20seriously%20injured%20in%20Hernando%20wreck&via=SuncoastNews&url=https%3A%2F%2Fwww.suncoastnews.com%2Fcrime_crashes_fires%2Fone-dead-another-seriously-injured-in-hernando-wreck%2Farticle_2036e138-c50f-11eb-9ea7-13485452bf68.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/crime_crashes_fires/one-dead-another-seriously-injured-in-hernando-wreck/article_2036e138-c50f-11eb-9ea7-13485452bf68.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"2036e138-c50f-11eb-9ea7-13485452bf68"}' >
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="Tweet">
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=https://www.suncoastnews.com/crime_crashes_fires/one-dead-another-seriously-injured-in-hernando-wreck/article_2036e138-c50f-11eb-9ea7-13485452bf68.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/crime_crashes_fires/one-dead-another-seriously-injured-in-hernando-wreck/article_2036e138-c50f-11eb-9ea7-13485452bf68.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"2036e138-c50f-11eb-9ea7-13485452bf68"}' >
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="WhatsApp">
                    
                    <i class="fab tnt-whatsapp tnt-stack-1x"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.suncoastnews.com/tncms/asset/editorial/2036e138-c50f-11eb-9ea7-13485452bf68" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"2036e138-c50f-11eb-9ea7-13485452bf68"}'  rel="nofollow">
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="SMS">
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5Bsuncoastnews.com%5D%20One%20dead%2C%20another%20seriously%20injured%20in%20Hernando%20wreck&body=https%3A%2F%2Fwww.suncoastnews.com%2Fcrime_crashes_fires%2Fone-dead-another-seriously-injured-in-hernando-wreck%2Farticle_2036e138-c50f-11eb-9ea7-13485452bf68.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"2036e138-c50f-11eb-9ea7-13485452bf68"}'  rel="nofollow">
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="Email">
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li></ul></div>
        
    </div>

    

    <div class="row">
        <div class="main-content col-lg-8 col-md-7 has-sidebar"><div class="main-content-wrap">
            <div id="tncms-region-article_top" class="tncms-region hidden-print"></div>
            
            

            

            

            <div id="tncms-region-article_top_content" class="tncms-region hidden-print"></div>

            <div id="asset-content" data-asset-uuid="2036e138-c50f-11eb-9ea7-13485452bf68">
                

                <div class="row">
                    <div class="col-lg-12 col-md-12 col-sm-12" data-subscription-required-class="col-xs-12">
                        
                        <div class="asset-body" data-subscription-required-class="asset-body">
                            
                                <div class="share-container content-above" data-subscription-required-remove><ul class="social-share-links hidden-print list-inline icon"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.suncoastnews.com%2Fcrime_crashes_fires%2Fone-dead-another-seriously-injured-in-hernando-wreck%2Farticle_2036e138-c50f-11eb-9ea7-13485452bf68.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/crime_crashes_fires/one-dead-another-seriously-injured-in-hernando-wreck/article_2036e138-c50f-11eb-9ea7-13485452bf68.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"2036e138-c50f-11eb-9ea7-13485452bf68"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=One%20dead%2C%20another%20seriously%20injured%20in%20Hernando%20wreck&via=SuncoastNews&url=https%3A%2F%2Fwww.suncoastnews.com%2Fcrime_crashes_fires%2Fone-dead-another-seriously-injured-in-hernando-wreck%2Farticle_2036e138-c50f-11eb-9ea7-13485452bf68.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/crime_crashes_fires/one-dead-another-seriously-injured-in-hernando-wreck/article_2036e138-c50f-11eb-9ea7-13485452bf68.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"2036e138-c50f-11eb-9ea7-13485452bf68"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=https://www.suncoastnews.com/crime_crashes_fires/one-dead-another-seriously-injured-in-hernando-wreck/article_2036e138-c50f-11eb-9ea7-13485452bf68.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/crime_crashes_fires/one-dead-another-seriously-injured-in-hernando-wreck/article_2036e138-c50f-11eb-9ea7-13485452bf68.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"2036e138-c50f-11eb-9ea7-13485452bf68"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-whatsapp tnt-stack-1x"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.suncoastnews.com/tncms/asset/editorial/2036e138-c50f-11eb-9ea7-13485452bf68" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"2036e138-c50f-11eb-9ea7-13485452bf68"}'  rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5Bsuncoastnews.com%5D%20One%20dead%2C%20another%20seriously%20injured%20in%20Hernando%20wreck&body=https%3A%2F%2Fwww.suncoastnews.com%2Fcrime_crashes_fires%2Fone-dead-another-seriously-injured-in-hernando-wreck%2Farticle_2036e138-c50f-11eb-9ea7-13485452bf68.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"2036e138-c50f-11eb-9ea7-13485452bf68"}'  rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li><li class="social-share-link pr">
                <a href="javascript:window.print()" class="pr" title="Print" data-track='{"network":"Print","socialAction":"print","url":"/crime_crashes_fires/one-dead-another-seriously-injured-in-hernando-wreck/article_2036e138-c50f-11eb-9ea7-13485452bf68.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"2036e138-c50f-11eb-9ea7-13485452bf68"}'  rel="nofollow">
                    <span class="tnt-stack" >
                        
                        <i class="fas tnt-print tnt-stack-1x"></i>
                    </span>
                    <span class="sr-only">Print</span>
                </a>
            </li><li class="social-share-link sv">
        <a class="save-list-2036e138-c50f-11eb-9ea7-13485452bf68-btn save-asset " title="Save to list" href="#"  role="button" rel="nofollow" data-asset-uuid="2036e138-c50f-11eb-9ea7-13485452bf68" >
            
                <span class="tnt-stack">
                    
                    <i class="asset-save-icon far tnt-bookmark tnt-stack-1x "></i>
                </span>
            
            
                <span class="sr-only">Save</span>
            
        </a>
        </li>
        
    </ul><form method="post" data-uuid="2036e138-c50f-11eb-9ea7-13485452bf68" class="save-list-2036e138-c50f-11eb-9ea7-13485452bf68-form save-asset-to-list" action="/users/admin/list/">
        <input type="hidden" name="action" value="addasset" />
        <input type="hidden" name="format" value="json" />
        <input type="hidden" name="listasset" value="2036e138-c50f-11eb-9ea7-13485452bf68" />
        <input type="hidden" name="listapp" value="editorial" />
        <input type="hidden" name="autocreate" value="true" />
        <input type="hidden" name="listname" value="articles" />
        <input class="hide" type="submit" name="submit" value="Save" />
    </form>
</div>
                            

                            <div id="tncms-region-article_body_top" class="tncms-region hidden-print"></div>

                            <div  itemprop="articleBody" class="asset-content  subscriber-premium">
                                <meta itemprop="isAccessibleForFree" content="true"/>
                                
                                
                                <p>BROOKSVILLE — A two-vehicle accident Thursday afternoon in Brooksville left one motorist dead and another in serious condition.</p><p>According to the Florida Highway Patrol, the wreck occurred at approximately 1:12 p.m. on Broad Street, south of Twingate Avenue.</p><p>Reports state a 70-year-old Brooksville man driving a sedan was traveling northbound on Broad Street while a 50-year-old Brooksville man driving a sedan was traveling southbound on the same roadway. For unknown reasons, the 70-year-old man's vehicle entered the southbound lane and collided with the left side of the 50-year-old man's vehicle.</p>
        <div data-tnt-ads-tmp='{"vendor":"blox","type":"region","region":"fixed-big-ad-top-asset","id":"fixed-big-ad-top-asset","pos":"fixed-big-ad-top-asset, atf","fold":"above","include_domain":null,"size":"[300,250]","height":"250","width":"300","mobile":false,"js":{"video":"https:\/\/bloximages.newyork1.vip.townnews.com\/suncoastnews.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":null,"index_slug":null,"url":"\/crime_crashes_fires","refresh":false}' style="display:none;"></div><div id="tncms-region-ads-fixed-big-ad-top-asset" class="tncms-region-ads">

<div id="blox-ad-position-fixed-big-ad-top-asset1">
<script type="text/javascript">TNCMS.AdManager.render({region: 'fixed-big-ad-top-asset', slot: 1, fold: "above"});</script>

</div>
</div>
<div id="tncms-region-article_instory_top" class="tncms-region hidden-print"></div><p>The impact caused both vehicles to rotate to final rest along the southbound shoulder of Broad Street. Reports state the 70-year-old man, who was not wearing a seat belt, was ejected from his vehicle and suffered fatal injuries at the scene of the crash.</p><p>The 50-year-old man was transported to an area hospital with serious injuries.</p>
        <div data-tnt-ads-tmp='{"vendor":"blox","type":"region","region":"fixed-big-ad-bottom-asset","id":"fixed-big-ad-bottom-asset","pos":"fixed-big-ad-bottom-asset, btf","fold":"below","include_domain":null,"size":"[300,250]","height":"250","width":"300","mobile":false,"js":{"video":"https:\/\/bloximages.newyork1.vip.townnews.com\/suncoastnews.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":null,"index_slug":null,"url":"\/crime_crashes_fires","refresh":false}' style="display:none;"></div><div id="tncms-region-ads-fixed-big-ad-bottom-asset" class="tncms-region-ads">

<div id="blox-ad-position-fixed-big-ad-bottom-asset1">
<script type="text/javascript">TNCMS.AdManager.render({region: 'fixed-big-ad-bottom-asset', slot: 1, fold: "below"});</script>

</div>
</div>
<div id="tncms-region-article_instory_bottom" class="tncms-region hidden-print"></div>
                                <div id="tncms-region-article_bottom_content" class="tncms-region hidden-print"></div>
                                
                            </div>

                            

                            
    


                            
                                <div class="share-container content-below" data-subscription-required-remove><ul class="social-share-links hidden-print list-inline icon"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.suncoastnews.com%2Fcrime_crashes_fires%2Fone-dead-another-seriously-injured-in-hernando-wreck%2Farticle_2036e138-c50f-11eb-9ea7-13485452bf68.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/crime_crashes_fires/one-dead-another-seriously-injured-in-hernando-wreck/article_2036e138-c50f-11eb-9ea7-13485452bf68.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"2036e138-c50f-11eb-9ea7-13485452bf68"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=One%20dead%2C%20another%20seriously%20injured%20in%20Hernando%20wreck&via=SuncoastNews&url=https%3A%2F%2Fwww.suncoastnews.com%2Fcrime_crashes_fires%2Fone-dead-another-seriously-injured-in-hernando-wreck%2Farticle_2036e138-c50f-11eb-9ea7-13485452bf68.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/crime_crashes_fires/one-dead-another-seriously-injured-in-hernando-wreck/article_2036e138-c50f-11eb-9ea7-13485452bf68.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"2036e138-c50f-11eb-9ea7-13485452bf68"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=https://www.suncoastnews.com/crime_crashes_fires/one-dead-another-seriously-injured-in-hernando-wreck/article_2036e138-c50f-11eb-9ea7-13485452bf68.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/crime_crashes_fires/one-dead-another-seriously-injured-in-hernando-wreck/article_2036e138-c50f-11eb-9ea7-13485452bf68.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"2036e138-c50f-11eb-9ea7-13485452bf68"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-whatsapp tnt-stack-1x"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.suncoastnews.com/tncms/asset/editorial/2036e138-c50f-11eb-9ea7-13485452bf68" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"2036e138-c50f-11eb-9ea7-13485452bf68"}'  rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5Bsuncoastnews.com%5D%20One%20dead%2C%20another%20seriously%20injured%20in%20Hernando%20wreck&body=https%3A%2F%2Fwww.suncoastnews.com%2Fcrime_crashes_fires%2Fone-dead-another-seriously-injured-in-hernando-wreck%2Farticle_2036e138-c50f-11eb-9ea7-13485452bf68.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"2036e138-c50f-11eb-9ea7-13485452bf68"}'  rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li><li class="social-share-link pr">
                <a href="javascript:window.print()" class="pr" title="Print" data-track='{"network":"Print","socialAction":"print","url":"/crime_crashes_fires/one-dead-another-seriously-injured-in-hernando-wreck/article_2036e138-c50f-11eb-9ea7-13485452bf68.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"2036e138-c50f-11eb-9ea7-13485452bf68"}'  rel="nofollow">
                    <span class="tnt-stack" >
                        
                        <i class="fas tnt-print tnt-stack-1x"></i>
                    </span>
                    <span class="sr-only">Print</span>
                </a>
            </li><li class="social-share-link sv">
        <a class="save-list-2036e138-c50f-11eb-9ea7-13485452bf68-btn save-asset " title="Save to list" href="#"  role="button" rel="nofollow" data-asset-uuid="2036e138-c50f-11eb-9ea7-13485452bf68" >
            
                <span class="tnt-stack">
                    
                    <i class="asset-save-icon far tnt-bookmark tnt-stack-1x "></i>
                </span>
            
            
                <span class="sr-only">Save</span>
            
        </a>
        </li>
        
    </ul><form method="post" data-uuid="2036e138-c50f-11eb-9ea7-13485452bf68" class="save-list-2036e138-c50f-11eb-9ea7-13485452bf68-form save-asset-to-list" action="/users/admin/list/">
        <input type="hidden" name="action" value="addasset" />
        <input type="hidden" name="format" value="json" />
        <input type="hidden" name="listasset" value="2036e138-c50f-11eb-9ea7-13485452bf68" />
        <input type="hidden" name="listapp" value="editorial" />
        <input type="hidden" name="autocreate" value="true" />
        <input type="hidden" name="listname" value="articles" />
        <input class="hide" type="submit" name="submit" value="Save" />
    </form>
</div>
                            
                        </div>
                        
                    </div></div><!-- /asset-content -->

                <div id="asset-below">
                    

                    

                    

                    

                    

                    
                        <div class="asset-tags hidden-print">
                            <h4>Tags</h4>
                            <ul class="list-inline"><li>
                <a href="/search/?k=%22hernando%20county%22#tncms-source=keyword" class="tag-hernando-county label label-default" >Hernando County</a>
            </li> <li>
                <a href="/search/?k=%22brooksville%22#tncms-source=keyword" class="tag-brooksville label label-default" >Brooksville</a>
            </li> <li>
                <a href="/search/?k=%22broad%20street%22#tncms-source=keyword" class="tag-broad-street label label-default" >Broad Street</a>
            </li> <li>
                <a href="/search/?k=%22fhp%22#tncms-source=keyword" class="tag-fhp label label-default" >Fhp</a>
            </li> <li>
                <a href="/search/?k=%22florida%20highway%20patrol%22#tncms-source=keyword" class="tag-florida-highway-patrol label label-default" >Florida Highway Patrol</a>
            </li> <li>
                <a href="/search/?k=%22wreck%22#tncms-source=keyword" class="tag-wreck label label-default" >Wreck</a>
            </li> <li>
                <a href="/search/?k=%22accident%22#tncms-source=keyword" class="tag-accident label label-default" >Accident</a>
            </li> <li>
                <a href="/search/?k=%22death%22#tncms-source=keyword" class="tag-death label label-default" >Death</a>
            </li> <li>
                <a href="/search/?k=%22fatal%22#tncms-source=keyword" class="tag-fatal label label-default" >Fatal</a>
            </li> <li>
                <a href="/search/?k=%22injuries%22#tncms-source=keyword" class="tag-injuries label label-default" >Injuries</a>
            </li> </ul>
                        </div>
                    

                    

                    

                    

                    

                    

                    

                    

                    <div id="tncms-region-article_bottom" class="tncms-region hidden-print"><div id="tncms-block-1044046" class="tncms-block"><div class="zergnet-widget" id="zergnet-widget-loader"></div></div></div><div id="taboola-video-outstream"></div><div id="taboola-below-article-thumbnails" class="asset-recommend taboola hidden-print" data-page="article" data-mode="thumbnails-a" data-container="taboola-below-article-thumbnails" data-placement="Below Article Thumbnails"></div><div id="taboola-below-article-text-links" class="asset-recommend taboola hidden-print" data-page="article" data-mode="hybrid-text-links-a" data-container="taboola-below-article-text-links" data-placement="Below Article Text Links"></div>

                    <div class="asset-comments hidden-print"></div>
                    
                    <div id="tncms-region-article_container_bottom" class="tncms-region hidden-print"></div></div>
            </div>

            

            </div>
        </div><div class="main-sidebar col-lg-4 col-md-5 hidden-print">
                <div class="main-sidebar-wrap">
                    <div id="tncms-region-article_side_top" class="tncms-region hidden-print"></div>
        <div data-tnt-ads-tmp='{"vendor":"blox","type":"region","region":"fixed-big-ad-top","id":"fixed-big-ad-top","pos":"fixed-big-ad-top, atf","fold":"above","include_domain":null,"size":"[[300,250], [300,600]]","height":"250","width":"300","not_mobile":false,"js":{"video":"https:\/\/bloximages.newyork1.vip.townnews.com\/suncoastnews.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":null,"index_slug":null,"url":"\/crime_crashes_fires","refresh":false}' style="display:none;"></div><div id="tncms-region-ads-fixed-big-ad-top" class="tncms-region-ads">

<div id="blox-ad-position-fixed-big-ad-top1">
<script type="text/javascript">TNCMS.AdManager.render({region: 'fixed-big-ad-top', slot: 1, fold: "above"});</script>

</div>
</div>
<div id="tncms-region-asset_side_top" class="tncms-region hidden-print"></div><div id="tncms-region-global-side-primary" class="tncms-region "><div id="tncms-block-1050832" class="tncms-block">
        <div id="blox-ad-position-block-top-300x1001" data-tnt-ads='{"vendor":"blox","type":"position","display":"default","region":"block-top-300x100","slot":"1","fold":"","width":"","js":{"video":"https:\/\/bloximages.newyork1.vip.townnews.com\/suncoastnews.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":"","refresh":false}' class="blox-ad tnt-ads-container ">
        
        </div></div><div id="tncms-block-896902" class="tncms-block"><section id="block-896902" class="block emphasis-h3   " ><div class="clearfix">
    
    <div class="block-title title-896902 ">
        <div class="block-title-inner">
            <h3>
                
                Weekly COVID-19 update
                
            </h3>
        </div>
    </div></div><div class=" ">
        
            
            <article id="card-showcase-21536f60-c211-11eb-9ec3-cfb6a3ecee25" class="clearfix card showcase position-0 odd  tnt-section-news">
            <div class="card-container"><div class="card-image ">
                <div class="media-preview-21536f60-c211-11eb-9ec3-cfb6a3ecee25 media-preview article-asset" data-aspect="16:9"><figure class="photo layout-horizontal letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/news/pasco-county-s-covid-19-numbers-still-declining/article_21536f60-c211-11eb-9ec3-cfb6a3ecee25.html" class="tnt-asset-link" >                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAABAAAAAJCAQAAACRI2S5AAAAEklEQVR42mM8U8+AFzCOKgADAHdUC60wg0dkAAAAAElFTkSuQmCC"
                            alt="Pasco County’s COVID-19 numbers still declining"
                            class="img-responsive lazyload full default"
                            width="1662"
                            height="935"
                            data-sizes="auto"
                            data-srcset="https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/4/47/44741d28-75d7-11ea-aecc-4b2353234c75/5e877db263642.image.png?crop=1662%2C935%2C0%2C97&resize=150%2C84&order=crop%2Cresize 150w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/4/47/44741d28-75d7-11ea-aecc-4b2353234c75/5e877db263642.image.png?crop=1662%2C935%2C0%2C97&resize=200%2C113&order=crop%2Cresize 200w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/4/47/44741d28-75d7-11ea-aecc-4b2353234c75/5e877db263642.image.png?crop=1662%2C935%2C0%2C97&resize=225%2C127&order=crop%2Cresize 225w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/4/47/44741d28-75d7-11ea-aecc-4b2353234c75/5e877db263642.image.png?crop=1662%2C935%2C0%2C97&resize=300%2C169&order=crop%2Cresize 300w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/4/47/44741d28-75d7-11ea-aecc-4b2353234c75/5e877db263642.image.png?crop=1662%2C935%2C0%2C97&resize=400%2C225&order=crop%2Cresize 400w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/4/47/44741d28-75d7-11ea-aecc-4b2353234c75/5e877db263642.image.png?crop=1662%2C935%2C0%2C97&resize=540%2C304&order=crop%2Cresize 540w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/4/47/44741d28-75d7-11ea-aecc-4b2353234c75/5e877db263642.image.png?crop=1662%2C935%2C0%2C97&resize=640%2C360&order=crop%2Cresize 640w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/4/47/44741d28-75d7-11ea-aecc-4b2353234c75/5e877db263642.image.png?crop=1662%2C935%2C0%2C97&resize=750%2C422&order=crop%2Cresize 750w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/4/47/44741d28-75d7-11ea-aecc-4b2353234c75/5e877db263642.image.png?crop=1662%2C935%2C0%2C97&resize=990%2C557&order=crop%2Cresize 990w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/4/47/44741d28-75d7-11ea-aecc-4b2353234c75/5e877db263642.image.png?crop=1662%2C935%2C0%2C97&resize=1035%2C582&order=crop%2Cresize 1035w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/4/47/44741d28-75d7-11ea-aecc-4b2353234c75/5e877db263642.image.png?crop=1662%2C935%2C0%2C97&resize=1200%2C675&order=crop%2Cresize 1200w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/4/47/44741d28-75d7-11ea-aecc-4b2353234c75/5e877db263642.image.png?crop=1662%2C935%2C0%2C97&resize=1333%2C750&order=crop%2Cresize 1333w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/4/47/44741d28-75d7-11ea-aecc-4b2353234c75/5e877db263642.image.png?crop=1662%2C935%2C0%2C97&resize=1476%2C830&order=crop%2Cresize 1476w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/4/47/44741d28-75d7-11ea-aecc-4b2353234c75/5e877db263642.image.png?crop=1662%2C935%2C0%2C97&resize=1662%2C935&order=crop%2Cresize 2008w" />
                </a>
                
            </div>
            
        </figure></div>
            </div><div class="card-body">
        <div class="card-headline"><h3 class="tnt-headline ">
        
             <a href="/news/pasco-county-s-covid-19-numbers-still-declining/article_21536f60-c211-11eb-9ec3-cfb6a3ecee25.html" class="tnt-asset-link">
        

        
            Pasco County’s COVID-19 numbers still declining</a></h3></div>
    <div class="card-meta">
            <ul class="list-inline"><li class="card-date">
        <time datetime="2021-05-31T09:07:00-04:00" class="tnt-date asset-date text-muted">May 31, 2021</time></li></ul>
        </div>
                        <div class="card-social pull-right">
                            <ul class="social-share-links hidden-print list-inline icon"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.suncoastnews.com%2Fnews%2Fpasco-county-s-covid-19-numbers-still-declining%2Farticle_21536f60-c211-11eb-9ec3-cfb6a3ecee25.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/news/pasco-county-s-covid-19-numbers-still-declining/article_21536f60-c211-11eb-9ec3-cfb6a3ecee25.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"21536f60-c211-11eb-9ec3-cfb6a3ecee25"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=Pasco%20County%E2%80%99s%20COVID-19%20numbers%20still%20declining&via=SuncoastNews&url=https%3A%2F%2Fwww.suncoastnews.com%2Fnews%2Fpasco-county-s-covid-19-numbers-still-declining%2Farticle_21536f60-c211-11eb-9ec3-cfb6a3ecee25.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/news/pasco-county-s-covid-19-numbers-still-declining/article_21536f60-c211-11eb-9ec3-cfb6a3ecee25.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"21536f60-c211-11eb-9ec3-cfb6a3ecee25"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=https://www.suncoastnews.com/news/pasco-county-s-covid-19-numbers-still-declining/article_21536f60-c211-11eb-9ec3-cfb6a3ecee25.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/news/pasco-county-s-covid-19-numbers-still-declining/article_21536f60-c211-11eb-9ec3-cfb6a3ecee25.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"21536f60-c211-11eb-9ec3-cfb6a3ecee25"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-whatsapp tnt-stack-1x"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.suncoastnews.com/tncms/asset/editorial/21536f60-c211-11eb-9ec3-cfb6a3ecee25" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"21536f60-c211-11eb-9ec3-cfb6a3ecee25"}'  rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5Bsuncoastnews.com%5D%20Pasco%20County%E2%80%99s%20COVID-19%20numbers%20still%20declining&body=https%3A%2F%2Fwww.suncoastnews.com%2Fnews%2Fpasco-county-s-covid-19-numbers-still-declining%2Farticle_21536f60-c211-11eb-9ec3-cfb6a3ecee25.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"21536f60-c211-11eb-9ec3-cfb6a3ecee25"}'  rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li></ul>
                        </div>
                    
                    
                        <div class="card-lead">
                            <p>Florida Department of Health reported 248 new COVID-19 cases and three deaths for Pasco County from May 23-27. The tally of cases increased to 42,754 and the death toll rose to 781. </p>
                        </div>
                    </div>
            </div>
            <div class="clearfix"></div>
        </article>
            
        
    </div></section></div><div id="tncms-block-501366" class="tncms-block visible-lg visible-md"><section id="block-501366" class="block emphasis-h4 dark  " ><div class="clearfix">
    
    <div class="block-title title-501366 ">
        <div class="block-title-inner">
            <h4>
                
                Latest News
                
            </h4>
        </div>
    </div></div>
    <div class=" card-bg-color"><div class="card-panel panel">
            <div class="panel-body"><ul class="card headline-list bullet-square border border-dashed"><li class="">
            <span class="tnt-headline ">
        
             <a href="/sports/rob-walden-steps-down-as-central-football-coach/article_3d843b9e-c557-11eb-b29e-bfd6c5c8f450.html" class="tnt-asset-link">
        

        
            Rob Walden steps down as Central football coach</a></span>
        </li><li class="">
            <span class="tnt-headline ">
        
             <a href="/sports/post-spring-super-7-prep-football-poll/article_2ae1f1b2-c510-11eb-b97e-ebb978201103.html" class="tnt-asset-link">
        

        
            Post-Spring ‘Super 7’ Prep Football Poll</a></span>
        </li><li class="">
            <span class="tnt-headline ">
        
             <a href="/news/traffic-analysis-doesn-t-warrant-port-richey-speed-limit-change/article_7adee99a-c425-11eb-a43e-3fc6765af05c.html" class="tnt-asset-link">
        

        
            Traffic analysis doesn’t warrant Port Richey speed limit change</a></span>
        </li><li class="">
            <span class="tnt-headline ">
        
             <a href="/news/tarpon-springs-social-dog-club-s-yappy-hour-at-anclote-brew/article_714b7b84-c423-11eb-8774-f7d14d5ad258.html" class="tnt-asset-link">
        

        
            Tarpon Springs Social Dog Club’s Yappy Hour at Anclote Brew</a></span>
        </li><li class="">
            <span class="tnt-headline ">
        
             <a href="/crime_crashes_fires/one-dead-another-seriously-injured-in-hernando-wreck/article_2036e138-c50f-11eb-9ea7-13485452bf68.html" class="tnt-asset-link">
        

        
            One dead, another seriously injured in Hernando wreck</a></span>
        </li><li class="">
            <span class="tnt-headline ">
        
             <a href="/news/p-a-c-k-summer-camps-for-challenged-youth-back-after-year-off/article_e88290a6-c3e3-11eb-b722-3b6427b5f1d4.html" class="tnt-asset-link">
        

        
            P.A.C.K. summer camps for challenged youth back after year off</a></span>
        </li><li class="">
            <span class="tnt-headline ">
        
             <a href="/sports/16th-annual-anthony-becht-football-camp-starting-up/article_7266fffe-c499-11eb-9d07-2b345d6ab5d3.html" class="tnt-asset-link">
        

        
            16th annual Anthony Becht football camp starting up</a></span>
        </li><li class="">
            <span class="tnt-headline ">
        
             <a href="/news/july-4-fireworks-returning-to-tarpon-springs/article_42c78522-c3e3-11eb-af80-bf93abbe80d5.html" class="tnt-asset-link">
        

        
            July 4 fireworks returning to Tarpon Springs</a></span>
        </li><li class="">
            <span class="tnt-headline ">
        
             <a href="/news/pasco-award-winners-conserve-water-by-example/article_ba94833a-c3e2-11eb-82ce-4b668e1bde16.html" class="tnt-asset-link">
        

        
            Pasco award winners conserve water by example</a></span>
        </li><li class="">
            <span class="tnt-headline ">
        
             <a href="/news/hernando-sheriff-seeks-regulation-of-internet-cafes-commissioners-decline-to-pursue/article_c23f5834-c3b1-11eb-ad71-c3f4dba33f8c.html" class="tnt-asset-link">
        

        
            Hernando sheriff seeks regulation of ‘internet cafes’; commissioners decline to pursue</a></span>
        </li></ul></div>
        </div></div></section></div><div id="tncms-block-644299" class="tncms-block">
        <div id="blox-ad-position-block-right-rail1" data-tnt-ads='{"vendor":"blox","type":"position","display":"default","region":"block-right-rail","slot":"1","fold":"","width":"","js":{"video":"https:\/\/bloximages.newyork1.vip.townnews.com\/suncoastnews.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":"","refresh":false}' class="blox-ad tnt-ads-container ">
        
        </div></div><div id="tncms-block-501416" class="tncms-block"><section id="block-501416" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-501416 ">
        <div class="block-title-inner">
            <h4>
                
                Most Popular
                
            </h4>
        </div>
    </div></div><div class="most-popular">
    <ul class="nav nav-tabs nav-tabs-popular">
        
            <li class="active">
                <a href="#articles-501416" data-toggle="tab"><i class="far tnt-file-alt" title="Articles"></i><span class="tab-text"> Articles</span></a>
            </li>
        
        
            <li >
                <a href="#images-501416" data-toggle="tab"><i class="far tnt-image" title="images"></i><span class="tab-text"> Images</span></a>
            </li>
        
        
            <li >
                <a href="#videos-501416" data-toggle="tab"><i class="fas tnt-play-circle" title="Videos"></i><span class="tab-text"> Videos</span></a>
            </li>
        
        
        
        
            <li >
                <a href="#commented-501416" data-toggle="tab"><i class="far tnt-comments" title="Commented"></i><span class="tab-text"> Commented</span></a>
            </li>
        
    </ul>
    <div class="tab-content">
        
            <div id="articles-501416" class="tab-pane tab-pane-articles fade in active">
                <h4 class="tab-content-heading">Articles</h4><ul class="tab-content-list bullet-disc "><li><a href="/crime_crashes_fires/npr-police-deadly-accident-on-u-s-19-caused-by-red-light-runner/article_7957da7e-c3de-11eb-a859-7b877cf3f133.html">NPR Police: Deadly accident on U.S. 19 caused by red-light runner</a></li><li><a href="/crime_crashes_fires/released-from-pasco-county-jail-man-found-dead-in-land-o-lakes/article_1a1543aa-c3e1-11eb-8210-eb3f835ae540.html">Released from Pasco County Jail, man found dead in Land O’ Lakes</a></li><li><a href="/crime_crashes_fires/pedestrian-killed-crossing-u-s-19-in-port-richey/article_6b850fb4-c1e2-11eb-8457-9730dc919a8e.html">Pedestrian killed crossing U.S. 19 in Port Richey</a></li><li><a href="/news/tarpon-icon-remembered-salivaras-owner-of-mykonos-restaurant-laid-to-rest/article_23c0b9c4-c35b-11eb-86cb-37cac6abe54d.html">Tarpon icon remembered: Salivaras, owner of Mykonos Restaurant, laid to rest</a></li><li><a href="/news/around-hernando-sex-offender-in-hiding-for-21-years-arrested-in-hernando/article_c9e5e634-c307-11eb-8a12-9b722fd54e57.html">Around Hernando: Sex offender in hiding for 21 years arrested in Hernando</a></li><li><a href="/news/brooksville-vintage-opening-by-flag-day/article_8120173e-c308-11eb-a91a-3b303945689c.html">Brooksville Vintage opening by Flag Day</a></li><li><a href="/sports/the-fishin-report-gag-grouper-season-is-open-so-go-get-you-some/article_5daea632-c3b5-11eb-b5cf-5f35db672559.html">The Fishin’ Report: Gag grouper season is open, so go get you some</a></li><li><a href="/news/uncertainties-shelve-new-port-richey-golf-cart-rule-changes/article_d446b89e-beeb-11eb-ac2e-434f918579d3.html">Uncertainties shelve New Port Richey golf cart rule changes</a></li><li><a href="/news/community-organizations-rally-to-prepare-hernando-residents-for-hurricane-season/article_03d4c8ba-c308-11eb-ac8f-2709573b76ea.html">Community organizations rally to prepare Hernando residents for hurricane season</a></li><li><a href="/crime_crashes_fires/update-person-of-interest-idd-in-cyclebar-trinity-hit-and-run/article_e3a5e8c0-c42a-11eb-8fc0-a3503c0a722e.html">UPDATE: Person of interest ID'd in CycleBar Trinity hit-and-run</a></li></ul></div>
        
        
            <div id="images-501416" class="tab-pane tab-pane-images fade in ">
                <h4 class="tab-content-heading">Images</h4><ul class="tab-content-list">
                            <li><figure class="photo layout-square letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/img-6729-alahouzos-martin-resolution-jpg/image_401a35a8-addc-11eb-8f7a-33f648f4fbf9.html" class="tnt-asset-link" >                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="IMG_6729 alahouzos martin resolution.jpg"
                            class="img-responsive lazyload full default"
                            width="1175"
                            height="1175"
                            data-sizes="auto"
                            data-srcset="https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/4/01/401a35a8-addc-11eb-8f7a-33f648f4fbf9/6092f8e078b0b.image.jpg?crop=1175%2C1175%2C0%2C294&resize=150%2C150&order=crop%2Cresize 150w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/4/01/401a35a8-addc-11eb-8f7a-33f648f4fbf9/6092f8e078b0b.image.jpg?crop=1175%2C1175%2C0%2C294&resize=200%2C200&order=crop%2Cresize 200w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/4/01/401a35a8-addc-11eb-8f7a-33f648f4fbf9/6092f8e078b0b.image.jpg?crop=1175%2C1175%2C0%2C294&resize=225%2C225&order=crop%2Cresize 225w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/4/01/401a35a8-addc-11eb-8f7a-33f648f4fbf9/6092f8e078b0b.image.jpg?crop=1175%2C1175%2C0%2C294&resize=300%2C300&order=crop%2Cresize 300w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/4/01/401a35a8-addc-11eb-8f7a-33f648f4fbf9/6092f8e078b0b.image.jpg?crop=1175%2C1175%2C0%2C294&resize=400%2C400&order=crop%2Cresize 400w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/4/01/401a35a8-addc-11eb-8f7a-33f648f4fbf9/6092f8e078b0b.image.jpg?crop=1175%2C1175%2C0%2C294&resize=540%2C540&order=crop%2Cresize 540w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/4/01/401a35a8-addc-11eb-8f7a-33f648f4fbf9/6092f8e078b0b.image.jpg?crop=1175%2C1175%2C0%2C294&resize=640%2C640&order=crop%2Cresize 640w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/4/01/401a35a8-addc-11eb-8f7a-33f648f4fbf9/6092f8e078b0b.image.jpg?crop=1175%2C1175%2C0%2C294&resize=750%2C750&order=crop%2Cresize 750w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/4/01/401a35a8-addc-11eb-8f7a-33f648f4fbf9/6092f8e078b0b.image.jpg?crop=1175%2C1175%2C0%2C294&resize=990%2C990&order=crop%2Cresize 990w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/4/01/401a35a8-addc-11eb-8f7a-33f648f4fbf9/6092f8e078b0b.image.jpg?crop=1175%2C1175%2C0%2C294&resize=1035%2C1035&order=crop%2Cresize 1035w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/4/01/401a35a8-addc-11eb-8f7a-33f648f4fbf9/6092f8e078b0b.image.jpg?crop=1175%2C1175%2C0%2C294&resize=1175%2C1175&order=crop%2Cresize 1200w" />
                </a>
                
            </div>
            
        </figure></li>
                        
                            <li><figure class="photo layout-square letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/new-port-richey-robbery-suspects-at-large/image_c29b428a-b357-11eb-be95-f30ca7aed93b.html" class="tnt-asset-link" >                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="New Port Richey robbery suspects at large"
                            class="img-responsive lazyload full default"
                            width="867"
                            height="867"
                            data-sizes="auto"
                            data-srcset="https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/c/29/c29b428a-b357-11eb-be95-f30ca7aed93b/609c2ba23cf65.image.jpg?crop=867%2C867%2C141%2C0&resize=150%2C150&order=crop%2Cresize 150w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/c/29/c29b428a-b357-11eb-be95-f30ca7aed93b/609c2ba23cf65.image.jpg?crop=867%2C867%2C141%2C0&resize=200%2C200&order=crop%2Cresize 200w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/c/29/c29b428a-b357-11eb-be95-f30ca7aed93b/609c2ba23cf65.image.jpg?crop=867%2C867%2C141%2C0&resize=225%2C225&order=crop%2Cresize 225w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/c/29/c29b428a-b357-11eb-be95-f30ca7aed93b/609c2ba23cf65.image.jpg?crop=867%2C867%2C141%2C0&resize=300%2C300&order=crop%2Cresize 300w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/c/29/c29b428a-b357-11eb-be95-f30ca7aed93b/609c2ba23cf65.image.jpg?crop=867%2C867%2C141%2C0&resize=400%2C400&order=crop%2Cresize 400w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/c/29/c29b428a-b357-11eb-be95-f30ca7aed93b/609c2ba23cf65.image.jpg?crop=867%2C867%2C141%2C0&resize=540%2C540&order=crop%2Cresize 540w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/c/29/c29b428a-b357-11eb-be95-f30ca7aed93b/609c2ba23cf65.image.jpg?crop=867%2C867%2C141%2C0&resize=640%2C640&order=crop%2Cresize 640w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/c/29/c29b428a-b357-11eb-be95-f30ca7aed93b/609c2ba23cf65.image.jpg?crop=867%2C867%2C141%2C0&resize=750%2C750&order=crop%2Cresize 750w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/c/29/c29b428a-b357-11eb-be95-f30ca7aed93b/609c2ba23cf65.image.jpg?crop=867%2C867%2C141%2C0&resize=867%2C867&order=crop%2Cresize 990w" />
                </a>
                
            </div>
            
        </figure></li>
                        
                            <li><figure class="photo layout-square letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/dsc-0062-jpg/image_0231722e-bd09-11eb-8942-bf1134e5898a.html" class="tnt-asset-link" >                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="DSC_0062.JPG"
                            class="img-responsive lazyload full default"
                            width="1223"
                            height="1223"
                            data-sizes="auto"
                            data-srcset="https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/0/23/0231722e-bd09-11eb-8942-bf1134e5898a/60ac6e6b65087.image.jpg?crop=1223%2C1223%2C81%2C0&resize=150%2C150&order=crop%2Cresize 150w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/0/23/0231722e-bd09-11eb-8942-bf1134e5898a/60ac6e6b65087.image.jpg?crop=1223%2C1223%2C81%2C0&resize=200%2C200&order=crop%2Cresize 200w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/0/23/0231722e-bd09-11eb-8942-bf1134e5898a/60ac6e6b65087.image.jpg?crop=1223%2C1223%2C81%2C0&resize=225%2C225&order=crop%2Cresize 225w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/0/23/0231722e-bd09-11eb-8942-bf1134e5898a/60ac6e6b65087.image.jpg?crop=1223%2C1223%2C81%2C0&resize=300%2C300&order=crop%2Cresize 300w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/0/23/0231722e-bd09-11eb-8942-bf1134e5898a/60ac6e6b65087.image.jpg?crop=1223%2C1223%2C81%2C0&resize=400%2C400&order=crop%2Cresize 400w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/0/23/0231722e-bd09-11eb-8942-bf1134e5898a/60ac6e6b65087.image.jpg?crop=1223%2C1223%2C81%2C0&resize=540%2C540&order=crop%2Cresize 540w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/0/23/0231722e-bd09-11eb-8942-bf1134e5898a/60ac6e6b65087.image.jpg?crop=1223%2C1223%2C81%2C0&resize=640%2C640&order=crop%2Cresize 640w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/0/23/0231722e-bd09-11eb-8942-bf1134e5898a/60ac6e6b65087.image.jpg?crop=1223%2C1223%2C81%2C0&resize=750%2C750&order=crop%2Cresize 750w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/0/23/0231722e-bd09-11eb-8942-bf1134e5898a/60ac6e6b65087.image.jpg?crop=1223%2C1223%2C81%2C0&resize=990%2C990&order=crop%2Cresize 990w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/0/23/0231722e-bd09-11eb-8942-bf1134e5898a/60ac6e6b65087.image.jpg?crop=1223%2C1223%2C81%2C0&resize=1035%2C1035&order=crop%2Cresize 1035w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/0/23/0231722e-bd09-11eb-8942-bf1134e5898a/60ac6e6b65087.image.jpg?crop=1223%2C1223%2C81%2C0&resize=1200%2C1200&order=crop%2Cresize 1200w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/0/23/0231722e-bd09-11eb-8942-bf1134e5898a/60ac6e6b65087.image.jpg?crop=1223%2C1223%2C81%2C0&resize=1223%2C1223&order=crop%2Cresize 1333w" />
                </a>
                
            </div>
            
        </figure></li>
                        
                            <li><figure class="photo layout-square letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/braciulis-jpg/image_08746eec-bfda-11eb-af1d-03edf5e010a6.html" class="tnt-asset-link" >                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="braciulis.jpg"
                            class="img-responsive lazyload full default"
                            width="480"
                            height="480"
                            data-sizes="auto"
                            data-srcset="https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/0/87/08746eec-bfda-11eb-af1d-03edf5e010a6/60b128190dcfa.image.jpg?crop=480%2C480%2C0%2C59&resize=150%2C150&order=crop%2Cresize 150w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/0/87/08746eec-bfda-11eb-af1d-03edf5e010a6/60b128190dcfa.image.jpg?crop=480%2C480%2C0%2C59&resize=200%2C200&order=crop%2Cresize 200w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/0/87/08746eec-bfda-11eb-af1d-03edf5e010a6/60b128190dcfa.image.jpg?crop=480%2C480%2C0%2C59&resize=225%2C225&order=crop%2Cresize 225w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/0/87/08746eec-bfda-11eb-af1d-03edf5e010a6/60b128190dcfa.image.jpg?crop=480%2C480%2C0%2C59&resize=300%2C300&order=crop%2Cresize 300w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/0/87/08746eec-bfda-11eb-af1d-03edf5e010a6/60b128190dcfa.image.jpg?crop=480%2C480%2C0%2C59&resize=400%2C400&order=crop%2Cresize 400w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/0/87/08746eec-bfda-11eb-af1d-03edf5e010a6/60b128190dcfa.image.jpg?crop=480%2C480%2C0%2C59&resize=480%2C480&order=crop%2Cresize 540w" />
                </a>
                
            </div>
            
        </figure></li>
                        
                            <li><figure class="photo layout-square letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/batman4/image_b4e9572a-b80d-11eb-a73c-b33d784d8cd3.html" class="tnt-asset-link" >                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="Batman4"
                            class="img-responsive lazyload full default"
                            width="563"
                            height="563"
                            data-sizes="auto"
                            data-srcset="https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/b/4e/b4e9572a-b80d-11eb-a73c-b33d784d8cd3/60a41310d994b.image.jpg?crop=563%2C563%2C66%2C128&resize=150%2C150&order=crop%2Cresize 150w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/b/4e/b4e9572a-b80d-11eb-a73c-b33d784d8cd3/60a41310d994b.image.jpg?crop=563%2C563%2C66%2C128&resize=200%2C200&order=crop%2Cresize 200w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/b/4e/b4e9572a-b80d-11eb-a73c-b33d784d8cd3/60a41310d994b.image.jpg?crop=563%2C563%2C66%2C128&resize=225%2C225&order=crop%2Cresize 225w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/b/4e/b4e9572a-b80d-11eb-a73c-b33d784d8cd3/60a41310d994b.image.jpg?crop=563%2C563%2C66%2C128&resize=300%2C300&order=crop%2Cresize 300w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/b/4e/b4e9572a-b80d-11eb-a73c-b33d784d8cd3/60a41310d994b.image.jpg?crop=563%2C563%2C66%2C128&resize=400%2C400&order=crop%2Cresize 400w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/b/4e/b4e9572a-b80d-11eb-a73c-b33d784d8cd3/60a41310d994b.image.jpg?crop=563%2C563%2C66%2C128&resize=540%2C540&order=crop%2Cresize 540w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/b/4e/b4e9572a-b80d-11eb-a73c-b33d784d8cd3/60a41310d994b.image.jpg?crop=563%2C563%2C66%2C128&resize=563%2C563&order=crop%2Cresize 640w" />
                </a>
                
            </div>
            
        </figure></li>
                        
                            <li><figure class="photo layout-square letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/pi-mykonosownerremembered3-060221-jpg/image_b973dfdc-c35b-11eb-bb4d-5bf225334363.html" class="tnt-asset-link" >                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="PI-MykonosOwnerRemembered3-060221.JPG"
                            class="img-responsive lazyload full default"
                            width="1287"
                            height="1287"
                            data-sizes="auto"
                            data-srcset="https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/b/97/b973dfdc-c35b-11eb-bb4d-5bf225334363/60b70a2c90f13.image.jpg?crop=1287%2C1287%2C161%2C0&resize=150%2C150&order=crop%2Cresize 150w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/b/97/b973dfdc-c35b-11eb-bb4d-5bf225334363/60b70a2c90f13.image.jpg?crop=1287%2C1287%2C161%2C0&resize=200%2C200&order=crop%2Cresize 200w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/b/97/b973dfdc-c35b-11eb-bb4d-5bf225334363/60b70a2c90f13.image.jpg?crop=1287%2C1287%2C161%2C0&resize=225%2C225&order=crop%2Cresize 225w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/b/97/b973dfdc-c35b-11eb-bb4d-5bf225334363/60b70a2c90f13.image.jpg?crop=1287%2C1287%2C161%2C0&resize=300%2C300&order=crop%2Cresize 300w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/b/97/b973dfdc-c35b-11eb-bb4d-5bf225334363/60b70a2c90f13.image.jpg?crop=1287%2C1287%2C161%2C0&resize=400%2C400&order=crop%2Cresize 400w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/b/97/b973dfdc-c35b-11eb-bb4d-5bf225334363/60b70a2c90f13.image.jpg?crop=1287%2C1287%2C161%2C0&resize=540%2C540&order=crop%2Cresize 540w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/b/97/b973dfdc-c35b-11eb-bb4d-5bf225334363/60b70a2c90f13.image.jpg?crop=1287%2C1287%2C161%2C0&resize=640%2C640&order=crop%2Cresize 640w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/b/97/b973dfdc-c35b-11eb-bb4d-5bf225334363/60b70a2c90f13.image.jpg?crop=1287%2C1287%2C161%2C0&resize=750%2C750&order=crop%2Cresize 750w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/b/97/b973dfdc-c35b-11eb-bb4d-5bf225334363/60b70a2c90f13.image.jpg?crop=1287%2C1287%2C161%2C0&resize=990%2C990&order=crop%2Cresize 990w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/b/97/b973dfdc-c35b-11eb-bb4d-5bf225334363/60b70a2c90f13.image.jpg?crop=1287%2C1287%2C161%2C0&resize=1035%2C1035&order=crop%2Cresize 1035w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/b/97/b973dfdc-c35b-11eb-bb4d-5bf225334363/60b70a2c90f13.image.jpg?crop=1287%2C1287%2C161%2C0&resize=1200%2C1200&order=crop%2Cresize 1200w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/b/97/b973dfdc-c35b-11eb-bb4d-5bf225334363/60b70a2c90f13.image.jpg?crop=1287%2C1287%2C161%2C0&resize=1287%2C1287&order=crop%2Cresize 1333w" />
                </a>
                
            </div>
            
        </figure></li>
                        
                            <li><figure class="photo layout-square letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/pi-mykonosownerpasses-052621-mykonos-facebook-jpeg/image_bef0e972-bda3-11eb-aa12-43e63b3c6140.html" class="tnt-asset-link" >                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="PI-MykonosOwnerPasses-052621 (MYKONOS FACEBOOK).jpeg"
                            class="img-responsive lazyload full default"
                            width="539"
                            height="539"
                            data-sizes="auto"
                            data-srcset="https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/b/ef/bef0e972-bda3-11eb-aa12-43e63b3c6140/60ad72068bbd1.image.jpg?crop=539%2C539%2C25%2C0&resize=150%2C150&order=crop%2Cresize 150w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/b/ef/bef0e972-bda3-11eb-aa12-43e63b3c6140/60ad72068bbd1.image.jpg?crop=539%2C539%2C25%2C0&resize=200%2C200&order=crop%2Cresize 200w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/b/ef/bef0e972-bda3-11eb-aa12-43e63b3c6140/60ad72068bbd1.image.jpg?crop=539%2C539%2C25%2C0&resize=225%2C225&order=crop%2Cresize 225w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/b/ef/bef0e972-bda3-11eb-aa12-43e63b3c6140/60ad72068bbd1.image.jpg?crop=539%2C539%2C25%2C0&resize=300%2C300&order=crop%2Cresize 300w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/b/ef/bef0e972-bda3-11eb-aa12-43e63b3c6140/60ad72068bbd1.image.jpg?crop=539%2C539%2C25%2C0&resize=400%2C400&order=crop%2Cresize 400w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/b/ef/bef0e972-bda3-11eb-aa12-43e63b3c6140/60ad72068bbd1.image.jpg?crop=539%2C539%2C25%2C0&resize=539%2C539&order=crop%2Cresize 540w" />
                </a>
                
            </div>
            
        </figure></li>
                        
                            <li><figure class="photo layout-square letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/pi-desantisvisitstarpon11-051721-jpg/image_75266584-b825-11eb-bccb-13702de59c9e.html" class="tnt-asset-link" >                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="PI-DeSantisVisitsTarpon11-051721.JPG"
                            class="img-responsive lazyload full default"
                            width="1287"
                            height="1287"
                            data-sizes="auto"
                            data-srcset="https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/7/52/75266584-b825-11eb-bccb-13702de59c9e/60a43aaa5db4b.image.jpg?crop=1287%2C1287%2C0%2C161&resize=150%2C150&order=crop%2Cresize 150w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/7/52/75266584-b825-11eb-bccb-13702de59c9e/60a43aaa5db4b.image.jpg?crop=1287%2C1287%2C0%2C161&resize=200%2C200&order=crop%2Cresize 200w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/7/52/75266584-b825-11eb-bccb-13702de59c9e/60a43aaa5db4b.image.jpg?crop=1287%2C1287%2C0%2C161&resize=225%2C225&order=crop%2Cresize 225w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/7/52/75266584-b825-11eb-bccb-13702de59c9e/60a43aaa5db4b.image.jpg?crop=1287%2C1287%2C0%2C161&resize=300%2C300&order=crop%2Cresize 300w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/7/52/75266584-b825-11eb-bccb-13702de59c9e/60a43aaa5db4b.image.jpg?crop=1287%2C1287%2C0%2C161&resize=400%2C400&order=crop%2Cresize 400w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/7/52/75266584-b825-11eb-bccb-13702de59c9e/60a43aaa5db4b.image.jpg?crop=1287%2C1287%2C0%2C161&resize=540%2C540&order=crop%2Cresize 540w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/7/52/75266584-b825-11eb-bccb-13702de59c9e/60a43aaa5db4b.image.jpg?crop=1287%2C1287%2C0%2C161&resize=640%2C640&order=crop%2Cresize 640w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/7/52/75266584-b825-11eb-bccb-13702de59c9e/60a43aaa5db4b.image.jpg?crop=1287%2C1287%2C0%2C161&resize=750%2C750&order=crop%2Cresize 750w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/7/52/75266584-b825-11eb-bccb-13702de59c9e/60a43aaa5db4b.image.jpg?crop=1287%2C1287%2C0%2C161&resize=990%2C990&order=crop%2Cresize 990w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/7/52/75266584-b825-11eb-bccb-13702de59c9e/60a43aaa5db4b.image.jpg?crop=1287%2C1287%2C0%2C161&resize=1035%2C1035&order=crop%2Cresize 1035w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/7/52/75266584-b825-11eb-bccb-13702de59c9e/60a43aaa5db4b.image.jpg?crop=1287%2C1287%2C0%2C161&resize=1200%2C1200&order=crop%2Cresize 1200w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/7/52/75266584-b825-11eb-bccb-13702de59c9e/60a43aaa5db4b.image.jpg?crop=1287%2C1287%2C0%2C161&resize=1287%2C1287&order=crop%2Cresize 1333w" />
                </a>
                
            </div>
            
        </figure></li>
                        
                            <li><figure class="photo layout-square letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/pa0602-splash-park-5-jpg/image_22e54340-c431-11eb-a361-87b708a55faa.html" class="tnt-asset-link" >                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="PA0602 Splash Park 5.JPG"
                            class="img-responsive lazyload full default"
                            width="1175"
                            height="1175"
                            data-sizes="auto"
                            data-srcset="https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/2/2e/22e54340-c431-11eb-a361-87b708a55faa/60b870384b780.image.jpg?crop=1175%2C1175%2C294%2C0&resize=150%2C150&order=crop%2Cresize 150w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/2/2e/22e54340-c431-11eb-a361-87b708a55faa/60b870384b780.image.jpg?crop=1175%2C1175%2C294%2C0&resize=200%2C200&order=crop%2Cresize 200w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/2/2e/22e54340-c431-11eb-a361-87b708a55faa/60b870384b780.image.jpg?crop=1175%2C1175%2C294%2C0&resize=225%2C225&order=crop%2Cresize 225w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/2/2e/22e54340-c431-11eb-a361-87b708a55faa/60b870384b780.image.jpg?crop=1175%2C1175%2C294%2C0&resize=300%2C300&order=crop%2Cresize 300w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/2/2e/22e54340-c431-11eb-a361-87b708a55faa/60b870384b780.image.jpg?crop=1175%2C1175%2C294%2C0&resize=400%2C400&order=crop%2Cresize 400w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/2/2e/22e54340-c431-11eb-a361-87b708a55faa/60b870384b780.image.jpg?crop=1175%2C1175%2C294%2C0&resize=540%2C540&order=crop%2Cresize 540w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/2/2e/22e54340-c431-11eb-a361-87b708a55faa/60b870384b780.image.jpg?crop=1175%2C1175%2C294%2C0&resize=640%2C640&order=crop%2Cresize 640w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/2/2e/22e54340-c431-11eb-a361-87b708a55faa/60b870384b780.image.jpg?crop=1175%2C1175%2C294%2C0&resize=750%2C750&order=crop%2Cresize 750w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/2/2e/22e54340-c431-11eb-a361-87b708a55faa/60b870384b780.image.jpg?crop=1175%2C1175%2C294%2C0&resize=990%2C990&order=crop%2Cresize 990w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/2/2e/22e54340-c431-11eb-a361-87b708a55faa/60b870384b780.image.jpg?crop=1175%2C1175%2C294%2C0&resize=1035%2C1035&order=crop%2Cresize 1035w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/2/2e/22e54340-c431-11eb-a361-87b708a55faa/60b870384b780.image.jpg?crop=1175%2C1175%2C294%2C0&resize=1175%2C1175&order=crop%2Cresize 1200w" />
                </a>
                
            </div>
            
        </figure></li>
                        
                            <li><figure class="photo layout-square letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/cycle-bar-1-jpg/image_3e63b972-c42b-11eb-a74f-43667fc1af42.html" class="tnt-asset-link" >                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="Cycle Bar (1).jpg"
                            class="img-responsive lazyload full default"
                            width="935"
                            height="935"
                            data-sizes="auto"
                            data-srcset="https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/3/e6/3e63b972-c42b-11eb-a74f-43667fc1af42/60b86655698c6.image.jpg?crop=935%2C935%2C153%2C0&resize=150%2C150&order=crop%2Cresize 150w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/3/e6/3e63b972-c42b-11eb-a74f-43667fc1af42/60b86655698c6.image.jpg?crop=935%2C935%2C153%2C0&resize=200%2C200&order=crop%2Cresize 200w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/3/e6/3e63b972-c42b-11eb-a74f-43667fc1af42/60b86655698c6.image.jpg?crop=935%2C935%2C153%2C0&resize=225%2C225&order=crop%2Cresize 225w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/3/e6/3e63b972-c42b-11eb-a74f-43667fc1af42/60b86655698c6.image.jpg?crop=935%2C935%2C153%2C0&resize=300%2C300&order=crop%2Cresize 300w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/3/e6/3e63b972-c42b-11eb-a74f-43667fc1af42/60b86655698c6.image.jpg?crop=935%2C935%2C153%2C0&resize=400%2C400&order=crop%2Cresize 400w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/3/e6/3e63b972-c42b-11eb-a74f-43667fc1af42/60b86655698c6.image.jpg?crop=935%2C935%2C153%2C0&resize=540%2C540&order=crop%2Cresize 540w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/3/e6/3e63b972-c42b-11eb-a74f-43667fc1af42/60b86655698c6.image.jpg?crop=935%2C935%2C153%2C0&resize=640%2C640&order=crop%2Cresize 640w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/3/e6/3e63b972-c42b-11eb-a74f-43667fc1af42/60b86655698c6.image.jpg?crop=935%2C935%2C153%2C0&resize=750%2C750&order=crop%2Cresize 750w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/assets/v3/editorial/3/e6/3e63b972-c42b-11eb-a74f-43667fc1af42/60b86655698c6.image.jpg?crop=935%2C935%2C153%2C0&resize=935%2C935&order=crop%2Cresize 990w" />
                </a>
                
            </div>
            
        </figure></li>
                        </ul></div>
        
        <div id="videos-501416" class="tab-pane tab-pane-videos fade in ">
                <h4 class="tab-content-heading">Videos</h4><p class="no-results text-muted">Sorry, there are no recent results for popular videos.</p></div>
        
        
        
        
            <div id="commented-501416" class="tab-pane tab-pane-commented fade in ">
                <h4 class="tab-content-heading">Commented</h4><p class="no-results text-muted">Sorry, there are no recent results for popular commented articles.</p></div>
        
    </div>
</div></section></div><div id="tncms-block-501393" class="tncms-block"></div><div id="tncms-block-644301" class="tncms-block">
        <div id="blox-ad-position-block-right-rail2" data-tnt-ads='{"vendor":"blox","type":"position","display":"default","region":"block-right-rail","slot":"2","fold":"","width":"","js":{"video":"https:\/\/bloximages.newyork1.vip.townnews.com\/suncoastnews.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":"","refresh":false}' class="blox-ad tnt-ads-container ">
        
        </div></div><div id="tncms-block-633912" class="tncms-block"></div></div>
        <div data-tnt-ads-tmp='{"vendor":"blox","type":"region","region":"fixed-big-ad-middle","id":"fixed-big-ad-middle","pos":"fixed-big-ad-middle, stf","fold":"span","include_domain":null,"size":"[[300,250], [300,600]]","height":"250","width":"300","not_mobile":false,"js":{"video":"https:\/\/bloximages.newyork1.vip.townnews.com\/suncoastnews.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":null,"index_slug":null,"url":"\/crime_crashes_fires","refresh":false}' style="display:none;"></div><div id="tncms-region-ads-fixed-big-ad-middle" class="tncms-region-ads">

<div id="blox-ad-position-fixed-big-ad-middle1">
<script type="text/javascript">TNCMS.AdManager.render({region: 'fixed-big-ad-middle', slot: 1, fold: "span"});</script>

</div>
</div>
<div id="tncms-region-asset_side_middle" class="tncms-region hidden-print"></div><div id="tncms-region-article_side_middle" class="tncms-region hidden-print"></div><div id="tncms-region-global-side-secondary" class="tncms-region hidden-print"><div id="tncms-block-501387" class="tncms-block"></div></div>
        <div data-tnt-ads-tmp='{"vendor":"blox","type":"region","region":"fixed-big-ad-bottom","id":"fixed-big-ad-bottom","pos":"fixed-big-ad-bottom, btf","fold":"below","include_domain":null,"size":"[[300,250], [300,600]]","height":"250","width":"300","not_mobile":false,"js":{"video":"https:\/\/bloximages.newyork1.vip.townnews.com\/suncoastnews.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":null,"index_slug":null,"url":"\/crime_crashes_fires","refresh":false}' style="display:none;"></div><div id="tncms-region-asset_side_bottom" class="tncms-region hidden-print"></div><div id="tncms-region-global-side-tertiary" class="tncms-region "></div><div id="tncms-region-article_side_bottom" class="tncms-region hidden-print"></div><div id="insticator-container" style="position:relative;margin-left:auto;margin-right:auto;width:300px;margin-bottom:40px;">
                    <div id="div-insticator-ad-1" style="height: 280px; margin-bottom: 20px;"></div>
                    <div id="insticator-embed"></div>
                    <div id="div-insticator-ad-2"></div>
                </div>
                <div id="sticky-right-rail-spacer">
                    <div id="sticky-right-rail"><div id="tncms-region-global-side-sticky" class="tncms-region hidden-print"></div><div id="tncms-region-asset_side_sticky" class="tncms-region hidden-print"></div></div>
                </div>
                </div>
            </div></div>
</article>
<div class="row">
            <div class="col-md-12"><div id="tncms-region-global-container-bottom" class="tncms-region "><div id="tncms-block-501339" class="tncms-block hidden-xs">
        <div id="blox-ad-position-block-leaderboard-bottom1" data-tnt-ads='{"vendor":"blox","type":"position","display":"default","region":"block-leaderboard-bottom","slot":"1","fold":"below","width":"728","js":{"video":"https:\/\/bloximages.newyork1.vip.townnews.com\/suncoastnews.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":"","refresh":false}' class="blox-ad tnt-ads-container ">
        
        </div></div><div id="tncms-block-501340" class="tncms-block visible-xs">
        <div id="blox-ad-position-block-leaderboard-bottom-mobile1" data-tnt-ads='{"vendor":"blox","type":"position","display":"default","region":"block-leaderboard-bottom-mobile","slot":"1","fold":"below","width":"320","js":{"video":"https:\/\/bloximages.newyork1.vip.townnews.com\/suncoastnews.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":"","refresh":false}' class="blox-ad tnt-ads-container ">
        
        </div></div><div id="tncms-block-585128" class="tncms-block visible-xs">
        <div id="blox-ad-position-block-leaderboard-bottom-mobile2" data-tnt-ads='{"vendor":"blox","type":"position","display":"default","region":"block-leaderboard-bottom-mobile","slot":"2","fold":"below","width":"320","js":{"video":"https:\/\/bloximages.newyork1.vip.townnews.com\/suncoastnews.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":"","refresh":false}' class="blox-ad tnt-ads-container ">
        
        </div></div></div></div>
        </div></section>
    <section id="main-bottom-container" class="container-fullscreen-region container-fluid">
        <div class="fullscreen-region"><div id="tncms-region-global-container-bottom-fullscreen" class="tncms-region "></div></div>
    </section><!-- / main-body-container -->
    </div>
    <div id="site-footer-container" class="hidden-print">
         
            <div class="container">
                <div id="asset-container-bottom" class="col-md-12">
                    <div id="tncms-region-asset_container_bottom" class="tncms-region hidden-print"></div> 
                </div>
            </div>
        

        
            <footer id="site-footer" class="container well-main">
                
                <div id="tncms-region-footer-top-col-full" class="tncms-region "></div>
                <div class="row">
                    <div id="footer-col-one" class="col-md-4 col-sm-4"><div id="tncms-region-footer-col-one" class="tncms-region "><div id="tncms-block-501401" class="tncms-block"><section id="block-501401" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-501401 ">
        <div class="block-title-inner">
            <h4>
                
                Sections
                
            </h4>
        </div>
    </div></div></section></div></div><div id="tncms-region-nav-footer-col-one-nav" class="tncms-region-nav"><ul id="footer-col-one-nav_menu" class="bullet-nav nav-list" ><li>
                <a class="nav-link  nav-home  tnt-section-home"  href="/"  tabindex="0">
                    <span class="nav-icon fas tnt-home tnt-fw"></span> <span class="nav-label">Home</span>
                </a></li><li>
                <a class="nav-link   tnt-section-news"  href="/news/"  tabindex="0">
                    <span class="nav-label">News</span>
                </a></li><li>
                <a class="nav-link   tnt-section-sports"  href="/sports/"  tabindex="0">
                    <span class="nav-label">Sports</span>
                </a></li><li>
                <a class="nav-link   tnt-section-business"  href="/business/"  tabindex="0">
                    <span class="nav-label">Business</span>
                </a></li><li>
                <a class="nav-link   tnt-section-obituaries"  href="/obituaries/"  tabindex="0">
                    <span class="nav-label">Obituaries</span>
                </a></li><li>
                <a class="nav-link   tnt-section-multimedia"  href="/multimedia/"  tabindex="0">
                    <span class="nav-label">Multimedia</span>
                </a></li></ul></div></div>
    <div id="footer-col-two" class="col-md-4 col-sm-4"><div id="tncms-region-footer-col-two" class="tncms-region "><div id="tncms-block-501402" class="tncms-block"><section id="block-501402" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-501402 ">
        <div class="block-title-inner">
            <h4>
                
                Services
                
            </h4>
        </div>
    </div></div></section></div></div><div id="tncms-region-nav-footer-col-two-nav" class="tncms-region-nav"><ul id="footer-col-two-nav_menu" class="bullet-nav nav-list" ><li>
                <a class="nav-link   tnt-section-subscription-services"  href="/site/forms/subscription_services/"  tabindex="0">
                    <span class="nav-label">Subscription Services</span>
                </a></li><li>
                <a class="nav-link   tnt-section-submission-forms"  href="/site/forms/"  tabindex="0">
                    <span class="nav-label">Submission Forms</span>
                </a></li><li>
                <a class="nav-link   tnt-section-classifieds"  href="/classifieds/"  tabindex="0">
                    <span class="nav-label">Classifieds</span>
                </a></li><li>
                <a class="nav-link   tnt-section-place-an-ad"  href="http://www.suncoastnews.com/site/contact.html"  target="_blank" rel="noopener" tabindex="0">
                    <span class="nav-label">Place an Ad</span>
                </a></li><li>
                <a class="nav-link   tnt-section-calendar"  href="/calendar/"  tabindex="0">
                    <span class="nav-label">Calendar</span>
                </a></li><li>
                <a class="nav-link   tnt-section-search"  href="/search/"  tabindex="0">
                    <span class="nav-label">Search</span>
                </a></li><li>
                <a class="nav-link   tnt-section-weather"  href="/weather/"  tabindex="0">
                    <span class="nav-label">Weather</span>
                </a></li></ul></div></div>
    <div id="footer-col-three" class="col-md-4 col-sm-4"><div id="tncms-region-footer-col-three" class="tncms-region "><div id="tncms-block-501415" class="tncms-block padding-bottom"><section id="block-501415" class="block emphasis-h3   " ><div class="block"><a href="/" rel="nofollow" >
            <img 
                
                src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg==" 
                data-srcset="https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/custom/image/17727cd0-7120-11e6-8a40-33d15f4612ac.jpg?resize=150%2C64 150w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/custom/image/17727cd0-7120-11e6-8a40-33d15f4612ac.jpg?resize=200%2C86 200w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/custom/image/17727cd0-7120-11e6-8a40-33d15f4612ac.jpg?resize=225%2C96 225w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/custom/image/17727cd0-7120-11e6-8a40-33d15f4612ac.jpg?resize=300%2C128 300w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/custom/image/17727cd0-7120-11e6-8a40-33d15f4612ac.jpg?resize=400%2C171 400w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/custom/image/17727cd0-7120-11e6-8a40-33d15f4612ac.jpg?resize=540%2C231 540w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/custom/image/17727cd0-7120-11e6-8a40-33d15f4612ac.jpg?resize=640%2C274 640w, https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/content/tncms/custom/image/17727cd0-7120-11e6-8a40-33d15f4612ac.jpg 750w" 
                data-sizes="auto" 
                class=" img-responsive lazyload tnt-prop-img"
                width="750"
                height="321"
                alt=""></a></div></section></div><div id="tncms-block-501407" class="tncms-block"><section id="block-501407" class="block emphasis-h4   " ><address>
    <strong>www.SuncoastNews.com</strong><br>
    11321 U.S. Hwy 19 North<br>
    Port Richey, FL. 34668
    <br>
    
        <strong>Phone:</strong> 727-815-1023<br>
        <strong>Email:</strong> <a href="mailto:dpleus@SuncoastNews.com">dpleus@SuncoastNews.com</a><br>
    
</address></section></div><div id="tncms-block-501424" class="tncms-block padding-bottom"><div class="follow-links-501424 default">
    
    <section id="block-501424" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-501424 ">
        <div class="block-title-inner">
            <h4>
                
                Follow Us
                
            </h4>
        </div>
    </div></div><ul class="list-inline">
        
            <li>
                <a href="http://facebook.com/SuncoastNews/" title="Facebook" target="_blank" rel="noopener" class="btn btn-md btn-link fb" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-facebook-f"></i>
                    <span class="sr-only">Facebook</span>
                </a>
            </li>
        
        
            <li>
                <a href="http://twitter.com/SuncoastNews/" title="Twitter" target="_blank" rel="noopener" class="btn btn-md btn-link tw" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-twitter"></i>
                    <span class="sr-only">Twitter</span>
                </a>
            </li>
        
        
        
            <li>
                <a href="http://www.youtube.com/user/SCNPasco" title="Youtube" target="_blank" rel="noopener" class="btn btn-md btn-link yt" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-youtube"></i>
                    <span class="sr-only">YouTube</span>
                </a>
            </li>
        
        
        
        
        
        
        
        
        
        
        
        
        
        
    </ul>
    </section>
</div>
<script type="application/ld+json">
{ "@context" : "https://schema.org",
  "@type" : "Organization",
  "url" : "http://www.suncoastnews.com",
  "sameAs" : ["http://facebook.com/SuncoastNews/","http://twitter.com/SuncoastNews/","http://www.youtube.com/user/SCNPasco"]
}
</script>
<div class="clearfix"></div></div></div></div>
                </div>
                <div id="tncms-region-footer-bottom-col-full" class="tncms-region "></div>
                
            </footer>
        

        <div id="site-copyright-container" class="container">
            <div id="tncms-region-footer-copyright" class="tncms-region "><div id="tncms-block-501408" class="tncms-block"><div id="site-copyright" class="row">
    <section id="block-501408"><div class="col-md-7"><small>&copy; Copyright 2021 <a href="/">suncoastnews.com</a>, 9911 Seminole Blvd. Seminole, FL</small></div>
        <div class="col-md-5"><small>Powered by <a href="https://bloxcms.com" title="BLOX Content Management System" target="_blank" rel="noopener">BLOX Content Management System</a> from <a href="https://townnews.com/" title="TownNews.com BLOX Newspaper Content Management" target="_blank" rel="noopener">TownNews.com</a>.</small></div>
    </section>
</div></div></div>
        </div>
    </div>
    
    
        </div><!-- / offcanvas close  -->
    

    
    
    <!-- / site-container close -->
    </div>
    
    
        <div data-tnt-ads-tmp='{"vendor":"blox","type":"region","region":"fixed-impact-bottom","id":"fixed-impact-bottom","pos":"fixed-impact-bottom, btf","fold":"below","include_domain":null,"size":"[1,1]","height":"1","width":"1","js":{"video":"https:\/\/bloximages.newyork1.vip.townnews.com\/suncoastnews.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"index_slug":null,"url":"\/crime_crashes_fires","refresh":false}' style="display:none;"></div>
    <script>
        window.__tnt = window.__tnt || {};
        __tnt.compatibility = __tnt.compatibility || {};

        __tnt.compatibility.status = '';
        __tnt.compatibility.check = function() {
            if (typeof __tnt.advertisements == 'undefined') {
                __tnt.compatibility.status = 'FAIL: object 0 undefined';
                return false;
            }
            return true;
        };
        __tnt.compatibility.notification = function() {
            if (!document.getElementById('notification-area')) {
                    var el = document.createElement('div');
                    el.id = 'notification-area';
                    document.querySelector('#asset-content .asset-body').appendChild(el);
                }
                __tnt.template(
                    document.getElementById('template-blox-message-incompatible'),
                    document.getElementById('notification-area'),
                    true,
                    [],
                    function(el) {
                        setTimeout(function() {
                            var message = document.getElementById('blox-message-incompatible');
                            var authStatusCls = (__tnt.user.authToken) ? 'logged-in' : 'not-logged-in';
                                Array.from(message.getElementsByClassName(authStatusCls)).forEach(function(el) {
                                    el.style.display = 'block';
                                });
                            
                            if (__tnt.user.services) {
                                message.parentNode.removeChild(message);
                            } else {
                                message.style.display = 'block';
                                }
                        }, 100);
                    }
                );
            };
        (function() {
            function compatibilityCheck() {
                if (!__tnt.compatibility.check()) {
                    __tnt.trackEvent({
                        'category':'subscription',
                        'action':'adblock',
                        'label':'adblock detected',
                        'value':'1'
                    });
                    __tnt.compatibility.notification();
                }
            }

            if (document.readyState != 'loading') {
                compatibilityCheck();
            } else {
                document.addEventListener('DOMContentLoaded', compatibilityCheck);
            }
        })();
    </script>
    <template id="template-blox-message-incompatible">
            </template>
    
    
    <script>
        jQuery(function() {
            if(typeof TNCMS.Tracking != 'undefined'){
                jQuery(TNCMS.Tracking.trackDeclarativeEvents);
            }dataLayer.push({'tncms.client.recent_five':__tnt.recentFive.add("2036e138-c50f-11eb-9ea7-13485452bf68")});});
    </script>

    <script>
        __tnt.trackEvent = function(obj) {
            if (typeof obj === 'object') {
                    if (obj.category && obj.action) {
                        __tnt.googleEvent(obj);
                    } else if (obj.network && obj.socialAction) {
                        __tnt.googleSocial(obj);
                    } else if (obj.url) {
                        __tnt.googlePageView(obj);
                    }
                    if (typeof TNCMS.Tracking != 'undefined' && obj.metric) {
                        TNCMS.Tracking.addEvent({
                            app: obj.app,
                            metric: obj.metric,
                            id: obj.uuid
                        });
                    }
            }
        };

        if (__tnt.trackEventLater.length > 0) {
            __tnt.trackEventLater.forEach(function(obj) {
                __tnt.trackEvent(obj);
            });
        }

        Array.from(document.querySelectorAll('body [data-track]')).forEach(function(el) {
            el.addEventListener(__tnt.client.clickEvent, function() {
                __tnt.trackEvent(JSON.parse(el.dataset.track));
            });
        });
        Array.from(document.querySelectorAll('body [data-tncms-track-event]')).forEach(function(el) {
            el.addEventListener(__tnt.client.clickEvent, function() {
                __tnt.trackEvent(JSON.parse(el.dataset.tncmsTrackEvent));
            });
        });
        
        Array.from(document.querySelectorAll('body [data-tncms-track-dmp]')).forEach(function(el) {
            el.addEventListener(__tnt.client.clickEvent, function() {
                var dmpData = el.dataset.tncmsTrackDmp;
                
            });
        });
    
    </script>
    
    
<script>/*<![CDATA[*/ 
                __tnt.googleEvent = function(obj) {
                    dataLayer.push({
                        'event': 'tncms.event.trigger',
                             'tncms.event.trigger.category': obj.category,
                             'tncms.event.trigger.action': obj.action,
                             'tncms.event.trigger.label': obj.label, 
                             'tncms.event.trigger.value': obj.value
                    });
                }
                /* Virtual page view */
                __tnt.googlePageView = function(obj) {
                    var sURL = obj.url.replace(/^.*\/\/[^\/]+/, '');
                    dataLayer.push({
                        'event': 'tncms.event.virtual_pageview',
                            'tncms.event.virtual_pageview.url': sURL,
                            'tncms.event.virtual_pageview.title': obj.title
                    });
                }
                /* Social event */
                __tnt.googleSocial = function(obj) {
                    dataLayer.push({
                        'event': 'tncms.event.social',
                            'tncms.event.social.network': obj.network,
                            'tncms.event.social.action': obj.socialAction,
                            'tncms.event.social.target': obj.url
                    });
                } /*]]>*/</script>
<script src="https://bloximages.newyork1.vip.townnews.com/suncoastnews.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/asset-edit.60e8e67e04be1194326dcfbe7f00b8c3.js"></script>
<script>/*<![CDATA[*/ 
                        !function(t,i,n){var e,a,s,o,c,d={init:function(){a=i.getElementById("site-navbar-container"),n.client.platform.ios?a.classList.add("affix-sticky"):(e=i.getElementById("main-body-container"),s=a.offsetHeight||a.clientHeight,o=!1,c=0,t.addEventListener("scroll",d.navPosition,!1),t.addEventListener("mousewheel",d.navPosition,!1))},navPosition:function(){o||(o=!0,setTimeout(function(){var n=a.getBoundingClientRect(),d=t.pageYOffset||i.documentElement.scrollTop,f=n.top+d;d>=f&&d>c?a.classList.contains("affix")||(c=f,a.classList.add("affix"),a.classList.remove("affix-top"),e.style.marginTop=s+"px"):a.classList.contains("affix-top")||(a.classList.remove("affix"),a.classList.add("affix-top"),e.style.marginTop="0px"),o=!1},25))}};"loading"==i.readyState?i.addEventListener("DOMContentLoaded",d.init,!1):d.init()}(window,document,__tnt);
                    document.addEventListener('DOMContentLoaded', function() {
                        var isIOS = /iPad|iPhone|iPod/.test(navigator.userAgent) && !window.MSStream;
                        if (isIOS) {
                            Array.from(document.querySelectorAll('[data-toggle="offcanvas"]')).forEach(function(drawer) {
                                drawer.addEventListener("mouseover", function(e) {
                                    var drawerCls = drawer.dataset.target === 'left' ? 'active-left' : 'active-right';
                                    document.documentElement.classList.add('drawer-open', drawerCls);
                                })
                            })
                        }
                    }); /*]]>*/</script>
<script>/*<![CDATA[*/ (function(){ var fallback = 72508; let zergnet = document.createElement("SCRIPT"); zergnet.type = 'text/javascript'; zergnet.async = true; zergnet.src = "https://www.zergnet.com/zerg-lk.js?ref="+encodeURIComponent(document.location.href)+"&domain="+encodeURIComponent(ZERG.domain)+"&fb="+encodeURIComponent(fallback)+"&u="+encodeURIComponent(ZERG.user); document.getElementsByTagName("HEAD")[0].appendChild( zergnet ); })(); /*]]>*/</script>
<script>/*<![CDATA[*/ (function (a, c, s, u){'Insticator'in a || (a.Insticator={ad:{loadAd: function (b){Insticator.ad.q.push(b)}, q: []}, helper:{}, embed:{}, version: '3.0', q: [], load: function (t, o){Insticator.q.push({t: t, o: o})}}); var b=c.createElement(s); b.src=u; b.async=!0; var d=c.getElementsByTagName(s)[0]; d.parentNode.insertBefore(b, d)})(window, document, 'script', '//d2na2p72vtqyok.cloudfront.net/client-embed/b1ad8512-0208-404a-8bef-42066664235a.js');
                            /*&lt;![CDATA[[*/Insticator.ad.loadAd('div-insticator-ad-1');Insticator.ad.loadAd('div-insticator-ad-2');Insticator.load('em',{id:'40c1ddd3-f53e-4cc2-99cf-8551b04a81fa'})/*]]&gt;*/ /*]]>*/</script></body>
</html>